[PATCH] gnome-boxes: Add 'qemu' as propagated-input

  • Done
  • quality assurance status badge
Details
4 participants
  • Jacob Hrbek
  • Liliana Marie Prikler
  • Ludovic Courtès
  • Maxime Devos
Owner
unassigned
Submitted by
Jacob Hrbek
Severity
normal
Merged with
J
J
Jacob Hrbek wrote on 14 Sep 2022 20:17
(address . guix-patches@gnu.org)
20220914181624.13204-1-kreyren@rixotstudio.cz
Fixes:

(gnome-boxes:9304): Boxes-WARNING **: 19:54:29.345: review-page.vala:32: Box setup failed: Failed to create volume: internal error: creation of non-raw file images is not supported without qemu-img.

(gnome-boxes:9304): Boxes-CRITICAL **: 19:54:29.345: boxes_assistant_review_page_populate: assertion 'machine != NULL' failed

Steps to reproduce:
1. Open gnome-boxes on GNU Guix
2. Try to create a box with GNU Guix ISO and expect failure above
Attachment: signature.asc
M
M
Maxime Devos wrote on 15 Sep 2022 15:03
706db9e7-4906-525c-5ccb-84580ce71392@telenet.be
On 14-09-2022 20:17, Jacob Hrbek wrote:
Toggle quote (11 lines)
> Fixes:
>
> (gnome-boxes:9304): Boxes-WARNING **: 19:54:29.345: review-page.vala:32: Box setup failed: Failed to create volume: internal error: creation of non-raw file images is not supported without qemu-img.
>
> (gnome-boxes:9304): Boxes-CRITICAL **: 19:54:29.345: boxes_assistant_review_page_populate: assertion 'machine != NULL' failed
>
> Steps to reproduce:
> 1. Open gnome-boxes on GNU Guix
> 2. Try to create a box with GNU Guix ISO and expect failure above
>
>
Instead of propagation, I recommend doing a substitute* instead, to
avoid the usual downsides of propagation. Searching for 'qemu-img' in
the source code of gnome-boxes (with tar, grep -rF and guix build
--source), I found:
src/installed-media.vala: string[] argv = { "qemu-img",
"convert", "-O", "qcow2", device_file, destination_path };
Could you substitute* "qemu-img" -> (search-input-file inputs
"bin/qemu-img") and move QEMU from 'propagated-inputs' to 'inputs'.
Greetings,
Maxime.
Attachment: OpenPGP_signature
J
J
Jacob Hrbek wrote on 18 Sep 2022 22:43
[PATCH] gnome-boxes: Patch 'qemu-img' path
(address . 57809@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20220918204335.1734-1-kreyren@rixotstudio.cz
---
gnu/packages/gnome.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d6d22f8eb1..89f5999920 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12111,6 +12111,7 @@ (define-public polari
(home-page "https://wiki.gnome.org/Apps/Polari")
(license license:gpl2+)))

+;; NOTE(Krey): src/util-app.vala might need patched paths
(define-public gnome-boxes
(package
(name "gnome-boxes")
@@ -12133,7 +12134,12 @@ (define-public gnome-boxes
#:phases #~(modify-phases %standard-phases
(add-after 'unpack 'disable-gtk-update-icon-cache
(lambda _
- (setenv "DESTDIR" "/"))))))
+ (setenv "DESTDIR" "/")))
+ (add-before 'configure 'substitute-qemu-dependencies
+ (lambda _
+
(substitute* "src/installed-media.vala"
+ (("qemu-img")
+ (search-input-file %build-inputs "/bin/qemu-img"))))))))
(native-inputs
(list desktop-file-utils ;for update-desktop-database
gettext-minimal
@@ -12141,6 +12147,7 @@ (define-public gnome-boxes
itstool
pkg-config
python
+ qemu-minimal ;for qemu-img
vala))
(inputs
(list glib-networking ;for TLS support
--
2.37.1
Attachment: signature.asc
J
J
Jacob Hrbek wrote on 18 Sep 2022 22:46
(address . 57809@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20220918204629.10703-1-kreyren@rixotstudio.cz
---
gnu/packages/gnome.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d6d22f8eb1..d9cfa5ebed 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12133,7 +12133,12 @@ (define-public gnome-boxes
#:phases #~(modify-phases %standard-phases
(add-after 'unpack 'disable-gtk-update-icon-cache
(lambda _
- (setenv "DESTDIR" "/"))))))
+ (setenv "DESTDIR" "/")))
+ (add-before 'configure 'substitute-qemu-dependencies
+ (lambda _
+ (substitute* "src/installed-media.vala"
+ (("qemu-img")
+ (search-input-file %build-inputs "/bin/qemu-img"))))))))
(native-inputs
(list desktop-file-utils ;for update-desktop-
database
gettext-minimal
@@ -12141,6 +12146,7 @@ (define-public gnome-boxes
itstool
pkg-config
python
+ qemu-minimal ;for qemu-img
vala))
(inputs
(list glib-networking ;for TLS support
--
2.37.1
Attachment: signature.asc
J
J
J
Jacob Hrbek wrote on 18 Sep 2022 23:05
Re: [PATCH] gnome-boxes: Patch 'qemu-img' path
(address . 57809@debbugs.gnu.org)
4WBFIR.MWKWLBB5GNEL1@rixotstudio.cz
isn't that going to break if the user invokes `guix cg -D` though?
On Ne, zá? 18 2022 at 20:43:43 +0000, Jacob Hrbek
<kreyren@rixotstudio.cz> wrote:
Toggle quote (44 lines)
> ---
> gnu/packages/gnome.scm | 9 ++++++++-
> 1 file changed, 8 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index d6d22f8eb1..89f5999920 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -12111,6 +12111,7 @@ (define-public polari
> (home-page "<https://wiki.gnome.org/Apps/Polari>")
> (license license:gpl2+)))
>
> +;; NOTE(Krey): src/util-app.vala might need patched paths
> (define-public gnome-boxes
> (package
> (name "gnome-boxes")
> @@ -12133,7 +12134,12 @@ (define-public gnome-boxes
> #:phases #~(modify-phases %standard-phases
> (add-after 'unpack
> 'disable-gtk-update-icon-cache
> (lambda _
> - (setenv "DESTDIR" "/"))))))
> + (setenv "DESTDIR" "/")))
> + (add-before 'configure
> 'substitute-qemu-dependencies
> + (lambda _
> + (substitute* "src/installed-media.vala"
> + (("qemu-img")
> + (search-input-file %build-inputs
> "/bin/qemu-img"))))))))
> (native-inputs
> (list desktop-file-utils ;for update-desktop-database
> gettext-minimal
> @@ -12141,6 +12147,7 @@ (define-public gnome-boxes
> itstool
> pkg-config
> python
> + qemu-minimal ;for qemu-img
> vala))
> (inputs
> (list glib-networking ;for TLS support
> --
> 2.37.1
>
Attachment: file
Attachment: signature.asc
M
M
Maxime Devos wrote on 18 Sep 2022 23:14
Re: [bug#57809] [PATCH] gnome-boxes: Patch 'qemu-img' path
8c563d18-53eb-49ef-467f-29c3d242fea6@telenet.be
On 18-09-2022 23:05, Jacob Hrbek wrote:
Toggle quote (1 lines)
> isn't that going to break if the user invokes `guix cg -D` though?
No, "guix gc" only deletes things that aren't (indirectly) referred to
by a root (being a garbage collector), and by adding that substitution,
the compiled gnome-boxes refers to qemu(-minimal).
(Unless the reference is obfuscated, but Vala has a C-like compilation
model, so I wouldn't expect that.)
Toggle quote (3 lines)
> + (substitute* "src/installed-media.vala"
> + (("qemu-img")
> + (search-input-file %build-inputs "/bin/qemu-img"))))))))
I find (search-input-file inputs "/bin/qemu-img") clearer -- 'inputs' /
'native-inputs' is sufficiently complicated on its own, no need to bring
%build-inputs and friends in the equation when it can be avoided.
Toggle quote (1 lines)
> +;; NOTE(Krey): src/util-app.vala might need patched paths
(1) the convention is TODO or FIXME, not NOTE
(2) who discovered the potential problem, does not need to be mentioned
-- there is still "git blame" (which can be used for other things than
blaming) and "git log" if it turns out to be somehow useful information
after all (e.g. for attribution).
Greetings,
Maxime.
Attachment: OpenPGP_signature
J
J
Jacob Hrbek wrote on 18 Sep 2022 23:32
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 57809@debbugs.gnu.org)
P5DFIR.K7JI549PMIPU2@rixotstudio.cz
On Ne, zá? 18 2022 at 23:14:12 +0200, Maxime Devos
<maximedevos@telenet.be> wrote:
Toggle quote (5 lines)
> I find (search-input-file inputs "/bin/qemu-img") clearer -- 'inputs'
> /
> 'native-inputs' is sufficiently complicated on its own, no need to
> bring
> %build-inputs and friends in the equation when it can be avoided.
That ain't working for me: https://i.imgur.com/Co4Xsjl.png
unbound-variable #f "Unbound variable: ~S" (native-inputs) #f
> (1) the convention is TODO or FIXME, not NOTE
It's not:
- TODO as in "To Do something" or "for something to be done"
- FIXME as in "Low priority thing or quality assurance something that
needs to be fixed"
More like handing over note to the next guy about possible issue in the
future and leaving the signature here so that they can just go on chat
and ask instead of wasting ~3 min on average searching git blame/log
which gets exponentially more unsustainable to track
At least that's how it works where i work O_o .. personally i find it
better way than the generic TODO/FIXME
Attachment: file
Attachment: signature.asc
M
M
Maxime Devos wrote on 18 Sep 2022 23:50
(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)(address . 57809@debbugs.gnu.org)
d9346de3-50d0-85d3-f033-5c06753e846e@telenet.be
On 18-09-2022 23:32, Jacob Hrbek wrote:
Toggle quote (8 lines)
> On Ne, zá? 18 2022 at 23:14:12 +0200, Maxime Devos
> <maximedevos@telenet.be> wrote:
>> I find (search-input-file inputs "/bin/qemu-img") clearer -- 'inputs'
>> / 'native-inputs' is sufficiently complicated on its own, no need to
>> bring %build-inputs and friends in the equation when it can be avoided.
>
> That ain't working for me: https://i.imgur.com/Co4Xsjl.png
> <https://i.imgur.com/Co4Xsjl.png>
Quoting the relevant code would be sufficient, no need for image links.
Besides, text is more accessible than images of text, text would reach
a wider audience.
Toggle quote (1 lines)
>     unbound-variable #f "Unbound variable: ~S" (native-inputs) #f
(1) 'qemu-minimal' is in the wrong place, it needs to be in 'inputs',
not 'native-inputs', otherwise it is compiled for the wrong
architecture. (In both the phase and the inputs/native-inputs field)
(2) 'native-inputs' (or 'inputs'), is unbound. For information on how
to use search-input-file, inputs and phases, see the manual, in
particular (guix)Build Utilities (index entry: search-input-file) and
its example.
Toggle quote (3 lines)
>> (1) the convention is TODO or FIXME, not NOTE It's not: - TODO as in "To Do something" or "for something to be done"
> - FIXME as in "Low priority thing or quality assurance something that
> needs to be fixed"
A missing hardcoded file name can easily be a (usually low-priority)
bug, so FIXME applies, it's also something to investigate and solve (if
appropriate), so TODO applies.
Toggle quote (2 lines)
> More like handing over note to the next guy about possible issue in the
> future and leaving the signature here so that they can just go on chat
The required information is already in the "TODO: [stuff about file
names]", they do not need to go 'on chat', and if they do anyway,
hardcoding file names is a relatively well-known solution, so I don't
expect a contact person to be needed.
If that's not sufficient, you can insert an (impersonal) link to the
Guix issue https://issues.guix.gnu.org/issue/57809, which has all the
relevant information (which is available even when you aren't available
for chatting, and also when your IRC nick is unknown or if you're gone).
Also, there are no gender restrictions in Guix.
Greetings,
Maxime.
Attachment: OpenPGP_signature
J
J
Jacob Hrbek wrote on 19 Sep 2022 06:09
[PATCH] gnome-boxes: Patch 'qemu-img' path
(address . 57809@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20220919040932.5298-1-kreyren@rixotstudio.cz
---
gnu/packages/gnome.scm | 12 +++++++++---
1 file changed, 9 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d6d22f8eb1..ff5cb92907 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12131,9 +12131,14 @@ (define-public gnome-boxes
#$output
"/lib/gnome-boxes"))
#:phases #~(modify-phases %standard-phases
- (add-after 'unpack 'disable-gtk-update-icon-cache
- (lambda _
- (setenv "DESTDIR" "/"))))))
+ (add-after 'unpack 'disable-gtk-update-icon-cache
+ (lambda _
+ (setenv "DESTDIR" "/")))
+ (add-before 'configure 'substitute-qemu-dependencies
+ (lambda* (#:key inputs #:allow-other-keys)
+
(substitute* "src/installed-media.vala"
+ (("qemu-img")
+ (search-input-file inputs "/bin/qemu-img"))))))))
(native-inputs
(list desktop-file-utils ;for update-desktop-database
gettext-minimal
@@ -12162,6 +12167,7 @@ (define-public gnome-boxes
sparql-query
spice-gtk
tracker
+ qemu-minimal ;for qemu-img
vte
webkitgtk-with-libsoup2)) ;for webkit2gtk-4.0
(home-page "https://wiki.gnome.org/Apps/Boxes")
--
2.37.3
Attachment: signature.asc
J
J
Jacob Hrbek wrote on 19 Sep 2022 06:28
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 57809@debbugs.gnu.org)
yAQyCUxhSoIJVBCrTEfwP_BgPwyV6Bgyaa3xrQSPXylBZOv6CPcs_XZ4pFI315RydLw--b3nm2umqYkTI3Bv2F8EueVVvPXZnroTVgfzdeg=@rixotstudio.cz
Toggle quote (6 lines)
>> (2) 'native-inputs' (or 'inputs'), is unbound. For information on how

>> to use search-input-file, inputs and phases, see the manual, in particular (guix)Build Utilities (index entry: search-input-file) >> and

>> its example.

I've been searching through that thing endlessly for almost 5 hours >_> it doesn't help much for that.. I can grep the code to look for usage though which is what I did here ^-^

Toggle quote (4 lines)
>> If that's not sufficient, you can insert an (impersonal) link to the

>> Guix issue

meh, imho takes too much time especially when it's from a newbie like me who needs guidance which adds bunch of useless info to the issue.

Toggle quote (6 lines)
>> which has all the

>> relevant information (which is available even when you aren't available

>> for chatting, and also when your IRC nick is unknown or if you're gone).

The idea is that people are using chat/client that has chat history and sends notifications so that people can respond quickly or when they are available worst case sending an email..

-- Jacob "Kreyren" Hrbek

------- Original Message -------
On Sunday, September 18th, 2022 at 11:50 PM, Maxime Devos <maximedevos@telenet.be> wrote:


Toggle quote (78 lines)
>

>

> On 18-09-2022 23:32, Jacob Hrbek wrote:
>

> > On Ne, zá? 18 2022 at 23:14:12 +0200, Maxime Devos
> > maximedevos@telenet.be wrote:
> >

> > > I find (search-input-file inputs "/bin/qemu-img") clearer -- 'inputs'
> > > / 'native-inputs' is sufficiently complicated on its own, no need to
> > > bring %build-inputs and friends in the equation when it can be avoided.
> >

> > That ain't working for me: https://i.imgur.com/Co4Xsjl.png
> > https://i.imgur.com/Co4Xsjl.png
>

>

> Quoting the relevant code would be sufficient, no need for image links.
> Besides, text is more accessible than images of text, text would reach
> a wider audience.
>

> > unbound-variable #f "Unbound variable: ~S" (native-inputs) #f
>

>

> (1) 'qemu-minimal' is in the wrong place, it needs to be in 'inputs',
> not 'native-inputs', otherwise it is compiled for the wrong
> architecture. (In both the phase and the inputs/native-inputs field)
> (2) 'native-inputs' (or 'inputs'), is unbound. For information on how
> to use search-input-file, inputs and phases, see the manual, in
> particular (guix)Build Utilities (index entry: search-input-file) and
> its example.
>

> > > (1) the convention is TODO or FIXME, not NOTE It's not: - TODO as in "To Do something" or "for something to be done"
> > > - FIXME as in "Low priority thing or quality assurance something that
> > > needs to be fixed"
>

>

> A missing hardcoded file name can easily be a (usually low-priority)
> bug, so FIXME applies, it's also something to investigate and solve (if
> appropriate), so TODO applies.
>

> > More like handing over note to the next guy about possible issue in the
> > future and leaving the signature here so that they can just go on chat
>

>

> The required information is already in the "TODO: [stuff about file
> names]", they do not need to go 'on chat', and if they do anyway,
> hardcoding file names is a relatively well-known solution, so I don't
> expect a contact person to be needed.
>

> If that's not sufficient, you can insert an (impersonal) link to the
> Guix issue https://issues.guix.gnu.org/issue/57809, which has all the
>

> relevant information (which is available even when you aren't available
> for chatting, and also when your IRC nick is unknown or if you're gone).
>

> Also, there are no gender restrictions in Guix.
>

> Greetings,
> Maxime.
Attachment: signature.asc
M
M
Maxime Devos wrote on 19 Sep 2022 15:35
(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)(address . 57809@debbugs.gnu.org)
91c51099-88b9-bcd6-6856-1ea776ec17ee@telenet.be
On 19-09-2022 06:28, Jacob Hrbek wrote:
Toggle quote (7 lines)
>>> (2) 'native-inputs' (or 'inputs'), is unbound. For information on how
>
>>> to use search-input-file, inputs and phases, see the manual, in particular (guix)Build Utilities (index entry: search-input-file) >> and
>
>>> its example.
>
> I've been searching through that thing endlessly for almost 5 hours >_> it doesn't help much for that.. I can grep the code to look for usage though which is what I did here ^-^
Here are some proposed methods for finding it, which can be adapted for
other searches as well.
* "info guix" followed by 's' 'search-input-file'
(free-form text search, good for finding examples)
* "info guix" followed by 'i' 'search-input-file'
(index entry, works well for procedure names)
* "info guix" > "Programming Interface" > "Build Utilities", followed
by some scrolling, then find 'search-input-file' there.
(using the TOC)
The first two options only take a few seconds. The latter can be quick
or long, depending on whether your guess on where it's located is good
or bad.
And a fourth option, since you seem to like grepping:
* git grep -F search-input-file doc/
(in a git checkout of Guix)
Greetings,
Maxime.
Attachment: OpenPGP_signature
M
M
Maxime Devos wrote on 19 Sep 2022 15:41
a9400538-e7d2-8a88-5531-657d2c111366@telenet.be
On 19-09-2022 06:09, Jacob Hrbek wrote:
Toggle quote (7 lines)
> + (setenv "DESTDIR" "/")))
> + (add-before 'configure 'substitute-qemu-dependencies
> + (lambda* (#:key inputs #:allow-other-keys)
> +
> (substitute* "src/installed-media.vala"
> + (("qemu-img")
> + (search-input-file inputs "/bin/qemu-img"))))))))
Aside from the indentation (which would IIUC be corrected by "guix
style", see point (5) of the checklist in "(guix)Submitting Patches")) ...
Toggle quote (7 lines)
> (native-inputs
> (list desktop-file-utils ;for update-desktop-database
> gettext-minimal
> @@ -12162,6 +12167,7 @@ (define-public gnome-boxes
> sparql-query
> spice-gtk
> tracker
Toggle quote (1 lines)
> + qemu-minimal ;for qemu-img
... and the non-alphabetical sorting, ...
Toggle quote (2 lines)
> vte
> webkitgtk-with-libsoup2)) ;for webkit2gtk-4.0
... looks good to me (though to be clear, I did not test the changes),
though those problems can be addressed by the committer (just a note for
future submissions).
Greetings,
Maxime.
Attachment: OpenPGP_signature
J
J
Jacob Hrbek wrote on 19 Sep 2022 23:36
[PATCH] gnome-boxes: Fix path for 'qemu-img'
(address . 57809@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20220919213607.24888-1-kreyren@rixotstudio.cz
---
gnu/packages/gnome.scm | 102 ++++++++++++++++++++++-------------------
1 file changed, 55 insertions(+), 47 deletions(-)

Toggle diff (132 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d6d22f8eb1..65054fc4ac 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12115,67 +12115,75 @@ (define-public gnome-boxes
(package
(name "gnome-boxes")
(version "42.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/gnome-boxes/"
- (version-major version) "/"
- "gnome-boxes-" version ".tar.xz"))
- (sha256
- (base32 "1lv0bdh935qj6wkv3ixg2pcv8yrapj79z02gw4fal3rhz3xggvsn"))))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gnome-boxes/"
+ (version-major version)
+ "/"
+
"gnome-boxes-"
+ version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "1lv0bdh935qj6wkv3ixg2pcv8yrapj79z02gw4fal3rhz3xggvsn"))))
(build-system meson-build-system)
(arguments
(list #:glib-or-gtk? #t
#:configure-flags #~(list "-Drdp=false"
- (string-append "-Dc_link_args=-Wl,-rpath="
- #$output
- "/lib/gnome-boxes"))
+ (string-append
+ "-Dc_link_args=-Wl,-rpath="
+ #$output "/lib/gnome-boxes"))
#:phases #~(modify-phases %standard-phases
(add-after 'unpack 'disable-gtk-update-icon-cache
(lambda _
- (
setenv "DESTDIR" "/"))))))
- (native-inputs
- (list desktop-file-utils ;for update-desktop-database
- gettext-minimal
- `(,glib "bin") ;for glib-compile-resources
- itstool
- pkg-config
- python
- vala))
- (inputs
- (list glib-networking ;for TLS support
- gsettings-desktop-schemas
- gtk+
- gtk-vnc
- gtksourceview
- json-glib
- libarchive
- libgudev
- libhandy
- libosinfo
- libsecret
- libsoup-minimal-2
- libusb
- libvirt
- libvirt-glib
- libxml2
- sparql-query
- spice-gtk
- tracker
- vte
- webkitgtk-with-libsoup2)) ;for webkit2gtk-4.0
+ (setenv "DESTDIR" "/")))
+ (add-before 'configure 'substitut
e-qemu-dependencies
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/installed-media.vala"
+ (("qemu-img")
+ (search-input-file inputs "/bin/qemu-img"))))))))
+ (native-inputs (list desktop-file-utils ;for update-desktop-database
+ gettext-minimal
+ `(,glib "bin") ;for glib-compile-resources
+ itstool
+ pkg-config
+ python
+ vala))
+ (inputs (list glib-networking ;for TLS support
+ gsettings-desktop-schemas
+ gtk+
+ gtk-vnc
+ gtksourceview
+ json-glib
+ libarchive
+ libgudev
+ libhandy
+ libosinfo
+ libsecret
+
libsoup-minimal-2
+ libusb
+ libvirt
+ libvirt-glib
+ libxml2
+ qemu-minimal ;for qemu-img
+ sparql-query
+ spice-gtk
+ tracker
+ vte
+ webkitgtk-with-libsoup2)) ;for webkit2gtk-4.0
(home-page "https://wiki.gnome.org/Apps/Boxes")
(synopsis "View, access, and manage remote and virtual systems")
- (description "GNOME Boxes is a simple application to view, access, and
+ (description
+ "GNOME Boxes is a simple application to view, access, and
manage remote and virtual systems. Note that this application requires the
@code{libvirt} and @code{virtlog} daemons to run. Use the command
@command{info '(guix) Virtualization Services'} to learn how to configure
these services on the Guix System.")
(license (list
- ;; For data/icons/empty-boxes.png.
-
license:cc-by2.0
- ;; For all others.
- license:lgpl2.0+))))
+ ;; For data/icons/empty-boxes.png.
+ license:cc-by2.0
+ ;; For all others.
+ license:lgpl2.0+))))

(define-public geary
(package
--
2.37.3
Attachment: signature.asc
L
L
Liliana Marie Prikler wrote on 20 Sep 2022 07:18
4220be69b689cb13ab74c3f62f7a122db712d104.camel@gmail.com
Am Montag, dem 19.09.2022 um 21:36 +0000 schrieb Jacob Hrbek:
Toggle quote (3 lines)
> ---
>  gnu/packages/gnome.scm | 102 ++++++++++++++++++++++-----------------
> --
Too much noise. Please separate cosmetic and non-cosmetic changes.

Thanks
J
J
Jacob Hrbek wrote on 20 Sep 2022 09:55
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 57809@debbugs.gnu.org)
zm8VtAMiUfewezJCbIpFNyZR34sTjCzjVChzgbuNUggfDEdpA4iGVdQvrptarOmi7X8AlOySRA0-2tY-Lp9QRoR6mzkXWSoowUNzYp3oozE=@rixotstudio.cz
Toggle quote (4 lines)
>> [Krey format the code it looks like trash]

>> [Krey there is too much cosmetic noise it looks like trash]

...


https://issues.guix.gnu.org/57809#13is the solution + `$ guix style gnome-boxes`

------- Original Message -------
On Tuesday, September 20th, 2022 at 7:18 AM, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:


Toggle quote (12 lines)
> Am Montag, dem 19.09.2022 um 21:36 +0000 schrieb Jacob Hrbek:
>

> > ---
> > gnu/packages/gnome.scm | 102 ++++++++++++++++++++++-----------------
> > --
>

> Too much noise. Please separate cosmetic and non-cosmetic changes.
>

> Thanks
Attachment: signature.asc
L
L
Liliana Marie Prikler wrote on 20 Sep 2022 19:12
(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)(address . 57809@debbugs.gnu.org)
f6442ed8a77dd63e9367c92356b7d85de9f358d8.camel@gmail.com
Am Dienstag, dem 20.09.2022 um 07:55 +0000 schrieb Jacob Hrbek:
Toggle quote (3 lines)
> > > [Krey format the code it looks like trash]
>
> > > [Krey there is too much cosmetic noise it looks like trash]
It is admittedly our fault that we're advertising tools which don't do
their job, but it's not our fault that neither you nor your text editor
know how to match up parentheses with indentation levels.
L
L
Ludovic Courtès wrote on 26 Sep 2022 22:55
control message for bug #57809
(address . control@debbugs.gnu.org)
8735cdkg92.fsf@gnu.org
merge 57809 57810
quit
L
L
Ludovic Courtès wrote on 26 Sep 2022 23:03
Re: bug#57809: [PATCH] gnome-boxes: Add 'qemu' as propagated-input
(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)(address . 57809-done@debbugs.gnu.org)
87v8p9j1ba.fsf_-_@gnu.org
Hi,

Jacob Hrbek <kreyren@rixotstudio.cz> skribis:

Toggle quote (25 lines)
> ---
> gnu/packages/gnome.scm | 12 +++++++++---
> 1 file changed, 9 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index d6d22f8eb1..ff5cb92907 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -12131,9 +12131,14 @@ (define-public gnome-boxes
> #$output
> "/lib/gnome-boxes"))
> #:phases #~(modify-phases %standard-phases
> - (add-after 'unpack 'disable-gtk-update-icon-cache
> - (lambda _
> - (setenv "DESTDIR" "/"))))))
> + (add-after 'unpack 'disable-gtk-update-icon-cache
> + (lambda _
> + (setenv "DESTDIR" "/")))
> + (add-before 'configure 'substitute-qemu-dependencies
> + (lambda* (#:key inputs #:allow-other-keys)
> +
> (substitute* "src/installed-media.vala"
> + (("qemu-img")
> + (search-input-file inputs "/bin/qemu-img"))))))))

Applied with minor tweaks and a commit log, thanks!|

Ludo’.
Closed
L
L
Ludovic Courtès wrote on 26 Sep 2022 23:07
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87o7v1j151.fsf_-_@gnu.org
Hey Liliana,

Please let’s not try to find “whose fault it is”. We’re all trying to
help.

In such a situation, my experience is that it is not only more pleasant
but also more efficient to apply the patch and those remaining tweaks by
yourself so the submitter can see what changes were made and learn from
it.

Thanks in advance,
Ludo’.
?