[PATCH] gnu: Add gnudatalanguage.

  • Open
  • quality assurance status badge
Details
5 participants
  • Andreas Enge
  • Antero Mejr
  • Ludovic Courtès
  • Sharlatan Hellseher
  • Simon Tournier
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal
A
A
Antero Mejr wrote on 25 Aug 2022 21:38
(address . guix-patches@gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20220825193833.1157970-1-antero@mailbox.org
* gnu/packages/maths.scm (gnudatalanguage): New variable.
---
Depends on eccodes, patch #57410

gnu/packages/maths.scm | 51 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (77 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 72d5e9a83a..f276b72697 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -98,6 +98,7 @@ (define-module (gnu packages maths)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages c)
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
@@ -116,8 +117,10 @@ (define-module (gnu packages maths)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gd)
+ #:use-module (gnu packages geo)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages graph)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages icu4c)
@@ -7823,3 +7826,51 @@ (define-public optizelle
provided for applications written in C++ and Python. Parallel
computation is supported via MPI.")
(license license:bsd-2))))
+
+(define-public gnudatalanguage
+ (package
+ (name "gnudatalanguage")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnudatalanguage/gdl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bb3nin3qrzx2dwdk08vffp4bblrcpv6vv1ybaj499qhqcpqpc12"))))
+ (build-system cmake-build-system)
+ (native-inputs (list python python-numpy))
+ (inputs (list eccodes
+ eigen
+ expat
+ fftw
+ fftwf
+ glpk
+ graphicsmagick
+ gsl
+ hdf4-alt
+ hdf5
+ libgeotiff
+ libjpeg-turbo
+ libpng
+ libtiff
+ libtirpc
+ ncurses
+ netcdf
+ plplot
+ proj
+ readline
+ shapelib
+ udunits
+ wxwidgets
+ zlib))
+ (home-page "https://gnudatalanguage.github.io/")
+ (synopsis "Compiler for GDL, an IDL-compatible programming language")
+ (description "GDL (GNU Data Language) is an incremental compiler compatible
+with IDL (Interactive Data Language) and to some extent with PV-WAVE. Together
+with its library routines it serves as a tool for data analysis and
+visualization in such disciplines as astronomy, geosciences and medical
+imaging.")
+ (license license:gpl2)))
--
2.37.2
A
A
Antero Mejr wrote on 25 Aug 2022 21:48
[PATCH] gnu: Add plplot.
(address . 57416@debbugs.gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20220825194803.1159036-1-antero@mailbox.org
* gnu/packages/graph.scm (plplot): New variable.
---
gnu/packages/graph.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 109ba68675..4560fa1023 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -62,6 +62,7 @@ (define-module (gnu packages graph)
#:use-module (gnu packages statistics)
#:use-module (gnu packages swig)
#:use-module (gnu packages time)
+ #:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xml))
(define-public plfit
@@ -659,3 +660,48 @@ (define-public python-graph-tool
time) to that of a pure C/C++ library.")
(home-page "https://graph-tool.skewed.de/")
(license license:lgpl3+)))
+
+(define-public plplot
+ (package
+ (name "plplot")
+ (version "5.15.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/plplot/plplot/"
+ version "%20Source/plplot-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0ywccb6bs1389zjfmc9zwdvdsvlpm7vg957whh6b5a96yvcf8bdr"))
+ (modules '((guix build utils)))
+ (snippet #~(begin (delete-file-recursively "www")
+ (substitute* "CMakeLists.txt"
+ (("add_subdirectory\\(www\\)") ""))))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list (string-append "-DLIB_DIR=" #$output "/lib")
+ "-DBUILD_TEST=TRUE"
+ "-DENABLE_wxwidgets=TRUE")))
+ (native-inputs (list pkg-config))
+ (inputs (list wxwidgets))
+ (home-page "http://plplot.org/") ;no HTTPS
+ (synopsis "Scientific plotting library with Unicode support")
+ (description "PLplot is a software package for creating scientific plots.
+The PLplot core library can be used to create:
+
+@itemize
+@item standard x-y plots
+@item semi-log plots
+@item log-log plots
+@item contour plots
+@item 3D surface plots
+@item mesh plots
+@item bar charts
+@item pie charts
+@end itemize")
+ (license (list license:lgpl2.0
+ license:gpl2+ ;octave bindings
+ license:bsd-2 ;docbook docs
+ license:ogl-psi1.0 ;files in data/ss
+ license:cc-by-sa3.0 ;examples/Chloe.pgm
+ license:expat)))) ;Cmake files
--
2.37.2
S
S
Sharlatan Hellseher wrote on 13 Dec 2022 11:56
(address . 57416@debbugs.gnu.org)
CAO+9K5pdVOVbH1Ri6nQTSg9Qf-g=01Ug-Py+tMUGB3uj-riHyA@mail.gmail.com
Hi,
GDL is very nice project to have in Guix Asto belt, there is a large chain
which depends on IDL (commercial version) but could be compiled with GDL.
PLPlot was in a queue to review for a long time as it needs more love for
packaging all components and adjust configure to detect all of the inputs.
I've got some progress on it but it still not picking up most of the inputs.
Regards,
Oleg
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
S
S
Sharlatan Hellseher wrote on 3 Feb 2023 00:58
(address . 57416@debbugs.gnu.org)
CAO+9K5q-U0ow6VG_pLLi-iianHZu9DbCrvL8zbMsDRPpwWru=w@mail.gmail.com
Hi Guix team,
Upping this issue as GDL is a nice tool (widely used in astronomy) and
Libre replacement of commercial IDL
Related paaper:
Regards,
Oleg
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
S
S
Simon Tournier wrote on 17 Feb 2023 18:14
(address . 57416@debbugs.gnu.org)
87h6vk43kf.fsf@gmail.com
Hi,

CC: team science

Thanks for this patch.

On jeu., 25 août 2022 at 15:38, Antero Mejr via Guix-patches via <guix-patches@gnu.org> wrote:

Toggle quote (2 lines)
> + (license license:gpl2)))

Since GDL is a piece of software, maybe the license of GDL is not only
GPL version 2. For instance, according to Debian, it reads:


Well, WDYT?


Cheers,
simon
A
A
Andreas Enge wrote on 18 Feb 2023 11:01
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
Y/CiDoJfQJ0pwI4t@jurong
Hello,

Am Fri, Feb 17, 2023 at 06:14:24PM +0100 schrieb Simon Tournier:
Toggle quote (4 lines)
> Since GDL is a piece of software, maybe the license of GDL is not only
> GPL version 2. For instance, according to Debian, it reads:
> https://metadata.ftp-master.debian.org/changelogs//main/g/gnudatalanguage/gnudatalanguage_0.9.9-13_copyright

looking at this page, the combined licenses combine to gpl2+.
I do not think it is necessary to be as detailed as Debian in our
poor little license field, so would add the "+" to the patch.

Andreas
S
S
Sharlatan Hellseher wrote on 13 Oct 2023 01:48
(address . 57416@debbugs.gnu.org)
CAO+9K5oE8MLYjqjrMEr0DNZVPif39wDymmnmOBWCfZ2HfnOyXA@mail.gmail.com
Hi,

I can help with adjusting this patch set if it would help.

Regards,
Oleg
Attachment: file
L
L
Ludovic Courtès wrote on 22 Dec 2023 17:17
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 57416@debbugs.gnu.org)
875y0qb499.fsf@gnu.org
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (2 lines)
> I can help with adjusting this patch set if it would help.

Yes, please! Looks almost ready.

Thanks,
Ludo’.
?