(address . guix-patches@gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
* gnu/packages/maths.scm (gnudatalanguage): New variable.
---
Depends on eccodes, patch #57410
gnu/packages/maths.scm | 51 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)
Toggle diff (77 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 72d5e9a83a..f276b72697 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -98,6 +98,7 @@ (define-module (gnu packages maths)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages c)
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
@@ -116,8 +117,10 @@ (define-module (gnu packages maths)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gd)
+ #:use-module (gnu packages geo)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages graph)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages icu4c)
@@ -7823,3 +7826,51 @@ (define-public optizelle
provided for applications written in C++ and Python. Parallel
computation is supported via MPI.")
(license license:bsd-2))))
+
+(define-public gnudatalanguage
+ (package
+ (name "gnudatalanguage")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnudatalanguage/gdl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bb3nin3qrzx2dwdk08vffp4bblrcpv6vv1ybaj499qhqcpqpc12"))))
+ (build-system cmake-build-system)
+ (native-inputs (list python python-numpy))
+ (inputs (list eccodes
+ eigen
+ expat
+ fftw
+ fftwf
+ glpk
+ graphicsmagick
+ gsl
+ hdf4-alt
+ hdf5
+ libgeotiff
+ libjpeg-turbo
+ libpng
+ libtiff
+ libtirpc
+ ncurses
+ netcdf
+ plplot
+ proj
+ readline
+ shapelib
+ udunits
+ wxwidgets
+ zlib))
+ (home-page "https://gnudatalanguage.github.io/")
+ (synopsis "Compiler for GDL, an IDL-compatible programming language")
+ (description "GDL (GNU Data Language) is an incremental compiler compatible
+with IDL (Interactive Data Language) and to some extent with PV-WAVE. Together
+with its library routines it serves as a tool for data analysis and
+visualization in such disciplines as astronomy, geosciences and medical
+imaging.")
+ (license license:gpl2)))
--
2.37.2