[PATCH 0/2] Add boohu.

  • Open
  • quality assurance status badge
Details
2 participants
  • Cairn
  • Maxime Devos
Owner
unassigned
Submitted by
Cairn
Severity
normal
C
(address . guix-patches@gnu.org)(name . Cairn)(address . cairn@pm.me)
20220824215510.5546-1-cairn@pm.me

This is both the normal terminal version and a graphical version that uses Tcl/Tk.

Harmonist, another game by the same developer, used to use Tcl/Tk like Boohu does here. It switched to SDL2, and `harmonist-tk` was removed from Guix[1]. I just submitted a patchset for the SDL2 version of Harmonist[2], and I'll gladly do the same if Boohu gets SDL2 support backported. Until then, the Tcl/Tk version is perfectly stable, and I wouldn't consider it out-of-date.


Cairn (2):
gnu: Add boohu.
gnu: Add boohu-tk.

gnu/packages/games.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

--
2.37.2
C
[PATCH 1/2] gnu: Add boohu.
(address . 57392@debbugs.gnu.org)(name . Cairn)(address . cairn@pm.me)
20220824215624.5646-1-cairn@pm.me
* gnu/packages/games.scm (boohu): New variable.
---
gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a3278b8918..ac9190d1a7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9505,6 +9505,36 @@ (define-public harmonist
on items and player adaptability for character progression.")
(license license:isc)))
+(define-public boohu
+ (package
+ (name "boohu")
+ (version "0.13.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.tuxfamily.org/boohu/boohu.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g8sziji2bpqfqlmxw51zgnx048k245149cpn29cadpmw75viz44"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "git.tuxfamily.org/boohu/boohu"))
+ (inputs (list go-github-com-gdamore-tcell-v2
+ go-github.com-nsf-termbox-go
+ go-github-com-anaseto-gruid
+ go-github-com-anaseto-gruid-tcell))
+ (home-page "https://download.tuxfamily.org/boohu/index.html")
+ (synopsis "Tactical positioning coffee-break roguelike game")
+ (description "Break Out Of Hareka's Underground (Boohu) is a turn-based
+coffee-break roguelike game with a heavy focus on tactical positioning
+mechanisms. This focus strongly influenced its weapon attack patterns,
+consumables and terrain features. Aiming for a replayable streamlined
+experience, the game avoids manual inventory management and complex character
+building, relying on items and player adaptability for character progression.")
+ (license license:isc)))
+
(define-public drascula
(package
(name "drascula")
--
2.37.2
C
[PATCH 2/2] gnu: Add boohu-tk.
(address . 57392@debbugs.gnu.org)(name . Cairn)(address . cairn@pm.me)
20220824215647.5707-1-cairn@pm.me
* gnu/packages/games.scm (boohu-tk): New variable.
---
gnu/packages/games.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ac9190d1a7..b201c6a074 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9535,6 +9535,19 @@ (define-public boohu
building, relying on items and player adaptability for character progression.")
(license license:isc)))
+(define-public boohu-tk
+ (package
+ (inherit boohu)
+ (name "boohu-tk")
+ (inputs
+ (modify-inputs (package-inputs boohu)
+ (append go-github.com-nsf-gothic)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments boohu)
+ ((#:build-flags flags ''())
+ `(append '("--tags" "tk")
+ ,flags))))))
+
(define-public drascula
(package
(name "drascula")
--
2.37.2
M
M
Maxime Devos wrote on 19 Sep 2022 15:18
Re: bug#57932: Mes has overly-generic MES_PREFIX search path (was: `environment_variables` in build containers are set wrong)
7a4e8523-e9b1-ed51-16e8-0d1e918693ba@telenet.be
retitle 57392 Mes has overly-generic MES_PREFIX search path
thanks
On 19-09-2022 13:17, Ekaitz Zarraga wrote:
Toggle quote (14 lines)
> Hi,
>
> I have a package that depends on `mes`.
>
> When I build it with `guix build $package -K` and I jump to the resulting build directory, the `environment_variables` file looks like this:
>
> ```
> [...]
> export MES_PREFIX="/gnu/store/hy6abswwv4d89zp464fw52z65fkzr7h5-perl-5.34.0/"
> ```
>
> The `MES_PREFIX` is set to Perl's installation directory, which is also the first element in `LIBRARY_PATH`.
>
> If I change the order of the package inputs the order of the `LIBRARY_PATH` changes, which is not important, but the first element of `LIBRARY_PATH` is always the one in the `MES_PREFIX`. This doesn't look like the proper behavior: it should always be /gnu/store/*-mes-*
Looking at the search paths of 'mes', it has
(search-path-specification
(variable "MES_PREFIX")
(separator #f)
(files '("")))))
so it 'accept's _all_ the store items. As such, I've renamed the issue
(if you think the new name is inappropriate, feel free to rename it back.)
How about, instead of having a $MES_PREFIX environment variable and
search path, substitute* uses of MES_PREFIX to #$output in a phase?
Greetings,
Maxime.
Attachment: OpenPGP_signature
C
(name . Maxime Devos)(address . maximedevos@telenet.be)(name . 57392@debbugs.gnu.org)(address . 57392@debbugs.gnu.org)
4BB_VkserRUMKIZOMtiL6xEFKn-qONGv_ACBDel4WRtZ0NXgAEZWd0U1JnJ_8jZdba7YjRMAEy81tpAvBYUGa3S0FsY28oknu7zhWgdOJhY=@pm.me
Toggle quote (3 lines)
> retitle 57392 Mes has overly-generic MES_PREFIX search path
> thanks

Just noticed this email. Looks like you sent it to the wrong issue number! Could you retitle this one to the original title?
Attachment: signature.asc
M
M
M
Maxime Devos wrote on 11 Oct 2022 16:20
(name . Cairn)(address . cairn@pm.me)(name . 57392@debbugs.gnu.org)(address . 57392@debbugs.gnu.org)
792e3c74-d7ec-12a1-7bea-179ce2a07f4d@telenet.be
On 11-10-2022 05:24, Cairn wrote:
Toggle quote (4 lines)
>> retitle 57392 Mes has overly-generic MES_PREFIX search path
>> thanks
>
> Just noticed this email. Looks like you sent it to the wrong issue number! Could you retitle this one to the original title?
Done.
Attachment: OpenPGP_signature
?