[PATCH 0/3] gnu: Add harmonist-sdl.

  • Done
  • quality assurance status badge
Details
2 participants
  • Cairn
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Cairn
Severity
normal

Debbugs page

Cairn wrote 3 years ago
(address . guix-patches@gnu.org)(name . Cairn)(address . cairn@pm.me)
20220824180118.28815-1-cairn@pm.me
This is the SDL2 version of Harmonist.


It's just an inheritence of the `harmonist` package, but I'm hoping the difference between the two packages is obvious enough not to require its own description. I didn't find a lot of inherited packages which change the original description, so I'm following their example.

Cairn (3):
gnu: Add go-github-com-veandco-go-sdl2.
gnu: Add go-github-com-anaseto-gruid-sdl.
gnu: Add harmonist-sdl.

gnu/packages/games.scm | 43 +++++++++++++++++++++++++++++++++++++++++
gnu/packages/golang.scm | 32 ++++++++++++++++++++++++++++++
2 files changed, 75 insertions(+)

--
2.37.2
Cairn wrote 3 years ago
[PATCH 1/3] gnu: Add go-github-com-veandco-go-sdl2.
(address . 57390@debbugs.gnu.org)(name . Cairn)(address . cairn@pm.me)
20220824180447.29003-1-cairn@pm.me
* gnu/packages/golang.scm (go-github-com-veandco-go-sdl2): New variable.
---
gnu/packages/golang.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d2f3dc39df..b295b826e9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
;;; Copyright © 2022 Pier-Hugues Pellerin <phpellerin@gmail.com>
;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 Cairn <cairn@pm.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -83,6 +84,7 @@ (define-module (gnu packages golang)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
+ #:use-module (gnu packages sdl)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
@@ -9914,3 +9916,33 @@ (define-public go-github-com-sourcegraph-jsonrpc2
(description
"Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")
(license license:expat)))
+
+(define-public go-github-com-veandco-go-sdl2
+ (package
+ (name "go-github-com-veandco-go-sdl2")
+ (version "0.4.25")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/veandco/go-sdl2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jvk0bpbq7dbza03a5j9yisij65si59zqzn2x9km2xjdjzbdzpyy"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:tests? #f
+ #:import-path "github.com/veandco/go-sdl2/sdl"
+ #:unpack-path "github.com/veandco/go-sdl2"))
+ (native-inputs (list pkg-config))
+ (propagated-inputs (list sdl2
+ sdl2-image
+ sdl2-mixer
+ sdl2-ttf
+ sdl2-gfx))
+ (home-page "https://github.com/veandco/go-sdl2")
+ (synopsis "Go bindings for the SDL2 library")
+ (description "Go-SDL2 is SDL2 wrapped for Go users. It enables
+interoperability between Go and the SDL2 library.")
+ (license license:bsd-3)))
--
2.37.2
Cairn wrote 3 years ago
[PATCH 2/3] gnu: Add go-github-com-anaseto-gruid-sdl.
(address . 57390@debbugs.gnu.org)(name . Cairn)(address . cairn@pm.me)
20220824180614.29179-1-cairn@pm.me
* gnu/packages/games.scm (go-github-com-anaseto-gruid-sdl): New variable.
---
gnu/packages/games.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a3278b8918..7f5d59cce1 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9474,6 +9474,32 @@ (define-public go-github-com-anaseto-gruid-tcell
terminal full-window applications.")
(license license:isc)))
+(define-public go-github-com-anaseto-gruid-sdl
+ (package
+ (name "go-github-com-anaseto-gruid-sdl")
+ (version "0.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anaseto/gruid-sdl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14g26kskkkp509bnql5brbainxxvp59qb59b5s7qqgv9hxgx201m"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/anaseto/gruid-sdl"))
+ (native-inputs (list pkg-config))
+ (inputs (list go-github-com-anaseto-gruid
+ go-golang-org-x-image))
+ (propagated-inputs (list go-github-com-veandco-go-sdl2))
+ (home-page "https://github.com/anaseto/gruid-sdl")
+ (synopsis "Gruid driver for using the SDL2 library")
+ (description "The gruid-sdl2 module provides a Gruid driver for
+building native graphical applications with SDL2.")
+ (license license:isc)))
+
(define-public harmonist
(package
(name "harmonist")
--
2.37.2
Cairn wrote 3 years ago
[PATCH 3/3] gnu: Add harmonist-sdl.
(address . 57390@debbugs.gnu.org)(name . Cairn)(address . cairn@pm.me)
20220824180646.29263-1-cairn@pm.me
* gnu/packages/games.scm (harmonist-sdl): New variable.
---
gnu/packages/games.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7f5d59cce1..6e8e695c02 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -73,6 +73,7 @@
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Cairn <cairn@pm.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9531,6 +9532,22 @@ (define-public harmonist
on items and player adaptability for character progression.")
(license license:isc)))
+(define-public harmonist-sdl
+ (package
+ (inherit harmonist)
+ (name "harmonist-sdl")
+ (native-inputs
+ (modify-inputs (package-native-inputs harmonist)
+ (append pkg-config)))
+ (inputs
+ (modify-inputs (package-inputs harmonist)
+ (append go-github-com-anaseto-gruid-sdl)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments harmonist)
+ ((#:build-flags flags ''())
+ `(append '("--tags" "sdl")
+ ,flags))))))
+
(define-public drascula
(package
(name "drascula")
--
2.37.2
Sharlatan Hellseher wrote 4 weeks ago
[PATCH 0/3] gnu: Add harmonist-sdl.
(address . 57390-done@debbugs.gnu.org)
87v7tbch3f.fsf@gmail.com
Hi,

Thanks for the proposed patches, I've mentioned you as co-author during
update on Harmonist to 0.5.1 and include harmonist-sdl as package
variant.

298ebc3c1f0 * gnu: Remove go-github-com-anaseto-gruid.
7b9fc84a693 * gnu: Remove go-github-com-anaseto-gruid-tcell.
bf17046d8bf * gnu: harmonist: Update to 0.5.1.
54e86bc1706 * gnu: Add go-codeberg-org-anaseto-gruid-tcell.
ca625c59551 * gnu: Add go-codeberg-org-anaseto-gruid-sdl.
679c74fc4a2 * gnu: Add go-github-com-veandco-go-sdl2.
014a5fc785f * gnu: Add go-codeberg-org-anaseto-gruid-js.
751b5c5b654 * gnu: Add go-codeberg-org-anaseto-gruid.

Closing as resolved in other way.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmewv3QACgkQdtcnv/Ys
0rVVMQ/+MKUAnBno+f9n237R+BcHEz0DZOYI1H+Nm3iuCKRCBE1EUarS49/OdlFE
gCrFR84wbWU54F8Cd37rZq9q+TEAaQuz2wkHB6cueDYueD6ABJxpOtxWZvU56hjA
84LUIuHqawZ/mJ2hl1B6OSPK1eB8wVUUbP6eKhvgJy4VujaqB1iX6J5LsIEv+OnI
NeLL2pz2OFBkFxwZJYayQJjF7iB9DB9k6e3lZaiXsIAps/nBZIn0tYVMzIzdlQ5n
G1S9Nmo9CoWQPI2jnmMRqc8Tn3/cFMFCB5pZu5Iilkg1Qx1Dg/qeIZXg/ae9HrC5
GPr4yH8DkmaTKreBM2m/BSbcP6FBaKVsakCfGstoFvz2qHPZpNaNdiYEKdXWQ7Lr
5/7m4lPhmcDzgd9rP8VK+dL1mCKqgkcGf4zFvmFnok5z1DFfD+C0od3wJzFUTwSk
IL/EkGCOYBtd2erQiz0Iuqf0ZU17c91cqprPpxZJFCnZiXUKS+YpJYsvJVB8ovV9
z6xxAyAfX822ZgIP9dpdoLGj9C1RKL73sYXYg4zCLG7yPhAt3RGWdUknVrpfFat1
FxRWez5/cGOeIiP8bZJC3EDZNS1VOkf+LesmvUJD//G2Pww/fuDzwKWtmDlK4VD7
uc/F0z027+s/dxKReFuGTBX3VSvRBHNmcs+/Ey8pZuQwGb1Y1+c=
=43Io
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 57390@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57390
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help