[PATCH] gnu: packages: Add nmail.

  • Open
  • quality assurance status badge
Details
2 participants
  • M
  • Mathieu Othacehe
Owner
unassigned
Submitted by
M
Severity
normal
Merged with
M
(address . guix-patches@gnu.org)(name . M)(address . matf@disr.it)
d4bd4555b09366c28463643e16b272ad7ca4eed8.1659826927.git.matf@disr.it
* gnu/packages/nmail.scm: Reorder module imports. Remove
duplicate imports.
(nmail): New variable. Fix style.
---
gnu/packages/mail.scm | 23 ++++++++++++-----------
1 file changed, 12 insertions(+), 11 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 0bc6519dd2..24730d5eb3 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -456,19 +456,20 @@ (define-public nmail
"07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
(build-system cmake-build-system)
(arguments
- (list #:phases #~(modify-phases %standard-phases
+ (list #:phases
+ #~(modify-phases %standard-phases
(replace 'check
- (lambda*
- (#:key tests? #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests? (invoke "ctest" "--output-on-failure")))))))
- (inputs (list libetpan
- xapian
- sqlite
- cyrus-sasl
- ncurses
- openssl
- file
- (list util-linux "lib")))
+ (inputs
+ (list cyrus-sasl
+ file
+ libetpan
+ ncurses
+ openssl
+ sqlite
+ (list util-linux "lib")
+ xapian))
(native-inputs (list pkg-config))
(home-page "https://github.com/d99kris/nmail")
(synopsis "Terminal-based email client")
--
2.34.0
M
M
Mathieu wrote on 7 Aug 2022 01:24
merge 56994 57201
(address . control@debbugs.gnu.org)
e1b4c5ad-ffb1-4aed-a26f-92ac831441f6@disroot.org
merge 56994 57021
M
M
Mathieu Othacehe wrote on 12 Aug 2022 10:53
Re: bug#57021: [PATCH] gnu: packages: Add nmail.
(name . M)(address . matf@disr.it)(address . 57021@debbugs.gnu.org)
8735e1267m.fsf@gnu.org
Hello,

Toggle quote (4 lines)
> * gnu/packages/nmail.scm: Reorder module imports. Remove
> duplicate imports.
> (nmail): New variable. Fix style.

Thanks for this first contribution. As you are adding a new package, the
preferred way to proceed is to amend your first patch with those changes
and submit a new revision (v2).

The module re-ordering stuff should also be part of a new patch. In
short, we would expect something like:

* gnu: Reorder mail module imports.
* gnu: nmail: New variable.

Do you think you could send those two patches in a v3? Don't hesitate to
ask for guidance here or on IRC if I'm unclear.

Mathieu
M
M
Mathieu wrote on 16 Aug 2022 15:38
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 57021@debbugs.gnu.org)
ba2164c2-3b4c-4264-8277-74541f61fd15@disroot.org
Thanks, I'll try to do that. However I see that the nmail dev is currently fixing multiple bugs that were reported lately, so I think it would be best if I wait until the next release.

Thanks for your help!

M

On 2022-08-12 10:53 Mathieu Othacehe <othacehe@gnu.org> wrote:

Toggle quote (24 lines)
>
> Hello,
>
>> * gnu/packages/nmail.scm: Reorder module imports. Remove
>> duplicate imports.
>> (nmail): New variable. Fix style.
>
> Thanks for this first contribution. As you are adding a new package,
> the
> preferred way to proceed is to amend your first patch with those
> changes
> and submit a new revision (v2).
>
> The module re-ordering stuff should also be part of a new patch. In
> short, we would expect something like:
>
> * gnu: Reorder mail module imports.
> * gnu: nmail: New variable.
>
> Do you think you could send those two patches in a v3? Don't hesitate
> to
> ask for guidance here or on IRC if I'm unclear.
>
> Mathieu
M
[PATCH v3] gnu: Add nmail.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220911214146.9920-1-matf@disr.it
* gnu/packages/mail.scm (nmail): New variable.
---
gnu/packages/mail.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 65d8060862..0526ccb521 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -405,6 +406,42 @@ (define-public mailutils
;; Libraries are under LGPLv3+, and programs under GPLv3+.
(list license:gpl3+ license:lgpl3+))))
+(define-public nmail
+ (package
+ (name "nmail")
+ (version "3.74")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/d99kris/nmail/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda*
+ (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "ctest" "--output-on-failure")))))))
+ (inputs (list libetpan
+ xapian
+ sqlite
+ cyrus-sasl
+ ncurses
+ openssl
+ file
+ (list util-linux "lib")))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/d99kris/nmail")
+ (synopsis "Terminal-based email client")
+ (description
+ "@command{nmail} is a terminal-based email client with a
+@code{ncurses} user interface similar to @code{alpine} and @code{pine}.")
+ (license license:expat)))
+
(define-public go-gitlab.com-shackra-goimapnotify
(package
(name "go-gitlab.com-shackra-goimapnotify")
--
2.37.2
M
M
Mathieu wrote on 11 Sep 2022 23:46
(address . 57021@debbugs.gnu.org)
ed6d2d10-dce7-486e-9ec5-e0f570857efd@disroot.org
I am sending a v3 patch even though a new version of nmail has not been released upstream, but will try to update it when a new version is available.

As far as I understand, the imports are no longer necessary with master, I think all required modules are already in mail.scm now, and properly sorted in alphabetic order (so that should not be necessary either). Please let me know if I got something wrong.
M
M
Mathieu wrote on 11 Sep 2022 23:56
(name . M)(address . matf@disr.it)(address . 57021@debbugs.gnu.org)
7256f1ab-46c7-4609-b3e0-f7ae92c30a05@disroot.org
And I'll be sending a v4 very soon because I see that the v3 above doesn't take into account the latest changesi from the v2, I reused an outdated version of the patch. My bad.
M
[PATCH v4] gnu: Add nmail.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220911220108.32405-1-matf@disr.it
* gnu/packages/mail.scm (nmail): New variable.
---
gnu/packages/mail.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 65d8060862..8f2452a61f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -405,6 +406,43 @@ (define-public mailutils
;; Libraries are under LGPLv3+, and programs under GPLv3+.
(list license:gpl3+ license:lgpl3+))))
+(define-public nmail
+ (package
+ (name "nmail")
+ (version "3.74")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/d99kris/nmail/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "ctest" "--output-on-failure")))))))
+ (inputs
+ (list cyrus-sasl
+ file
+ libetpan
+ ncurses
+ openssl
+ sqlite
+ (list util-linux "lib")
+ xapian))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/d99kris/nmail")
+ (synopsis "Terminal-based email client")
+ (description
+ "@command{nmail} is an easily configurable terminal-based email client with
+a @code{ncurses} user interface similar to @code{alpine} and @code{pine}.")
+ (license license:expat)))
+
(define-public go-gitlab.com-shackra-goimapnotify
(package
(name "go-gitlab.com-shackra-goimapnotify")
--
2.37.2
M
[PATCH v5] gnu: Add nmail.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220915122417.22636-1-matf@disr.it
* gnu/packages/mail.scm (nmail): New variable.
---
gnu/packages/mail.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 65d8060862..8f2452a61f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -405,6 +406,43 @@ (define-public mailutils
;; Libraries are under LGPLv3+, and programs under GPLv3+.
(list license:gpl3+ license:lgpl3+))))
+(define-public nmail
+ (package
+ (name "nmail")
+ (version "3.74")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/d99kris/nmail/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "ctest" "--output-on-failure")))))))
+ (inputs
+ (list cyrus-sasl
+ file
+ libetpan
+ ncurses
+ openssl
+ sqlite
+ (list util-linux "lib")
+ xapian))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/d99kris/nmail")
+ (synopsis "Terminal-based email client")
+ (description
+ "@command{nmail} is an easily configurable terminal-based email client with
+a @code{ncurses} user interface similar to @code{alpine} and @code{pine}.")
+ (license license:expat)))
+
(define-public go-gitlab.com-shackra-goimapnotify
(package
(name "go-gitlab.com-shackra-goimapnotify")
--
2.37.2
M
[PATCH v6] Enable login in cyrus-sasl, as Exchange servers expect it
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220915122601.29255-1-matf@disr.it
---
gnu/packages/cyrus-sasl.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 2cd18f3e5e..4e23bd5fe0 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,7 +55,8 @@ (define-public cyrus-sasl
(list ;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
mit-krb5))
(arguments
- '(#:configure-flags (list (string-append "--with-plugindir="
+ '(#:configure-flags (list (string-append "--enable-login"
+ "--with-plugindir="
(assoc-ref %outputs "out")
"/lib/sasl2"))
--
2.37.2
M
[PATCH v7] gnu: cyrus-sasl: Enable login.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220915123703.3852-1-matf@disr.it
* gnu/packages/cyrus-sasl.scm (cyrus-sasl)[arguments]: Enable login.

Exchange servers require login for e-mail clients that use cyrus-sasl.
---
gnu/packages/cyrus-sasl.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 2cd18f3e5e..4e23bd5fe0 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,7 +55,8 @@ (define-public cyrus-sasl
(list ;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
mit-krb5))
(arguments
- '(#:configure-flags (list (string-append "--with-plugindir="
+ '(#:configure-flags (list (string-append "--enable-login"
+ "--with-plugindir="
(assoc-ref %outputs "out")
"/lib/sasl2"))
--
2.37.2
M
[PATCH v7 1/2] gnu: Add nmail.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220916092244.1741-1-matf@disr.it
* gnu/packages/mail.scm (nmail): New variable.
---
gnu/packages/mail.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 65d8060862..8f2452a61f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -405,6 +406,43 @@ (define-public mailutils
;; Libraries are under LGPLv3+, and programs under GPLv3+.
(list license:gpl3+ license:lgpl3+))))
+(define-public nmail
+ (package
+ (name "nmail")
+ (version "3.74")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/d99kris/nmail/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "ctest" "--output-on-failure")))))))
+ (inputs
+ (list cyrus-sasl
+ file
+ libetpan
+ ncurses
+ openssl
+ sqlite
+ (list util-linux "lib")
+ xapian))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/d99kris/nmail")
+ (synopsis "Terminal-based email client")
+ (description
+ "@command{nmail} is an easily configurable terminal-based email client with
+a @code{ncurses} user interface similar to @code{alpine} and @code{pine}.")
+ (license license:expat)))
+
(define-public go-gitlab.com-shackra-goimapnotify
(package
(name "go-gitlab.com-shackra-goimapnotify")
--
2.37.2
M
[PATCH v7 2/2] gnu: cyrus-sasl: Enable login.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220916092244.1741-2-matf@disr.it
* gnu/packages/cyrus-sasl.scm (cyrus-sasl)[arguments]: Enable login.

Exchange servers require login for e-mail clients that use cyrus-sasl.
---
gnu/packages/cyrus-sasl.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 2cd18f3e5e..edeb2dded2 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,10 +55,11 @@ (define-public cyrus-sasl
(list ;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
mit-krb5))
(arguments
- '(#:configure-flags (list (string-append "--with-plugindir="
+ '(#:configure-flags (list "--enable-login"
+ (string-append "--with-plugindir="
(assoc-ref %outputs "out")
"/lib/sasl2"))
-
+
;; The 'plugins' directory has shared source files, such as
;; 'plugin_common.c'. When building the shared libraries there, libtool
;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
--
2.37.2
M
[PATCH v8 1/2] gnu: Add nmail.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220924135518.21476-1-matf@disr.it
* gnu/packages/mail.scm (nmail): New variable.
---
gnu/packages/mail.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 65d8060862..8f2452a61f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -405,6 +406,43 @@ (define-public mailutils
;; Libraries are under LGPLv3+, and programs under GPLv3+.
(list license:gpl3+ license:lgpl3+))))
+(define-public nmail
+ (package
+ (name "nmail")
+ (version "3.74")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/d99kris/nmail/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "ctest" "--output-on-failure")))))))
+ (inputs
+ (list cyrus-sasl
+ file
+ libetpan
+ ncurses
+ openssl
+ sqlite
+ (list util-linux "lib")
+ xapian))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/d99kris/nmail")
+ (synopsis "Terminal-based email client")
+ (description
+ "@command{nmail} is an easily configurable terminal-based email client with
+a @code{ncurses} user interface similar to @code{alpine} and @code{pine}.")
+ (license license:expat)))
+
(define-public go-gitlab.com-shackra-goimapnotify
(package
(name "go-gitlab.com-shackra-goimapnotify")
--
2.37.2
M
[PATCH v8 2/2] gnu: cyrus-sasl: Enable login.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220924135518.21476-2-matf@disr.it
* gnu/packages/cyrus-sasl.scm (cyrus-sasl)[arguments]: Enable login.

Exchange servers require login for e-mail clients that use cyrus-sasl.
---
gnu/packages/cyrus-sasl.scm | 6 ++++--
gnu/packages/mail.scm | 4 ++--
2 files changed, 6 insertions(+), 4 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 2cd18f3e5e..edeb2dded2 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,10 +55,11 @@ (define-public cyrus-sasl
(list ;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
mit-krb5))
(arguments
- '(#:configure-flags (list (string-append "--with-plugindir="
+ '(#:configure-flags (list "--enable-login"
+ (string-append "--with-plugindir="
(assoc-ref %outputs "out")
"/lib/sasl2"))
-
+
;; The 'plugins' directory has shared source files, such as
;; 'plugin_common.c'. When building the shared libraries there, libtool
;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 8f2452a61f..f127772a92 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -409,7 +409,7 @@ (define-public mailutils
(define-public nmail
(package
(name "nmail")
- (version "3.74")
+ (version "3.89")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -418,7 +418,7 @@ (define-public nmail
(file-name (git-file-name name version))
(sha256
(base32
- "07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
+ "1ris5fijmk41279hm9kp1v0niiq83a2lk2mmq1r9z31k7n2yg2v2"))))
(build-system cmake-build-system)
(arguments
(list #:phases
--
2.37.2
?