[PATCH] gnu: packages: Add nmail.

  • Done
  • quality assurance status badge
Details
5 participants
  • Christina O'Donnell
  • Christopher Baines
  • M
  • Mathieu
  • Mathieu Othacehe
Owner
Somebody
Submitted by
M
Severity
normal
Merged with
M
(address . guix-patches@gnu.org)(name . M)(address . matf@disr.it)
d4bd4555b09366c28463643e16b272ad7ca4eed8.1659826927.git.matf@disr.it
* gnu/packages/nmail.scm: Reorder module imports. Remove
duplicate imports.
(nmail): New variable. Fix style.
---
gnu/packages/mail.scm | 23 ++++++++++++-----------
1 file changed, 12 insertions(+), 11 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 0bc6519dd2..24730d5eb3 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -456,19 +456,20 @@ (define-public nmail
"07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
(build-system cmake-build-system)
(arguments
- (list #:phases #~(modify-phases %standard-phases
+ (list #:phases
+ #~(modify-phases %standard-phases
(replace 'check
- (lambda*
- (#:key tests? #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests? (invoke "ctest" "--output-on-failure")))))))
- (inputs (list libetpan
- xapian
- sqlite
- cyrus-sasl
- ncurses
- openssl
- file
- (list util-linux "lib")))
+ (inputs
+ (list cyrus-sasl
+ file
+ libetpan
+ ncurses
+ openssl
+ sqlite
+ (list util-linux "lib")
+ xapian))
(native-inputs (list pkg-config))
(home-page "https://github.com/d99kris/nmail")
(synopsis "Terminal-based email client")
--
2.34.0
M
M
Mathieu wrote on 7 Aug 2022 01:24
merge 56994 57201
(address . control@debbugs.gnu.org)
e1b4c5ad-ffb1-4aed-a26f-92ac831441f6@disroot.org
merge 56994 57021
M
M
Mathieu Othacehe wrote on 12 Aug 2022 10:53
Re: bug#57021: [PATCH] gnu: packages: Add nmail.
(name . M)(address . matf@disr.it)(address . 57021@debbugs.gnu.org)
8735e1267m.fsf@gnu.org
Hello,

Toggle quote (4 lines)
> * gnu/packages/nmail.scm: Reorder module imports. Remove
> duplicate imports.
> (nmail): New variable. Fix style.

Thanks for this first contribution. As you are adding a new package, the
preferred way to proceed is to amend your first patch with those changes
and submit a new revision (v2).

The module re-ordering stuff should also be part of a new patch. In
short, we would expect something like:

* gnu: Reorder mail module imports.
* gnu: nmail: New variable.

Do you think you could send those two patches in a v3? Don't hesitate to
ask for guidance here or on IRC if I'm unclear.

Mathieu
M
M
Mathieu wrote on 16 Aug 2022 15:38
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 57021@debbugs.gnu.org)
ba2164c2-3b4c-4264-8277-74541f61fd15@disroot.org
Thanks, I'll try to do that. However I see that the nmail dev is currently fixing multiple bugs that were reported lately, so I think it would be best if I wait until the next release.

Thanks for your help!

M

On 2022-08-12 10:53 Mathieu Othacehe <othacehe@gnu.org> wrote:

Toggle quote (24 lines)
>
> Hello,
>
>> * gnu/packages/nmail.scm: Reorder module imports. Remove
>> duplicate imports.
>> (nmail): New variable. Fix style.
>
> Thanks for this first contribution. As you are adding a new package,
> the
> preferred way to proceed is to amend your first patch with those
> changes
> and submit a new revision (v2).
>
> The module re-ordering stuff should also be part of a new patch. In
> short, we would expect something like:
>
> * gnu: Reorder mail module imports.
> * gnu: nmail: New variable.
>
> Do you think you could send those two patches in a v3? Don't hesitate
> to
> ask for guidance here or on IRC if I'm unclear.
>
> Mathieu
M
[PATCH v3] gnu: Add nmail.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220911214146.9920-1-matf@disr.it
* gnu/packages/mail.scm (nmail): New variable.
---
gnu/packages/mail.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 65d8060862..0526ccb521 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -405,6 +406,42 @@ (define-public mailutils
;; Libraries are under LGPLv3+, and programs under GPLv3+.
(list license:gpl3+ license:lgpl3+))))
+(define-public nmail
+ (package
+ (name "nmail")
+ (version "3.74")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/d99kris/nmail/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda*
+ (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "ctest" "--output-on-failure")))))))
+ (inputs (list libetpan
+ xapian
+ sqlite
+ cyrus-sasl
+ ncurses
+ openssl
+ file
+ (list util-linux "lib")))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/d99kris/nmail")
+ (synopsis "Terminal-based email client")
+ (description
+ "@command{nmail} is a terminal-based email client with a
+@code{ncurses} user interface similar to @code{alpine} and @code{pine}.")
+ (license license:expat)))
+
(define-public go-gitlab.com-shackra-goimapnotify
(package
(name "go-gitlab.com-shackra-goimapnotify")
--
2.37.2
M
M
Mathieu wrote on 11 Sep 2022 23:46
(address . 57021@debbugs.gnu.org)
ed6d2d10-dce7-486e-9ec5-e0f570857efd@disroot.org
I am sending a v3 patch even though a new version of nmail has not been released upstream, but will try to update it when a new version is available.

As far as I understand, the imports are no longer necessary with master, I think all required modules are already in mail.scm now, and properly sorted in alphabetic order (so that should not be necessary either). Please let me know if I got something wrong.
M
M
Mathieu wrote on 11 Sep 2022 23:56
(name . M)(address . matf@disr.it)(address . 57021@debbugs.gnu.org)
7256f1ab-46c7-4609-b3e0-f7ae92c30a05@disroot.org
And I'll be sending a v4 very soon because I see that the v3 above doesn't take into account the latest changesi from the v2, I reused an outdated version of the patch. My bad.
M
[PATCH v4] gnu: Add nmail.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220911220108.32405-1-matf@disr.it
* gnu/packages/mail.scm (nmail): New variable.
---
gnu/packages/mail.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 65d8060862..8f2452a61f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -405,6 +406,43 @@ (define-public mailutils
;; Libraries are under LGPLv3+, and programs under GPLv3+.
(list license:gpl3+ license:lgpl3+))))
+(define-public nmail
+ (package
+ (name "nmail")
+ (version "3.74")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/d99kris/nmail/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "ctest" "--output-on-failure")))))))
+ (inputs
+ (list cyrus-sasl
+ file
+ libetpan
+ ncurses
+ openssl
+ sqlite
+ (list util-linux "lib")
+ xapian))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/d99kris/nmail")
+ (synopsis "Terminal-based email client")
+ (description
+ "@command{nmail} is an easily configurable terminal-based email client with
+a @code{ncurses} user interface similar to @code{alpine} and @code{pine}.")
+ (license license:expat)))
+
(define-public go-gitlab.com-shackra-goimapnotify
(package
(name "go-gitlab.com-shackra-goimapnotify")
--
2.37.2
M
[PATCH v5] gnu: Add nmail.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220915122417.22636-1-matf@disr.it
* gnu/packages/mail.scm (nmail): New variable.
---
gnu/packages/mail.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 65d8060862..8f2452a61f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -405,6 +406,43 @@ (define-public mailutils
;; Libraries are under LGPLv3+, and programs under GPLv3+.
(list license:gpl3+ license:lgpl3+))))
+(define-public nmail
+ (package
+ (name "nmail")
+ (version "3.74")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/d99kris/nmail/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "ctest" "--output-on-failure")))))))
+ (inputs
+ (list cyrus-sasl
+ file
+ libetpan
+ ncurses
+ openssl
+ sqlite
+ (list util-linux "lib")
+ xapian))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/d99kris/nmail")
+ (synopsis "Terminal-based email client")
+ (description
+ "@command{nmail} is an easily configurable terminal-based email client with
+a @code{ncurses} user interface similar to @code{alpine} and @code{pine}.")
+ (license license:expat)))
+
(define-public go-gitlab.com-shackra-goimapnotify
(package
(name "go-gitlab.com-shackra-goimapnotify")
--
2.37.2
M
[PATCH v6] Enable login in cyrus-sasl, as Exchange servers expect it
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220915122601.29255-1-matf@disr.it
---
gnu/packages/cyrus-sasl.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 2cd18f3e5e..4e23bd5fe0 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,7 +55,8 @@ (define-public cyrus-sasl
(list ;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
mit-krb5))
(arguments
- '(#:configure-flags (list (string-append "--with-plugindir="
+ '(#:configure-flags (list (string-append "--enable-login"
+ "--with-plugindir="
(assoc-ref %outputs "out")
"/lib/sasl2"))
--
2.37.2
M
[PATCH v7] gnu: cyrus-sasl: Enable login.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220915123703.3852-1-matf@disr.it
* gnu/packages/cyrus-sasl.scm (cyrus-sasl)[arguments]: Enable login.

Exchange servers require login for e-mail clients that use cyrus-sasl.
---
gnu/packages/cyrus-sasl.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 2cd18f3e5e..4e23bd5fe0 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,7 +55,8 @@ (define-public cyrus-sasl
(list ;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
mit-krb5))
(arguments
- '(#:configure-flags (list (string-append "--with-plugindir="
+ '(#:configure-flags (list (string-append "--enable-login"
+ "--with-plugindir="
(assoc-ref %outputs "out")
"/lib/sasl2"))
--
2.37.2
M
[PATCH v7 1/2] gnu: Add nmail.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220916092244.1741-1-matf@disr.it
* gnu/packages/mail.scm (nmail): New variable.
---
gnu/packages/mail.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 65d8060862..8f2452a61f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -405,6 +406,43 @@ (define-public mailutils
;; Libraries are under LGPLv3+, and programs under GPLv3+.
(list license:gpl3+ license:lgpl3+))))
+(define-public nmail
+ (package
+ (name "nmail")
+ (version "3.74")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/d99kris/nmail/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "ctest" "--output-on-failure")))))))
+ (inputs
+ (list cyrus-sasl
+ file
+ libetpan
+ ncurses
+ openssl
+ sqlite
+ (list util-linux "lib")
+ xapian))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/d99kris/nmail")
+ (synopsis "Terminal-based email client")
+ (description
+ "@command{nmail} is an easily configurable terminal-based email client with
+a @code{ncurses} user interface similar to @code{alpine} and @code{pine}.")
+ (license license:expat)))
+
(define-public go-gitlab.com-shackra-goimapnotify
(package
(name "go-gitlab.com-shackra-goimapnotify")
--
2.37.2
M
[PATCH v7 2/2] gnu: cyrus-sasl: Enable login.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220916092244.1741-2-matf@disr.it
* gnu/packages/cyrus-sasl.scm (cyrus-sasl)[arguments]: Enable login.

Exchange servers require login for e-mail clients that use cyrus-sasl.
---
gnu/packages/cyrus-sasl.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 2cd18f3e5e..edeb2dded2 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,10 +55,11 @@ (define-public cyrus-sasl
(list ;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
mit-krb5))
(arguments
- '(#:configure-flags (list (string-append "--with-plugindir="
+ '(#:configure-flags (list "--enable-login"
+ (string-append "--with-plugindir="
(assoc-ref %outputs "out")
"/lib/sasl2"))
-
+
;; The 'plugins' directory has shared source files, such as
;; 'plugin_common.c'. When building the shared libraries there, libtool
;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
--
2.37.2
M
[PATCH v8 1/2] gnu: Add nmail.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220924135518.21476-1-matf@disr.it
* gnu/packages/mail.scm (nmail): New variable.
---
gnu/packages/mail.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 65d8060862..8f2452a61f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -405,6 +406,43 @@ (define-public mailutils
;; Libraries are under LGPLv3+, and programs under GPLv3+.
(list license:gpl3+ license:lgpl3+))))
+(define-public nmail
+ (package
+ (name "nmail")
+ (version "3.74")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/d99kris/nmail/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "ctest" "--output-on-failure")))))))
+ (inputs
+ (list cyrus-sasl
+ file
+ libetpan
+ ncurses
+ openssl
+ sqlite
+ (list util-linux "lib")
+ xapian))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/d99kris/nmail")
+ (synopsis "Terminal-based email client")
+ (description
+ "@command{nmail} is an easily configurable terminal-based email client with
+a @code{ncurses} user interface similar to @code{alpine} and @code{pine}.")
+ (license license:expat)))
+
(define-public go-gitlab.com-shackra-goimapnotify
(package
(name "go-gitlab.com-shackra-goimapnotify")
--
2.37.2
M
[PATCH v8 2/2] gnu: cyrus-sasl: Enable login.
(address . 57021@debbugs.gnu.org)(name . M)(address . matf@disr.it)
20220924135518.21476-2-matf@disr.it
* gnu/packages/cyrus-sasl.scm (cyrus-sasl)[arguments]: Enable login.

Exchange servers require login for e-mail clients that use cyrus-sasl.
---
gnu/packages/cyrus-sasl.scm | 6 ++++--
gnu/packages/mail.scm | 4 ++--
2 files changed, 6 insertions(+), 4 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 2cd18f3e5e..edeb2dded2 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,10 +55,11 @@ (define-public cyrus-sasl
(list ;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
mit-krb5))
(arguments
- '(#:configure-flags (list (string-append "--with-plugindir="
+ '(#:configure-flags (list "--enable-login"
+ (string-append "--with-plugindir="
(assoc-ref %outputs "out")
"/lib/sasl2"))
-
+
;; The 'plugins' directory has shared source files, such as
;; 'plugin_common.c'. When building the shared libraries there, libtool
;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 8f2452a61f..f127772a92 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -409,7 +409,7 @@ (define-public mailutils
(define-public nmail
(package
(name "nmail")
- (version "3.74")
+ (version "3.89")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -418,7 +418,7 @@ (define-public nmail
(file-name (git-file-name name version))
(sha256
(base32
- "07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
+ "1ris5fijmk41279hm9kp1v0niiq83a2lk2mmq1r9z31k7n2yg2v2"))))
(build-system cmake-build-system)
(arguments
(list #:phases
--
2.37.2
C
C
Christina O'Donnell wrote 5 days ago
owner 57021 !
(address . control@debbugs.gnu.org)
df9f3972-ba15-a2e4-8ac1-94f143291a8f@mutix.org
owner 57021 !
user guix
usertag 57021 + under-review
usertag 57021 + patch-review-hackers-list
quit
C
C
Christina O'Donnell wrote 5 days ago
[PATCH v9] gnu: Add nmail.
(address . 57021@debbugs.gnu.org)
051069797f9f8254cd903abad67770fb8261291c.1713705610.git.cdo@mutix.org
From: M <matf@disr.it>

* gnu/packages/mail.scm (nmail): New variable.

Reviewed-by: Christina O'Donnell <cdo@mutix.org>
Change-Id: I850ac3a1b6e6db6d1869bb3fe8ff9d3a9e71cc86
---
gnu/packages/mail.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index e0fbd0a5ff3..3eb4f57e67e 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2022 ( <paren@disroot.org>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023 Arjan Adriaanse <arjan@adriaan.se>
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
@@ -455,6 +456,43 @@ (define-public mairix
Maildir, MH, MMDF or mbox folders.")
(license license:gpl2))))
+(define-public nmail
+ (package
+ (name "nmail")
+ (version "4.54")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/d99kris/nmail/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bk2kq0pk1r4w5xv94yh37vrwxs8lczjg11gfraxh9cxyjigwsrp"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ctest" "--output-on-failure")))))))
+ (inputs (list cyrus-sasl
+ file
+ libetpan
+ ncurses
+ openssl
+ sqlite
+ (list util-linux "lib")
+ xapian))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/d99kris/nmail")
+ (synopsis "Terminal-based email client")
+ (description
+ "@command{nmail} is an easily configurable terminal-based email client with
+a @code{ncurses} user interface similar to @code{alpine} and @code{pine}.")
+ (license license:expat)))
+
(define-public go-gitlab.com-shackra-goimapnotify
(package
(name "go-gitlab.com-shackra-goimapnotify")

base-commit: ba52975ea91af49e8e6a436438a578589a209ecc
--
2.41.0
C
C
Christina O'Donnell wrote 5 days ago
Re: bug#57021: [PATCH] gnu: packages: Add nmail.
(address . othacehe@gnu.org)
db8a5d71-70ce-650c-4209-ecdeb4d97a30@mutix.org
Hi Mathieu Laparie,

Thank you for your patch. Sorry it has taken so long to get to it.

This patch looks good. It applies and runs and lints with few issues.

I've re-rolled a version 9 patch on the latest master branch, updating
the version and changing the formatting slightly.

Regarding the second diff, I'm not sure what the justification is for
changing cyrus-sasl in the same patch, so I've removed that part. If
that change needs to happen then I would think it would make more sense
as a separate patch.

Kind regards,
Christina
C
C
Christina wrote 4 days ago
(name . Mathieu)(address . mlaparie@disr.it)(address . 57021@debbugs.gnu.org)
49b576c9-47be-4e8f-ae52-2e43d78b6cc7@mutix.org
Hi Mathieu,

I'm testing it right now connecting to my server on IMAP STARTTLS.

It's working fine for me over IMAP and works over on SMTP over SSL if you receive this message.

Is --enable-login required for OAUTH?

I did notice it failed to build a second time due to missing dependencies which is odd. I'll send an update patch to fix that shortly.

Kind regards,
Christina

On 2024-04-22 10:21 Mathieu <mlaparie@disr.it> wrote:

Toggle quote (32 lines)
> Awesome news, thanks a ton Christina!
>
> Have you tried sending emails without the `cyrus-sasl` patch? Unless
> the package changed since I submitted this patch, sending emails may
> fail because `cyrus-sasl` needs to be compiled with the
> `--enable-login` flag, which I think was not default. I haven't
> tested lately though because I was running `nmail` and `cyrus-sasl`
> from my private channel since a long time.
>
> Mathieu
>
> On 2024-04-21 16:03 Christina O'Donnell <cdo@mutix.org> wrote:
>
>> Hi Mathieu Laparie,
>>
>> Thank you for your patch. Sorry it has taken so long to get to it.
>>
>> This patch looks good. It applies and runs and lints with few
>> issues.
>>
>> I've re-rolled a version 9 patch on the latest master branch,
>> updating the version and changing the formatting slightly.
>>
>> Regarding the second diff, I'm not sure what the justification is
>> for
>> changing cyrus-sasl in the same patch, so I've removed that part.
>> If
>> that change needs to happen then I would think it would make more
>> sense as a separate patch.
>>
>> Kind regards, Christina
>>
C
C
Christina O'Donnell wrote 4 days ago
[PATCH v10] gnu: Add nmail.
2487067d8a5bf3c0e3c55f2bc360fcb6ca32c8f3.1713784082.git.cdo@mutix.org
From: M <matf@disr.it>

* gnu/packages/mail.scm (nmail): New variable.

Reviewed-by: Christina O'Donnell <cdo@mutix.org>
Change-Id: I850ac3a1b6e6db6d1869bb3fe8ff9d3a9e71cc86
---
gnu/packages/mail.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 6d5deca741b..139150224a5 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2022 ( <paren@disroot.org>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023 Arjan Adriaanse <arjan@adriaan.se>
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
@@ -455,6 +456,46 @@ (define-public mairix
Maildir, MH, MMDF or mbox folders.")
(license license:gpl2))))
+(define-public nmail
+ (package
+ (name "nmail")
+ (version "4.54")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/d99kris/nmail/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bk2kq0pk1r4w5xv94yh37vrwxs8lczjg11gfraxh9cxyjigwsrp"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ctest" "--output-on-failure")))))))
+ (inputs (list curl
+ cyrus-sasl
+ expat
+ file
+ libetpan
+ ncurses
+ openssl
+ sqlite
+ (list util-linux "lib")
+ xapian
+ zlib))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/d99kris/nmail")
+ (synopsis "Terminal-based email client")
+ (description
+ "@command{nmail} is an easily configurable terminal-based email client with
+a @code{ncurses} user interface similar to @code{alpine} and @code{pine}.")
+ (license license:expat)))
+
(define-public go-gitlab.com-shackra-goimapnotify
(package
(name "go-gitlab.com-shackra-goimapnotify")

base-commit: 28e41dc3bcb37bfe0dffb118d1b60b6df98a49e2
--
2.41.0
M
M
Mathieu wrote 4 days ago
Re: bug#57021: [PATCH] gnu: packages: Add nmail.
(name . Christina O'Donnell)(address . cdo@mutix.org)
864e413a-baa5-405b-a0d5-df37dce6fa00@disroot.org
Awesome news, thanks a ton Christina!

Have you tried sending emails without the `cyrus-sasl` patch? Unless the package changed since I submitted this patch, sending emails may fail because `cyrus-sasl` needs to be compiled with the `--enable-login` flag, which I think was not default. I haven't tested lately though because I was running `nmail` and `cyrus-sasl` from my private channel since a long time.

Mathieu

On 2024-04-21 16:03 Christina O'Donnell <cdo@mutix.org> wrote:

Toggle quote (16 lines)
> Hi Mathieu Laparie,
>
> Thank you for your patch. Sorry it has taken so long to get to it.
>
> This patch looks good. It applies and runs and lints with few issues.
>
> I've re-rolled a version 9 patch on the latest master branch,
> updating the version and changing the formatting slightly.
>
> Regarding the second diff, I'm not sure what the justification is for
> changing cyrus-sasl in the same patch, so I've removed that part. If
> that change needs to happen then I would think it would make more
> sense as a separate patch.
>
> Kind regards, Christina
>
C
C
Christopher Baines wrote 3 days ago
Re: [bug#57021] [PATCH] gnu: packages: Add nmail.
(name . Mathieu)(address . mlaparie@disr.it)
87frvc19c6.fsf@cbaines.net
Mathieu <mlaparie@disr.it> writes:

Toggle quote (9 lines)
> Awesome news, thanks a ton Christina!
>
> Have you tried sending emails without the `cyrus-sasl` patch? Unless
> the package changed since I submitted this patch, sending emails may
> fail because `cyrus-sasl` needs to be compiled with the
> `--enable-login` flag, which I think was not default. I haven't tested
> lately though because I was running `nmail` and `cyrus-sasl` from my
> private channel since a long time.

Given cyrus-sasl has a lot of dependencies (as reported by guix refresh
-l), it would be good to submit this patch separately, even though that
change is required for some functionality in nmail.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmYnu3lfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeKOg/8DeFmSdxcfO5jfuEzSFJM+d5P8bgzUDai
fwhswc7Z8Dy4U4iUyh7lEqWLw27ycBSYMPW7cVQObRJaSwbtmO9rrMVcul3iU/hd
7gpmxHpRVi6wxm52Bu/3VYMjKOG4sxNkkPrT7JSARm3IRyrxRAvQaWJFFFi81hf+
44slG2gwUVhPabKMoI2hYQmMr4wYoOi8h6Mn8HQXIlpo2CUZGKw1fnPESwwGICm3
KSFnVF9wz85dXlUa5onQrh2uJCRhmkAa6BUU3SiQH+1/FCzlmfpZgEE2A/U+wDUe
W3V+k1ExpqltxNAl9VWGprRncJL+jVDcbJr2JzbtIqGLw01gINNVbxPdc+7/JDdy
3J28wM+ZrrXqsCqTR7VcLe2usndRMoruCkRF3K2JXTDSvnl/JzPBQ/RJS/FNvNXK
Ozm6l+knrI4IhsTE/7SNav+DUP/HfmWoyEUEDj9+MkGpZ+Q/ShkvxQhJlh3mXQd6
cX29vR7KrCFCaJJ7FOo+gP+A5mXvgHa2S+fblb31zm+faNlz8nWYXJMJi6VZdt0r
ypIKNGpIhP4v91F+yONjqnJWgc+jax2ZmEtUA0eB71JZssoFw6pF3skq7VvfyAaQ
SAZ9WFd2iamh2SGOdjF1afrGUcyxASuwNiR1vXjR82Bt93LzSTNSQFUi7gZMhhmX
rr6a2zUq+bo=
=xKaJ
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote 3 days ago
Re: [bug#57021] [PATCH v10] gnu: Add nmail.
(name . Christina O'Donnell)(address . cdo@mutix.org)
87a5lk199i.fsf@cbaines.net
Christina O'Donnell <cdo@mutix.org> writes:

Toggle quote (10 lines)
> From: M <matf@disr.it>
>
> * gnu/packages/mail.scm (nmail): New variable.
>
> Reviewed-by: Christina O'Donnell <cdo@mutix.org>
> Change-Id: I850ac3a1b6e6db6d1869bb3fe8ff9d3a9e71cc86
> ---
> gnu/packages/mail.scm | 41 +++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 41 insertions(+)

Thanks all, I've pushed this to master now as
8dbe101b3049e6159afaab1df38354b7bd657733.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmYnu9lfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeGuQ//cS6zLG+Mr1W+Q08n6yuwRTy2bFWT5wV0
qzOtbSdnpUqUWAT7vl3pNkfWmtKgroow4LbR+h9slypyE5vQ1ktiX8RfciT15+wd
ppx6mf0pIEYzBzyH3VYASeFlH+kyXdYLIekMSyXFwAq+HovxJ9fegzsaCMDdO/3M
vECWExiPy8Wl2tlG9jPXEtlb5Zv3eodyjPfPjt0phHAnB/0OUbLn59WECaPmgpvj
v3X4a/MqFBrqWxrLKb5FS589UUqubmXjiBvvmtW8h1kjFr29nltysg/o2Qr5l0nH
lRrVrw0MGD9yVfdd2GSCCCj0eS3cDcxvo6uPycTr677KioX77/bUn82TR6ZPbVNG
6o/1NjsRrpeV7whrM/YYo+ND+dylXYvDo+jaohOvanN1wQ3tBE45NdsRWlZmkEB+
xshiCYXEoRvcaahj7052tJ1QRhyBno+F8g1M4A0WeapHVdfcOuFXJJLCBRvr8JPX
MiMrPfe9kE4T9X35wbw8r3XFC7ei+hElrUoGMuydyASjK5kb5Ad2l/HRBShbBppH
Tu6AbfNwKxfnzJmBYXrh4iu4vByrl53Z8bgjWxU3242epaIEtdIZQTHTvtD5aEd3
RpYDVD1Z/YwAD4rfbZEBCtckHZChvzqV8Xvn0hj3VQRRt5r46u2npxHPYCCwb8ZJ
1tLK/nYVOQo=
=GwF7
-----END PGP SIGNATURE-----

Closed
?