[PATCH] gnu: fortune-mod: Remove off database.

  • Done
  • quality assurance status badge
Details
7 participants
  • bokr
  • kiasoc5
  • Liliana Marie Prikler
  • Ludovic Courtès
  • Maxime Devos
  • Tobias Geerinckx-Rice
  • raingloom
Owner
unassigned
Submitted by
raingloom
Severity
normal
R
R
raingloom wrote on 16 Jul 2022 14:21
(address . guix-patches@gnu.org)
20220716122126.26328-1-raingloom@riseup.net
* gnu/packages/games.scm (fortune-mod): Delete off database after install phase.
---
gnu/packages/games.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 713f9339b2..cf10ebc9b6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7721,7 +7721,10 @@ (define-public fortune-mod
(lambda _
(with-directory-excursion #$output
(rename-file "games/fortune" "bin/fortune")
- (rmdir "games")))))))
+ (rmdir "games"))))
+ (add-after 'install 'commit-censorship
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively (string-append (assoc-ref outputs "out") "/share/fortunes/off/")))))))
(inputs (list recode))
(native-inputs
(list perl
--
2.37.0
L
L
Ludovic Courtès wrote on 3 Aug 2022 15:43
Re: bug#54691: fortune-mod propagates various non-nice things
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87y1w5sarm.fsf_-_@gnu.org
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:

Toggle quote (6 lines)
> Since the addition of fortune-jkirchartz, it is no longer necessary to
> keep around a package that propagates various non-nice things.
> For a complete list, see <https://bugs.gnu.org/54691>.
>
> * gnu/packages/games.scm (fortune-mod): Delete variable.

[...]

Toggle quote (2 lines)
> -(define-public fortune-mod

(Perhaps also make “fortune-mod” a deprecated name for
“fortune-jkirchartz”.)

FWIW I’m fine with this change. Note that there’s also another patch
that removes the ‘off’ database of ‘fortune-mod’¹, though I don’t know
whether that would fully address the issues raised in this thread. It
will have to closed if/once this series is applied.

Thanks,
Ludo’.

K
K
kiasoc5 wrote on 3 Aug 2022 17:02
RE: [PATCH] gnu: fortune-mod: Remove off database.
(address . 56599@debbugs.gnu.org)
20220803150238.53824a26@aria
Censorship is a tricky term, and it does not directly address why the
database is being removed. The phase should be more simply renamed to
remove-offensive-database, and include a comment on why the database is
being removed, referencing #54691.
L
L
Liliana Marie Prikler wrote on 3 Aug 2022 19:09
Re: bug#54691: fortune-mod propagates various non-nice things
(name . Ludovic Courtès)(address . ludo@gnu.org)
c1d10237e964842e74f39c114d5a379b1f89c079.camel@gmail.com
Hi Ludo,

Am Mittwoch, dem 03.08.2022 um 15:43 +0200 schrieb Ludovic Courtès:
Toggle quote (5 lines)
> [...]
> > -(define-public fortune-mod
>
> (Perhaps also make “fortune-mod” a deprecated name for
> “fortune-jkirchartz”.)
I'm getting mixed messages here. On the one hand, Maxime suggests not
propagating daikichi from fortune-jkirchartz (which makes it a plain
data package lacking a `fortune' command), on the other we want to mark
fortune-mod as deprecated. These are mutually exclusive options.

Toggle quote (4 lines)
> FWIW I’m fine with this change.  Note that there’s also another patch
> that removes the ‘off’ database of ‘fortune-mod’¹, though I don’t
> know whether that would fully address the issues raised in this
> thread.  It will have to closed if/once this series is applied.
IIRC, I responded to such a patch already, though perhaps not that
thread in particular. To summarize, fortune-mod also propagates non-
nice things outside of ‘off’, so removing it is not enough.


Cheers
L
L
Ludovic Courtès wrote on 4 Aug 2022 14:23
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
8735ecmc2u.fsf@gnu.org
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:

Toggle quote (11 lines)
> Am Mittwoch, dem 03.08.2022 um 15:43 +0200 schrieb Ludovic Courtès:
>> [...]
>> > -(define-public fortune-mod
>>
>> (Perhaps also make “fortune-mod” a deprecated name for
>> “fortune-jkirchartz”.)
> I'm getting mixed messages here. On the one hand, Maxime suggests not
> propagating daikichi from fortune-jkirchartz (which makes it a plain
> data package lacking a `fortune' command), on the other we want to mark
> fortune-mod as deprecated. These are mutually exclusive options.

To me use of ‘deprecated-package’ in this case is just to ensure that
users who run ‘guix upgrade’ will transparently get
‘fortune-jkirchartz’. I don’t have a strong opinion though.

Toggle quote (8 lines)
>> FWIW I’m fine with this change.  Note that there’s also another patch
>> that removes the ‘off’ database of ‘fortune-mod’¹, though I don’t
>> know whether that would fully address the issues raised in this
>> thread.  It will have to closed if/once this series is applied.
> IIRC, I responded to such a patch already, though perhaps not that
> thread in particular. To summarize, fortune-mod also propagates non-
> nice things outside of ‘off’, so removing it is not enough.

Alright, let’s remove ‘fortune-mod’ then.

Thanks for taking care of it!

Ludo’.
T
T
Tobias Geerinckx-Rice wrote on 4 Aug 2022 17:37
E61C2DFA-D252-43C8-B946-5805C1C24847@tobias.gr
Toggle quote (4 lines)
>To me use of ‘deprecated-package’ in this case is just to ensure that
>users who run ‘guix upgrade’ will transparently get
>‘fortune-jkirchartz’. I don’t have a strong opinion though.

I believe what Liliana meant is that it's worse to 'transparently' upgrade to a data package that doesn't provide the 'fortune' command at all (or conversely, an implementation of the command that doesn't propagate the actual fortune data), than it is to signal to users through an error message that something's up and they need to stop and think.

(Er, that's a lot more words to put in someone's mouth than I intended to, sorry :-)

I'd suggest a news item but I really don't think this warrants it.

Kind regards,

T G-R

Sent on the go. Excuse or enjoy my brevity.
L
L
Liliana Marie Prikler wrote on 4 Aug 2022 19:12
8ddb8ad9db66e89534184df1a2b20bd3124672fc.camel@gmail.com
Am Donnerstag, dem 04.08.2022 um 15:37 +0000 schrieb Tobias Geerinckx-
Rice:
Toggle quote (13 lines)
> > To me use of ‘deprecated-package’ in this case is just to ensure
> > that users who run ‘guix upgrade’ will transparently get
> > ‘fortune-jkirchartz’.  I don’t have a strong opinion though.
>
> I believe what Liliana meant is that it's worse to 'transparently'
> upgrade to a data package that doesn't provide the 'fortune' command
> at all (or conversely, an implementation of the command that doesn't
> propagate the actual fortune data), than it is to signal to users
> through an error message that something's up and they need to stop
> and think.
>
> (Er, that's a lot more words to put in someone's mouth than I
> intended to, sorry :-)
I'm not saying either option is worse than the other, just that we
can't pick both in a manner that provides a functioning package, and
that transparently upgrading to a package that does nothing is a pretty
bad option. We could transparently upgrade to daikichi, but that'd
just say "no fortunes found" because FORTUNE_PATH will be empty. Other
options would include a metapackage (also rejected by Maxime) or
providing a dummy fortune-mod package that fails at build with a
helpful message and is disabled in CI (came up as a shower thought).

Cheers
T
T
Tobias Geerinckx-Rice wrote on 4 Aug 2022 21:58
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87k07nbvwl@nckx
Hi Liliana,

Liliana Marie Prikler ???
Toggle quote (2 lines)
> I'm not saying either option is worse than the other

I see; thanks for the clarification.

Then I *will* say that transparently upgrading to a package that
does nothing is worse than simple removal.

In fact, all of the proposed hacks are…

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYuwqug0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW159pkBAJG1d8cwDpMY5aa1wPG/sns1PY55p1+W1rA+sl2Y
a11gAQDTR2Ifz1PFhVVflIQ8jQjSXESzk6XjHHytveECW5MPCg==
=681v
-----END PGP SIGNATURE-----

B
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
20220806230112.GA16948@LionPure
Hi,

On +2022-08-04 21:58:16 +0200, Tobias Geerinckx-Rice via Bug reports for GNU Guix wrote:
Toggle quote (16 lines)
> Hi Liliana,
>
> Liliana Marie Prikler ???
> > I'm not saying either option is worse than the other
>
> I see; thanks for the clarification.
>
> Then I *will* say that transparently upgrading to a package that does
> nothing is worse than simple removal.
>
> In fact, all of the proposed hacks are…
>
> Kind regards,
>
> T G-R

I hope the original is preserved somewhere for history's sake.
So where can I get a copy to see what all the fuss is about? :)
--
Regards,
Bengt Richter
It ain't what they call you, it's what you answer to.
-- W. C. Fields
Start every day off with a smile and get it over with.
-- W. C. Fields
M
M
Maxime Devos wrote on 7 Aug 2022 01:05
a17282f6-8de5-9d45-ef42-2023c09e11d8@telenet.be
On 07-08-2022 01:01, bokr@bokr.com wrote:
Toggle quote (2 lines)
> I hope the original is preserved somewhere for history's sake.
> So where can I get a copy to see what all the fuss is about? :)
It's not merged yet IIUC, so you can just use the Guix package manager
to install the original.
For the history thing: we have "guix time-machine" and the SWH fallback.
Greetings,
Maxime.
Attachment: OpenPGP_signature
L
L
Liliana Marie Prikler wrote on 30 Aug 2022 12:22
bfe141bd453f399e821068878d97130910415ae7.camel@gmail.com
Am Sonntag, dem 07.08.2022 um 01:05 +0200 schrieb Maxime Devos:
Toggle quote (6 lines)
> On 07-08-2022 01:01, bokr@bokr.com wrote:
>
> > I hope the original is preserved somewhere for history's sake.
> > So where can I get a copy to see what all the fuss is about? :)
>
> It's not merged yet IIUC
It is merged now, so take out your time machines if you want to have
offensive fortunes. Or build the datfiles with daikichi, I can't stop
you ;)
Closed
?