[PATCH] gnu: Added breeze-gtk package.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Samuel Fadel
Owner
unassigned
Submitted by
Samuel Fadel
Severity
normal
Merged with
S
S
Samuel Fadel wrote on 29 Jun 2022 11:26
(address . guix-patches@gnu.org)(name . Samuel Fadel)(address . samuel@nihil.ws)
8c2173a9d5264c7b811927e64f6e8878f9ca013f.1656494787.git.samuel@nihil.ws
I personally like my GTK and Qt programs to have a consistent look. I
noticed the GTK port of the Breeze theme was missing from the repos, so
this is adding it.

I am unsure about the licensing as their current repo mentions both the
LGPL 2.1 and BSD 3-clause. How should I set it properly? Is just LGPL
2.1 enough?

---
gnu/packages/kde-plasma.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 5621d8ea35..558efe0562 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -83,6 +83,31 @@ (define-public breeze
the Plasma Desktop. Breeze is the default theme for the KDE Plasma desktop.")
(license license:gpl2+)))
+(define-public breeze-gtk
+ (package
+ (name "breeze-gtk")
+ (version "5.19.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1j2nq9yw1ragmgwrz9f6ca4ifpi86qv1bbprdgd2qm2yh7vb44sj"))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)))) ; Test phase not defined
+ (native-inputs
+ (list breeze extra-cmake-modules sassc python python-pycairo))
+ (home-page "https://invent.kde.org/plasma/breeze")
+ (synopsis "Default KDE Plasma theme (GTK+ port)")
+ (description "GTK+ port of the Breeze visual style for the Plasma Desktop.
+Breeze is the default theme for the KDE Plasma desktop.")
+ (license license:lgpl2.1)))
+
+
(define-public kdecoration
(package
(name "kdecoration")
--
2.36.1
T
T
Tobias Geerinckx-Rice wrote on 29 Jun 2022 19:51
(address . control@debbugs.gnu.org)
8EBB49A2-1455-4162-A764-7537BA9D020D@tobias.gr
merge 56299 56300

Kind regards,

T G-R

Sent on the go. Excuse or enjoy my brevity.
S
S
Samuel Fadel wrote on 6 Jul 2022 10:20
(address . control@debbugs.gnu.org)
87pmiitzyh.fsf@t490
merge 56300 56321
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56299@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56299
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch