[PATCH v2] gnu: Add breeze-gtk.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Samuel Fadel
Owner
unassigned
Submitted by
Samuel Fadel
Severity
normal
Merged with
S
S
Samuel Fadel wrote on 30 Jun 2022 09:58
(address . guix-patches@gnu.org)(name . Samuel Fadel)(address . samuel@nihil.ws)
20220630075834.24362-1-samuel@nihil.ws
This adds the GTK port of the Breeze theme. This v2 of the patch
includes more accurate licensing infomation.

* gnu/packages/kde-plasma.scm (breeze-gtk): Added package.
---
gnu/packages/kde-plasma.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 5621d8ea35..dde74b084d 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -83,6 +83,32 @@ (define-public breeze
the Plasma Desktop. Breeze is the default theme for the KDE Plasma desktop.")
(license license:gpl2+)))
+(define-public breeze-gtk
+ (package
+ (name "breeze-gtk")
+ (version "5.19.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1j2nq9yw1ragmgwrz9f6ca4ifpi86qv1bbprdgd2qm2yh7vb44sj"))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)))) ; Test phase not defined
+ (native-inputs
+ (list breeze extra-cmake-modules sassc python python-pycairo))
+ (home-page "https://invent.kde.org/plasma/breeze")
+ (synopsis "Default KDE Plasma theme (GTK+ port)")
+ (description "GTK+ port of the Breeze visual style for the Plasma Desktop.
+Breeze is the default theme for the KDE Plasma desktop.")
+ (license (list
+ license:bsd-3 ; cmake/FindSass.cmake
+ license:lgpl2.1)))) ; <all other files>
+
(define-public kdecoration
(package
(name "kdecoration")
--
2.36.1
S
S
Samuel Fadel wrote on 6 Jul 2022 10:20
[bug#56300] [PATCH] gnu: Added breeze-gtk package.
(address . control@debbugs.gnu.org)
87pmiitzyh.fsf@t490
merge 56300 56321
quit
L
L
Ludovic Courtès wrote on 12 Jul 2022 23:39
Re: bug#56321: [PATCH v2] gnu: Add breeze-gtk.
(name . Samuel Fadel)(address . samuel@nihil.ws)(address . 56321-done@debbugs.gnu.org)
87a69ec8nz.fsf@gnu.org
Hi,

Samuel Fadel <samuel@nihil.ws> skribis:

Toggle quote (5 lines)
> This adds the GTK port of the Breeze theme. This v2 of the patch
> includes more accurate licensing infomation.
>
> * gnu/packages/kde-plasma.scm (breeze-gtk): Added package.

Applied with the changes below.

Thanks,
Ludo’.
Toggle diff (37 lines)
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index dde74b084d..4ae6ac9484 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -31,11 +31,14 @@ (define-module (gnu packages kde-plasma)
#:use-module (gnu packages compression)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
#:use-module (gnu packages qt)
- #:use-module (gnu packages xorg))
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages web))
(define-public breeze
(package
@@ -95,10 +98,7 @@ (define-public breeze-gtk
(base32
"1j2nq9yw1ragmgwrz9f6ca4ifpi86qv1bbprdgd2qm2yh7vb44sj"))))
(build-system qt-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'check)))) ; Test phase not defined
+ (arguments '(#:tests? #f)) ;no 'test' target
(native-inputs
(list breeze extra-cmake-modules sassc python python-pycairo))
(home-page "https://invent.kde.org/plasma/breeze")
@@ -306,3 +306,4 @@ (define-public libksysguard
with a ksysguardd daemon, which may also run on a remote system.")
(license license:gpl3+)))
+
Closed
?