[PATCH] Add timewarrior 1.4.3

  • Done
  • quality assurance status badge
Details
3 participants
  • Nicolas Goaziou
  • Maxime Devos
  • Zac Berkowitz
Owner
unassigned
Submitted by
Zac Berkowitz
Severity
normal
Z
Z
Zac Berkowitz wrote on 9 Jun 2022 17:11
(address . guix-patches@gnu.org)
CANNGBfmtyGVoYSC+QkqvShkOZijyr0XRwp6ZML+ks-ndUEAPdQ@mail.gmail.com

From dc3cd50a62ddce3fcc2ea9c374036192411b833a Mon Sep 17 00:00:00 2001
From: Zac Berkowitz <zac.berkowitz@gmail.com>
Date: Fri, 13 May 2022 11:56:51 -0400
Subject: [PATCH] gnu: Add timewarrior.

* gnu/packages/task-management.scm (timewarrior): New variable
---
gnu/packages/task-management.scm | 38 ++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index aeedbfbe6a..3a21c1a44d 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -38,6 +38,7 @@ (define-module (gnu packages task-management)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
#:use-module (guix download)
@@ -145,6 +146,43 @@ (define-public taskwarrior
and querying data, exposing task data in multiple formats to other tools.")
(license license:expat)))
+(define-public timewarrior
+ (package
+ (name "timewarrior")
+ (version "1.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/GothenburgBitFactory/timewarrior/releases/download/v" version
+ "/timew-" version ".tar.gz"))
+ (sha256 (base32
+ "0lyaqzcg8np2fpsmih0hlkjxd3qbadc7khr24m1pq9lsdhq7xpy4"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("ruby-asciidoctor" ,ruby-asciidoctor)
+ ("python" ,python)))
+ (inputs
+ `(("gnutls" ,gnutls)
+ ("util-linux:lib" ,util-linux "lib")))
+ ;; (list gnutls
+ ;; `(,util-linux "lib")))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'install-license-files) ; Already installed by package
+ (add-after 'patch-source-shebangs 'patch-cmake-shell
+ (lambda _
+ (substitute* "src/commands/CMakeLists.txt"
+ (("/bin/sh") (which "sh"))))))))
+ (home-page "https://timewarrior.net")
+ (synopsis "Command line utility to track and report time")
+ (description
+ "Timewarrior is a command line time tracking application, which allows
+you to record time spent on activities. You may be tracking your time for
+curiosity, or because your work requires it.")
+ (license license:expat)))
+
(define-public worklog
(let ((commit "0f545ad6697ef4de7f68d92cd7cc5c6a4c60517b")
(revision "1"))
--
2.36.1
M
M
Maxime Devos wrote on 9 Jun 2022 21:50
fbec639f90f6e6dd91f78b40952c319ed8c69971.camel@telenet.be
Zac Berkowitz schreef op do 09-06-2022 om 11:11 [-0400]:
Toggle quote (10 lines)
> +       (method url-fetch)
> +       (uri (string-append
> +            
> "https://github.com/GothenburgBitFactory/timewarrior/releases/download/v
> " version
> +             "/timew-" version ".tar.gz"))
> +       (sha256 (base32
> +               
> "0lyaqzcg8np2fpsmih0hlkjxd3qbadc7khr24m1pq9lsdhq7xpy4"))))

I can confirm the hash matches, and hashing the file with sha256sum
agrees with the hash mentioned on https://timewarrior.net/releases/.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqJPHRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7p7gAQDWOjgqQiu1MscBaxtOxB8I4A8i
987j81Vfw4kjw+HGZwEAqmfisqo6m47JgzIzl5ZkkledAUvNBWaDSXUY7blkCgo=
=SKqG
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 9 Jun 2022 21:53
e10249aa44483f4f057403ec9e960390fe1bfade.camel@telenet.be
Zac Berkowitz schreef op do 09-06-2022 om 11:11 [-0400]:
Toggle quote (7 lines)
> +    (native-inputs
> +     `(("ruby-asciidoctor" ,ruby-asciidoctor)
> +       ("python" ,python)))
> +    (inputs
> +     `(("gnutls" ,gnutls)
> +       ("util-linux:lib" ,util-linux "lib")))

Nowadays, these can be simplified to.

(native-inputs (list ruby-asciidoctor python))

Where did you learn about the old form?

Likewise (if I remember the syntax right):

(list gnutls `(,util-linux "lib"))

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqJPxRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7gspAP4wZASyqH8fyMT+o7XKLSsGMlP4
6ITfM+XPDiPnUxAwXQEA2e15ViBWTg1C+HTYPqt1BU5n9hh7OzNh5kzFRKqcAAw=
=VnNW
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 9 Jun 2022 21:55
c4e2154a3b8ade436b19fe1514161d4ea7bef2c7.camel@telenet.be
Zac Berkowitz schreef op do 09-06-2022 om 11:11 [-0400]:
+         (delete 'install-license-files) ; Already installed by
package

Not a problem I think -- at worst, the license file will appear twice,
but identical files are automatically deduplicated, and even if not, they
are relatively small files anyway.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqJQFRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7iLHAP0T6p5CeAMifQtofWOWB7RXJhGr
rz1QMfoSVGEdN9wb6gEA6AO84U5qFbfTuhL4pqC5YQnqE4wgr2RE8/H3llStbA0=
=H/UA
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 9 Jun 2022 21:56
81396756098f5459b17cb29d640a937830f53f95.camel@telenet.be
Zac Berkowitz schreef op do 09-06-2022 om 11:11 [-0400]:
Toggle quote (3 lines)
> +             (substitute* "src/commands/CMakeLists.txt"
> +               (("/bin/sh") (which "sh"))))))))

In this context, (which "sh") can maybe be simplified to just "sh", not
that it really matters.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqJQcRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7j0pAP0c/Lqwho5EY8ieXNrvQS5kMg18
et3pOYyzWW08mmQsDgD+NMmpZM0Q6FG7aRsCfZjZ40OpEOMHuVLvs9Z9e6R26w4=
=5/JI
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 9 Jun 2022 22:01
0503b01df689d2e4af62ff112672ed343ac67050.camel@telenet.be
Zac Berkowitz schreef op do 09-06-2022 om 11:11 [-0400]:
Toggle quote (2 lines)
> * gnu/packages/task-management.scm (timewarrior): New variable

This contains a binary src/libshared/src/wcwidth.h, which should be
built from source with the generator

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqJRixccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7qvJAQDCbp7m2AkbsL6MyjHJHil7MPz8
4dRrlwb1vjIXi+9eSAD/U5Nbfm7wBAING4KpQy+2GCHX/rVgS4yadwHhrwWpuAQ=
=171S
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 9 Jun 2022 22:06
7ae686d14e77e1cae8e458fdafb35788e8bd9d2c.camel@telenet.be
Zac Berkowitz schreef op do 09-06-2022 om 11:11 [-0400]:
Toggle quote (3 lines)
> * gnu/packages/task-management.scm (timewarrior): New variable


-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqJSvhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7nuzAP4qmcFEG/CUcmppwFXVPryNvDC2
38oA5rZjXF9JQxkjmQEA/U/BtM4pv0q11lXD69/kt3zZMFfx/CbHIZQ2t+T/ywY=
=qDqq
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 9 Jun 2022 22:08
395752216d24481be235782d3cb782cec4e20f45.camel@telenet.be
Zac Berkowitz schreef op do 09-06-2022 om 11:11 [-0400]:
Toggle quote (4 lines)
> +    (native-inputs
> +     `(("ruby-asciidoctor" ,ruby-asciidoctor)
> +       ("python" ,python)))

According to Debian, additional (native-)inputs are required:


Are the tests actually run and can the man page be read?

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqJTIRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7mHjAPwLdjlXu5Z7T8+kFY6jP++uHzTa
qxQH6dvtT8J2qNz8HQEAra4Mlz09IJRRuCGVP60vuie0FlZX21l2cvCeHqUugw0=
=z7LB
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 9 Jun 2022 22:09
5bdbcd625540ce4c89e3f6ae512608639b1e07a6.camel@telenet.be
Zac Berkowitz schreef op do 09-06-2022 om 11:11 [-0400]:
Toggle quote (8 lines)
> +       (method url-fetch)
> +       (uri (string-append
> +            
> "https://github.com/GothenburgBitFactory/timewarrior/releases/download/v
> " version
> +             "/timew-" version ".tar.gz"))
> +       (sha256 (base32

The tests are missing:


so maybe use the source code on git instead?
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqJTahccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7rOrAQCGNtnDHoWN7854/fl5b6WbeK8Q
4OiCPJd2g69Q43BmhgD6A5rAXq9v/NPKsuc1lKX7U5FKlxnvB7OtMwRz3RPXagU=
=JzaW
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 9 Jun 2022 22:10
f8a6d83fd343aa20a7dd81e8da7c639e5816034f.camel@telenet.be
Zac Berkowitz schreef op do 09-06-2022 om 11:11 [-0400]:
Toggle quote (9 lines)
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +            
> "https://github.com/GothenburgBitFactory/timewarrior/releases/download/v
> " version
> +             "/timew-" version ".tar.gz"))
> +       (sha256 (base32

Is the bash completion installed in the right location?
According to Debian, it isn't:

-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqJTqxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7gvJAP0fFnC6eiJTCewyduG2Onnxg+nH
GX8b5/mkl4feg9CGogD+KoyglwIl+qQr1DFuaIWM1PrOu7yaS6Nck2kYRRbXfwM=
=13+n
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 9 Jun 2022 22:12
5abef1f5d4f29660832066999dac4d4f2287ca0b.camel@telenet.be
Zac Berkowitz schreef op do 09-06-2022 om 11:11 [-0400]:
Toggle quote (4 lines)
> +    (native-inputs
> +     `(("ruby-asciidoctor" ,ruby-asciidoctor)
> +       ("python" ,python)))

Are the scripts in ext/*.py installed somewhere? If so, 'python' needs
to be in 'inputs' instead for cross-compilation.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqJUJBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7pHMAQCa4zVpS9CvTatqqscigFt1sez+
fuz+7MBV7DzFU8ouugD+PwaZiqwnpU8jsMVALZqXw17PdxcsQAYrdyoeotjRkQw=
=Ocmy
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 9 Jun 2022 22:17
56ba51f3df6a70e78518630ad45c3dfc07fdd2a9.camel@telenet.be
According to archlinux, there are some bogus man pages:


are they absent here? (Also, archlinux has the same hash!)
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqJVSRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7oMnAP9k2l/TRTqBzYr2OfS4+jwz+aba
7ZuQ6ALZW5nj0tTkfAEAqGZZXXtZv2Mhd9ouGl3RbSAX7QR0wlxbzdUKKvXQ/Ao=
=770W
-----END PGP SIGNATURE-----


Z
Z
Zac Berkowitz wrote on 10 Jun 2022 03:36
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55874@debbugs.gnu.org)
CANNGBfkQGne5VV2CjT8OqtKb4-2BBm1g+19w3qnrEEYDYC5qCw@mail.gmail.com
Maxime,

Thanks for all of the great feedback -- seems like "works for me"
wasn't nearly good enough in this case! I'll chip away at these
issues next week when I've got some time. Is submitting a new patch
on this bug # the best way forward? Or should I close this and open a
new patch issue when it's ready?

Cheers,

Zac

On Thu, Jun 9, 2022 at 4:17 PM Maxime Devos <maximedevos@telenet.be> wrote:
Toggle quote (6 lines)
>
> According to archlinux, there are some bogus man pages:
>
> https://archlinuxarm.org/packages/aarch64/timew/files/PKGBUILD
>
> are they absent here? (Also, archlinux has the same hash!)
M
M
Maxime Devos wrote on 10 Jun 2022 09:49
(name . Zac Berkowitz)(address . zac.berkowitz@gmail.com)(address . 55874@debbugs.gnu.org)
c78c6132514b8ec6bd68760e3990f915e32748c0.camel@telenet.be
Zac Berkowitz schreef op do 09-06-2022 om 21:36 [-0400]:
Toggle quote (8 lines)
> Maxime,
>
> Thanks for all of the great feedback -- seems like "works for me"
> wasn't nearly good enough in this case!  I'll chip away at these
> issues next week when I've got some time.  Is submitting a new patch
> on this bug # the best way forward?  Or should I close this and open a
> new patch issue when it's ready?

Send it as a v2 to 55874@, then all the relevant information is kept

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqL3lBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7uXAAQChlFMtBZZEZboBDTKgGEt2gOcD
kKmX0mFSPTsC6vjgTAEAjYpYvbWV0IgKJ7jZ0ZUdVQyBy7+yUhICRs2RNH/7mwI=
=Evsm
-----END PGP SIGNATURE-----


Z
Z
Zac Berkowitz wrote on 10 Jun 2022 16:04
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55874@debbugs.gnu.org)
CANNGBfkndu19UdqkeMBwjWhDWcUzwS2mb08O4EFtnt0BJ4yweA@mail.gmail.com
Maxime,

Ended up having a bit of time today to look through what you brought
up. Thanks again for it!

Toggle quote (10 lines)
>> + (native-inputs
>> + `(("ruby-asciidoctor" ,ruby-asciidoctor)
>> + ("python" ,python)))
>
> According to Debian, additional (native-)inputs are required:
>
> https://salsa.debian.org/tasktools-team/timew/-/blob/master/debian/tests/control
>
> Are the tests actually run and can the man page be read?

According to the source
asciidoctor is required to build the docs, but python is not a
requirement at runtime.
I'm able to run the timew executable in a pure shell without moving
python to the input list, so this seems to be a debian issue?

The python scripts in ext/ are completely optional according to the
README in that same directory. Like taskwarrior, timewarrior can
execute python scripts as hooks in response to various commands, but
they're not necessary for base use.
Maybe this is why debian adds the python requirement? So hooks just
work out of the box? How does guix deal with optional dependencies
like this?

Tests are run and pass, but that doesn't rule out determinism issues,
I'll see what debian did to address that.

man pages are not available, I'll correct that.

Toggle quote (13 lines)
>> + (native-inputs
>> + `(("ruby-asciidoctor" ,ruby-asciidoctor)
>> + ("python" ,python)))
>> + (inputs
>> + `(("gnutls" ,gnutls)
>> + ("util-linux:lib" ,util-linux "lib")))
>
> Nowadays, these can be simplified to.
>
> (native-inputs (list ruby-asciidoctor python))
>
> Where did you learn about the old form?

Wouldn't say "learn" - I'm very new to lisps! The code here is mostly
adapted from taskwarrior (same developer) and other snippets from
gnu/packages. I'm sure I grep'd for another package that required
asciidoctor and adapted their portion of the code.

Toggle quote (7 lines)
>>+ (delete 'install-license-files) ; Already installed by
>> package
>
> Not a problem I think -- at worst, the license file will appear twice,
> but identical files are automatically deduplicated, and even if not, they
> are relatively small files anyway.

This is from taskwarrior from the same developer and has a similar
build setup. Seems like both packages should be consistent, but I'm
happy to remove this directive if needed.

Toggle quote (6 lines)
>> + (substitute* "src/commands/CMakeLists.txt"
>> + (("/bin/sh") (which "sh"))))))))
>
> In this context, (which "sh") can maybe be simplified to just "sh", not
> that it really matters.

Ok.




On Fri, Jun 10, 2022 at 3:49 AM Maxime Devos <maximedevos@telenet.be> wrote:
Toggle quote (15 lines)
>
> Zac Berkowitz schreef op do 09-06-2022 om 21:36 [-0400]:
> > Maxime,
> >
> > Thanks for all of the great feedback -- seems like "works for me"
> > wasn't nearly good enough in this case! I'll chip away at these
> > issues next week when I've got some time. Is submitting a new patch
> > on this bug # the best way forward? Or should I close this and open a
> > new patch issue when it's ready?
>
> Send it as a v2 to 55874@, then all the relevant information is kept
> together at <https://issues.guix.gnu.org/55874>.
>
> Greetings,
> Maxime.
M
M
Maxime Devos wrote on 10 Jun 2022 16:54
(name . Zac Berkowitz)(address . zac.berkowitz@gmail.com)(address . 55874@debbugs.gnu.org)
6590de620d1c20115e12eafcacddb7637d903a9e.camel@telenet.be
Zac Berkowitz schreef op vr 10-06-2022 om 10:04 [-0400]:
Toggle quote (9 lines)
> The python scripts in ext/ are completely optional according to the
> README in that same directory.  Like taskwarrior, timewarrior can
> execute python scripts as hooks in response to various commands, but
> they're not necessary for base use.
> Maybe this is why debian adds the python requirement?  So hooks just
> work out of the box?  How does guix deal with optional dependencies
> like this?
>

If it increases the closure size a lot and does not provide much extra
functionality, the extra dependency (and the components that require
that dependency) is removed. (Alternatively the ext/ scripts can be
changed to use the 'python' in $PATH instead of a baked-in 'python',
though such things are avoided where feasible for robustness).

Even if they are optional, adding python might be required such that
the _correct_ python is used when cross-compiling. As a test, you
could try running "guix gc --references" on the timewarrior store item
-- if the output contains python, the ext/... is installed with python.

Probably most people would have python anyway, so I don't think it has
to be removed.

Looking at the output of "guix gc --references", it does indeed use
python from somewhere.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqNbFxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7tP5AP0TSC6Uz5dEDZqeuaXCO97vrp9h
ejUUEww4GeMgOSs+8wD/eHxceU9/h6YZq4HDmSU7Kub/tcIKm+jfmYVyPny9Rg0=
=vzOv
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 10 Jun 2022 16:56
(name . Zac Berkowitz)(address . zac.berkowitz@gmail.com)(address . 55874@debbugs.gnu.org)
98bbd6a0425170530af91a9908d9a4b519987e85.camel@telenet.be
Zac Berkowitz schreef op vr 10-06-2022 om 10:04 [-0400]:
Toggle quote (5 lines)
> According to the source
> (https://github.com/GothenburgBitFactory/timewarrior/blob/develop/INSTALL)
> asciidoctor is required to build the docs, but python is not a
> requirement at runtime.

Then something appears to be broken somewhere, because I'm not seeing
any docs (except for some README) in
</gnu/store/n2hl121g9qgvdpmx4qmsfr1d77hrpxps-timewarrior-1.4.3/>.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqNbhRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7vY5AQDPAS5CgvqQGoXkQzBIqyF8CUm9
ydQq8ib0t4YGjWDIUgD5Ack/EcyXqYv5vbsueMCjAhj/ROrXRq6f3uOUoFasbQw=
=6gj7
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 10 Jun 2022 17:00
(name . Zac Berkowitz)(address . zac.berkowitz@gmail.com)(address . 55874@debbugs.gnu.org)
fc7fa8e3118d9ed6cfc8d924c8c6722b8b763ccb.camel@telenet.be
Zac Berkowitz schreef op vr 10-06-2022 om 10:04 [-0400]:
Toggle quote (5 lines)
> The python scripts in ext/ are completely optional according to the
> README in that same directory.  Like taskwarrior, timewarrior can
> execute python scripts as hooks in response to various commands, but
> they're not necessary for base use.

Two comments:

* the scripts are installed in share/doc/timew, so I don't think they
are actually automatically or discoverable by the user, so FWIW
as-is they can be removed (removing the reference to python).
Alternatively you could look into making them functional, as some
other distros do.

* the scripts do subprocess.call(['timew', ...]). For robustness,
if these scripts are kept, the 'timew' needs to be replaced by the
/gnu/store/.../bin/timew (by using 'substitute*' in a phase).

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqNccxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7pCpAQCtciXnri4wpXFvxKD0LtpitueA
DG5312lNxbRBHvcFLgEAxG/dwXis0huCBV6Tc5vM9GpbJte2YFAEF1XfrseR/g4=
=MmTW
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 10 Jun 2022 17:00
(name . Zac Berkowitz)(address . zac.berkowitz@gmail.com)(address . 55874@debbugs.gnu.org)
5cd4cc70c147ec1e4615b6bbf917a36d88891c20.camel@telenet.be
Zac Berkowitz schreef op vr 10-06-2022 om 10:04 [-0400]:
Toggle quote (6 lines)
> Wouldn't say "learn" - I'm very new to lisps! The code here is mostly
> adapted from taskwarrior (same developer) and other snippets from
> gnu/packages.  I'm sure I grep'd for another package that required
> asciidoctor and adapted their portion of the code.
>

Ok, not all old packages have been converted yet.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqNckRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7gWbAQDsYPiN97wObg9jYo3CFYJWodzF
KzF0Usg/SuCAQZXvbgD+Na0+Z8JTWhKQXdHNbocxV+/InsUr7miuOgny8Otq8wQ=
=nzto
-----END PGP SIGNATURE-----


Z
Z
Zac Berkowitz wrote on 13 Jun 2022 20:14
Re: [bug#55874] [PATCH v2] Add timewarrior 1.4.3
(address . 55874@debbugs.gnu.org)
CANNGBf=5uZB_tOD=CpoHAgH5dB7KgjYZCwhR3Q=3mUgouZbdWw@mail.gmail.com
A new patch that addresses many of the issues from the first attempt:

- python moved to an input dependency. Eases use of bundled but
optional python scripts
- man pages built and installed in share/man/man1/ and share/man/man7/
- bash completions installed to etc/bash_completion.d/
- non-deterministic tests skipped using same patch from debian

That last one I'm sure if it's the best way to go. It still has the
original attribution within the patch file itself, which is good.
Alternatives would be equivalent changes through snippets (hard) or
re-implementing the patch ourselves (silly).

Zac

On Fri, Jun 10, 2022 at 11:00 AM Maxime Devos <maximedevos@telenet.be> wrote:
Toggle quote (9 lines)
>
> Zac Berkowitz schreef op vr 10-06-2022 om 10:04 [-0400]:
> > Wouldn't say "learn" - I'm very new to lisps! The code here is mostly
> > adapted from taskwarrior (same developer) and other snippets from
> > gnu/packages. I'm sure I grep'd for another package that required
> > asciidoctor and adapted their portion of the code.
> >
>
> Ok, not all old packages have been converted yet.
N
N
Nicolas Goaziou wrote on 28 Jan 2023 11:08
(name . Zac Berkowitz)(address . zac.berkowitz@gmail.com)(address . 55874-done@debbugs.gnu.org)
878rhnj7it.fsf@nicolasgoaziou.fr
Hello,

Zac Berkowitz <zac.berkowitz@gmail.com> writes:

Toggle quote (8 lines)
> A new patch that addresses many of the issues from the first attempt:
>
> - python moved to an input dependency. Eases use of bundled but
> optional python scripts
> - man pages built and installed in share/man/man1/ and share/man/man7/
> - bash completions installed to etc/bash_completion.d/
> - non-deterministic tests skipped using same patch from debian

Thank you.

Toggle quote (2 lines)
> That last one I'm sure if it's the best way to go.

I don't know either, but I think your current proposal has merits.

Toggle quote (2 lines)
> Subject: [PATCH] gnu: Add timewarrior.

I added a proper commit message, used G-expressions in the package
definition, registered the patch in local.mk and applied everything.

Sorry for the delay!

Regards,
--
Nicolas Goaziou
Closed
?