(address . guix-patches@gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
* gnu/packages/c.scm (qbe): New variable.
---
Hare + QBE builds, tested running a Hello World program using the stdlib.
gnu/packages/c.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
Toggle diff (52 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index e14e56ad71..01fd2e9a96 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 David Dashyan <mail@davie.li>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1096,3 +1097,37 @@ (define-public utf8-h
C and C++. The functions it provides are like those from the C header
string.h, but with a utf8* prefix instead of the str* prefix.")
(license license:unlicense))))
+
+(define-public qbe
+ (let ((commit "9a3e131cf713f8619705f906caf28c5809708ad0") (revision "0"))
+ (package
+ (name "qbe")
+ (version (git-version "0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://c9x.me/qbe.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04dhdm2j84h9hlqj934wh9v456v3kzh0ayxs1gncyh4inv3b41cf"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no test suite
+ #:make-flags
+ (list (string-append "CC="
+ ,(cc-for-target))
+ (string-append "DESTDIR="
+ (assoc-ref %outputs "out"))
+ "PREFIX=")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ;no configure script
+ (supported-systems (list "x86_64-linux" "aarch64-linux" "riscv64-linux"))
+ (home-page "https://c9x.me/compile/")
+ (synopsis "Compiler backend written in C")
+ (description
+ "QBE aims to be a pure C embeddable backend that provides 70% of the
+performance of advanced compilers in 10% of the code.")
+ (license license:expat))))
--
2.36.1