nar-error on pull
(address . bug-guix@gnu.org)
I’m getting an error when trying to pull inside a docker
container:
Toggle snippet (69 lines)
guix# guix pull
substitute: updating substitutes from
'https://ci.guix.gnu.org'... 100.0%
0.0 MB will be downloaded
le-certs-1 5KiB
552KiB/s 00:00 [##################] 100.0%Updating channel 'guix'
from Git repository at
'https://git.savannah.gnu.org/git/guix.git'...
Authenticating channel 'guix', commits 9edb3f6 to f0e9048 (92 new
commits)...
Building from this channel:
guix https://git.savannah.gnu.org/git/guix.git f0e9048
substitute: updating substitutes from
'https://ci.guix.gnu.org'... 100.0%
[…]
lz4-1.9.3 156KiB
libxft-2.3.3 45KiB
perl-5.34.0 15.1MiB
guix substitute: error: mkdir: File exists
Backtrace:
18 (primitive-load
"/gnu/store/p411j4q9hjk639rwcy1p3s6v89c9bxhr-comput
In ice-9/eval.scm:
155:9 17 (_ _)
159:9 16 (_ #(#(#(#(#(#(#(#(#(#(#(#(#(#(#(#(#<directory
(guile-u?> ?) ?) ?)
In ice-9/boot-9.scm:
152:2 15 (with-fluid* _ _ _)
152:2 14 (with-fluid* _ _ _)
In ./guix/store.scm:
2155:24 13 (run-with-store #<store-connection 256.99
7fe9ea44c140> #<procedure
1983:8 12 (_ #<store-connection 256.99 7fe9ea44c140>)
In ./guix/gexp.scm:
300:22 11 (_ #<store-connection 256.99 7fe9ea44c140>)
1181:2 10 (_ #<store-connection 256.99 7fe9df0440f0>)
1047:2 9 (_ #<store-connection 256.99 7fe9df0440f0>)
893:4 8 (_ #<store-connection 256.99 7fe9df0440f0>)
In ./guix/store.scm:
2040:12 7 (_ #<store-connection 256.99 7fe9df0440f0>)
1395:13 6 (map/accumulate-builds #<store-connection 256.99
7fe9df0440f0> #<pr
1391:5 5 (map/accumulate-builds #<store-connection 256.99
7fe9df0440f0> #<pr
1406:15 4 (_ #<store-connection 256.99 7fe9df0440f0>
("/gnu/store/8v8y8rc4rwd
1406:15 3 (loop #f)
711:11 2 (process-stderr #<store-connection 256.99
7fe9df0440f0> _)
In ./guix/serialization.scm:
102:11 1 (read-int #<input-output: file 10>)
80:6 0 (get-bytevector-n* #<input-output: file 10> 8)
./guix/serialization.scm:80:6: In procedure get-bytevector-n*:
ERROR:
1. &nar-error:
file: #f
port: #<input-output: file 10>
guix pull: error: You found a bug: the program
'/gnu/store/p411j4q9hjk639rwcy1p3
failed to compute the derivation for Guix (version:
"f0e9048e98f0789aa98de88984f
host version: "1.3.0-27.598f728"; pull-version: 1).
Please report the COMPLETE output above by email to
<bug-guix@gnu.org>.
The container was made from this manifest:
Toggle snippet (32 lines)
(use-modules (gnu))
(use-package-modules shells)
(operating-system
(host-name "guix")
(timezone "America/New_York")
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(targets '("/dev/vda"))))
(file-systems (list
(file-system
(mount-point "/")
(device "/dev/vda1")
(type "ext4"))))
(packages (append (map specification->package
'("zsh"))
%base-packages))
(users (cons* (user-account
(name "bjc")
(group "users")
(comment "brian")
(shell (file-append zsh "/bin/zsh"))
(home-directory "/home/bjc")
(supplementary-groups
'("wheel" "netdev" "audio" "video")))
%base-user-accounts)))
With this command:
Toggle snippet (3 lines)
$ guix system image -t docker minimal-sysconf.scm
-bjc