(address . guix-patches@gnu.org)(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
* gnu/packages/python-xyz.scm (python-librouteros): New variable
Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
gnu/packages/python-xyz.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9a5d311680..8d6b91c8f7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -119,6 +119,7 @@
;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -12347,6 +12348,22 @@ (define-public python-idna
(define-public python2-idna
(package-with-python2 python-idna))
+(define-public python-librouteros
+ (package
+ (name "python-librouteros")
+ (version "3.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "librouteros" version))
+ (sha256
+ (base32
+ "121z8w47sx9hczg0jhxwsy2ld1r52z9nnyxqzljb4vfphi0gkh78"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/luqasz/librouteros")
+ (synopsis "Python implementation of MikroTik RouterOS API")
+ (description "Python implementation of MikroTik RouterOS API")
+ (license license:gpl2)))
+
(define-public python-libsass
(package
(name "python-libsass")
--
2.35.1