[PATCH 00/13] gnu: Add multiple haskell packages

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxime Devos
  • Thomas Albers Raviola
Owner
unassigned
Submitted by
Thomas Albers Raviola
Severity
normal
T
T
Thomas Albers Raviola wrote on 18 Apr 2022 20:00
(address . guix-patches@gnu.org)
87bkwyxo1f.fsf@thomaslabs.org
Hello Guix,

the following is a patch series with some of the dependencies needed to
add the `haskell-language-server' package to guix. HSL requires around
100 dependencies not yet included inside of guix. I have working package
declaration for all of them, HSL included, but I need some time to
write useful synopsis and descriptions. Also sending a ~100 entries long
patch series is probably a bad idea.

Regards,
Thomas
T
T
Thomas Albers wrote on 18 Apr 2022 20:09
[PATCH 01/13] gnu: Add ghc-primes
(address . 55005@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20220418180957.19545-1-thomas@thomaslabs.org
---
gnu/packages/haskell-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 0ce47e0902..beba6a5d0c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
;;; Copyright © 2021 Alice BRENON <alice.brenon@ens-lyon.fr>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -16105,3 +16106,23 @@ (define-public ghc-singleton-bool
"This package provides Type-level booleans.")
(license license:bsd-3)))
+(define-public ghc-primes
+ (package
+ (name "ghc-primes")
+ (version "0.2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/primes/primes-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "0ny6fzr967d1fifk050k95j9snnbjjif2bxf3v9s93k3zdc6bmkl"))))
+ (build-system haskell-build-system)
+ (outputs '("out" "static"))
+ (home-page "https://github.com/sebfisch/primes")
+ (synopsis "Purely functional generation of prime numbers")
+ (description
+ "This library provides an efficient lazy wheel sieve for prime generation.")
+ (license license:bsd-3)))
--
2.35.1
T
T
Thomas Albers wrote on 18 Apr 2022 20:09
[PATCH 02/13] gnu: Add ghc-direct-sqlite
(address . 55005@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20220418180957.19545-2-thomas@thomaslabs.org
---
gnu/packages/haskell-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index beba6a5d0c..a1f4678730 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16126,3 +16126,27 @@ (define-public ghc-primes
(description
"This library provides an efficient lazy wheel sieve for prime generation.")
(license license:bsd-3)))
+
+(define-public ghc-direct-sqlite
+ (package
+ (name "ghc-direct-sqlite")
+ (version "2.3.26")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/direct-sqlite/direct-sqlite-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "1z7rwaqhxl9hagbcndg3dkqysr5n2bcz2jrrvdl9pdi905x2663y"))))
+ (build-system haskell-build-system)
+ (outputs '("out" "static"))
+ (inputs (list ghc-semigroups))
+ (native-inputs (list ghc-hunit ghc-base16-bytestring ghc-temporary))
+ (home-page "https://github.com/IreneKnapp/direct-sqlite")
+ (synopsis "Low-level binding to SQLite3")
+ (description
+ "Low-level binding to SQLite3. It supports strings encoded as UTF8, and
+BLOBs represented as ByteStrings.")
+ (license license:bsd-3)))
--
2.35.1
T
T
Thomas Albers wrote on 18 Apr 2022 20:09
[PATCH 03/13] gnu: Add ghc-sqlite-simple
(address . 55005@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20220418180957.19545-3-thomas@thomaslabs.org
---
gnu/packages/haskell-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index a1f4678730..18baf7b2f8 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16150,3 +16150,32 @@ (define-public ghc-direct-sqlite
"Low-level binding to SQLite3. It supports strings encoded as UTF8, and
BLOBs represented as ByteStrings.")
(license license:bsd-3)))
+
+(define-public ghc-sqlite-simple
+ (package
+ (name "ghc-sqlite-simple")
+ (version "0.4.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/sqlite-simple/sqlite-simple-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "00icsf8pgrcqcn5562lmn12yz1f16a2v2q6bl90iknvjyrk1hgzp"))))
+ (build-system haskell-build-system)
+ (outputs '("out" "static"))
+ (inputs
+ (list ghc-attoparsec
+ ghc-blaze-builder
+ ghc-blaze-textual
+ ghc-direct-sqlite
+ ghc-semigroups
+ ghc-only))
+ (native-inputs (list ghc-base16-bytestring ghc-hunit))
+ (home-page "https://github.com/nurpax/sqlite-simple")
+ (synopsis "Mid-Level SQLite client library")
+ (description
+ "Mid-level SQLite client library, based on postgresql-simple.")
+ (license license:bsd-3)))
--
2.35.1
T
T
Thomas Albers wrote on 18 Apr 2022 20:09
[PATCH 04/13] gnu: Add ghc-githash
(address . 55005@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20220418180957.19545-4-thomas@thomaslabs.org
---
gnu/packages/haskell-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 18baf7b2f8..314209f573 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16179,3 +16179,28 @@ (define-public ghc-sqlite-simple
(description
"Mid-level SQLite client library, based on postgresql-simple.")
(license license:bsd-3)))
+
+(define-public ghc-githash
+ (package
+ (name "ghc-githash")
+ (version "0.1.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/githash/githash-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "1vkwc7j71vdrxy01vlm6xfp16kam7m9bnj9y3h217fzhq5mjywhz"))))
+ (build-system haskell-build-system)
+ (outputs '("out" "static"))
+ (arguments `(#:tests? #f))
+ (inputs (list ghc-th-compat))
+ (native-inputs (list ghc-hspec ghc-temporary ghc-unliftio))
+ (home-page "https://github.com/snoyberg/githash")
+ (synopsis "Compile git revision info into Haskell projects")
+ (description
+ "Template Haskell splices for including the current git hash and branch
+in the code of a project.")
+ (license license:bsd-3)))
--
2.35.1
T
T
Thomas Albers wrote on 18 Apr 2022 20:09
[PATCH 05/13] gnu: Add ghc-optparse-simple
(address . 55005@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20220418180957.19545-5-thomas@thomaslabs.org
---
gnu/packages/haskell-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 314209f573..b9b2824dc4 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16204,3 +16204,25 @@ (define-public ghc-githash
"Template Haskell splices for including the current git hash and branch
in the code of a project.")
(license license:bsd-3)))
+
+(define-public ghc-optparse-simple
+ (package
+ (name "ghc-optparse-simple")
+ (version "0.1.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/optparse-simple/optparse-simple-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "0y3qgab8csiwyv60cnpzpv65n3c0ikvdx5b5mfkfahkv8xfdh08x"))))
+ (build-system haskell-build-system)
+ (outputs '("out" "static"))
+ (inputs (list ghc-githash ghc-optparse-applicative ghc-th-compat))
+ (home-page "https://github.com/fpco/optparse-simple")
+ (synopsis "Simple interface to @code{ghc-optparse-applicative}")
+ (description
+ "Simple helper functions to work with @code{ghc-optparse-applicative}.")
+ (license license:bsd-3)))
--
2.35.1
T
T
Thomas Albers wrote on 18 Apr 2022 20:09
[PATCH 07/13] gnu: Add ghc-record-hasfield
(address . 55005@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20220418180957.19545-7-thomas@thomaslabs.org
---
gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5352e9f0b6..4d50437ed4 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16252,3 +16252,26 @@ (define-public ghc-algebraic-graphs
"Library for algebraic construction and manipulation of graphs in
Haskell.")
(license license:expat)))
+
+(define-public ghc-record-hasfield
+ (package
+ (name "ghc-record-hasfield")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/record-hasfield/record-hasfield-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "1jlyhj4nlj4hrypdcv7393nccjmfjnh1311incgqhm5wzigjygaj"))))
+ (build-system haskell-build-system)
+ (outputs '("out" "static"))
+ (home-page "https://github.com/ndmitchell/record-hasfield")
+ (synopsis "Implementation of @code{GHC.Records}")
+ (description
+ "This package provides a version of @code{GHC.Records} as it will be
+after the implementation of GHC proposal #42, plus some helper functions over
+it.")
+ (license license:bsd-3)))
--
2.35.1
T
T
Thomas Albers wrote on 18 Apr 2022 20:09
[PATCH 08/13] gnu: Add ghc-record-dot-preprocessor
(address . 55005@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20220418180957.19545-8-thomas@thomaslabs.org
---
gnu/packages/haskell-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 4d50437ed4..657eb496a5 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16275,3 +16275,24 @@ (define-public ghc-record-hasfield
after the implementation of GHC proposal #42, plus some helper functions over
it.")
(license license:bsd-3)))
+
+(define-public ghc-record-dot-preprocessor
+ (package
+ (name "ghc-record-dot-preprocessor")
+ (version "0.2.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "record-dot-preprocessor" version))
+ (sha256
+ (base32 "07hq90pk30p14jqk016wchmqrc1qhwa9qajaj90i363g3arcb24p"))))
+ (build-system haskell-build-system)
+ (outputs '("out" "static"))
+ (inputs (list ghc-uniplate ghc-extra))
+ (native-inputs (list ghc-record-hasfield))
+ (home-page "https://github.com/ndmitchell/record-dot-preprocessor")
+ (synopsis "Preprocessor to allow @code{record.field} syntax")
+ (description
+ "Preprocessor to allow the @code{record.field} syntax to access the
+fields of records in Haskell.")
+ (license license:bsd-3)))
--
2.35.1
T
T
Thomas Albers wrote on 18 Apr 2022 20:09
[PATCH 09/13] gnu: Add ghc-monoid-subclasses
(address . 55005@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20220418180957.19545-9-thomas@thomaslabs.org
---
gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 657eb496a5..fdc9edabde 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16296,3 +16296,29 @@ (define-public ghc-record-dot-preprocessor
"Preprocessor to allow the @code{record.field} syntax to access the
fields of records in Haskell.")
(license license:bsd-3)))
+
+(define-public ghc-monoid-subclasses
+ (package
+ (name "ghc-monoid-subclasses")
+ (version "1.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "monoid-subclasses" version))
+ (sha256
+ (base32 "1nglki10rlpi872p55pa8g809q5sna7yzh3zw4rqfhq89kb15wcv"))))
+ (build-system haskell-build-system)
+ (outputs '("out" "static"))
+ (inputs (list ghc-primes ghc-vector))
+ (native-inputs
+ (list ghc-quickcheck
+ ghc-quickcheck-instances
+ ghc-tasty
+ ghc-tasty-quickcheck))
+ (home-page "https://github.com/blamario/monoid-subclasses/")
+ (synopsis "Subclasses of Monoid")
+ (description
+ "This package provides a hierarchy of subclasses of @code{Monoid}
+together with their instances for all data structures from base, containers,
+and text packages.")
+ (license license:bsd-3)))
--
2.35.1
T
T
Thomas Albers wrote on 18 Apr 2022 20:09
[PATCH 10/13] gnu: Add ghc-fuzzy
(address . 55005@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20220418180957.19545-10-thomas@thomaslabs.org
---
gnu/packages/haskell-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index fdc9edabde..35a3e7a078 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16322,3 +16322,24 @@ (define-public ghc-monoid-subclasses
together with their instances for all data structures from base, containers,
and text packages.")
(license license:bsd-3)))
+
+(define-public ghc-fuzzy
+ (package
+ (name "ghc-fuzzy")
+ (version "0.1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "fuzzy" version))
+ (sha256
+ (base32 "16pl4ba9f3wlx69pg8va1c2qg4zb9c0w50d7f6d84x9b5ysaza5w"))))
+ (build-system haskell-build-system)
+ (outputs '("out" "static"))
+ (inputs (list ghc-monoid-subclasses))
+ (native-inputs (list ghc-hunit))
+ (home-page "https://github.com/joom/fuzzy")
+ (synopsis "Filter a list based on a fuzzy string search.")
+ (description
+ "Fuzzy string search library for Haskell. Uses TextualMonoid from
+monoid-subclasses to be able to run on different types of strings.")
+ (license license:expat)))
--
2.35.1
T
T
Thomas Albers wrote on 18 Apr 2022 20:09
[PATCH 11/13] gnu: Add ghc-strict-list
(address . 55005@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20220418180957.19545-11-thomas@thomaslabs.org
---
gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 35a3e7a078..cd6de908c6 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16343,3 +16343,29 @@ (define-public ghc-fuzzy
"Fuzzy string search library for Haskell. Uses TextualMonoid from
monoid-subclasses to be able to run on different types of strings.")
(license license:expat)))
+
+(define-public ghc-strict-list
+ (package
+ (name "ghc-strict-list")
+ (version "0.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "strict-list" version))
+ (sha256
+ (base32 "0cbf3my7fghifplk7l2m77cc0x7xkh1pyv5k36h7dl6m2ddhmdc1"))))
+ (build-system haskell-build-system)
+ (outputs '("out" "static"))
+ (inputs (list ghc-hashable ghc-semigroupoids))
+ (native-inputs
+ (list ghc-quickcheck
+ ghc-quickcheck-instances
+ ghc-rerebase
+ ghc-tasty
+ ghc-tasty-hunit
+ ghc-tasty-quickcheck))
+ (home-page "https://github.com/nikita-volkov/strict-list")
+ (synopsis "Strict linked list")
+ (description
+ "Implementation of strict linked list with care taken about stack.")
+ (license license:expat)))
--
2.35.1
T
T
Thomas Albers wrote on 18 Apr 2022 20:09
[PATCH 12/13] gnu: Add ghc-deque
(address . 55005@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20220418180957.19545-12-thomas@thomaslabs.org
---
gnu/packages/haskell-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index cd6de908c6..2b8ea5c8e8 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16369,3 +16369,30 @@ (define-public ghc-strict-list
(description
"Implementation of strict linked list with care taken about stack.")
(license license:expat)))
+
+(define-public ghc-deque
+ (package
+ (name "ghc-deque")
+ (version "0.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "deque" version))
+ (sha256
+ (base32 "1x0rjdqgf4kwgpyisx618waz6r9gki3ivav9m4biysyc04hdhinn"))))
+ (build-system haskell-build-system)
+ (outputs '("out" "static"))
+ (inputs (list ghc-hashable ghc-strict-list))
+ (native-inputs
+ (list ghc-quickcheck
+ ghc-quickcheck-instances
+ ghc-rerebase
+ ghc-tasty
+ ghc-tasty-hunit
+ ghc-tasty-quickcheck))
+ (home-page "https://github.com/nikita-volkov/deque")
+ (synopsis "Double-ended queues")
+ (description
+ "Strict and lazy implementations of Double-Ended Queue based on head-tail
+linked list.")
+ (license license:expat)))
--
2.35.1
T
T
Thomas Albers wrote on 18 Apr 2022 20:09
[PATCH 13/13] gnu: Add ghc-mod
(address . 55005@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20220418180957.19545-13-thomas@thomaslabs.org
---
gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 2b8ea5c8e8..9c378f795f 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16396,3 +16396,29 @@ (define-public ghc-deque
"Strict and lazy implementations of Double-Ended Queue based on head-tail
linked list.")
(license license:expat)))
+
+(define-public ghc-mod
+ (package
+ (name "ghc-mod")
+ (version "0.1.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "mod" version))
+ (sha256
+ (base32 "0m92yd323kjjwnphqlima2aj0hh7i1gnpblc8a29ks25gj0sv66v"))))
+ (build-system haskell-build-system)
+ (outputs '("out" "static"))
+ (inputs (list ghc-semirings ghc-primitive ghc-vector))
+ (native-inputs
+ (list ghc-quickcheck-classes-base
+ ghc-tasty
+ ghc-tasty-quickcheck
+ ghc-quickcheck-classes
+ ghc-quickcheck-classes))
+ (home-page "https://github.com/Bodigrim/mod")
+ (synopsis "Type-safe modular arithmetic")
+ (description
+ "Modular arithmetic, promoting moduli to the type level, with an emphasis
+on performance. Originally part of @code{arithmoi} package.")
+ (license license:expat)))
--
2.35.1
T
T
Thomas Albers wrote on 18 Apr 2022 20:09
[PATCH 06/13] gnu: Add ghc-algebraic-graphs
(address . 55005@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20220418180957.19545-6-thomas@thomaslabs.org
---
gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b9b2824dc4..5352e9f0b6 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16226,3 +16226,29 @@ (define-public ghc-optparse-simple
(description
"Simple helper functions to work with @code{ghc-optparse-applicative}.")
(license license:bsd-3)))
+
+(define-public ghc-algebraic-graphs
+ (package
+ (name "ghc-algebraic-graphs")
+ (version "0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/algebraic-graphs/algebraic-graphs-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "1d3gwyimrzcc7i2qj3iimab3wz6vicgwybhq7ac3da86b8pjlgim"))))
+ (build-system haskell-build-system)
+ (outputs '("out" "static"))
+ (native-inputs (list ghc-extra ghc-inspection-testing ghc-quickcheck))
+ (arguments
+ `(#:cabal-revision
+ ("1" "0f7ih4d0jls7399slxc3zkg38z32jm80jv74iyy42l8s6m5ya1cv")))
+ (home-page "https://github.com/snowleopard/alga")
+ (synopsis "Library for algebraic graph construction and transformation")
+ (description
+ "Library for algebraic construction and manipulation of graphs in
+Haskell.")
+ (license license:expat)))
--
2.35.1
M
M
Maxime Devos wrote on 18 Apr 2022 20:27
Re: [bug#55005] [PATCH 04/13] gnu: Add ghc-githash
7342b568f5f436782e8617f9e6f2450dc7b7d065.camel@telenet.be
Thomas Albers via Guix-patches via schreef op ma 18-04-2022 om 20:09
[+0200]:
Toggle quote (4 lines)
> ---
>  gnu/packages/haskell-xyz.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)

A commit message is mising.

Toggle quote (21 lines)
> diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
> index 18baf7b2f8..314209f573 100644
> --- a/gnu/packages/haskell-xyz.scm
> +++ b/gnu/packages/haskell-xyz.scm
> @@ -16179,3 +16179,28 @@ (define-public ghc-sqlite-simple
>      (description
>       "Mid-level SQLite client library, based on postgresql-simple.")
>      (license license:bsd-3)))
> +
> +(define-public ghc-githash
> +  (package
> +    (name "ghc-githash")
> +    (version "0.1.6.2")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://hackage.haskell.org/package/githash/githash-"
> +             version
> +             ".tar.gz"))

I would Put 'version' and ".tar.gz" on one line here.

Toggle quote (5 lines)
> +       (sha256
> +        (base32 "1vkwc7j71vdrxy01vlm6xfp16kam7m9bnj9y3h217fzhq5mjywhz"))))
> +    (build-system haskell-build-system)
> +    (outputs '("out" "static"))

What are the static libraries for?

Toggle quote (2 lines)
> +    (arguments `(#:tests? #f))

Why are they disabled?

Greetings,
Maxime
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYl2tqxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7sWBAQC4rgFNiCACDJVMdHwc2sHdkJFI
RPIdJ7u3NpDoc4K/pAEA3lWnF1ZzqLKJ/RkeROmWzkCo7upVp5iIomSKQXZ8Wg0=
=oDPl
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 18 Apr 2022 20:30
Re: [bug#55005] [PATCH 05/13] gnu: Add ghc-optparse-simple
3e588b196a05ccf6a9730d9a2763689eb4936f22.camel@telenet.be
Thomas Albers via Guix-patches via schreef op ma 18-04-2022 om 20:09
[+0200]:
Toggle quote (4 lines)
> +    (synopsis "Simple interface to @code{ghc-optparse-applicative}")
> +    (description
> +     "Simple helper functions to work with @code{ghc-optparse-applicative}.")

The synopsis and description is virtually identical, and this doesn't
explain what ghc-optparse-simple is useful for.

More generally, upstream synopses and descriptions are rather limited
and need to be expanded and rewritten a bit. ‘Synopses and
Descriptions’ in the manual has some tips.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYl2uKxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7gmeAP4mNKYWA7Xkkvkj2MMART7AubzZ
zx/9T3Ns8J/XqhCd6AD/WttzKAWdT2fSg0BV1uhycyt/O+RACJTL7GkW20HrWgA=
=6UNg
-----END PGP SIGNATURE-----


T
T
Thomas Albers Raviola wrote on 18 Apr 2022 20:35
Re: [bug#55005] [PATCH 04/13] gnu: Add ghc-githash
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55005@debbugs.gnu.org)
877d7mxm9u.fsf@thomaslabs.org
Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (9 lines)
> [[PGP Signed Part:Undecided]]
> Thomas Albers via Guix-patches via schreef op ma 18-04-2022 om 20:09
> [+0200]:
>> ---
>>  gnu/packages/haskell-xyz.scm | 25 +++++++++++++++++++++++++
>>  1 file changed, 25 insertions(+)
>
> A commit message is mising.
>
You're right. Not only for that package, but for all in the series. I
was convinced 'git send-email' would add them automatically like it
usually does. Is there a command line option for this that I am missing?
Toggle quote (30 lines)
>> diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
>> index 18baf7b2f8..314209f573 100644
>> --- a/gnu/packages/haskell-xyz.scm
>> +++ b/gnu/packages/haskell-xyz.scm
>> @@ -16179,3 +16179,28 @@ (define-public ghc-sqlite-simple
>>      (description
>>       "Mid-level SQLite client library, based on postgresql-simple.")
>>      (license license:bsd-3)))
>> +
>> +(define-public ghc-githash
>> +  (package
>> +    (name "ghc-githash")
>> +    (version "0.1.6.2")
>> +    (source
>> +     (origin
>> +       (method url-fetch)
>> +       (uri (string-append
>> +             "https://hackage.haskell.org/package/githash/githash-"
>> +             version
>> +             ".tar.gz"))
>
> I would Put 'version' and ".tar.gz" on one line here.
>
>> +       (sha256
>> +        (base32 "1vkwc7j71vdrxy01vlm6xfp16kam7m9bnj9y3h217fzhq5mjywhz"))))
>> +    (build-system haskell-build-system)
>> +    (outputs '("out" "static"))
>
> What are the static libraries for?
>
I am myself no sure. They are generated in the build process, so I
thought to add them.
Toggle quote (4 lines)
>> +    (arguments `(#:tests? #f))
>
> Why are they disabled?
>
Tests attempt to write to the read-only file-system. I'll add a comment
explaining this.

Is there a way to correct patches without having to send all over again?
Is it possible to fix the mistakes by adding more patches to the series
on top of the existing ones?

Greetings,
Thomas
M
M
Maxime Devos wrote on 18 Apr 2022 20:55
(name . Thomas Albers Raviola)(address . thomas@thomaslabs.org)(address . 55005@debbugs.gnu.org)
7c7867e9b404ca319a247f6d82ec74935f0adc9d.camel@telenet.be
Thomas Albers Raviola schreef op ma 18-04-2022 om 20:35 [+0200]:
Toggle quote (4 lines)
> You're right. Not only for that package, but for all in the series. I
> was convinced 'git send-email' would add them automatically like it
> usually does. Is there a command line option for this that I am missing?

Not that I'm aware of, AFAIK 'git send-email' automatically includes
the commit message made during "git committ", though it won't write it
for you.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYl20ExccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7lmPAQCe8xqPyhxY5goG+aoyrk/cwyVw
zCFesN+5cRKRZF+argEA+iDA8Y0Pl+AqpVy3izffZGWEZmN1PdPBRWAwhVmL6QE=
=KOVW
-----END PGP SIGNATURE-----


?