guix-daemon, locale, LANG, and unicode in git tag names
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
i'm trying to build a golang package that i have just imported. its repo has a tag with unicode in it, namely v½.2.0, as observable at https://github.com/klauspost/pgzip/tags
(define-public the-pkg
(package
(name "go-github-com-klauspost-pgzip")
(version "1.0.2-0.20170402124221-0bf5dcad4ada")
(source
(origin
(method git-fetch)
(uri (git-reference
(commit "0bf5dcad4ada")))
(file-name (git-file-name name version))
(sha256
(base32 "0dgp2iljvhibzxia1g3lsfg4bjmfh4kf0bfrmfi7sd49hwhrvk7s"))))
(build-system go-build-system)
(arguments '(#:skip-build? #t #:import-path "github.com/klauspost/pgzip"))
(home-page "https://github.com/klauspost/pgzip")
(synopsis "pgzip")
(description
"Package pgzip implements reading and writing of gzip format compressed files, as
specified in @url{https://rfc-editor.org/rfc/rfc1952.html,RFC1952}.")
(license license:expat)))
i have attached the build log, but the essence is this:
guile: warning: failed to install locale
and i can't get rid of this^ warning. i installed glibc-locales to root and my user, reconfigured, restarted the guix-daemon.
which is probably the cause of the ultimate error:
warning: failed to delete .git/refs/tags/v??.2.0: No such file or directory
r:sha256 hash mismatch for...
the daemon starts from an empty env:
and then copies the env from the derivation, but it doesn't seem to contain any LANG value. i assume guile is also launched then without a LANG env. BTW, guile could be more informative in its warning, too.
--
• attila lendvai
• PGP: 963F 5D5F 45C7 DFCD 0A39
--
“The unexamined life is not worth living for a human being.”
— Socrates (c. 470–399 BC, tried and executed), 'Apology' (399 BC)