[PATCH] gnu: Add r-wppi.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220411142916.16841-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-wppi): New variable.
---
gnu/packages/bioconductor.scm | 39 +++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ce1e23f0bf..9d6c7cd5a3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9315,6 +9315,45 @@ (define-public r-xcms
data for high-throughput, untargeted analyte profiling.")
(license license:gpl2+)))
+(define-public r-wppi
+ (package
+ (name "r-wppi")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "wppi" version))
+ (sha256
+ (base32
+ "1spwa8p6w3pyw21dvd1lrhcz1sphdsmsd408jv55ss9nbgvgrp23"))))
+ (properties `((upstream-name . "wppi")))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs (list r-dplyr
+ r-igraph
+ r-logger
+ r-magrittr
+ r-matrix
+ r-omnipathr
+ r-progress
+ r-purrr
+ r-rcurl
+ r-rlang
+ r-tibble
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/AnaGalhoz37/wppi")
+ (synopsis "Weighting protein-protein interactions")
+ (description
+ "This package predicts functional relevance of protein-protein
+interactions based on functional annotations such as Human Protein Ontology and
+Gene Ontology, and prioritizes genes based on network topology, functional
+scores and a path search algorithm.")
+ (license license:expat)))
+
(define-public r-wrench
(package
(name "r-wrench")
--
2.34.0
Ricardo Wurmus wrote 3 years ago
(address . 54857-done@debbugs.gnu.org)
87ee20vt3l.fsf@elephly.net
Applied with an extra comment to explain why HOME must be set. Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54857@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54857
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help