(address . guix-patches@gnu.org)(name . Philip Munksgaard)(address . philip@munksgaard.me)
As discussed in #53655 [0], haskell-build-system.scm does not currently
support packages which contain multiple libraries, such as attoparsec
[1]. Such libraries are often used for internal or convenience libraries, as
detailed in the documentation [2].
The current state of affairs means that attoparsec and any other libraries
with similar structure cannot be built on guix, nor can any library or
executable that depends on such a library.
Instead of assuming that `runhaskell Setup.hs --gen-pkg-config=...` always
outputs a single file, we detect whether the result was a directory. If so, we
need to handle each file independently in lexicographic order by calling the
new private function `install-from-config-file`.
Because `install-transitive-deps` can now be called multiple times for each
call to `register`, it has also been amended to support the files already
installed.
---
guix/build/haskell-build-system.scm | 34 ++++++++++++++++++-----------
1 file changed, 21 insertions(+), 13 deletions(-)
Toggle diff (64 lines)
diff --git a/guix/build/haskell-build-system.scm b/guix/build/haskell-build-system.scm
index ef6cb316ee..e827e23aba 100644
--- a/guix/build/haskell-build-system.scm
+++ b/guix/build/haskell-build-system.scm
@@ -217,11 +217,13 @@ (define* (register #:key name system inputs outputs #:allow-other-keys)
(if (not (vhash-assoc id seen))
(let ((dep-conf (string-append src "/" id ".conf"))
(dep-conf* (string-append dest "/" id ".conf")))
- (when (not (file-exists? dep-conf))
+ (unless (file-exists? dep-conf*)
+ (when (not (file-exists? dep-conf))
(error (format #f "File ~a does not exist. This usually means the dependency ~a is missing. Was checking conf-file ~a." dep-conf id conf-file)))
- (copy-file dep-conf dep-conf*) ;XXX: maybe symlink instead?
- (loop (vhash-cons id #t seen)
- (append lst (conf-depends dep-conf))))
+ (copy-file dep-conf dep-conf*) ;XXX: maybe symlink instead?
+
+ (loop (vhash-cons id #t seen)
+ (append lst (conf-depends dep-conf*)))))
(loop seen tail))))))
(let* ((out (assoc-ref outputs "out"))
@@ -234,13 +236,12 @@ (define* (register #:key name system inputs outputs #:allow-other-keys)
"/ghc-" version
"/" name ".conf.d"))
(id-rx (make-regexp "^id:[ \n\t]+([^ \t\n]+)$" regexp/newline))
- (config-file (string-append out "/" name ".conf"))
+ (config-output (string-append out "/" name ".conf"))
(params
- (list (string-append "--gen-pkg-config=" config-file))))
+ (list (string-append "--gen-pkg-config=" config-output))))
(run-setuphs "register" params)
- ;; The conf file is created only when there is a library to register.
- (when (file-exists? config-file)
- (mkdir-p config-dir)
+
+ (define (install-from-config-file config-file)
(let* ((contents (call-with-input-file config-file read-string))
(config-file-name+id (match:substring (first (list-matches id-rx contents)) 1)))
@@ -270,10 +271,17 @@ (define* (register #:key name system inputs outputs #:allow-other-keys)
(install-transitive-deps config-file %tmp-db-dir config-dir)
(rename-file config-file
(string-append config-dir "/"
- config-file-name+id ".conf"))
- (invoke "ghc-pkg"
- (string-append "--package-db=" config-dir)
- "recache")))
+ config-file-name+id ".conf"))))
+
+ ;; The conf file is created only when there is a library to register.
+ (when (file-exists? config-output)
+ (mkdir-p config-dir)
+ (if (file-is-directory? config-output)
+ (for-each install-from-config-file (find-files config-output))
+ (install-from-config-file config-output))
+ (invoke "ghc-pkg"
+ (string-append "--package-db=" config-dir)
+ "recache"))
#t))
(define* (check #:key tests? test-target #:allow-other-keys)
--
2.35.1