(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
* gnu/packages/emacs-xyz.scm (emacs-pyimport): New variable.
Hi Guixers,
Here is emacs-pyimport.
Also available as a pre-release at https://whereis.???/
all best,
jgart
---
gnu/packages/emacs-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)
Toggle diff (50 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bc9a9f1c28..5b17fd9b65 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30828,6 +30828,43 @@ (define-public emacs-org-modern
headlines, keywords, tables and source blocks.")
(license license:gpl3+)))
+(define-public emacs-pyimport
+ (let ((commit "a6f63cf7ed93f0c0f7c207e6595813966f8852b9")
+ (revision "0"))
+ (package
+ (name "emacs-pyimport")
+ (version (git-version "1.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/Wilfred/pyimport")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1q5gqhvh4zq5dy8vns694warcz48j1hdnxg16sjck4gsi9xivbvs"))))
+ (build-system emacs-build-system)
+ (inputs
+ (list python-pyflakes))
+ (propagated-inputs
+ (list emacs-dash emacs-s emacs-shut-up))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-pyflakes-executable
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((python-pyflakes (assoc-ref inputs "python-pyflakes")))
+ (make-file-writable "pyimport.el")
+ (substitute* "pyimport.el"
+ (("\"pyflakes")
+ (string-append "\"" python-pyflakes "/bin/pyflakes")))))))))
+ (home-page "https://github.com/Wilfred/pyimport")
+ (synopsis "Manage Python imports from Emacs")
+ (description
+"@code{emacs-pyimport} manages python imports from Emacs via @code{python-pyflakes}.")
+ (license license:gpl3+)))) ; License is in pyimport.el
+
(define-public emacs-osm
(package
(name "emacs-osm")
--
2.34.0