(name . Guix Patches)(address . guix-patches@gnu.org)
All the best,
P?ladhammika
From fcd7308b757170c86913b5e97df1971398d30270 Mon Sep 17 00:00:00 2001
From: paladhammika <paladhammika@protonmail.com>
Date: Thu, 10 Feb 2022 16:26:03 -0500
Subject: [PATCH] gnu: Add python-onlykey
---
gnu/packages/python-crypto.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
Toggle diff (39 lines)
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index e49ccdf1f2..8559cc9fd0 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1757,3 +1757,32 @@ (define-public python-sop
scaffolding for the command line, which should make it relatively easy to
supply a handful of python functions as methods to a class.")
(license license:expat))) ; MIT license
+
+(define-public python-onlykey
+ (package
+ (name "python-onlykey")
+ (version "1.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "onlykey" version))
+ (sha256
+ (base32 "1mq02x6qncsjqadqjakywdnfclsv7jaabfk1kzwrm5x05c0hbzji"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ;no tests
+ (native-inputs
+ (list python-cython))
+ (propagated-inputs
+ (list python-aenum
+ python-ecdsa
+ python-hidapi
+ python-onlykey-solo-python
+ python-prompt-toolkit
+ python-pynacl
+ python-six
+ onlykey-udev-rules))
+ (home-page "https://github.com/trustcrypto/python-onlykey")
+ (synopsis "OnlyKey client and command-line tool")
+ (description "@code{OnlyKey Python Command-Line Utility} is a command line tool
+targeted towards more advanced users. This can be used for configuration and testing.")
+ (license license:expat)))
--
2.34.0