[PATCH] gnu: Add python-onlykey

  • Open
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Maxime Devos
  • P?ladhammika
Owner
unassigned
Submitted by
P?ladhammika
Severity
normal
P
P
P?ladhammika wrote on 10 Feb 2022 22:30
(name . Guix Patches)(address . guix-patches@gnu.org)
INC5bc2y4g2zrFljB3GJRhp96xFBl03g3kqEtB3fiidtdqRM0TbdckmnlE8NY7FSXHUyMg8jAWS4MEeRu5ylrrtEOjR777co1aRgfV1ZHNI=@protonmail.com
All the best,
P?ladhammika
From fcd7308b757170c86913b5e97df1971398d30270 Mon Sep 17 00:00:00 2001
From: paladhammika <paladhammika@protonmail.com>
Date: Thu, 10 Feb 2022 16:26:03 -0500
Subject: [PATCH] gnu: Add python-onlykey

---
gnu/packages/python-crypto.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index e49ccdf1f2..8559cc9fd0 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1757,3 +1757,32 @@ (define-public python-sop
scaffolding for the command line, which should make it relatively easy to
supply a handful of python functions as methods to a class.")
(license license:expat))) ; MIT license
+
+(define-public python-onlykey
+ (package
+ (name "python-onlykey")
+ (version "1.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "onlykey" version))
+ (sha256
+ (base32 "1mq02x6qncsjqadqjakywdnfclsv7jaabfk1kzwrm5x05c0hbzji"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ;no tests
+ (native-inputs
+ (list python-cython))
+ (propagated-inputs
+ (list python-aenum
+ python-ecdsa
+ python-hidapi
+ python-onlykey-solo-python
+ python-prompt-toolkit
+ python-pynacl
+ python-six
+ onlykey-udev-rules))
+ (home-page "https://github.com/trustcrypto/python-onlykey")
+ (synopsis "OnlyKey client and command-line tool")
+ (description "@code{OnlyKey Python Command-Line Utility} is a command line tool
+targeted towards more advanced users. This can be used for configuration and testing.")
+ (license license:expat)))
--
2.34.0
M
M
Maxime Devos wrote on 12 Feb 2022 18:48
c6d4e3805b356c88b13304e78be5a1d36de2b7ed.camel@telenet.be
P?ladhammika via Guix-patches via schreef op do 10-02-2022 om 21:30
[+0000]:
Toggle quote (2 lines)
> +   (arguments '(#:tests? #f))           ;no tests

I see a 'tests' directory, so it appears there actually are tests.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYgfy1hccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7ur9APwLPtargRZ1IrdOnNcl/4FzZyiq
14Bd47QbEpMcHbQv9AD/UzuQzZW2et+IolwCPyKHUdpsLhzjItP6geLmIIxNqwM=
=Czc9
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 12 Feb 2022 18:53
087add2ce88b652930582d187ac9fb6b7328df92.camel@telenet.be
P?ladhammika via Guix-patches via schreef op do 10-02-2022 om 21:30
[+0000]:
Toggle quote (6 lines)
> +   (synopsis "OnlyKey client and command-line tool")
> +   (description "@code{OnlyKey Python Command-Line Utility} is a
> command line tool
> +targeted towards more advanced users.  This can be used for
> configuration and testing.")

This tells me that 'OnlyKey Python Command-Line Utility’ is a CLI
tool with some configuration and testing, and it makes a distinction
between ‘advanced users’ and ... ‘not-advanced users’?

Making a judgement about user's ‘advancedness’ doesn't seem nice,
can the description be factual and descriptive, so potential users
can decide for theirselves whether this package is suitable for them?

Also, this description doesn't tell me anything what this package is
useful for. If I replace ‘Onlykey ... Utility’ by ‘shepherd’, then
this might as well be a description for the 'shepherd' package.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYgf0GRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7rnuAP9yCx1HqPU0CORJ/utEdBa6/PLl
Y+cJp5Jlw3YAd075HwD8Cw83UobVfGQVqrQM7kfQIVNUsZoCYwQTGd5w5/qtgAQ=
=RiYV
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 12 Feb 2022 18:55
8645544b2ba50c6068f9a484944232cff6272dbf.camel@telenet.be
P?ladhammika via Guix-patches via schreef op do 10-02-2022 om 21:30
[+0000]:
Toggle quote (2 lines)
> +   (license license:expat)))

How did you determine this license? I'm not seeing the Expat license
text anywhere in the git repo, and the only mention of 'expat' or 'MIT'
appears to be in in ‘setup.py’, but ‘setup.py’ only says

license='MIT'

which does not seem sufficient to me.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYgf0oxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7q8PAQCc4Slpu7UwnqUsmrNUvbSzHWYt
A/XGwh+pDc5EyYz1KAD+NRTKRvPNAQ3Lo50MpuPnOhPlVSU6zDSGc78HvZewawk=
=PoeB
-----END PGP SIGNATURE-----


P
P
P?ladhammika wrote on 12 Feb 2022 23:02
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 53929@debbugs.gnu.org)
khOC7bNnehbNosGAoRhCIO-RZvMP5f5DJucBVzjE1ZSP2pVofB-4OCIHhBedWThj5xp7Y7lFeenPcqRfM_8skXX3aX9ci_u8qkAfdv4nqV0=@protonmail.com

All the best,
P?ladhammika

------- Original Message -------

On Saturday, February 12th, 2022 at 5:48 PM, Maxime Devos <maximedevos@telenet.be> wrote:

Toggle quote (11 lines)
> P?ladhammika via Guix-patches via schreef op do 10-02-2022 om 21:30
>
> [+0000]:
>
> > +   (arguments '(#:tests? #f))           ;no tests
>
> I see a 'tests' directory, so it appears there actually are tests.
>
> Greetings,
>
> Maxime.
P
P
P?ladhammika wrote on 12 Feb 2022 23:14
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 53929@debbugs.gnu.org)
_5MWuFe-sXDHK90TaKvOd_qPXBmA5dZYpeMS8_ryJJxaasg4wgoYM9vGybPEU2B4nYfza_0xUW37WE6Ni9H27EmgzL-Ti-WtPTDiNGW50ho=@protonmail.com
This was auto-generated by `guix import pypi onlykey`. Also checked it against the Nix definition (https://github.com/NixOS/nixpkgs/blob/7adc9c14ec74b27358a8df9b973087e351425a79/pkgs/tools/security/onlykey-cli/default.nix#L31)and MIT can be see as the license on PyPI (https://pypi.org/project/onlykey/). Other than that there seems to be no declaration of a license.

All the best,
P?ladhammika

Sent with ProtonMail Secure Email.

------- Original Message -------

On Saturday, February 12th, 2022 at 5:55 PM, Maxime Devos <maximedevos@telenet.be> wrote:

Toggle quote (19 lines)
> P?ladhammika via Guix-patches via schreef op do 10-02-2022 om 21:30
>
> [+0000]:
>
> > +   (license license:expat)))
>
> How did you determine this license? I'm not seeing the Expat license
>
> text anywhere in the git repo, and the only mention of 'expat' or 'MIT'
>
> appears to be in in ‘setup.py’, but ‘setup.py’ only says
>
> license='MIT'
>
> which does not seem sufficient to me.
>
> Greetings,
>
> Maxime.
P
P
P?ladhammika wrote on 12 Feb 2022 23:15
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 53929@debbugs.gnu.org)
bCLP-lc1UWTrBzT2Tox0nPPXH8sT_oST7jMqJetu-ehofk40bTjD8M8mNA7R9U95uwuYbN-BOYAz_YamJ5QxIBWmxGBB8mdaZOv1PhL96qw=@protonmail.com
Taken from the horses mouth: "A command line interface to the OnlyKey (Similar functionality to OnlyKey App) that can be used for configuration, scripting, and testing." -- Is this considered sufficient?

All the best,
P?ladhammika

------- Original Message -------

On Saturday, February 12th, 2022 at 5:53 PM, Maxime Devos <maximedevos@telenet.be> wrote:

Toggle quote (35 lines)
> P?ladhammika via Guix-patches via schreef op do 10-02-2022 om 21:30
>
> [+0000]:
>
> > +   (synopsis "OnlyKey client and command-line tool")
> >
> > +   (description "@code{OnlyKey Python Command-Line Utility} is a
> >
> > command line tool
> >
> > +targeted towards more advanced users.  This can be used for
> >
> > configuration and testing.")
>
> This tells me that 'OnlyKey Python Command-Line Utility’ is a CLI
>
> tool with some configuration and testing, and it makes a distinction
>
> between ‘advanced users’ and ... ‘not-advanced users’?
>
> Making a judgement about user's ‘advancedness’ doesn't seem nice,
>
> can the description be factual and descriptive, so potential users
>
> can decide for theirselves whether this package is suitable for them?
>
> Also, this description doesn't tell me anything what this package is
>
> useful for. If I replace ‘Onlykey ... Utility’ by ‘shepherd’, then
>
> this might as well be a description for the 'shepherd' package.
>
> Greetings,
>
> Maxime.
L
L
Ludovic Courtès wrote on 6 Mar 2022 22:23
Re: bug#53929: [PATCH] gnu: Add python-onlykey
(name . P?ladhammika)(address . paladhammika@protonmail.com)
87a6e2kc6t.fsf_-_@gnu.org
Hi P?ladhammika,

P?ladhammika <paladhammika@protonmail.com> skribis:

Toggle quote (2 lines)
In Guix the QA standard is to run tests by default. When tests cannot
be run for some reason, we add a short comment next to #:tests? #f
explaining why.

Could you take this and Maxime’s other comments into account and send an
updated patch?

Thanks in advance!

Ludo’.
L
L
Ludovic Courtès wrote on 5 Apr 2022 18:09
(name . P?ladhammika)(address . paladhammika@protonmail.com)
87wng3ldg9.fsf_-_@gnu.org
Hi P?ladhammika,

A friendly reminder:


TIA,
Ludo’.

Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (16 lines)
> Hi P?ladhammika,
>
> P?ladhammika <paladhammika@protonmail.com> skribis:
>
>> I see. Took the Nix package definition as an example (https://github.com/NixOS/nixpkgs/blob/7adc9c14ec74b27358a8df9b973087e351425a79/pkgs/tools/security/onlykey-cli/default.nix#L25) which turned off tests.
>
> In Guix the QA standard is to run tests by default. When tests cannot
> be run for some reason, we add a short comment next to #:tests? #f
> explaining why.
>
> Could you take this and Maxime’s other comments into account and send an
> updated patch?
>
> Thanks in advance!
>
> Ludo’.
L
L
Ludovic Courtès wrote on 27 Apr 2022 23:07
87czh2i6bo.fsf_-_@gnu.org
Hi!

P?ladhammika let me know privately that they won’t be able to take care
of it in the foreseeable future.

Any takers?

If not, I suggest closing this issue in a couple of weeks.

Ludo’.
?