(name . bug-guix)(address . bug-guix@gnu.org)
Hello Guix!
Consider the following:
Toggle snippet (46 lines)
$ mkdir /tmp/test && cd /tmp/test
$ cat <<EOF > manifest.scm
(packages->manifest
(list (specification->package "make")))
EOF
$ guix shell
guix shell: error: not loading '/tmp/test/manifest.scm' because not authorized to do so
hint: To allow automatic loading of `/tmp/test/manifest.scm' when running `guix shell', you must explicitly
authorize its directory, like so:
echo /tmp/test >> /home/maxim/.config/guix/shell-authorized-directories
$ echo /tmp/test >> /home/maxim/.config/guix/shell-authorized-directories
$ guix shell
guix shell: loading environment from '/tmp/test/manifest.scm'...
The following derivation will be built:
/gnu/store/886dfpr1fc43insawzbnk8s713bh9nf8-profile.drv
building CA certificate bundle...
listing Emacs sub-directories...
building fonts directory...
building directory of Info manuals...
The following builds are still in progress:
/gnu/store/40p4vzxxmhz6ah25cx4iil3v5f87lmwn-info-dir.drv
/gnu/store/k0jkw8rfskymq3lnkdjs9ljmccvbwcc3-fonts-dir.drv
/gnu/store/y3y53p535v0nqvfjlzb3bw352m78xmdx-emacs-subdirs.drv
The following builds are still in progress:
/gnu/store/40p4vzxxmhz6ah25cx4iil3v5f87lmwn-info-dir.drv
/gnu/store/k0jkw8rfskymq3lnkdjs9ljmccvbwcc3-fonts-dir.drv
The following build is still in progress:
/gnu/store/40p4vzxxmhz6ah25cx4iil3v5f87lmwn-info-dir.drv
building profile with 1 package...
[env]$ exit
$ guix shell -C -- make
guix shell: warning: no packages specified; creating an empty environment
guix shell: error: make: command not found
The last command exhibit the problem.
Thanks,
Maxim