guix shell not reading manifest.scm when used with '--'

  • Done
  • quality assurance status badge
Details
3 participants
  • Josselin Poiret
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
Merged with
M
M
Maxim Cournoyer wrote on 9 Feb 2022 05:19
(name . bug-guix)(address . bug-guix@gnu.org)
87czjw1xl5.fsf@gmail.com
Hello Guix!

Consider the following:

Toggle snippet (46 lines)
$ mkdir /tmp/test && cd /tmp/test

$ cat <<EOF > manifest.scm
(packages->manifest
(list (specification->package "make")))
EOF

$ guix shell
guix shell: error: not loading '/tmp/test/manifest.scm' because not authorized to do so
hint: To allow automatic loading of `/tmp/test/manifest.scm' when running `guix shell', you must explicitly
authorize its directory, like so:

echo /tmp/test >> /home/maxim/.config/guix/shell-authorized-directories

$ echo /tmp/test >> /home/maxim/.config/guix/shell-authorized-directories

$ guix shell
guix shell: loading environment from '/tmp/test/manifest.scm'...
The following derivation will be built:
/gnu/store/886dfpr1fc43insawzbnk8s713bh9nf8-profile.drv

building CA certificate bundle...
listing Emacs sub-directories...
building fonts directory...
building directory of Info manuals...
The following builds are still in progress:
/gnu/store/40p4vzxxmhz6ah25cx4iil3v5f87lmwn-info-dir.drv
/gnu/store/k0jkw8rfskymq3lnkdjs9ljmccvbwcc3-fonts-dir.drv
/gnu/store/y3y53p535v0nqvfjlzb3bw352m78xmdx-emacs-subdirs.drv

The following builds are still in progress:
/gnu/store/40p4vzxxmhz6ah25cx4iil3v5f87lmwn-info-dir.drv
/gnu/store/k0jkw8rfskymq3lnkdjs9ljmccvbwcc3-fonts-dir.drv

The following build is still in progress:
/gnu/store/40p4vzxxmhz6ah25cx4iil3v5f87lmwn-info-dir.drv

building profile with 1 package...

[env]$ exit

$ guix shell -C -- make
guix shell: warning: no packages specified; creating an empty environment
guix shell: error: make: command not found

The last command exhibit the problem.

Thanks,

Maxim
J
J
Josselin Poiret wrote on 9 Feb 2022 10:15
87tud8mmdp.fsf@jpoiret.xyz
Hi Maxim,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (8 lines)
> --8<---------------cut here---------------start------------->8---
> $ guix shell -C -- make
> guix shell: warning: no packages specified; creating an empty environment
> guix shell: error: make: command not found
> --8<---------------cut here---------------end--------------->8---
>
> The last command exhibit the problem.

I believe this is [1].


Best,
--
Josselin Poiret
M
M
Maxim Cournoyer wrote on 9 Feb 2022 16:40
(name . Josselin Poiret)(address . dev@jpoiret.xyz)
87sfssyro9.fsf@gmail.com
merge 52347 53892
thanks

Hello Josselin!

Josselin Poiret <dev@jpoiret.xyz> writes:

Toggle quote (16 lines)
> Hi Maxim,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> --8<---------------cut here---------------start------------->8---
>> $ guix shell -C -- make
>> guix shell: warning: no packages specified; creating an empty environment
>> guix shell: error: make: command not found
>> --8<---------------cut here---------------end--------------->8---
>>
>> The last command exhibit the problem.
>
> I believe this is [1].
>
> [1] https://issues.guix.gnu.org/52347#18

Oh, I had missed it; thanks for pointing it out. I've merged the two
issues.

Thank you!

Maxim
L
L
Ludovic Courtès wrote on 2 Mar 2022 11:41
(name . Josselin Poiret)(address . dev@jpoiret.xyz)
87a6e84oxp.fsf@gnu.org
Hi,

Josselin Poiret <dev@jpoiret.xyz> skribis:

Toggle quote (14 lines)
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> --8<---------------cut here---------------start------------->8---
>> $ guix shell -C -- make
>> guix shell: warning: no packages specified; creating an empty environment
>> guix shell: error: make: command not found
>> --8<---------------cut here---------------end--------------->8---
>>
>> The last command exhibit the problem.
>
> I believe this is [1].
>
> [1] https://issues.guix.gnu.org/52347#18

Should we close as “notabug”?

Ludo’.
M
M
Maxim Cournoyer wrote on 2 Mar 2022 15:04
(name . Ludovic Courtès)(address . ludo@gnu.org)
874k4gjvqx.fsf@gmail.com
tags 53892 notabug
--

Hi Ludovic,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (20 lines)
> Hi,
>
> Josselin Poiret <dev@jpoiret.xyz> skribis:
>
>> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>>
>>> --8<---------------cut here---------------start------------->8---
>>> $ guix shell -C -- make
>>> guix shell: warning: no packages specified; creating an empty environment
>>> guix shell: error: make: command not found
>>> --8<---------------cut here---------------end--------------->8---
>>>
>>> The last command exhibit the problem.
>>
>> I believe this is [1].
>>
>> [1] https://issues.guix.gnu.org/52347#18
>
> Should we close as “notabug”?

That seems reasonable; and I see it's already documented as such.

Good for me! Thanks for pointing it out.

Maxim
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53892@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53892
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch