(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
---
gnu/packages/web.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (35 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7911378f29..54da8e0b97 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1489,6 +1489,28 @@ (define-public wabt
other systems that want to manipulate WebAssembly files.")
(license license:asl2.0)))
+(define-public binaryen
+ (package
+ (name "binaryen")
+ (version "105")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/WebAssembly/binaryen")
+ (commit (string-append "version_" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0yg9rarjv1gfbq225cj9hnbgx99n5az2m19qwfp8z41dwhh71igm"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/WebAssembly/binaryen")
+ (synopsis "Compiler infrastructure and toolchain library for WebAssembly")
+ (description "Binaryen is a compiler and toolchain infrastructure
+library for WebAssembly, written in C++. It aims to make compiling to
+WebAssembly easy, fast, and effective")
+ (license license:asl2.0)))
+
(define-public websocketpp
(package
(name "websocketpp")
--
2.34.0