Add binaryen

  • Open
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Maxime Devos
  • WinterHound
Owner
unassigned
Submitted by
WinterHound
Severity
normal
W
W
WinterHound wrote on 2 Feb 2022 18:08
(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
20220202170814.19498-1-winterhound@yandex.com
---
gnu/packages/web.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7911378f29..54da8e0b97 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1489,6 +1489,28 @@ (define-public wabt
other systems that want to manipulate WebAssembly files.")
(license license:asl2.0)))
+(define-public binaryen
+ (package
+ (name "binaryen")
+ (version "105")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/WebAssembly/binaryen")
+ (commit (string-append "version_" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0yg9rarjv1gfbq225cj9hnbgx99n5az2m19qwfp8z41dwhh71igm"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/WebAssembly/binaryen")
+ (synopsis "Compiler infrastructure and toolchain library for WebAssembly")
+ (description "Binaryen is a compiler and toolchain infrastructure
+library for WebAssembly, written in C++. It aims to make compiling to
+WebAssembly easy, fast, and effective")
+ (license license:asl2.0)))
+
(define-public websocketpp
(package
(name "websocketpp")
--
2.34.0
M
M
Maxime Devos wrote on 2 Feb 2022 20:21
7334a114e6e557226aa7e86fd6409b1fe889a35d.camel@telenet.be
WinterHound schreef op wo 02-02-2022 om 22:38 [+0530]:
Toggle quote (12 lines)
> +(define-public binaryen
> + (package
> + (name "binaryen")
> + (version "105")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/WebAssembly/binaryen")
> + (commit (string-append "version_" version))
> + (recursive? #t)))

There's some bundling in third_party (googletest, parts of llvm and
mozjs). IIRC this software is already in Guix, so can we use the
version from Guix instead?

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYfrZtxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7hlBAP9FVM2buTtWaDhaFHjIzr9Xa7Xx
yXz6h4nr16Ef9NaWPwEAhlxV+r441E7Ek27pE0cby8ATmfAX/1U43wPKIUI1Ng4=
=N7TC
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 6 Mar 2022 22:38
Re: bug#53730: Add binaryen
(name . WinterHound)(address . winterhound@yandex.com)
87wnh6iwx8.fsf_-_@gnu.org
Hi WinterHound,

Did you have a chance to look into Maxime’s suggestion?


Thanks in advance,
Ludo’.

Maxime Devos <maximedevos@telenet.be> skribis:

Toggle quote (19 lines)
> WinterHound schreef op wo 02-02-2022 om 22:38 [+0530]:
>> +(define-public binaryen
>> + (package
>> + (name "binaryen")
>> + (version "105")
>> + (source
>> + (origin
>> + (method git-fetch)
>> + (uri (git-reference
>> + (url "https://github.com/WebAssembly/binaryen")
>> + (commit (string-append "version_" version))
>> + (recursive? #t)))
>
> There's some bundling in third_party (googletest, parts of llvm and
> mozjs). IIRC this software is already in Guix, so can we use the
> version from Guix instead?
>
> Greetings,
> Maxime.
W
W
WinterHound wrote on 15 Mar 2022 07:32
[PATCH] Replaced with Guix packages
(address . 53730@debbugs.gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
20220315063258.6194-1-winterhound@yandex.com
---
gnu/packages/web.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 54da8e0b97..0642db78c7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1498,12 +1498,13 @@ (define-public binaryen
(method git-fetch)
(uri (git-reference
(url "https://github.com/WebAssembly/binaryen")
- (commit (string-append "version_" version))
- (recursive? #t)))
+ (commit (string-append "version_" version))))
(file-name (git-file-name name version))
(sha256
(base32 "0yg9rarjv1gfbq225cj9hnbgx99n5az2m19qwfp8z41dwhh71igm"))))
(build-system cmake-build-system)
+ (native-inputs (list googletest))
+ (inputs (list mozjs wabt llvm))
(home-page "https://github.com/WebAssembly/binaryen")
(synopsis "Compiler infrastructure and toolchain library for WebAssembly")
(description "Binaryen is a compiler and toolchain infrastructure
--
2.34.0
?