[PATCH] gnu: Add mold.

  • Done
  • quality assurance status badge
Details
5 participants
  • Ludovic Courtès
  • Andreas Rottmann
  • Maxime Devos
  • phodina
  • zamfofex
Owner
unassigned
Submitted by
Andreas Rottmann
Severity
normal
A
A
Andreas Rottmann wrote on 17 Jan 2022 20:56
(address . guix-patches@gnu.org)
87fspmyuji.fsf@r0tty.org
From ec3a1c3c0a742f5a98c3a6d2e86da663f993958e Mon Sep 17 00:00:00 2001
From: Andreas Rottmann <rotty@r0tty.org>
Date: Mon, 17 Jan 2022 21:03:10 +0100
Subject: [PATCH] gnu: Add mold.

* gnu/packages/mold.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
gnu/local.mk | 1 +
gnu/packages/mold.scm | 56 +++++++++++++++++++++++++++++++++++++++++++
2 files changed, 57 insertions(+)
create mode 100644 gnu/packages/mold.scm

Toggle diff (76 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index eac8652056..91da63703a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -403,6 +403,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/mingw.scm \
%D%/packages/microcom.scm \
%D%/packages/moe.scm \
+ %D%/packages/mold.scm \
%D%/packages/motti.scm \
%D%/packages/monitoring.scm \
%D%/packages/mono.scm \
diff --git a/gnu/packages/mold.scm b/gnu/packages/mold.scm
new file mode 100644
index 0000000000..87c106c069
--- /dev/null
+++ b/gnu/packages/mold.scm
@@ -0,0 +1,56 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Andreas Rottmann <rotty@r0tty.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages mold)
+ #:use-module ((guix licenses) #:select (agpl3+))
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix utils)
+ #:use-module (gnu packages cmake)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages digest)
+ #:use-module (gnu packages tls))
+
+(define-public mold
+ (package
+ (name "mold")
+ (version "1.0.1")
+ (home-page "https://github.com/rui314/mold")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ydgcx6vycg7jv4pksv4875cwqdysfm0cpscsdfy0inr5mjrbs8v"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; TODO: Tests require clang and hardcode `cc`
+ #:make-flags (list (string-append "CC=" ,(cc-for-target))
+ (string-append "CXX=" ,(cxx-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list cmake))
+ (inputs (list openssl zlib xxhash))
+ (synopsis "Modern Linker")
+ (description "mold is a faster drop-in replacement for existing Unix linkers.")
+ (license agpl3+)))
--
2.30.2
Z
Z
zamfofex wrote on 18 Jan 2022 07:47
(name . 53327@debbugs.gnu.org)(address . 53327@debbugs.gnu.org)
1962407340.961605.1642488443687@privateemail.com
Hello! I’m not a Guix maintainer, but wouldn’t it make sense to use the mold dependencies from their own packages instead of letting them be built (statically) from their copies in the mold repository?

Fairly coincidentally, I have actually packaged mold myself before, but I have not yet sent it as a patch here. You might be able to reuse some of my work. See: https://github.com/zamfofex/packages/blob/main/zamfofex/compilers/mold.scm
M
M
Maxime Devos wrote on 20 Jan 2022 21:16
93ded3273884b0afcd5ae9b654351b3568e334c2.camel@telenet.be
Hi,

(*partial* review)

There's a directory 'third_party' with bundled code, can it be removed
(in an origin snippet)?

Andreas Rottmann schreef op ma 17-01-2022 om 20:56 [+0100]:
Toggle quote (2 lines)
> +     `(#:tests? #f ; TODO: Tests require clang and hardcode `cc`

'clang'  can be added to native-inputs and hardcoded ‘cc’ can be
replaced with 'clang' or 'gcc' with 'substitute*'.

Toggle quote (4 lines)
> +       #:make-flags (list (string-append "CC=" ,(cc-for-target))
> +                          (string-append "CXX=" ,(cxx-for-target))
> +                          (string-append "PREFIX=" %output))

%output is being phased out, instead use #$output (make sure to add ,#~
before (list ...)).

Toggle quote (2 lines)
> + (inputs (list openssl zlib xxhash))

Why does mold need openssl here? I don't see the relation between
linking and TLS.

Toggle quote (2 lines)
> +    (synopsis "Modern Linker")

Why is ‘Linker’ capitalised? Also, as I understand it, the point
of mold is not chasing whatever is considered ‘modern’, but rather
being fast and requiring little memory, albeit at the cost of
supporting less (less targets, no linker scripts, ...).

Toggle quote (1 lines)
> + (description "mold is a faster drop-in replacement for existing
Unix linkers.")

It's a bit short, maybe you could write a bit about memory usage,
limitations

Since 'mold' is said to be very efficient, it might be interesting to
determine if Guix could use 'mold' instead of the linker from
'binutils' by default (with some exceptions like GRUB and Linux which
might actually need GNU ld linker scripts) ... that's more something
for guix-devel and future patches though.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYenDCRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7hoOAP4ib7b0crtdm9UD6bQHntVTtbmd
wL8f31BCJZIKExyEPgD7BKNbo6Y1hUT+FZejwo0o2jA/+HysHEtJw2opcphY1gU=
=HjET
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 7 Mar 2022 21:53
Re: bug#53327: [PATCH] gnu: Add mold.
(name . Andreas Rottmann)(address . mail@r0tty.org)
87v8wpa3hb.fsf_-_@gnu.org
Hi Andreas,

Long time no see! ;-)

Did you have a chance to look into Maxime’s suggestions?


(I have nothing to add to what Maxime wrote.)

TIA,
Ludo’.

Maxime Devos <maximedevos@telenet.be> skribis:

Toggle quote (46 lines)
> Hi,
>
> (*partial* review)
>
> There's a directory 'third_party' with bundled code, can it be removed
> (in an origin snippet)?
>
> Andreas Rottmann schreef op ma 17-01-2022 om 20:56 [+0100]:
>> +     `(#:tests? #f ; TODO: Tests require clang and hardcode `cc`
>
> 'clang'  can be added to native-inputs and hardcoded ‘cc’ can be
> replaced with 'clang' or 'gcc' with 'substitute*'.
>
>> +       #:make-flags (list (string-append "CC=" ,(cc-for-target))
>> +                          (string-append "CXX=" ,(cxx-for-target))
>> +                          (string-append "PREFIX=" %output))
>
> %output is being phased out, instead use #$output (make sure to add ,#~
> before (list ...)).
>
>> + (inputs (list openssl zlib xxhash))
>
> Why does mold need openssl here? I don't see the relation between
> linking and TLS.
>
>> +    (synopsis "Modern Linker")
>
> Why is ‘Linker’ capitalised? Also, as I understand it, the point
> of mold is not chasing whatever is considered ‘modern’, but rather
> being fast and requiring little memory, albeit at the cost of
> supporting less (less targets, no linker scripts, ...).
>
>> + (description "mold is a faster drop-in replacement for existing
> Unix linkers.")
>
> It's a bit short, maybe you could write a bit about memory usage,
> limitations
>
> Since 'mold' is said to be very efficient, it might be interesting to
> determine if Guix could use 'mold' instead of the linker from
> 'binutils' by default (with some exceptions like GRUB and Linux which
> might actually need GNU ld linker scripts) ... that's more something
> for guix-devel and future patches though.
>
> Greetings,
> Maxime.
P
P
phodina wrote on 2 Jul 2022 00:12
Another mold patch
(name . 53327@debbugs.gnu.org)(address . 53327@debbugs.gnu.org)
8ozgVvzSUKg3T47Lm39RhWIrA4tNDwgtywY6lPtvz9E7vjEWKggtlQ4iDg6VFpJVj6mwIIHMOIRTBedMLH7EgqaBYxyW3I_V6Bx6FW9jEWE=@protonmail.com
Hi!

I've also sumbitted patch for mold :-D in https://issues.guix.gnu.org/53601

If nobody is interested in upstreaming I can update the package and take into consideration the fixes Maxime mentioned.

----
Petr
Attachment: file
L
L
Ludovic Courtès wrote on 12 Feb 2023 01:47
Re: bug#60754: [PATCH 1/2] gnu: Add mold.
(name . Zhu Zihao)(address . all_but_last@163.com)
87357bn209.fsf_-_@gnu.org
Hi,

Zhu Zihao <all_but_last@163.com> skribis:

Toggle quote (4 lines)
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add new file.
> * gnu/packages/mold.scm: New file.
> * gnu/packages/mold.scm (mold): New variable.

[...]

Toggle quote (4 lines)
> * gnu/packages/mold.scm(make-mold-wrapper): New variable.
> (mold-wrapper): New variable.
> (mold-as-ld-wrapper): New variable.

Applied both with minor changes (see below), thanks.

I’m also closing the two other issues you mentioned that were adding
mold. Please let us know if there’s something to borrow from them!

Ludo’.
Toggle diff (20 lines)
diff --git a/gnu/packages/mold.scm b/gnu/packages/mold.scm
index 6514bd3b90..dfc452a329 100644
--- a/gnu/packages/mold.scm
+++ b/gnu/packages/mold.scm
@@ -77,12 +77,12 @@ (define-public mold
(delete-file "test/elf/rpath.sh"))))))
(inputs (list mimalloc openssl tbb xxhash zlib `(,zstd "lib")))
(home-page "https://github.com/rui314/mold")
- (synopsis "Faster drop-in replacement for Unix linkers")
+ (synopsis "Fast linker")
(description
- "Mold is a faster drop-in replacement for existing Unix linkers.
+ "Mold is a faster drop-in replacement for existing linkers.
It is designed to increase developer productivity by reducing build time,
especially in rapid debug-edit-rebuild cycles.")
- (license license:agpl3+)))
+ (license license:agpl3)))
(define* (make-mold-wrapper mold #:key mold-as-ld?)
"Return a MOLD wrapper. When MOLD-AS-LD? is true, create a 'ld' symlink that
Closed
?