[PATCH 0/3] Small fixes for some matrix packages

  • Done
  • quality assurance status badge
Details
4 participants
  • Morgan.J.Smith
  • Aleksandr Vityazev
  • Nicolas Goaziou
  • Maxime Devos
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 3 years ago
(address . guix-patches@gnu.org)
DM5PR03MB3163284853505D39FBEC2A63C5559@DM5PR03MB3163.namprd03.prod.outlook.com
So emacs-ement doesn't work without its inputs being propagated. I think pantalaimon works with its current inputs but the panctl program to control pantalaimon (which is part of the pantalaimon package) doesn't work without these inputs.

[PATCH 1/3] gnu: emacs-ement: Propagate inputs.
[PATCH 2/3] gnu: Add python-pydbus.
[PATCH 3/3] gnu: pantalaimon: Add needed inputs
Morgan.J.Smith wrote 3 years ago
[PATCH 1/3] gnu: emacs-ement: Propagate inputs.
(address . 53286@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB31631F0063DA07CC7291CFA2C5559@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz (emacs-ement) <inputs>: Change to propagated-inputs.
---
gnu/packages/emacs-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4a701d21e3..80d4228e64 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15244,7 +15244,7 @@ (define-public emacs-ement
(build-system emacs-build-system)
(arguments
`(#:emacs ,emacs)) ;need libxml support
- (inputs
+ (propagated-inputs
(list emacs-plz emacs-ts))
(home-page "https://github.com/alphapapa/ement.el")
(synopsis "Matrix client for Emacs")
--
2.34.0
Morgan.J.Smith wrote 3 years ago
[PATCH 2/3] gnu: Add python-pydbus.
(address . 53286@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163E280A7F9937E0F018AABC5559@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/python-xyz.scm (python-pydbus): New variable.
---
gnu/packages/python-xyz.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3f8f6d4618..ba8f4af6fd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9121,6 +9121,23 @@ (define-public python-user-agents
(define-public python2-user-agents
(package-with-python2 python-user-agents))
+(define-public python-pydbus
+ (package
+ (name "python-pydbus")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pydbus" version))
+ (sha256
+ (base32 "0b0gipvz7vcfa9ddmwq2jrx16d4apb0hdnl5q4i3h8jlzwp1c1s2"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-pygobject))
+ (home-page "https://github.com/LEW21/pydbus")
+ (synopsis "Pythonic DBus library")
+ (description "Pythonic DBus library")
+ (license #f)))
+
(define-public python-dbus
(package
(name "python-dbus")
--
2.34.0
Morgan.J.Smith wrote 3 years ago
[PATCH 3/3] gnu: pantalaimon: Add needed inputs
(address . 53286@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163CB732E7BAD07513EEB6FC5559@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/matrix.scm (pantalaimon) <propagated-inputs>: Add python-dbus,
python-notify2, python-pydbus, and python-pygobject.
---
gnu/packages/matrix.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index e2c27f5a4c..0c59a20306 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -24,6 +24,7 @@ (define-module (gnu packages matrix)
#:use-module (gnu packages check)
#:use-module (gnu packages crypto)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages monitoring)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
@@ -270,12 +271,16 @@ (define-public pantalaimon
python-attrs
python-cachetools
python-click
+ python-dbus
python-janus
python-keyring
python-logbook
python-matrix-nio
+ python-notify2
python-peewee
- python-prompt-toolkit))
+ python-prompt-toolkit
+ python-pydbus
+ python-pygobject))
(home-page "https://github.com/matrix-org/pantalaimon")
(synopsis "Matrix proxy daemon that adds E2E encryption capabilities")
(description
--
2.34.0
Aleksandr Vityazev wrote 3 years ago
Re: bug#53286: [PATCH 0/3] Small fixes for some matrix packages
(address . Morgan.J.Smith@outlook.com)(address . 53286@debbugs.gnu.org)
875yqlyls9.fsf@posteo.org
Hi,
On 2022-01-15, 11:28 -0500, Morgan.J.Smith@outlook.com wrote:

Toggle quote (9 lines)
> So emacs-ement doesn't work without its inputs being propagated. I think pantalaimon works with its
> current inputs but the panctl program to control pantalaimon (which is part of the pantalaimon
> package) doesn't work without these inputs.
>
> [PATCH 1/3] gnu: emacs-ement: Propagate inputs.
> [PATCH 2/3] gnu: Add python-pydbus.
> [PATCH 3/3] gnu: pantalaimon: Add needed inputs
>

Patches for pantalaimon have been submitted before:

--
Best regards,
Aleksandr Vityazev
Maxime Devos wrote 3 years ago
Re: [bug#53286] [PATCH 2/3] gnu: Add python-pydbus.
b29c42857225532b73c478cf37e4a92d7ef171d8.camel@telenet.be
Hi,

Morgan.J.Smith@outlook.com schreef op za 15-01-2022 om 11:52 [-0500]:
Toggle quote (2 lines)
> +    (license #f)))

According to the README it is lgpl2.1+.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYeMH5RccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7trGAQDpZtmuI/gFrwhJtV9VEDzDdKeo
GUQKOOK0m6AtnsgvKQEApgFR5v5mb6GlTC0n/PKqYQo4bdEzQFBjwM49OxFy9w0=
=qEby
-----END PGP SIGNATURE-----


Morgan.J.Smith wrote 3 years ago
[PATCH v2 0/3] Small fixes for some matrix packages
(address . 53286@debbugs.gnu.org)
DM5PR03MB31638BEC5C6C5419F26B451AC5559@DM5PR03MB3163.namprd03.prod.outlook.com
Thanks for catching that Maxime! That'll teach me to run guix lint before submitting patches :P

Thanks for pointing me to Bug#52700 Aleksandr! I've combined your changes into mine and made you a co-author. I hope that's ok with you.

These changes have been tested by installing them and using them. So I setup pantalaimon and had it decrypt some matrix messages for me which I viewed using emacs-ement.

[PATCH v2 1/3] gnu: emacs-ement: Propagate inputs.
[PATCH v2 2/3] gnu: Add python-pydbus.
[PATCH v2 3/3] gnu: pantalaimon: Add needed inputs
Morgan.J.Smith wrote 3 years ago
[PATCH v2 1/3] gnu: emacs-ement: Propagate inputs.
DM5PR03MB31633FEBD57D12E4EFF910DFC5559@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz (emacs-ement) <inputs>: Change to propagated-inputs.
---
gnu/packages/emacs-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4a701d21e3..80d4228e64 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15244,7 +15244,7 @@ (define-public emacs-ement
(build-system emacs-build-system)
(arguments
`(#:emacs ,emacs)) ;need libxml support
- (inputs
+ (propagated-inputs
(list emacs-plz emacs-ts))
(home-page "https://github.com/alphapapa/ement.el")
(synopsis "Matrix client for Emacs")
--
2.34.0
Morgan.J.Smith wrote 3 years ago
[PATCH v2 2/3] gnu: Add python-pydbus.
DM5PR03MB316346D77A6D3367C9756326C5559@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/python-xyz.scm (python-pydbus): New variable.

Co-authored-by: Aleksandr Vityazev <avityazev@posteo.org>
---
gnu/packages/python-xyz.scm | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3f8f6d4618..11219749a4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -92,8 +92,8 @@
;;; Copyright © 2020 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2019 Kristian Trandem <kristian@devup.no>
;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
-;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2021, 2022 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Ellis Kenyő <me@elken.dev>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
@@ -115,6 +115,7 @@
;;; Copyright © 2021 Filip Lajszczak <filip@lajszczak.dev>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9121,6 +9122,26 @@ (define-public python-user-agents
(define-public python2-user-agents
(package-with-python2 python-user-agents))
+(define-public python-pydbus
+ (package
+ (name "python-pydbus")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pydbus" version))
+ (sha256
+ (base32 "0b0gipvz7vcfa9ddmwq2jrx16d4apb0hdnl5q4i3h8jlzwp1c1s2"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-pygobject))
+ (home-page "https://github.com/LEW21/pydbus")
+ (synopsis "Pythonic D-Bus library")
+ (description "Pydbus provides a pythonic interface to the D-Bus
+message bus system. Pydbus can be used to access remote objects and
+also for object publication. It is based on PyGI, the Python GObject
+Introspection bindings, which is the recommended way to use GLib from Python.")
+ (license license:lgpl2.1+)))
+
(define-public python-dbus
(package
(name "python-dbus")
--
2.34.0
Morgan.J.Smith wrote 3 years ago
[PATCH v2 3/3] gnu: pantalaimon: Add needed inputs
DM5PR03MB31632244C65DB3E476B39125C5559@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/matrix.scm (pantalaimon)
<propagated-inputs>: Add python-dbus, python-notify2, python-pydbus, and
python-pygobject.
<arguments>: Run sanity-check phase.

Co-authored-by: Aleksandr Vityazev <avityazev@posteo.org>
---
gnu/packages/matrix.scm | 20 +++++++++++++-------
1 file changed, 13 insertions(+), 7 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index e2c27f5a4c..5f94eb2075 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -3,6 +3,8 @@
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
+;;; Copyright © 2022 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +26,7 @@ (define-module (gnu packages matrix)
#:use-module (gnu packages check)
#:use-module (gnu packages crypto)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages monitoring)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
@@ -257,25 +260,28 @@ (define-public pantalaimon
(lambda* (#:key tests? inputs outputs #:allow-other-keys)
(when tests?
(add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "tests"))))
- ;; XXX: The sanity check trips on optional GUI libraries for the
- ;; panctl command.
- (delete 'sanity-check))))
+ (invoke "pytest" "-vv" "tests")))))))
(native-inputs
- (list python-pytest python-faker python-pytest-aiohttp
- python-aioresponses))
+ (list python-aioresponses
+ python-faker
+ python-pytest
+ python-pytest-aiohttp))
(propagated-inputs
(list python-aiohttp
python-appdirs
python-attrs
python-cachetools
python-click
+ python-dbus
python-janus
python-keyring
python-logbook
python-matrix-nio
+ python-notify2
python-peewee
- python-prompt-toolkit))
+ python-prompt-toolkit
+ python-pydbus
+ python-pygobject))
(home-page "https://github.com/matrix-org/pantalaimon")
(synopsis "Matrix proxy daemon that adds E2E encryption capabilities")
(description
--
2.34.0
Nicolas Goaziou wrote 3 years ago
Re: [bug#53286] [PATCH v2 0/3] Small fixes for some matrix packages
(address . Morgan.J.Smith@outlook.com)
87h7a3i7zi.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (10 lines)
> Thanks for catching that Maxime! That'll teach me to run guix lint before submitting patches :P
>
> Thanks for pointing me to Bug#52700 Aleksandr! I've combined your changes into mine and made you a co-author. I hope that's ok with you.
>
> These changes have been tested by installing them and using them. So I setup pantalaimon and had it decrypt some matrix messages for me which I viewed using emacs-ement.
>
> [PATCH v2 1/3] gnu: emacs-ement: Propagate inputs.
> [PATCH v2 2/3] gnu: Add python-pydbus.
> [PATCH v2 3/3] gnu: pantalaimon: Add needed inputs

I applied the patch set. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53286@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53286
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help