* gnu/packages/matrix.scm: Import (gnu packages glib).
(pantalaimon):
[native-inputs]: Change formatting, add python-pygobject.
[propagated-inputs]: Add python-pydbus and python-notify2.
---
gnu/packages/matrix.scm | 11 +++++++++--
1 file changed, 9 insertions(+), 2 deletions(-)
Toggle diff (46 lines)
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 8cdfa38b32..8780b156af 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,6 +32,7 @@ (define-module (gnu packages matrix)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages glib)
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -256,10 +258,15 @@ (define-public pantalaimon
(add-installed-pythonpath inputs outputs)
(invoke "pytest" "-vv" "tests")))))))
(native-inputs
- (list python-pytest python-faker python-pytest-aiohttp
- python-aioresponses))
+ (list python-faker
+ python-pytest
+ python-pygobject
+ python-aioresponses
+ python-pytest-aiohttp))
(propagated-inputs
(list python-aiohttp
+ python-pydbus
+ python-notify2
python-appdirs
python-attrs
python-cachetools
--
2.34.0
--
Aleksandr Vityazev