gnu: Add newaita-reborn-icon-theme

  • Open
  • quality assurance status badge
Details
3 participants
  • Disseminate Dissent
  • Liliana Marie Prikler
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Disseminate Dissent
Severity
normal
D
D
Disseminate Dissent wrote on 9 Jan 2022 02:07
(name . Guix Patches)(address . guix-patches@gnu.org)
SZWuGYw9kPZ_NOYewVXrtIi7O_c76YRu-cKwDG7bPscjTIlpWgkww02-TfXev83RNjPgcqRt9QW7ml42z04ShJyc3C7iicFoY4RYKNPBNKw=@protonmail.com
Disseminate,
Peace
From 72d444ec36e81cb92f8b9f8151437ab912c68618 Mon Sep 17 00:00:00 2001
From: paladhammika <paladhammika@protonmail.com>
Date: Sat, 8 Jan 2022 20:03:21 -0500
Subject: [PATCH] gnu: Add newaita-reborn-icon-theme.

---
gnu/packages/icons.scm | 56 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)
create mode 100644 gnu/packages/icons.scm

Toggle diff (64 lines)
diff --git a/gnu/packages/icons.scm b/gnu/packages/icons.scm
new file mode 100644
index 0000000000..a70f7adcd6
--- /dev/null
+++ b/gnu/packages/icons.scm
@@ -0,0 +1,56 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Disseminate Dissent <disseminatedissent@protonmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages icons)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix git-download)
+ #:use-module (guix packages))
+
+(define-public newaita-reborn-icon-theme
+ (let ((commit "1bb3884112bd7d97fcf046ad9eaccebca3983f5b")
+ (revision "0"))
+ (package
+ (name "newaita-reborn-icon-theme")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cbrnix/Newaita-reborn")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ypgji3hmrdi515k8ms2aw82wy0qph06chzn4l0dfgjnhckm5598"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (delete 'build)
+ (delete 'install))))
+ (home-page "https://cbrnix.github.io/Newaita/")
+ (synopsis "Newaita Reborn icon theme, remastered, refreshed and made cleaner")
+ (description
+ "Newaita Reborn is a revision of the Newaita icon theme, resembling
+old style icons and the color of material design.")
+ (license license:gpl3+))))
--
2.34.0
L
L
Liliana Marie Prikler wrote on 9 Jan 2022 08:56
bab06d0e060bfa48055173a8e6235006a21a270e.camel@gmail.com
Hi,

Toggle quote (2 lines)
> Disseminate Dissent <disseminatedissent@protonmail.com>
> From: paladhammika <paladhammika@protonmail.com>
You probably want to set up your MUA or git correctly :)

There's no reason to set up an icons file. We have gnome-xyz, which
carries themes, icon-themes and extensions, which is also visually
grouped into these categories for the most part. Sort it into the
icons there.

Toggle quote (5 lines)
> + (let ((commit "1bb3884112bd7d97fcf046ad9eaccebca3983f5b")
> + (revision "0"))
> + (package
> + (name "newaita-reborn-icon-theme")
> + (version (git-version "0.0.0" revision commit))
Given that this has no release at all, can we really pin the current
head of master and assume this will be roughly the same Newaita as e.g.
on Arch or Gnome Look (which for the record is still broken in
Epiphany)?

Toggle quote (11 lines)
> + (build-system gnu-build-system)
> + (arguments
> + '(#:tests? #f
> + #:make-flags (list (string-append "PREFIX=" (assoc-ref
> %outputs "out")))
> + #:phases
> + (modify-phases %standard-phases
> + (delete 'bootstrap)
> + (delete 'configure)
> + (delete 'build)
> + (delete 'install))))
copy-build-system exists, so you might want to use that instead of
whatever this is trying to achieve.

Toggle quote (1 lines)
That Newaita appears to by CC BY-NC-SA, so it'd be disallowed in Guix.
On a related note:
Toggle quote (1 lines)
> + (license license:gpl3+))))
We have no ways of claiming that. Upstream only put the GPL (3, no
plus) somewhere in the repo and called it a day. You might want to ask
them to clarify where the license applies and whether it's a plus by
raising an issue.

Toggle quote (6 lines)
> + (synopsis "Newaita Reborn icon theme, remastered, refreshed and
> made cleaner")
> + (description
> + "Newaita Reborn is a revision of the Newaita icon theme,
> resembling
> +old style icons and the color of material design.")
Less advertisement, more description please :)

Cheers
D
D
Disseminate Dissent wrote on 9 Jan 2022 15:40
(address . 53132@debbugs.gnu.org)
7k7j8fyb5Ia9sY6-SbnT0SqKUUY8FrUbY0bk7DZ4nRsVj9Yxf1mx1uEMRWf9zyjZR8ikcxOXaEqGWaU3KypHGiaxGlwE1iC0j9caHwOXOyU=@protonmail.com
Hey lilyp,

Toggle quote (5 lines)
> There's no reason to set up an icons file. We have gnome-xyz, which
> carries themes, icon-themes and extensions, which is also visually
> grouped into these categories for the most part. Sort it into the
> icons there.

It was suggested in the IRC that I make an icons module for independent icon themes that are unaffiliated with GNOME and KDE. But I'd be happy to move it wherever it is preferred.

Toggle quote (5 lines)
> Given that this has no release at all, can we really pin the current
> head of master and assume this will be roughly the same Newaita as e.g.
> on Arch or Gnome Look (which for the record is still broken in
> Epiphany)?

I don't follow your line of thought. I'm currently using the icon theme with no issue whatsoever, how would adding it to the repository be any different?

Toggle quote (2 lines)
> That Newaita appears to by CC BY-NC-SA, so it'd be disallowed in Guix.

Ah yes, this was the wrong link -- pointing to the original Newaita icons. Newaita-reborn is GPL3. Is the declaration of GPL3 insufficient?

Disseminate,
Peace


??????? Original Message ???????

On Sunday, January 9th, 2022 at 7:56 AM, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:

Toggle quote (112 lines)
> Hi,
>
> > Disseminate Dissent disseminatedissent@protonmail.com
> >
> > From: paladhammika paladhammika@protonmail.com
>
> You probably want to set up your MUA or git correctly :)
>
> There's no reason to set up an icons file. We have gnome-xyz, which
>
> carries themes, icon-themes and extensions, which is also visually
>
> grouped into these categories for the most part. Sort it into the
>
> icons there.
>
> > - (let ((commit "1bb3884112bd7d97fcf046ad9eaccebca3983f5b")
> > - (revision "0"))
> >
> >
> > - (package
> > - (name "newaita-reborn-icon-theme")
> >
> >
> > - (version (git-version "0.0.0" revision commit))
> >
> >
>
> Given that this has no release at all, can we really pin the current
>
> head of master and assume this will be roughly the same Newaita as e.g.
>
> on Arch or Gnome Look (which for the record is still broken in
>
> Epiphany)?
>
> > - (build-system gnu-build-system)
> >
> >
> > - (arguments
> > - '(#:tests? #f
> >
> >
> > - #:make-flags (list (string-append "PREFIX=" (assoc-ref
> >
> >
> >
> > %outputs "out")))
> >
> > - #:phases
> >
> >
> > - (modify-phases %standard-phases
> >
> >
> > - (delete 'bootstrap)
> >
> >
> > - (delete 'configure)
> >
> >
> > - (delete 'build)
> >
> >
> > - (delete 'install))))
> >
> >
>
> copy-build-system exists, so you might want to use that instead of
>
> whatever this is trying to achieve.
>
> > - (home-page "https://cbrnix.github.io/Newaita/")
> >
> >
>
> That Newaita appears to by CC BY-NC-SA, so it'd be disallowed in Guix.
>
> On a related note:
>
> > - (license license:gpl3+))))
> >
> >
>
> We have no ways of claiming that. Upstream only put the GPL (3, no
>
> plus) somewhere in the repo and called it a day. You might want to ask
>
> them to clarify where the license applies and whether it's a plus by
>
> raising an issue.
>
> > - (synopsis "Newaita Reborn icon theme, remastered, refreshed and
> >
> >
> >
> > made cleaner")
> >
> > - (description
> >
> >
> > - "Newaita Reborn is a revision of the Newaita icon theme,
> >
> >
> >
> > resembling
> >
> > +old style icons and the color of material design.")
>
> Less advertisement, more description please :)
>
> Cheers
T
T
Tobias Geerinckx-Rice wrote on 9 Jan 2022 16:27
Re: [bug#53132] gnu: Add newaita-reborn-icon-theme
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87v8ys9ahn.fsf@nckx
Liliana Marie Prikler ???
Toggle quote (2 lines)
> There's no reason to set up an icons file.

I think there is. Putting GNOME extensions in gnome-xyz makes
sense, along with GNOME-specific themes. These icon themes are
neither.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYdsDpA0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15Z34BALAlGe62Qno2HmuwUDctDtoeJvtC2r4/IGrRjWAe
9JYpAQCJfWZHtDX78kSBptWrm93SYpFDA4jxgGwSkshiX0dLDg==
=xcWE
-----END PGP SIGNATURE-----

L
L
Liliana Marie Prikler wrote on 9 Jan 2022 17:52
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
8b82f308f78c884772765a0a552bf9f6075f581f.camel@gmail.com
Am Sonntag, dem 09.01.2022 um 16:27 +0100 schrieb Tobias Geerinckx-
Rice:
Toggle quote (6 lines)
> Liliana Marie Prikler ???
> > There's no reason to set up an icons file.
>
> I think there is.  Putting GNOME extensions in gnome-xyz makes
> sense, along with GNOME-specific themes.  These icon themes are
> neither.
While not necessarily GNOME-specific, I'd still say icon packs
primarily target a GNOME or KDE audience, with Guix traditionally
shipping more of the GNOME-adjacent ones. The name "newaita" also
sounds much like Adwaita, which as we all know is the default icon
theme for GNOME.

We currently have the following icon themes:
Toggle quote (39 lines)
> name: lxde-icon-theme
> location: gnu/packages/lxde.scm:434:2
>
> name: tango-icon-theme
> location: gnu/packages/gnome.scm:2882:2
>
> name: papirus-icon-theme
> location: gnu/packages/gnome-xyz.scm:185:2
>
> name: moka-icon-theme
> location: gnu/packages/gnome-xyz.scm:161:2
>
> name: mate-icon-theme
> location: gnu/packages/mate.scm:136:2
>
> name: mate-icon-theme-faenza
> location: gnu/packages/mate.scm:157:2
>
> name: hicolor-icon-theme
> location: gnu/packages/gnome.scm:3018:2
>
> name: gnome-icon-theme
> location: gnu/packages/gnome.scm:2835:2
>
> name: faba-icon-theme
> location: gnu/packages/gnome-xyz.scm:130:2
>
> name: elementary-xfce-icon-theme
> location: gnu/packages/xfce.scm:269:2
>
> name: delft-icon-theme
> location: gnu/packages/gnome-xyz.scm:97:2
>
> name: arc-icon-theme
> location: gnu/packages/gnome-xyz.scm:63:2
>
> name: adwaita-icon-theme
> location: gnu/packages/gnome.scm:2863:2

Would you suggest collecting them all in a single file? Can that even
be done (particularly the mate one looks sus in terms of dependencies)?
?