(name . Guix Patches)(address . guix-patches@gnu.org)
Disseminate,
Peace
From 72d444ec36e81cb92f8b9f8151437ab912c68618 Mon Sep 17 00:00:00 2001
From: paladhammika <paladhammika@protonmail.com>
Date: Sat, 8 Jan 2022 20:03:21 -0500
Subject: [PATCH] gnu: Add newaita-reborn-icon-theme.
---
gnu/packages/icons.scm | 56 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)
create mode 100644 gnu/packages/icons.scm
Toggle diff (64 lines)
diff --git a/gnu/packages/icons.scm b/gnu/packages/icons.scm
new file mode 100644
index 0000000000..a70f7adcd6
--- /dev/null
+++ b/gnu/packages/icons.scm
@@ -0,0 +1,56 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Disseminate Dissent <disseminatedissent@protonmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages icons)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix git-download)
+ #:use-module (guix packages))
+
+(define-public newaita-reborn-icon-theme
+ (let ((commit "1bb3884112bd7d97fcf046ad9eaccebca3983f5b")
+ (revision "0"))
+ (package
+ (name "newaita-reborn-icon-theme")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cbrnix/Newaita-reborn")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ypgji3hmrdi515k8ms2aw82wy0qph06chzn4l0dfgjnhckm5598"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (delete 'build)
+ (delete 'install))))
+ (home-page "https://cbrnix.github.io/Newaita/")
+ (synopsis "Newaita Reborn icon theme, remastered, refreshed and made cleaner")
+ (description
+ "Newaita Reborn is a revision of the Newaita icon theme, resembling
+old style icons and the color of material design.")
+ (license license:gpl3+))))
--
2.34.0