Pantalaimon build failure

  • Done
  • quality assurance status badge
Details
2 participants
  • Aleksandr Vityazev
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Aleksandr Vityazev
Severity
normal
A
A
Aleksandr Vityazev wrote on 16 Dec 2021 15:27
(name . bug-guix)(address . bug-guix@gnu.org)
87mtl07hhb.fsf@posteo.org
Hello,

The pantalaimon package sanity-check phase failure:

Toggle snippet (25 lines)
=================== 14 passed, 3 skipped, 1 warning in 1.65s ===================
phase `check' succeeded after 2.8 seconds
starting phase `sanity-check'
validating 'pantalaimon' /gnu/store/zjbcpf8m4l5jz56axsc5046y09zr65ks-pantalaimon-0.10.3/lib/python3.9/site-packages
...checking requirements: OK
...trying to load module pantalaimon: OK
...trying to load endpoint console_scripts panctl: ERROR:
Traceback (most recent call last):
File "/gnu/store/nwwr89v2vyg1hs48i49m083vhczsgh3m-sanity-check.py", line 85, in <module>
ep.load()
File "/gnu/store/p5fgysbcnnp8b1d91mrvjvababmczga0-python-3.9.6/lib/python3.9/site-packages/pkg_resources/__init__.py", line 2450, in load
return self.resolve()
File "/gnu/store/p5fgysbcnnp8b1d91mrvjvababmczga0-python-3.9.6/lib/python3.9/site-packages/pkg_resources/__init__.py", line 2456, in resolve
module = __import__(self.module_name, fromlist=['__name__'], level=0)
File "/gnu/store/zjbcpf8m4l5jz56axsc5046y09zr65ks-pantalaimon-0.10.3/lib/python3.9/site-packages/pantalaimon/panctl.py", line 26, in <module>
from gi.repository import GLib
ModuleNotFoundError: No module named 'gi'
...trying to load endpoint console_scripts pantalaimon: OK
error: in phase 'sanity-check': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("/gnu/store/nwwr89v2vyg1hs48i49m083vhczsgh3m-sanity-check.py" "/gnu/store/zjbcpf8m4l5jz56axsc5046y09zr65ks-pantalaimon-0.10.3/lib/python3.9/site-packages") exit-status: 1 term-signal: #f stop-signal: #f>
phase `sanity-check' failed after 0.7 seconds
command "python" "/gnu/store/nwwr89v2vyg1hs48i49m083vhczsgh3m-sanity-check.py" "/gnu/store/zjbcpf8m4l5jz56axsc5046y09zr65ks-pantalaimon-0.10.3/lib/python3.9/site-packages" failed with status 1


If you add python-pygobject to native-inputs, you get the following
error:

Toggle snippet (7 lines)
ModuleNotFoundError: No module named 'pydbus'
...trying to load endpoint console_scripts pantalaimon: OK
error: in phase 'sanity-check': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("/gnu/store/nwwr89v2vyg1hs48i49m083vhczsgh3m-sanity-check.py" "/gnu/store/4zbrpxm3ksyh7azwv4hsj37q83qjn0ga-pantalaimon-0.10.3/lib/python3.9/site-packages") exit-status: 1 term-signal: #f stop-signal: #f>


pydbus is not package yet.

--

Aleksandr Vityazev
A
A
Aleksandr Vityazev wrote on 21 Dec 2021 12:10
[PATCH 2/2] gnu: pantalaimon: Propagate python-pydbus and python-notify2.
(address . 52700@debbugs.gnu.org)(address . 52552@debbugs.gnu.org)
39ec9e0a29394db901cb69b601a576aa3a1b72fd.1640084945.git.avityazev@posteo.org
* gnu/packages/matrix.scm: Import (gnu packages glib).
(pantalaimon):
[native-inputs]: Change formatting, add python-pygobject.
[propagated-inputs]: Add python-pydbus and python-notify2.
---
gnu/packages/matrix.scm | 11 +++++++++--
1 file changed, 9 insertions(+), 2 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 8cdfa38b32..8780b156af 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,6 +32,7 @@ (define-module (gnu packages matrix)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages glib)
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -256,10 +258,15 @@ (define-public pantalaimon
(add-installed-pythonpath inputs outputs)
(invoke "pytest" "-vv" "tests")))))))
(native-inputs
- (list python-pytest python-faker python-pytest-aiohttp
- python-aioresponses))
+ (list python-faker
+ python-pytest
+ python-pygobject
+ python-aioresponses
+ python-pytest-aiohttp))
(propagated-inputs
(list python-aiohttp
+ python-pydbus
+ python-notify2
python-appdirs
python-attrs
python-cachetools
--
2.34.0



--

Aleksandr Vityazev
A
A
Aleksandr Vityazev wrote on 21 Dec 2021 12:10
[PATCH 1/2] gnu: Add python-pydbus.
(address . 52700@debbugs.gnu.org)(address . 52552@debbugs.gnu.org)
b4c7912ed65693643694ab4073757b74060373d3.1640084945.git.avityazev@posteo.org
* gnu/packages/python-xyz (python-pydbus): New variable.
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2af4794019..35590aece2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -112,6 +112,7 @@
;;; Copyright © 2021 Sébastien Lerique <sl@eauchat.org>
;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
;;; Copyright © 2021 ZmnSCPxj <ZmnSCPxj@protonmail.com>
+;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8929,6 +8930,26 @@ (define-public python-dbus-next
mobile environments.")
(license license:expat)))
+(define-public python-pydbus
+ (package
+ (name "python-pydbus")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pydbus" version))
+ (sha256
+ (base32 "0b0gipvz7vcfa9ddmwq2jrx16d4apb0hdnl5q4i3h8jlzwp1c1s2"))))
+ (inputs (list python-pygobject))
+ (build-system python-build-system)
+ (home-page "https://github.com/LEW21/pydbus")
+ (synopsis "Pythonic D-Bus library")
+ (description "Pydbus provides a pythonic interface to the D-Bus
+message bus system. Pydbus can be used to access remote objects and
+also for object publication. It is based on PyGI, the Python GObject
+Introspection bindings, which is the recommended way to use GLib from Python.")
+ (license license:lgpl2.1+)))
+
(define-public python-notify2
(package
(name "python-notify2")
--
2.34.0



--

Aleksandr Vityazev
N
N
Nicolas Goaziou wrote on 17 Jan 2022 00:21
(name . Aleksandr Vityazev)(address . avityazev@posteo.org)
87czkri7x5.fsf@nicolasgoaziou.fr
Hello,

Aleksandr Vityazev <avityazev@posteo.org> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz (python-pydbus): New variable.

This was applied in 4527743f0a2d58d7cdf5abdd74016908eecd66a6 and
subsequent commit.

Thank you!

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52552@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52552
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch