[PATCH 0/0]: gnu: Add HCL v2

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 12 Dec 2021 02:12
(address . guix-patches@gnu.org)
CAO+9K5qDKHC6Oi3E8uw2HOf9J2dccmgg+F4xCRbJHE01eudMEA@mail.gmail.com
Hi Guix team!
On the way to pack Terraform! Anyone welcome to join this 100+
dependency marathon :)
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
S
S
Sharlatan Hellseher wrote on 12 Dec 2021 02:18
(address . 52444@debbugs.gnu.org)
CAO+9K5pZyevQuPPg64FjR-7LC=1Cj+WHgrevcEWB0072xs-HVA@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 379b0685c5fd130f666d0b6c0403ff1c77722736 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 12 Dec 2021 00:45:11 +0000
Subject: [PATCH 1/6] gnu: Add tagparser

* gnu/packages/golang.scm: (go-github-com-vmihailenco-tagparser): New variable.
---
gnu/packages/golang.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 70731e2720..e484abd8e6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8924,3 +8924,24 @@ (define-public go-github-com-arceliar-ironwood
@url{https://github.com/yggdrasil-network/yggdrasil-go,Yggdrasil}, but it may
be useful for other network applications.")
(license license:mpl2.0)))
+
+(define-public go-github-com-vmihailenco-tagparser
+ (package
+ (name "go-github-com-vmihailenco-tagparser")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vmihailenco/tagparser")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13arliaz3b4bja9jj7cr5ax4zvxaxm484fwrn0q6d6jjm1l35m1k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/vmihailenco/tagparser"))
+ (home-page "https://github.com/vmihailenco/tagparser")
+ (synopsis "Tag parser for Golang")
+ (description "Simple Golang implementation of tag parser")
+ (license license:bsd-2)))
--
2.34.0
S
S
Sharlatan Hellseher wrote on 12 Dec 2021 02:18
(address . 52444@debbugs.gnu.org)
CAO+9K5oqL6N4_ZZfdxC7=1umm1+0yHMAKntX6-7SDPX_r6q+wQ@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 086798e9dd3c2cbec1f3795c21425edb0bb9b805 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 12 Dec 2021 00:54:41 +0000
Subject: [PATCH 3/6] gnu: Add go-textseg v13

* gnu/packages/golang.scm: (go-github-com-apparentlymart-go-textseg-v13,
go-github-com-apparentlymart-go-textseg-autoversion): New variables.
---
gnu/packages/golang.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 616a86cb99..566be61eec 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -70,6 +70,7 @@ (define-module (gnu packages golang)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages syncthing)
#:use-module (gnu packages terminals)
#:use-module (gnu packages textutils)
@@ -8973,3 +8974,41 @@ (define-public go-github-com-vmihailenco-msgpack-v4
"This package provides implementation of MessagePack encoding for Go
programming language")
(license license:bsd-2)))
+
+(define-public go-github-com-apparentlymart-go-textseg-v13
+ (package
+ (name "go-github-com-apparentlymart-go-textseg-v13")
+ (version "13.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/apparentlymart/go-textseg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gdgi0d52rq1xsdn9icc8lghn0f2q927cifmrlfxflf7bf21vism"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/apparentlymart/go-textseg/v13"
+ #:import-path "github.com/apparentlymart/go-textseg/v13/textseg"))
+ (native-inputs
+ `(("ruby" ,ruby)))
+ (home-page "https://github.com/apparentlymart/go-textseg")
+ (synopsis "Go implementation of Unicode Text Segmentation")
+ (description
+ "This package provides an implementation of the Unicode Text Segmentation
+specification for Go. Specifically, it currently includes only the grapheme
+cluster segmentation algorithm.")
+ ;; TODO: (Sharlatan-20211211T234916+0000): some not clear for me mixture of
+ ;; licenses, need verification
+ ;; https://github.com/apparentlymart/go-textseg/blob/master/LICENSE
+ (license #f)))
+
+(define-public go-github-com-apparentlymart-go-textseg-autoversion
+ (package
+ (inherit go-github-com-apparentlymart-go-textseg-v13)
+ (name "go-github-com-apparentlymart-go-textseg-autoversion")
+ (arguments
+ '(#:unpack-path "github.com/apparentlymart/go-textseg/autoversion"
+ #:import-path "github.com/apparentlymart/go-textseg/autoversion/textseg"))))
--
2.34.0
S
S
Sharlatan Hellseher wrote on 12 Dec 2021 02:19
(address . 52444@debbugs.gnu.org)
CAO+9K5qo56FoXxbAL8cApATKUJRsznr7J84uESVHZwjEnBSg2g@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 21a7043fd4830c76086e282384771c6758265f66 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 12 Dec 2021 00:57:37 +0000
Subject: [PATCH 4/6] gnu: Add go-cty

* gnu/packages/golang.scm: (go-github-com-zclconf-go-cty): New variable.
---
gnu/packages/golang.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 566be61eec..2e5a766c7e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9012,3 +9012,37 @@ (define-public go-github-com-apparentlymart-go-textseg-autoversion
(arguments
'(#:unpack-path "github.com/apparentlymart/go-textseg/autoversion"
#:import-path "github.com/apparentlymart/go-textseg/autoversion/textseg"))))
+
+(define-public go-github-com-zclconf-go-cty
+ (package
+ (name "go-github-com-zclconf-go-cty")
+ (version "1.10.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zclconf/go-cty")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0f9a6vy45gcx5pg5bnfs63manaqw80h7xzvmj3b80af38304zr71"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/zclconf/go-cty"
+ #:import-path "github.com/zclconf/go-cty/cty"))
+ (native-inputs
+ `(("go-github-com-google-go-cmp-cmp" ,go-github-com-google-go-cmp-cmp)))
+ (propagated-inputs
+ `(("go-golang-org-x-text" ,go-golang-org-x-text)
+ ("go-github-com-vmihailenco-msgpack-v4"
+ ,go-github-com-vmihailenco-msgpack-v4)
+ ("go-github-com-apparentlymart-go-textseg-v13"
+ ,go-github-com-apparentlymart-go-textseg-v13)))
+ (home-page "https://github.com/zclconf/go-cty")
+ (synopsis "Type system for dynamic values in Go applications")
+ (description
+ "@code{cty} (pronounced \"see-tie\") is a dynamic type system for
+applications written in Go that need to represent user-supplied values without
+losing type information. The primary intended use is for implementing
+configuration languages, but other uses may be possible too.")
+ (license license:expat)))
--
2.34.0
S
S
Sharlatan Hellseher wrote on 12 Dec 2021 02:19
(address . 52444@debbugs.gnu.org)
CAO+9K5pKNHZ7s_KckFbTyibHV3x-NcApkVHu3LxzF5AbQGdRxA@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From f744942805535fae2a43c57fcfcabb976b71d8b1 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 12 Dec 2021 00:59:12 +0000
Subject: [PATCH 5/6] gnu: Add levenshtein

* gnu/packages/golang.scm: (go-github-com-agext-levenshtein): New variable.
---
gnu/packages/golang.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2e5a766c7e..50f1947dba 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9046,3 +9046,26 @@ (define-public go-github-com-zclconf-go-cty
losing type information. The primary intended use is for implementing
configuration languages, but other uses may be possible too.")
(license license:expat)))
+
+(define-public go-github-com-agext-levenshtein
+ (package
+ (name "go-github-com-agext-levenshtein")
+ (version "1.2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/agext/levenshtein")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a26c8pp9h5w66bhd9vb6lpvmhp30mz46pnh3a8vrjx50givb2lw"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/agext/levenshtein"))
+ (home-page "https://github.com/agext/levenshtein")
+ (synopsis "Calculating the Levenshtein distance between two strings in Go")
+ (description
+ "Package levenshtein implements distance and similarity metrics for
+strings, based on the Levenshtein measure.")
+ (license license:asl2.0)))
--
2.34.0
S
S
Sharlatan Hellseher wrote on 12 Dec 2021 02:19
(address . 52444@debbugs.gnu.org)
CAO+9K5rTYNaRJs4R9gSycbFAn8nBUn=wH=Y9agaMvOOi4k-x8Q@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From adb69df26914bf926b43fa6e6894800e014dd966 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 12 Dec 2021 01:01:01 +0000
Subject: [PATCH 6/6] gnu: Add hcl v2

* gnu/packages/golang.scm: (go-github-com-hashicorp-hcl-v2): New variable.
---
gnu/packages/golang.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 50f1947dba..699bc49401 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2360,6 +2360,42 @@ (define-public go-github-com-hashicorp-hcl
(home-page "https://github.com/hashicorp/hcl")
(license license:mpl2.0))))
+(define-public go-github-com-hashicorp-hcl-v2
+ (package
+ (name "go-github-com-hashicorp-hcl-v2")
+ (version "2.11.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/hcl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0f9flmmkj7fr1337fc56cqy73faq87ix375hnz3id4wc023przv1"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hashicorp/hcl/v2"))
+ (native-inputs
+ `(("go-github-com-davecgh-go-spew" ,go-github-com-davecgh-go-spew)))
+ (inputs
+ `(("go-github-com-agext-levenshtein"
+ ,go-github-com-agext-levenshtein)
+ ("go-github-com-mitchellh-go-wordwrap"
+ ,go-github-com-mitchellh-go-wordwrap)
+ ("go-github-com-zclconf-go-cty"
+ ,go-github-com-zclconf-go-cty)
+ ("go-github-com-apparentlymart-go-textseg-v13"
+ ,go-github-com-apparentlymart-go-textseg-v13)))
+ (synopsis "Go implementation of HashiCorp Configuration Language V2")
+ (description
+ "This package contains the main implementation of the @acronym{HCL,
+HashiCorp Configuration Language}. HCL is designed to be a language for
+expressing configuration which is easy for both humans and machines to read.")
+ (home-page "https://github.com/hashicorp/hcl")
+ (license license:mpl2.0)))
+
(define-public go-golang-org-x-tools
(let ((commit "8b927904ee0dec805c89aaf9172f4459296ed6e8")
(revision "0"))
--
2.34.0
S
S
Sharlatan Hellseher wrote on 18 Dec 2021 17:16
(address . 52444@debbugs.gnu.org)
CAO+9K5q2y8BWk7QtneB5KCx2PNAkgAZJ0H0WMc7LFP+sJcEr1A@mail.gmail.com
Accedently sent to the wrong issue
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 168a3ab126a77006065076867997d2f16f72d35f Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 12 Dec 2021 00:48:20 +0000
Subject: [PATCH 2/6] gnu: Add msgpack v4

* gnu/packages/golang.scm: (go-github-com-vmihailenco-msgpack-v4): New variable.
---
gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e484abd8e6..616a86cb99 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8945,3 +8945,31 @@ (define-public go-github-com-vmihailenco-tagparser
(synopsis "Tag parser for Golang")
(description "Simple Golang implementation of tag parser")
(license license:bsd-2)))
+
+(define-public go-github-com-vmihailenco-msgpack-v4
+ (package
+ (name "go-github-com-vmihailenco-msgpack-v4")
+ (version "4.3.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vmihailenco/msgpack")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0aiavk7b5fn050bbc0naldk2bsl60f8wil5i6a1cfp3lxxnvmvng"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/vmihailenco/msgpack/v4"))
+ (native-inputs
+ `(("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)))
+ (propagated-inputs
+ `(("go-github-com-vmihailenco-tagparser"
+ ,go-github-com-vmihailenco-tagparser)))
+ (home-page "https://github.com/vmihailenco/msgpack")
+ (synopsis "MessagePack encoding for Golang")
+ (description
+ "This package provides implementation of MessagePack encoding for Go
+programming language")
+ (license license:bsd-2)))
--
2.34.0
N
N
Nicolas Goaziou wrote on 28 Jan 2022 10:39
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 52444-done@debbugs.gnu.org)
87fsp8urkj.fsf@nicolasgoaziou.fr
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (3 lines)
> On the way to pack Terraform! Anyone welcome to join this 100+
> dependency marathon :)

Good luck! :)

Meanwhile, I removed inputs labels, fixed licenses for textseg package,
and applied your patches.

Thank you!

Regards,
--
Nicolas Goaziou
Closed
?