[PATCH]: gnu: Add imppg

  • Done
  • quality assurance status badge
Details
3 participants
  • Nicolas Goaziou
  • Vinicius Monego
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 12 Nov 2021 22:22
(address . guix-patches@gnu.org)
CAO+9K5qpSjF-FLYFdVPYEknM_ffhEJ78gLjaEe5WqwR1r8OqjQ@mail.gmail.com
successfully built /gnu/store/14nqbnzy6k91x8l98c9hid6l1dxcza60-imppg-0.6.4.drv
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 8ba2e65db5753bd6b4c57e9957ec66b8581e4d69 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 12 Nov 2021 21:21:12 +0000
Subject: [PATCH] gnu: Add imppg

* gnu/packages/astronomy.scm: (imppg): New variable.
---
gnu/packages/astronomy.scm | 53 ++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (80 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index fc8959faad..57f62dc24d 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -32,6 +32,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
@@ -56,6 +57,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages qt)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
+ #:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -986,6 +988,57 @@ (define-public sgp4
It can be used to calculate the trajectory of satellites.")
(license license:asl2.0))))
+(define-public imppg
+ (package
+ (name "imppg")
+ (version "0.6.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/GreatAttractor/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04synbmyz0hkipl1cdc26nr42r57v494yjw8pi4jx0jrxrawgj9h"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No test provided
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (mkdir-p "build")
+ (chdir "build")
+ (invoke
+ "cmake"
+ "-G" "Unix Makefiles"
+ "-DCMAKE_BUILD_TYPE=Release"
+ (string-append "-DCMAKE_INSTALL_PREFIX=" (assoc-ref outputs "out"))
+ ".."))))))
+ (native-inputs
+ `(("boost" ,boost)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cfitsio" ,cfitsio)
+ ("freeimage" ,freeimage)
+ ("glew" ,glew)
+ ("wxwidgets" ,wxwidgets)))
+ (home-page "https://github.com/GreatAttractor/imppg")
+ (synopsis "Astronomical Image Post-Proccessor (ImPPG)")
+ (description
+ "ImPPG performs Lucy-Richardson deconvolution, unsharp masking, brightness
+normalization and tone curve adjustment. It can also apply previously specified
+processing settings to multiple images. All operations are performed using
+32-bit floating-point arithmetic.
+
+Supported input formats: FITS, BMP, JPEG, PNG, TIFF (most of bit depths and
+compression methods), TGA and more. Images are processed in grayscale and can be
+saved as: BMP 8-bit; PNG 8-bit; TIFF 8-bit, 16-bit, 32-bit floating-point (no
+compression, LZW- or ZIP-compressed), FITS 8-bit, 16-bit, 32-bit
+floating-point.")
+ (license license:gpl3+)))
+
(define-public indi
(package
(name "indi")
--
2.33.1
V
V
Vinicius Monego wrote on 13 Nov 2021 02:49
Re: [PATCH] gnu: Add imppg
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 51795@debbugs.gnu.org)
787ad36ea96bc67fae2a016ffbb3e0d5670a1c14.camel@posteo.net
Hi Sharlatan,

Em sex, 2021-11-12 às 21:21 +0000, Sharlatan Hellseher escreveu:
Toggle quote (41 lines)
> * gnu/packages/astronomy.scm: (imppg): New variable.
> ---
>  gnu/packages/astronomy.scm | 53
> ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 53 insertions(+)
>
> diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
> index fc8959faad..57f62dc24d 100644
> --- a/gnu/packages/astronomy.scm
> +++ b/gnu/packages/astronomy.scm
> @@ -32,6 +32,7 @@ (define-module (gnu packages astronomy)
>    #:use-module (gnu packages)
>    #:use-module (gnu packages algebra)
>    #:use-module (gnu packages autotools)
> +  #:use-module (gnu packages boost)
>    #:use-module (gnu packages check)
>    #:use-module (gnu packages compression)
>    #:use-module (gnu packages curl)
> @@ -56,6 +57,7 @@ (define-module (gnu packages astronomy)
>    #:use-module (gnu packages qt)
>    #:use-module (gnu packages version-control)
>    #:use-module (gnu packages video)
> +  #:use-module (gnu packages wxwidgets)
>    #:use-module (gnu packages xiph)
>    #:use-module (gnu packages xml)
>    #:use-module (gnu packages xorg)
> @@ -986,6 +988,57 @@ (define-public sgp4
>  It can be used to calculate the trajectory of satellites.")
>        (license license:asl2.0))))
>  
> +(define-public imppg
> +  (package
> +    (name "imppg")
> +    (version "0.6.4")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url (string-append
> "https://github.com/GreatAttractor/" name))

AFAIK we don't use 'name' in the url anymore, it should be hardcoded.

Toggle quote (22 lines)
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> "04synbmyz0hkipl1cdc26nr42r57v494yjw8pi4jx0jrxrawgj9h"))))
> +    (build-system cmake-build-system)
> +    (arguments
> +     `(#:tests? #f ; No test provided
> +       #:phases
> +       (modify-phases %standard-phases
> +         (replace 'configure
> +           (lambda* (#:key outputs #:allow-other-keys)
> +             (mkdir-p "build")
> +             (chdir "build")
> +             (invoke
> +              "cmake"
> +              "-G" "Unix Makefiles"
> +              "-DCMAKE_BUILD_TYPE=Release"
> +              (string-append "-DCMAKE_INSTALL_PREFIX=" (assoc-ref
> outputs "out"))
> +              ".."))))))

This is unusual. Why are we overriding the configure phase? I could
build the package just fine with the standard phase.

CMAKE_BUILD_TYPE can be set to Release using '#:build-type "Release"'.
Other CMake variables can be changed in #:configure-flags.

AFAIK Guix also avoids setting CMAKE_BUILD_TYPE to "Release" without a
good reason, such as debug symbols being too large.

Toggle quote (28 lines)
> +    (native-inputs
> +     `(("boost" ,boost)
> +       ("pkg-config" ,pkg-config)))
> +    (inputs
> +     `(("cfitsio" ,cfitsio)
> +       ("freeimage" ,freeimage)
> +       ("glew" ,glew)
> +       ("wxwidgets" ,wxwidgets)))
> +    (home-page "https://github.com/GreatAttractor/imppg")
> +    (synopsis "Astronomical Image Post-Proccessor (ImPPG)")
> +    (description
> +     "ImPPG performs Lucy-Richardson deconvolution, unsharp masking,
> brightness
> +normalization and tone curve adjustment.  It can also apply
> previously specified
> +processing settings to multiple images.  All operations are
> performed using
> +32-bit floating-point arithmetic.
> +
> +Supported input formats: FITS, BMP, JPEG, PNG, TIFF (most of bit
> depths and
> +compression methods), TGA and more.  Images are processed in
> grayscale and can be
> +saved as: BMP 8-bit; PNG 8-bit; TIFF 8-bit, 16-bit, 32-bit floating-
> point (no
> +compression, LZW- or ZIP-compressed), FITS 8-bit, 16-bit, 32-bit
> +floating-point.")

Description exceeded 78 columns in 3 lines.

Toggle quote (6 lines)
> +     (license license:gpl3+)))
> +
>  (define-public indi
>    (package
>      (name "indi")

LGTM otherwise!
S
S
Sharlatan Hellseher wrote on 13 Nov 2021 11:01
(address . 51795@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
CAO+9K5pz4HhfpKJjpe5yq_0GgaEJLruCN3OHtC_JPE5bfz=vVw@mail.gmail.com
Hi Vinicius,

Thank you for your fead back, I've updated patch with your suggestions.

successfully built /gnu/store/43jw7kaqriz7vb2vslkqjv3sn21gwdpf-imppg-0.6.4.drv

On Sat, 13 Nov 2021 at 01:49, Vinicius Monego <monego@posteo.net> wrote:
Toggle quote (118 lines)
>
> Hi Sharlatan,
>
> Em sex, 2021-11-12 às 21:21 +0000, Sharlatan Hellseher escreveu:
> > * gnu/packages/astronomy.scm: (imppg): New variable.
> > ---
> > gnu/packages/astronomy.scm | 53
> > ++++++++++++++++++++++++++++++++++++++
> > 1 file changed, 53 insertions(+)
> >
> > diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
> > index fc8959faad..57f62dc24d 100644
> > --- a/gnu/packages/astronomy.scm
> > +++ b/gnu/packages/astronomy.scm
> > @@ -32,6 +32,7 @@ (define-module (gnu packages astronomy)
> > #:use-module (gnu packages)
> > #:use-module (gnu packages algebra)
> > #:use-module (gnu packages autotools)
> > + #:use-module (gnu packages boost)
> > #:use-module (gnu packages check)
> > #:use-module (gnu packages compression)
> > #:use-module (gnu packages curl)
> > @@ -56,6 +57,7 @@ (define-module (gnu packages astronomy)
> > #:use-module (gnu packages qt)
> > #:use-module (gnu packages version-control)
> > #:use-module (gnu packages video)
> > + #:use-module (gnu packages wxwidgets)
> > #:use-module (gnu packages xiph)
> > #:use-module (gnu packages xml)
> > #:use-module (gnu packages xorg)
> > @@ -986,6 +988,57 @@ (define-public sgp4
> > It can be used to calculate the trajectory of satellites.")
> > (license license:asl2.0))))
> >
> > +(define-public imppg
> > + (package
> > + (name "imppg")
> > + (version "0.6.4")
> > + (source
> > + (origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url (string-append
> > "https://github.com/GreatAttractor/" name))
>
> AFAIK we don't use 'name' in the url anymore, it should be hardcoded.
>
> > + (commit (string-append "v" version))))
> > + (file-name (git-file-name name version))
> > + (sha256
> > + (base32
> > "04synbmyz0hkipl1cdc26nr42r57v494yjw8pi4jx0jrxrawgj9h"))))
> > + (build-system cmake-build-system)
> > + (arguments
> > + `(#:tests? #f ; No test provided
> > + #:phases
> > + (modify-phases %standard-phases
> > + (replace 'configure
> > + (lambda* (#:key outputs #:allow-other-keys)
> > + (mkdir-p "build")
> > + (chdir "build")
> > + (invoke
> > + "cmake"
> > + "-G" "Unix Makefiles"
> > + "-DCMAKE_BUILD_TYPE=Release"
> > + (string-append "-DCMAKE_INSTALL_PREFIX=" (assoc-ref
> > outputs "out"))
> > + ".."))))))
>
> This is unusual. Why are we overriding the configure phase? I could
> build the package just fine with the standard phase.
>
> CMAKE_BUILD_TYPE can be set to Release using '#:build-type "Release"'.
> Other CMake variables can be changed in #:configure-flags.
>
> AFAIK Guix also avoids setting CMAKE_BUILD_TYPE to "Release" without a
> good reason, such as debug symbols being too large.
>
> > + (native-inputs
> > + `(("boost" ,boost)
> > + ("pkg-config" ,pkg-config)))
> > + (inputs
> > + `(("cfitsio" ,cfitsio)
> > + ("freeimage" ,freeimage)
> > + ("glew" ,glew)
> > + ("wxwidgets" ,wxwidgets)))
> > + (home-page "https://github.com/GreatAttractor/imppg")
> > + (synopsis "Astronomical Image Post-Proccessor (ImPPG)")
> > + (description
> > + "ImPPG performs Lucy-Richardson deconvolution, unsharp masking,
> > brightness
> > +normalization and tone curve adjustment. It can also apply
> > previously specified
> > +processing settings to multiple images. All operations are
> > performed using
> > +32-bit floating-point arithmetic.
> > +
> > +Supported input formats: FITS, BMP, JPEG, PNG, TIFF (most of bit
> > depths and
> > +compression methods), TGA and more. Images are processed in
> > grayscale and can be
> > +saved as: BMP 8-bit; PNG 8-bit; TIFF 8-bit, 16-bit, 32-bit floating-
> > point (no
> > +compression, LZW- or ZIP-compressed), FITS 8-bit, 16-bit, 32-bit
> > +floating-point.")
>
> Description exceeded 78 columns in 3 lines.
>
> > + (license license:gpl3+)))
> > +
> > (define-public indi
> > (package
> > (name "indi")
>
> LGTM otherwise!
>


--

… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 2d6b1d7984b899965d588328b7b792c6f6f21160 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 13 Nov 2021 09:59:32 +0000
Subject: [PATCH] gnu: Add imppg

* gnu/packages/astronomy.scm: (imppg): New variable.
---
gnu/packages/astronomy.scm | 45 ++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (72 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index fc8959faad..41f7a929dc 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -32,6 +32,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
@@ -56,6 +57,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages qt)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
+ #:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -986,6 +988,49 @@ (define-public sgp4
It can be used to calculate the trajectory of satellites.")
(license license:asl2.0))))
+(define-public imppg
+ (package
+ (name "imppg")
+ (version "0.6.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/GreatAttractor/imppg"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04synbmyz0hkipl1cdc26nr42r57v494yjw8pi4jx0jrxrawgj9h"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No test provided
+ #:configure-flags
+ (list
+ (string-append
+ "-DCMAKE_INSTALL_PREFIX=" (assoc-ref %outputs "out")))))
+ (native-inputs
+ `(("boost" ,boost)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cfitsio" ,cfitsio)
+ ("freeimage" ,freeimage)
+ ("glew" ,glew)
+ ("wxwidgets" ,wxwidgets)))
+ (home-page "https://github.com/GreatAttractor/imppg")
+ (synopsis "Astronomical Image Post-Proccessor (ImPPG)")
+ (description
+ "ImPPG performs Lucy-Richardson deconvolution, unsharp masking,
+brightness normalization and tone curve adjustment. It can also apply
+previously specified processing settings to multiple images. All operations
+are performed using 32-bit floating-point arithmetic.
+
+Supported input formats: FITS, BMP, JPEG, PNG, TIFF (most of bit depths and
+compression methods), TGA and more. Images are processed in grayscale and can
+be saved as: BMP 8-bit; PNG 8-bit; TIFF 8-bit, 16-bit, 32-bit
+floating-point (no compression, LZW- or ZIP-compressed), FITS 8-bit, 16-bit,
+32-bit floating-point.")
+ (license license:gpl3+)))
+
(define-public indi
(package
(name "indi")
--
2.33.1
N
N
Nicolas Goaziou wrote on 5 Dec 2021 12:38
Re: [bug#51795] [PATCH]: gnu: Add imppg
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 51795-done@debbugs.gnu.org)
87czmbl1s6.fsf@nicolasgoaziou.fr
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (3 lines)
> successfully built
> /gnu/store/14nqbnzy6k91x8l98c9hid6l1dxcza60-imppg-0.6.4.drv

Thank you.

I applied it with the following minor change:

Toggle quote (6 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url (string-append "https://github.com/GreatAttractor/" name))

I hard-coded name into URL.

Regards,
--
Nicolas Goaziou
Closed
S
S
Sharlatan Hellseher wrote on 12 Dec 2021 02:18
(address . 51795@debbugs.gnu.org)
CAO+9K5rq5FdD2XS-9=r3HDnkix81HKFUNMo6VmU=YVZzbw8g7g@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 168a3ab126a77006065076867997d2f16f72d35f Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 12 Dec 2021 00:48:20 +0000
Subject: [PATCH 2/6] gnu: Add msgpack v4

* gnu/packages/golang.scm: (go-github-com-vmihailenco-msgpack-v4): New variable.
---
gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e484abd8e6..616a86cb99 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8945,3 +8945,31 @@ (define-public go-github-com-vmihailenco-tagparser
(synopsis "Tag parser for Golang")
(description "Simple Golang implementation of tag parser")
(license license:bsd-2)))
+
+(define-public go-github-com-vmihailenco-msgpack-v4
+ (package
+ (name "go-github-com-vmihailenco-msgpack-v4")
+ (version "4.3.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vmihailenco/msgpack")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0aiavk7b5fn050bbc0naldk2bsl60f8wil5i6a1cfp3lxxnvmvng"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/vmihailenco/msgpack/v4"))
+ (native-inputs
+ `(("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)))
+ (propagated-inputs
+ `(("go-github-com-vmihailenco-tagparser"
+ ,go-github-com-vmihailenco-tagparser)))
+ (home-page "https://github.com/vmihailenco/msgpack")
+ (synopsis "MessagePack encoding for Golang")
+ (description
+ "This package provides implementation of MessagePack encoding for Go
+programming language")
+ (license license:bsd-2)))
--
2.34.0
?