(address . bug-guix@gnu.org)
When using the pypi importer, a typo in the package name leads to an
ugly backtrace:
Toggle snippet (26 lines)
./pre-inst-env guix import pypi -r pytestrerunfailures
following redirection to `https://pypi.org/pypi/pytestrerunfailures/json/'...
Backtrace:
In ice-9/boot-9.scm:
1752:10 9 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In unknown file:
8 (apply-smob/0 #<thunk 7f3f0d996f60>)
In ice-9/boot-9.scm:
724:2 7 (call-with-prompt _ _ #<procedure default-prompt-handler (k proc)>)
In ice-9/eval.scm:
619:8 6 (_ #(#(#<directory (guile-user) 7f3f0d990c80>)))
In guix/ui.scm:
2206:7 5 (run-guix . _)
2169:10 4 (run-guix-command _ . _)
In guix/scripts/import.scm:
124:11 3 (guix-import . _)
In guix/scripts/import/pypi.scm:
96:18 2 (guix-import-pypi . _)
In guix/import/utils.scm:
498:27 1 (recursive-import "pytestrerunfailures" #:repo->guix-package _ #:guix-name _ …)
488:33 0 (lookup-node "pytestrerunfailures" #f)
guix/import/utils.scm:488:33: In procedure lookup-node:
Wrong number of values returned to continuation (expected 2)
--
Ricardo