(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
Dear,
Currently, there is 2 issues:
1. <from>->guix-package returning #f instead of (values #f '())
2. error incorrectly handled by guix/scripts/import/<from>
This corner case #1 happens when the package does not exist; then the function
'lookup-node' is not able to "unpack" the 'values' and throw and ugly
backtrace, as exposed in bug#44114 http://issues.guix.gnu.org/44115#3.
With these trivial patches, it is fixed for all the importers except 'opam'
(because of 'and-let' which needs some care).
Now, instead of throwing an ugly backtrace, it simply say almost nothing:
Toggle snippet (8 lines)
$ ./pre-inst-env guix import cran do-not-exist -r
error: failed to retrieve package information from "https://cran.r-project.org/web/packages/do-not-exist/DESCRIPTION": 404 ("Not Found")
$ ./pre-inst-env guix import pypi do-not-exist -r
following redirection to `https://pypi.org/pypi/do-not-exist/json/'...
#f
This non-existent message is because the error is poorly handled. With the 4
patches, the situation is the same as "guix import gem" for all the importers
with the recursive option. One way for a better error handling is done in the
last commit for 'guix import gem' only; the same trick can be done for all.
Toggle snippet (7 lines)
$ guix import gem do-not-exist -r
#f
$ ./pre-inst-env guix import gem do-not-exist -r
guix import: error: failed to download meta-data for package 'do-not-exist'
In my opinions, UI messages should not appear in guix/import/*.scm but only in
guix/scripts/*.scm.
If I understand correctly, then the way the errors are reported could be
uniformized between all the importers, and maybe the snippet in the subcommands
"guix import <from>" could be refactorized a bit.
WDYT?
All the best,
simon
zimoun (5):
import: pypi: Return 'values'.
import: hackage: Return 'values'.
import: elpa: Return 'values'.
import: cran: Return 'values'.
scripts: import: gem: Fix recursive error handling.
guix/import/cran.scm | 5 ++---
guix/import/elpa.scm | 7 ++-----
guix/import/hackage.scm | 16 ++++++++++------
guix/import/pypi.scm | 10 +++++-----
guix/scripts/import/gem.scm | 27 +++++++++++++++------------
5 files changed, 34 insertions(+), 31 deletions(-)
base-commit: 2d9c6542c804eb2ef3d8934e1e3ab8b24e9bbafb
prerequisite-patch-id: 6ce76af47a26307f4b99162b5ae2b47f5e5f220f
prerequisite-patch-id: 32b0ac51a8fbe72cc9204c5a6d0e2b987af7b7f6
prerequisite-patch-id: 3fa663069818b59ab4d324cc69fabcd62c5a9b50
--
2.29.2