(address . guix-patches@gnu.org)(name . Blake Shaw)(address . blake@nonconstructivism.com)
Signed-off-by: Blake Shaw <blake@nonconstructivism.com>
---
gnu/packages/notcurses.scm | 73 ++++++++++++++++++++++++++++++++++++++
1 file changed, 73 insertions(+)
create mode 100644 gnu/packages/notcurses.scm
Toggle diff (81 lines)
diff --git a/gnu/packages/notcurses.scm b/gnu/packages/notcurses.scm
new file mode 100644
index 0000000000..00e2fd92db
--- /dev/null
+++ b/gnu/packages/notcurses.scm
@@ -0,0 +1,73 @@
+;;; Copyright © 2021 Blake Shaw <blake@nonconstructivism.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages notcurses)
+ #:use-module (guix utils)
+ #:use-module (gnu packages)
+ #:use-module (guix packages)
+ #:use-module (guix build utils)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages gcc)
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages ncurses)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages libunistring)
+ #:use-module (ice-9 match))
+
+(define-public notcurses
+ (package
+ (name "notcurses")
+ (version "3.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dankamongmen/notcurses")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1y9s77m1pp6syfml559d8dvif61y6zjldrdx1zri18q9sr0zqm9m"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags
+ (list ,(string-append "CC=" (cc-for-target))
+ (string-append "prefix="))
+ #:configure-flags
+ (map (lambda (s)
+ (string-append "-D" s))
+ '("USE_CPP=off" "USE_COVERAGE=off" ;;here we set the default cmake
+ "USE_DOXYGEN=off" "USE_DOCTEST=off" ;;configuration. FSG=FSF approved only
+ "USE_GPM=off" "USE_MULTIMEDIA=ffmpeg" ;;other choices based on
+ "USE_PANDOC=off" "FSG_BUILD=ON")))) ;;reducing package footprint
+ (native-inputs
+ `(("gcc-toolchain" ,gcc)
+ ("ncurses" ,ncurses)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)
+ ("libdeflate" ,libdeflate)
+ ("libunistring" ,libunistring)
+ ("zlib" ,zlib)))
+ (synopsis "Library facilitating complex textual user interfaces on modern terminals")
+ (description "Notcurses is a library for building complex
+textual user interfaces on modern terminals. It does not use ncurses, while it does make use of libtinfo from that package.")
+ (home-page "https://notcurses.com/html/")
+ (license license:asl2.0)))
--
2.33.1