(address . guix-patches@gnu.org)
The current guix lint check is a bit overly conservative, and reports
several results which do not in practice actually cause issues.
This patch proposes to reduce the size by two characters (leaving only
two patches on guix master that need to be adjusted), uses a version
string more like what actually might be included in a tarball built
using "make dist", and adds a comment describing what the arbitrary
string actually is supposed to represent.
This should still even leave a little wiggle-room when guix hits version
100+ and/or 1000000+ commits, by which time hopefully guix has switched
to a tarball format that doesn't have such a short arbitrary file length
limit!
live well,
vagrant
From 6ad2050a8bbc308a328d30d4f66cb229d868b79d Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Fri, 19 Nov 2021 12:14:19 -0800
Subject: [PATCH] lint: Adjust patch file length check.
* guix/lint.scm (check-patch-file-names): Adjust margin used to check for
patch file lengths.
---
guix/lint.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
Toggle diff (18 lines)
diff --git a/guix/lint.scm b/guix/lint.scm
index ac2e7b3841..39b4a2ae85 100644
--- a/guix/lint.scm
+++ b/guix/lint.scm
@@ -957,7 +957,10 @@ patch could not be found."
;; Check whether we're reaching tar's maximum file name length.
(let ((prefix (string-length (%distro-directory)))
- (margin (string-length "guix-2.0.0rc3-10000-1234567890/"))
+ ;; Margin approximating the largest path that "make dist" might
+ ;; create, with a release candidate version, 123456 commits, and
+ ;; git commit hash abcde0.
+ (margin (string-length "guix-12.0.0rc3-123456-abcde0/"))
(max 99))
(filter-map (match-lambda
((? string? patch)
--
2.30.2
-----BEGIN PGP SIGNATURE-----
iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCYZgRtgAKCRDcUY/If5cW
qup5AQD81KiqA/DfiPpt9xQTyb4qvkp++22qCv9Wgl0Di+JB3wD/TyO2cTC2XkoX
dGk/JnNlOcLquHtSuQ4FmA0thjC/fgw=
=qx7F
-----END PGP SIGNATURE-----