Sharlatan Hellseher wrote 3 years ago
(address . guix-patches@gnu.org)
successfully built
/gnu/store/w870dhpqfq5ycggj9510kj1y54wqgz7v-python-gwcs-0.16.1.drv
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 5504205f6fcff3741c86bc8e9d203ea5da2ab431 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 11 Nov 2021 13:14:41 +0000
Subject: [PATCH] gnu: Add python-gwcs
* gnu/packages/astronomy.scm: (python-gwcs): New variable.
---
gnu/packages/astronomy.scm | 43 ++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)
Toggle diff (56 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index fc8959faad..59708e8e6b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -708,6 +708,49 @@ (define-public python-astropy
astronomy and astrophysics.")
(license license:bsd-3)))
+(define-public python-gwcs
+ (package
+ (name "python-gwcs")
+ (version "0.16.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gwcs" version))
+ (sha256
+ (base32 "0xjmv0v8bdzhpq61gvp76bx17pbcvxs8vp2gmn0rgs01zkrg8csk"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest" "--pyargs" "gwcs")))))))
+ (native-inputs
+ `(("python-jsonschema" ,python-jsonschema)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-doctestplus" ,python-pytest-doctestplus)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-semantic-version" ,python-semantic-version)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (propagated-inputs
+ `(("python-asdf" ,python-asdf)
+ ("python-astropy" ,python-astropy)
+ ("python-numpy" ,python-numpy)
+ ("python-scipy" ,python-scipy)))
+ (home-page "https://gwcs.readthedocs.io/en/latest/")
+ (synopsis "Generalized World Coordinate System")
+ (description
+ "Generalized World Coordinate System (GWCS) is an Astropy affiliated package
+providing tools for managing the World Coordinate System of astronomical data.
+
+GWCS takes a general approach to the problem of expressing transformations
+between pixel and world coordinates. It supports a data model which includes the
+entire transformation pipeline from input coordinates (detector by default) to
+world coordinates. It is tightly integrated with Astropy.")
+ (license license:bsd-3)))
+
(define-public libnova
(package
(name "libnova")
--
2.33.1