[PATCH 0/5] Update Astropy.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 24 Dec 2021 06:46
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211224054613.1009765-1-monego@posteo.net
Vinicius Monego (5):
gnu: python-pytest-arraydiff: Fix 'sanity-check phase.
gnu: python-pytest-doctestplus: Update to 0.11.2.
gnu: python-pytest-doctestplus: Honor #:tests?.
gnu: erfa: Update to 2.0.0.
gnu: python-astropy: Update to 5.0.

gnu/packages/astronomy.scm | 28 +++++++++++++++-------------
gnu/packages/python-check.scm | 22 ++++++++++++++++------
2 files changed, 31 insertions(+), 19 deletions(-)


base-commit: a296b5fff9f182da7c7b67cc7bdba0957623e650
--
2.30.2
V
V
Vinicius Monego wrote on 24 Dec 2021 06:47
[PATCH 1/5] gnu: python-pytest-arraydiff: Fix 'sanity-check phase.
(address . 52768@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211224054733.1009894-1-monego@posteo.net
* gnu/packages/python-check.scm (python-pytest-arraydiff)[native-inputs]: Add
python-pytest.
---
gnu/packages/python-check.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 6bd86d451f..e6cf2a4f85 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -387,6 +387,8 @@ astropy related packages.")
;; Tests require python-astropy, which itself requires this package.
;; Disable tests to avoid the circular dependency problem.
'(#:tests? #f))
+ (native-inputs
+ (list python-pytest)) ; for sanity-check
(propagated-inputs
(list python-numpy python-six))
(home-page "https://github.com/astropy/pytest-arraydiff")
--
2.30.2
V
V
Vinicius Monego wrote on 24 Dec 2021 06:47
[PATCH 2/5] gnu: python-pytest-doctestplus: Update to 0.11.2.
(address . 52768@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211224054733.1009894-2-monego@posteo.net
* gnu/packages/python-check.scm (python-pytest-doctestplus): Update to
0.11.2.
[arguments]<#:phases>: In the custom 'check phase, skip tests that require
remote data.
[native-inputs]: Add python-setuptools-scm.
---
gnu/packages/python-check.scm | 15 +++++++++++----
1 file changed, 11 insertions(+), 4 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index e6cf2a4f85..a745e735db 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -402,13 +402,13 @@ are too large to conveniently hard-code them in the tests.")
(define-public python-pytest-doctestplus
(package
(name "python-pytest-doctestplus")
- (version "0.7.0")
+ (version "0.11.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-doctestplus" version))
(sha256
- (base32 "1ai9kvd7xbq2jg2h8gmkb8lqzyrxvdh4zg3vxndg149iwd1hyi7d"))))
+ (base32 "0j1lvlj3ps975q9hmg8i6rpqm0313j3r18bc3l8mz6khb7vav4zk"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -417,9 +417,16 @@ are too large to conveniently hard-code them in the tests.")
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Make the installed plugin discoverable by Pytest.
(add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv"))))))
+ (invoke "python" "-m" "pytest" "-k"
+ (string-append ; skip tests that require remote data
+ "not test_remote_data_url"
+ " and not test_remote_data_float_cmp"
+ " and not test_remote_data_ignore_whitespace"
+ " and not test_remote_data_ellipsis"
+ " and not test_remote_data_requires"
+ " and not test_remote_data_ignore_warnings")))))))
(native-inputs
- (list python-pytest))
+ (list python-pytest python-setuptools-scm))
(home-page "https://github.com/astropy/pytest-doctestplus")
(synopsis "Pytest plugin with advanced doctest features")
(description
--
2.30.2
V
V
Vinicius Monego wrote on 24 Dec 2021 06:47
[PATCH 3/5] gnu: python-pytest-doctestplus: Honor #:tests?.
(address . 52768@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211224054733.1009894-3-monego@posteo.net
* gnu/packages/python-check.scm (python-pytest-doctestplus): Honor #:tests? in
the custom 'check phase.
---
gnu/packages/python-check.scm | 21 +++++++++++----------
1 file changed, 11 insertions(+), 10 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index a745e735db..50e63cb734 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -414,17 +414,18 @@ are too large to conveniently hard-code them in the tests.")
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
;; Make the installed plugin discoverable by Pytest.
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "-m" "pytest" "-k"
- (string-append ; skip tests that require remote data
- "not test_remote_data_url"
- " and not test_remote_data_float_cmp"
- " and not test_remote_data_ignore_whitespace"
- " and not test_remote_data_ellipsis"
- " and not test_remote_data_requires"
- " and not test_remote_data_ignore_warnings")))))))
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest" "-k"
+ (string-append ; skip tests that require remote data
+ "not test_remote_data_url"
+ " and not test_remote_data_float_cmp"
+ " and not test_remote_data_ignore_whitespace"
+ " and not test_remote_data_ellipsis"
+ " and not test_remote_data_requires"
+ " and not test_remote_data_ignore_warnings"))))))))
(native-inputs
(list python-pytest python-setuptools-scm))
(home-page "https://github.com/astropy/pytest-doctestplus")
--
2.30.2
V
V
Vinicius Monego wrote on 24 Dec 2021 06:47
[PATCH 4/5] gnu: erfa: Update to 2.0.0.
(address . 52768@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211224054733.1009894-4-monego@posteo.net
* gnu/packages/astronomy.scm (erfa): Update to 2.0.0.
(python-pyerfa): Update to 2.0.0.1.
[arguments]<#:phases>: Don't return #t.
[native-inputs]: Use the new style.
[inputs]: Likewise.
---
gnu/packages/astronomy.scm | 17 +++++++----------
1 file changed, 7 insertions(+), 10 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d88a0ef739..2cd3745cfb 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -188,7 +188,7 @@ for reading and writing.")
(define-public erfa
(package
(name "erfa")
- (version "1.7.3")
+ (version "2.0.0")
(source
(origin
(method git-fetch)
@@ -197,7 +197,7 @@ for reading and writing.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0nh12dr7gk4ki55lz95pkm4fpf7kazirra3zax9pab6v4qql4hlw"))))
+ (base32 "0s9dpj0jdkqcg552f00jhd722czji4pffabmpys5pgi6djckq4f4"))))
(build-system gnu-build-system)
(native-inputs
(list automake autoconf libtool pkg-config))
@@ -1170,13 +1170,13 @@ JPL ephemerides use to predict raw (x,y,z) planetary positions.")
(define-public python-pyerfa
(package
(name "python-pyerfa")
- (version "1.7.3")
+ (version "2.0.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyerfa" version))
(sha256
- (base32 "1jqqrxvrgly4r0br5f6dsy8nab2xmhz915vp6md5f31ysr2sdwvc"))
+ (base32 "0c6y1rm51kj8ahbr1vwbswck3ix77dc3zhc2fkg6w7iczrzn7m1g"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1189,14 +1189,11 @@ JPL ephemerides use to predict raw (x,y,z) planetary positions.")
(modify-phases %standard-phases
(add-before 'build 'use-system-liberfa
(lambda _
- (setenv "PYERFA_USE_SYSTEM_LIBERFA" "1")
- #t)))))
+ (setenv "PYERFA_USE_SYSTEM_LIBERFA" "1"))))))
(native-inputs
- `(("pytest-doctestplus" ,python-pytest-doctestplus)
- ("python-pytest" ,python-pytest)
- ("python-setuptools-scm" ,python-setuptools-scm)))
+ (list python-pytest-doctestplus python-pytest python-setuptools-scm))
(inputs
- `(("liberfa" ,erfa)))
+ (list erfa))
(propagated-inputs
(list python-numpy))
(home-page "https://github.com/liberfa/pyerfa")
--
2.30.2
V
V
Vinicius Monego wrote on 24 Dec 2021 06:50
[PATCH 5/5] gnu: python-astropy: Update to 5.0.
(address . 52768@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211224055018.1010067-1-monego@posteo.net
* gnu/packages/astronomy.scm (python-astropy): Update to 5.0.
[propagated-inputs]: Add python-packaging, python-pyyaml.
---
gnu/packages/astronomy.scm | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 2cd3745cfb..1f9eca9a44 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -612,13 +612,13 @@ accurately in real time at any rate desired.")
(define-public python-astropy
(package
(name "python-astropy")
- (version "4.3.1")
+ (version "5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "astropy" version))
(sha256
- (base32 "0lfd6n7v7kas4wvacddnwgccax3ks908735dzilg7dsf7ci52f9d"))
+ (base32 "09rr9z2kn5qw34fqpwxgcwsn9m5aw6f0dd0pm232aa8k3qakw83h"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -690,7 +690,12 @@ accurately in real time at any rate desired.")
(inputs
(list cfitsio expat))
(propagated-inputs
- (list python-configobj python-numpy python-ply python-pyerfa))
+ (list python-configobj
+ python-numpy
+ python-packaging
+ python-ply
+ python-pyerfa
+ python-pyyaml))
(home-page "https://www.astropy.org/")
(synopsis "Core package for Astronomy in Python")
(description
--
2.30.2
N
N
Nicolas Goaziou wrote on 26 Dec 2021 21:43
Re: [bug#52768] [PATCH 0/5] Update Astropy.
(name . Vinicius Monego)(address . monego@posteo.net)(address . 52768-done@debbugs.gnu.org)
87ee5zayh5.fsf@nicolasgoaziou.fr
Hello,

Vinicius Monego <monego@posteo.net> writes:

Toggle quote (7 lines)
> Vinicius Monego (5):
> gnu: python-pytest-arraydiff: Fix 'sanity-check phase.
> gnu: python-pytest-doctestplus: Update to 0.11.2.
> gnu: python-pytest-doctestplus: Honor #:tests?.
> gnu: erfa: Update to 2.0.0.
> gnu: python-astropy: Update to 5.0.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52768@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52768
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch