[PATCH 2/2] gnu: python-vcrpy: Update to 4.1.1.

  • Done
  • quality assurance status badge
Details
3 participants
  • Giacomo Leidi
  • Liliana Marie Prikler
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
Merged with
G
G
Giacomo Leidi wrote on 26 Oct 2021 21:28
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20211026192859.875-2-goodoldpaul@autistici.org
* gnu/packages/python-xyz.scm (python-vcrpy): Update to 4.1.1.
[arguments]: Replace 'check phase to run unit tests.
[native-inputs]: Add required dependencies.
---
gnu/packages/python-check.scm | 39 ++++++++++++++++++++++++++---------
1 file changed, 29 insertions(+), 10 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index a13bd0baa4..c70c3d3cf9 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -228,25 +228,44 @@ (define-public python-junit-xml
(define-public python-vcrpy
(package
(name "python-vcrpy")
- (version "2.0.1")
+ (version "4.1.1")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "vcrpy" version))
- (sha256
- (base32
- "0kws7l3hci1dvjv01nxw3805q9v2mwldw58bgl8s90wqism69gjp"))))
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "vcrpy" version))
+ (sha256
+ (base32 "16gmzxs3lzbgf1828n0q61vbmwyhpvzdlk37x6gdk8n05zr5n2ap"))))
(build-system python-build-system)
- (arguments `(#:tests? #f)) ; tests require more packages for python-pytest-httpbin
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? outputs #:allow-other-keys)
+ (when tests?
+ (substitute* "tox.ini"
+ (("AWS_ACCESS_KEY_ID") "PYTHONPATH"))
+ (setenv "PYTHONPATH" (string-append ".:" (getenv "PYTHONPATH")))
+ ;; These tests require network access.
+ (delete-file "tests/unit/test_stubs.py")
+ (invoke "pytest" "tests/unit")))))))
(propagated-inputs
`(("python-pyyaml" ,python-pyyaml)
("python-six" ,python-six)
("python-wrapt" ,python-wrapt)
("python-yarl" ,python-yarl)))
(native-inputs
- `(("python-mock" ,python-mock)
+ `(("python-black" ,python-black)
+ ("python-coverage" ,python-coverage)
+ ("python-flake8" ,python-flake8)
+ ("python-flask" ,python-flask)
+ ("python-httplib2" ,python-httplib2)
+ ("python-ipaddress" ,python-ipaddress)
+ ("python-mock" ,python-mock)
("python-pytest" ,python-pytest)
- ("python-pytest-httpbin" ,python-pytest-httpbin)))
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-httpbin" ,python-pytest-httpbin)
+ ("python-tox" ,python-tox)
+ ("python-urllib3" ,python-urllib3)))
(home-page "https://github.com/kevin1024/vcrpy")
(synopsis "Automatically mock your HTTP interactions")
(description
--
2.33.1
T
T
Tobias Geerinckx-Rice wrote on 26 Oct 2021 21:54
(no subject)
(name . Control)(address . control@debbugs.gnu.org)
d71b73e4b32633b209a62f6320c4a172@tobias.gr
merge 51419 51418
L
L
Liliana Marie Prikler wrote on 27 Oct 2021 17:44
Re: [bug#51418] Duplicate - please merge with 51419
e1fa7a631624444dd39fc3459153e4e9ca946bf1.camel@gmail.com
merge 51418 51419
thanks

Sorry, I typo'd, should be debbugs with 2b.
?