[PATCH 1/2] gnu: Add python-ipaddress.

  • Done
  • quality assurance status badge
Details
4 participants
  • Giacomo Leidi
  • Liliana Marie Prikler
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
Merged with
G
G
Giacomo Leidi wrote on 26 Oct 2021 21:28
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20211026192859.875-1-goodoldpaul@autistici.org
* gnu/packages/python-xyz.scm (python-ipaddress): New variable;
(python2-ipaddress): Use package-with-python2.
---
gnu/packages/python-xyz.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a7b1e0efe2..48404b441a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11159,9 +11159,9 @@ (define-public python-pyasn1-modules
(define-public python2-pyasn1-modules
(package-with-python2 python-pyasn1-modules))
-(define-public python2-ipaddress
+(define-public python-ipaddress
(package
- (name "python2-ipaddress")
+ (name "python-ipaddress")
(version "1.0.23")
(source (origin
(method url-fetch)
@@ -11170,17 +11170,17 @@ (define-public python2-ipaddress
(base32
"1qp743h30s04m3cg3yk3fycad930jv17q7dsslj4mfw0jlvf1y5p"))))
(build-system python-build-system)
- (arguments
- `(#:python ,python-2))
(home-page "https://github.com/phihag/ipaddress")
(synopsis "IP address manipulation library")
(description
"This package provides a fast, lightweight IPv4/IPv6 manipulation library
in Python. This library is used to create, poke at, and manipulate IPv4 and
- IPv6 addresses and networks. This is a port of the Python 3.3 ipaddress
- module to older versions of Python.")
+ IPv6 addresses and networks.")
(license license:psfl)))
+(define-public python2-ipaddress
+ (package-with-python2 python-ipaddress))
+
(define-public python-asn1tools
(package
(name "python-asn1tools")

base-commit: c6adc0947396daa6d85ab08837f9cbc86f4d8722
--
2.33.1
P
Duplicate - please merge with 51419
(address . 51418@debbugs.gnu.org)
8ceef358-2848-89db-a3e9-e55de3c3d058@autistici.org
Dear all,

I apologize this should be merged with 51419 . Is there a way to merge
two tickets from issues.guix.gnu.org?

Thank you,

giacomo
T
T
Tobias Geerinckx-Rice wrote on 26 Oct 2021 21:54
(no subject)
(name . Control)(address . control@debbugs.gnu.org)
d71b73e4b32633b209a62f6320c4a172@tobias.gr
merge 51419 51418
T
T
Tobias Geerinckx-Rice wrote on 26 Oct 2021 21:59
Re: [bug#51418] Duplicate - please merge with 51419
(name . paul)(address . goodoldpaul@autistici.org)(address . 51418@debbugs.gnu.org)
9daa6a3f2f4e5aedde36a7b25190249c@tobias.gr
Giacomo,

Toggle quote (2 lines)
> Is there a way to merge two tickets from issues.guix.gnu.org?

Yes. See my simple mail doing just that at

You can find the special recipient address and more information at

Kind regards,

T G-R
P
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 51418@debbugs.gnu.org)
a6776b39-a0ad-62e1-8877-fcfefcbad324@autistici.org
Dear Tobias,

thank you, for merging.

On 10/26/21 9:59 PM, Tobias Geerinckx-Rice wrote:
Toggle quote (3 lines)
> You can find the special recipient address and more information at
> https://debbugs.gnu.org/server-control.html

This is very useful, thanks!

giacomo
L
L
Liliana Marie Prikler wrote on 27 Oct 2021 17:44
e1fa7a631624444dd39fc3459153e4e9ca946bf1.camel@gmail.com
merge 51418 51419
thanks

Sorry, I typo'd, should be debbugs with 2b.
L
L
Ludovic Courtès wrote on 11 Dec 2021 23:39
Re: bug#51418: [PATCH 1/2] gnu: Add python-ipaddress.
(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)(address . 51418-done@debbugs.gnu.org)
874k7e6a18.fsf@gnu.org
Hi,

Giacomo Leidi <goodoldpaul@autistici.org> skribis:

Toggle quote (3 lines)
> * gnu/packages/python-xyz.scm (python-ipaddress): New variable;
> (python2-ipaddress): Use package-with-python2.

[...]

Toggle quote (4 lines)
> * gnu/packages/python-xyz.scm (python-vcrpy): Update to 4.1.1.
> [arguments]: Replace 'check phase to run unit tests.
> [native-inputs]: Add required dependencies.

This had fallen through the cracks but it’s been applied now.

Thanks!

Ludo’.
Closed
?