gajim fails to start call

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • rdes
Owner
unassigned
Submitted by
rdes
Severity
normal
R
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
ebIbv-b33jFgR0Op3qA8GdqEfG1j_1u9-fkCD5EDsaYxB9SFvoeYBekxxxXYH0TCpdaDcx_dwwIb4nRCpt1JPGBc--vUnn3rgHGW84XIaiQ=@protonmail.com
## Guix
guix 6cd33f8
branch: master
commit: 6cd33f855c88e63849c96d5df7ca256dd0379f4a

## Versions
- OS: Linux
- GTK Version: 3.24.24
- PyGObject Version: 3.34.0
- GLib Version : 2.62.6
- python-nbxmpp Version: 2.0.2
- Gajim Version: 1.3.2

## Traceback
```
Traceback (most recent call last):
File "/gnu/store/w4svc0x3azr64ik8jhbirapidncn3cbb-gajim-1.3.2/lib/python3.8/site-packages/gajim/chat_control.py", line 719, in _on_call_with_mic
self._on_jingle_button_toggled(['audio'])
File "/gnu/store/w4svc0x3azr64ik8jhbirapidncn3cbb-gajim-1.3.2/lib/python3.8/site-packages/gajim/chat_control.py", line 954, in _on_jingle_button_toggled
sid = con.get_module('Jingle').start_audio(
File "/gnu/store/w4svc0x3azr64ik8jhbirapidncn3cbb-gajim-1.3.2/lib/python3.8/site-packages/gajim/common/modules/jingle.py", line 164, in start_audio
jingle.add_content('voice', JingleAudio(jingle))
File "/gnu/store/w4svc0x3azr64ik8jhbirapidncn3cbb-gajim-1.3.2/lib/python3.8/site-packages/gajim/common/jingle_rtp.py", line 359, in __init__
self.setup_stream()
File "/gnu/store/w4svc0x3azr64ik8jhbirapidncn3cbb-gajim-1.3.2/lib/python3.8/site-packages/gajim/common/jingle_rtp.py", line 374, in setup_stream
JingleRTPContent.setup_stream(self, self._on_src_pad_added)
File "/gnu/store/w4svc0x3azr64ik8jhbirapidncn3cbb-gajim-1.3.2/lib/python3.8/site-packages/gajim/common/jingle_rtp.py", line 116, in setup_stream
self.p2pstream.set_transmitter_ht('nice', params)
gi.repository.GLib.GError: fs-error: Could not create the nicesrc element (1)

```
## Steps to reproduce the problem
...
start a chat -> open options and click 'start Call...' -> click 'With Microphone'
Attachment: file
R
[PATCH] gnu: gajim: adds libnice
(name . 51341@debbugs.gnu.org)(address . 51341@debbugs.gnu.org)
HddjSthJ_QqhhSeNaF95K8ljFJPMRAVpC5Osn8AzaYlhKsypEYbaPmKg5kYbPSOftywtOhYYPpw0cWkOB5ZBy6QqbUdfwgI2hnD0BFO9T-M=@protonmail.com
Hello,

The attached patch adds libnice to gajim, which fixed my start call issue.

Ryan
Attachment: file
R
(name . 51341@debbugs.gnu.org)(address . 51341@debbugs.gnu.org)
yPrw5SBnP_o5JrjG9dGdJAyrse7sk6b0374xbj1yFwXfJHcus9IkUXHdDWiWaZsxGU4nEKnsV6LXM5ilEnOfcH2HU8IE1aOwd-x3cb_dDKU=@protonmail.com
Sorry,
Actual patch attached this time.

Sent with [ProtonMail](https://protonmail.com/)Secure Email.

??????? Original Message ???????
On Tuesday, October 26th, 2021 at 8:56 PM, rdes <rdes@protonmail.com> wrote:

Toggle quote (6 lines)
> Hello,
>
> The attached patch adds libnice to gajim, which fixed my start call issue.
> Fixes: <https://issues.guix.gnu.org/51341>
>
> Ryan
Attachment: file
From 0b3bc36687e67d91a7f0ea6a41e789ac784ae602 Mon Sep 17 00:00:00 2001
From: Ryan Desfosses <rdes@protonmail.com>
Date: Tue, 26 Oct 2021 20:12:32 -0400
Subject: [PATCH] gnu: gajim: adds libnice


* gnu/package/messaging.scm (gajim): update
---
gnu/packages/messaging.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index d07c1c6566..8dcfc11ec8 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1158,6 +1158,7 @@ (define-public gajim
("gst-plugins-base" ,gst-plugins-base)
("gtk+" ,gtk+)
("gupnp-igd" ,gupnp-igd)
+ ("libnice" ,libnice)
("libsecret" ,libsecret)
("libsoup" ,libsoup)
("libxss" ,libxscrnsaver)
--
2.33.1
M
M
Mathieu Othacehe wrote on 26 Dec 2021 18:58
control message for bug #51341
(address . control@debbugs.gnu.org)
87k0frnt7y.fsf@meije.i-did-not-set--mail-host-address--so-tickle-me
close 51341
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51341@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51341
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch