Toggle diff (523 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 7433e1e7ea..11f9c62b55 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -328,6 +328,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/kawa.scm \
%D%/packages/kde.scm \
%D%/packages/kde-frameworks.scm \
+ %D%/packages/kde-games.scm \
%D%/packages/kde-internet.scm \
%D%/packages/kde-multimedia.scm \
%D%/packages/kde-pim.scm \
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2931d60954..9ce6489a56 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -146,8 +146,6 @@
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages javascript)
- #:use-module (gnu packages kde)
- #:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages less)
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages libedit)
@@ -10255,1558 +10253,6 @@ can be downloaded from @url{https://zero.sjeng.org/best-network}.")
(home-page "https://github.com/bernds/q5Go")
(license license:gpl2+)))
-(define-public ktuberling
- (package
- (name "ktuberling")
- (version "20.12.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/ktuberling-" version ".tar.xz"))
- (sha256
- (base32 "0mlv9qllg70p26dbrcsr820c70d3ib88hapc1z6wgjhdpmc12ni1"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)
- ("perl" ,perl)))
- (inputs
- `(("kcompletion" ,kcompletion)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("ki18n" ,ki18n)
- ("kio" ,kio)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kxmlgui" ,kxmlgui)
- ("libkdegames" ,libkdegames)
- ("python" ,python-wrapper)
- ("qtbase" ,qtbase-5)
- ("qtmultimedia" ,qtmultimedia)
- ("qtdeclarative" ,qtdeclarative)
- ("qtsvg" ,qtsvg)))
- (home-page "https://games.kde.org/")
- (synopsis "Stamp drawing toy")
- (description "KTuberling is a drawing toy intended for small children and
-adults who remain young at heart. The game has no winner; the only purpose is
-to make the funniest faces you can. Several activities are possible, e.g.:
-
-@itemize
-@item Give the potato a funny face, clothes, and other goodies
-@item Build a small town, complete with school, zoo, and fire department
-@item Create a fantastic moonscape with spaceships and aliens
-@item Top a pizza
-@end itemize
-
-KTuberling can speak the name of each the object in several languages,
-to assist in learning basic vocabulary.
-
-This package is part of the KDE games module.")
- (license (list license:gpl2+ license:fdl1.2+))))
-
-(define-public picmi
- (package
- (name "picmi")
- (version "20.12.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/picmi-" version ".tar.xz"))
- (sha256
- (base32 "1dfq9m4njh0czz8zws46rkz6xq2n6xra5w223m3s2f5civiw5msz"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("kdeclarative" ,kdeclarative)
- ("ki18n" ,ki18n)
- ("kio" ,kio)
- ("knewstuff" ,knewstuff)
- ("kxmlgui" ,kxmlgui)
- ("libkdegames" ,libkdegames)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)
- ("qtsvg" ,qtsvg)))
- (home-page "https://games.kde.org/")
- (synopsis "Number logic game")
- (description "Picmi is a number logic game in which cells in a grid have
-to be colored or left blank according to numbers given at the side of the
-grid. The aim is to reveal a hidden picture.
-
-This package is part of the KDE games module.")
- (license (list license:gpl2+ license:fdl1.2+))))
-
-(define-public kolf
- (package
- (name "kolf")
- (version "20.12.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/kolf-" version ".tar.xz"))
- (sha256
- (base32 "1lpp6pzr5dgd4si4a8c7hcvgxgqy0bgyhkx9m6jqb0zhll6dxj10"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kcompletion" ,kcompletion)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("ki18n" ,ki18n)
- ("kio" ,kio)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kxmlgui" ,kxmlgui)
- ("ktextwidgets" ,ktextwidgets)
- ("libkdegames" ,libkdegames)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)))
- (home-page "https://games.kde.org/")
- (synopsis "Miniature golf game")
- (description "Kolf is a miniature golf game for one to ten players. The
-game is played from an overhead view, with a short bar representing the golf
-club. Kolf features many different types of objects, such as water hazards,
-slopes, sand traps, and black holes (warps), among others.
-
-Features are:
-@itemize
-@item Single and Multi-player (up to ten players) modes
-@item High scores table
-@item Dynamic courses
-@item Third-party courses
-@item Course editor
-@end itemize
-
-This package is part of the KDE games module.")
- (license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
-
-(define-public libkmahjongg
- (package
- (name "libkmahjongg")
- (version "20.12.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/"
- version "/src/libkmahjongg-" version ".tar.xz"))
- (sha256
- (base32 "10ljzbf7qki5flydankrbksaihhkqpfyljb8c71fbwqwmkr7rgfq"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)))
- (inputs
- `(("kauth" ,kauth)
- ("kcompletion" ,kcompletion)
- ;("kconfig" ,kconfig)
- ("kcodecs" ,kcodecs)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("ki18n" ,ki18n)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("qtbase" ,qtbase-5)
- ("qtsvg" ,qtsvg)))
- (home-page "https://games.kde.org/")
- (synopsis "Shared library for kmahjongg and kshisen")
- (description "Shared library and common files for kmahjongg, kshisen and
-other Mah Jongg like games.")
- (license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
-
-(define-public kmahjongg
- (package
- (name "kmahjongg")
- (version "20.12.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/"
- version "/src/kmahjongg-" version ".tar.xz"))
- (sha256
- (base32 "1fcj4jb2zzbaxp7cp04w36y0c7lh77yzin66fmvrcxkl11xi2wwd"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kcompletion" ,kcompletion)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("kdeclarative" ,kdeclarative)
- ("ki18n" ,ki18n)
- ("knewstuff" ,knewstuff)
- ("kxmlgui" ,kxmlgui)
- ("libkdegames" ,libkdegames)
- ("libkmahjongg" ,libkmahjongg)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)
- ("qtsvg" ,qtsvg)))
- (home-page "https://games.kde.org/")
- (synopsis "Tile laying patience")
- (description "In KMahjongg the tiles are scrambled and staked on top of
-each other to resemble a certain shape. The player is then expected to remove
-all the tiles off the game board by locating each tile's matching pair.
-
-A variety of tile layouts are included, as well as an editor to create new
-layouts.
-
-This package is part of the KDE games module.")
- (license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
-
-(define-public kshisen
- (package
- (name "kshisen")
- (version "20.12.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/"
- version "/src/kshisen-" version ".tar.xz"))
- (sha256
- (base32 "1hrwr0f1kidivsp8lnwdbqz3xxagjvjwh72r3gma8smfilybygfb"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ;("perl" ,perl)
- ;("pkg-config" ,pkg-config)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kauth" ,kauth)
- ("kcompletion" ,kcompletion)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("ki18n" ,ki18n)
- ("kxmlgui" ,kxmlgui)
- ("libkdegames" ,libkdegames)
- ("libkmahjongg" ,libkmahjongg)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)))
- (home-page "https://games.kde.org/")
- (synopsis "Shisen-Sho solitaire game")
- (description "KShisen is a solitaire-like game played using the standard
-set of Mahjong tiles. Unlike Mahjong however, KShisen has only one layer of
-scrambled tiles
-
-This package is part of the KDE games module.")
- (license license:gpl2+)))
-
-(define-public kajongg
- (package
- (name "kajongg")
- (version "20.12.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/"
- version "/src/kajongg-" version ".tar.xz"))
- (sha256
- (base32 "03fdbnx7zx7vgcxvwd1h1098ks9gq162bwz35fhpyzpynr667m5r"))))
- (build-system qt-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/mjresource.py"
- (("'share', 'kmahjongglib'" all)
- (string-append "'" (assoc-ref inputs "libkmahjongg")
- "/share', 'kmahjongglib'")))))
- (add-after 'qt-wrap 'wrap
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (for-each (lambda (program)
- (wrap-program program
- `("GUIX_PYTHONPATH" ":" prefix
- (,(getenv "GUIX_PYTHONPATH")))))
- (list (string-append out "/bin/kajongg")
- (string-append out "/bin/kajonggserver")))))))))
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ;("perl" ,perl)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("ki18n" ,ki18n)
- ("libkmahjongg" ,libkmahjongg)
- ("python" ,python)
- ("python-twisted" ,python-twisted)
- ("python-pyqt" ,python-pyqt)
- ("python-zope-interface" ,python-zope-interface)
- ("qtbase" ,qtbase-5)
- ("qtsvg" ,qtsvg)))
- (home-page "https://games.kde.org/")
- (synopsis "Classical Mah Jongg game for 4 players")
- (description "Kajongg is the ancient Chinese board game for 4 players.
-
-If you are looking for the Mah Jongg solitaire please use the application
-kmahjongg.
-
-Kajongg can be used in two different ways: Scoring a manual game where you
-play as always and use Kajongg for the computation of scores and for
-bookkeeping. Or you can use Kajongg to play against any combination of other
-human players or computer players.
-
-This package is part of the KDE games module.")
- (license (list license:gpl2+ license:fdl1.2+))))
-
-(define-public kbreakout
- (package
- (name "kbreakout")
- (version "20.12.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/kbreakout-" version ".tar.xz"))
- (sha256
- (base32 "0kqj2cx0ny3qq65c6w5fpnzmrwl9irg8slzvpd3anck5cnvma3j4"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("ki18n" ,ki18n)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kxmlgui" ,kxmlgui)
- ("libkdegames" ,libkdegames)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)))
- (home-page "https://games.kde.org/")
- (synopsis "Breakout like game")
- (description "KBreakout is similar to the classics breakout and xboing,
-featuring a number of added graphical enhancements and effects. You control a
-paddle at the bottom of the playing-field, and must destroy bricks at the top
-by bouncing balls against them.
-
-This package is part of the KDE games module.")
- (license (list license:gpl2+ license:fdl1.2+))))
-
-(define-public kmines
- (package
- (name "kmines")
- (version "20.12.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/kmines-" version ".tar.xz"))
- (sha256
- (base32 "0hqjwh3jq2npqwkvh67fyn2xnq8swiasdw5jz8f0ikl0k28id775"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("ki18n" ,ki18n)
- ("ktextwidgets" ,ktextwidgets)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kxmlgui" ,kxmlgui)
- ("libkdegames" ,libkdegames)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)))
- (home-page "https://games.kde.org/")
- (synopsis "Classical mine sweeper game")
- (description "KMines is a classic Minesweeper game. The idea is to
-uncover all the squares without blowing up any mines. When a mine is blown
-up, the game is over.
-
-This package is part of the KDE games module.")
- (license (list license:gpl2+ license:fdl1.2+))))
-
-(define-public konquest
- (package
- (name "konquest")
- (version "20.12.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/"
- version "/src/konquest-" version ".tar.xz"))
- (sha256
- (base32 "0lnwj06vv4qx05hr8pzysnvrxh8y04asajrph0rsj37v8hs9g5lh"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("kguiaddons" ,kguiaddons)
- ("ki18n" ,ki18n)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kxmlgui" ,kxmlgui)
- ("libkdegames" ,libkdegames)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)
- ("qtsvg" ,qtsvg)))
- (home-page "https://games.kde.org/")
- (synopsis "Simple turn-based strategy game")
- (description "Konquest is the KDE version of Gnu-Lactic Konquest. Players
-conquer other planets by sending ships to them. The goal is to build an
-interstellar empire and ultimately conquer all other player's planets. The
-game can be played with up to nine empires, commanded either by the computer
-or by puny earthlings.
-
-This package is part of the KDE games module.")
- (license (list license:gpl2+ license:fdl1.2+))))
-
-(define-public kbounce
- (package
- (name "kbounce")
- (version "20.12.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/"
- version "/src/kbounce-" version ".tar.xz"))
- (sha256
- (base32 "0ymy0z1qlw3n653xs3dsa1xm78q4xaj09dnnci4km77rzis26vb6"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kcompletion" ,kcompletion)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("ki18n" ,ki18n)
- ("kio" ,kio)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kxmlgui" ,kxmlgui)
- ("libkdegames" ,libkdegames)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)
- ("qtsvg" ,qtsvg)))
- (home-page "https://games.kde.org/")
- (synopsis "Jezzball arcade game")
- (description "KBounce is a single player arcade game with the elements of
-puzzle. It is played on a field, surrounded by wall, with two or more balls
-bouncing around within the walls. The object of the game is to build new
-walls to decrease the size of the active field.
-
-This package is part of the KDE games module.")
- (license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
-
-(define-public kblocks
- (package
- (name "kblocks")
- (version "20.12.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/"
- version "/src/kblocks-" version ".tar.xz"))
- (sha256
- (base32 "09yfm9mzbamp294cvc5finq6ilxvxr68i0dnb0m72pa4sfzmij32"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("ki18n" ,ki18n)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kxmlgui" ,kxmlgui)
- ("libkdegames" ,libkdegames)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)
- ("qtsvg" ,qtsvg)))
- (home-page "https://games.kde.org/")
- (synopsis "Single player falling blocks puzzle game")
- (description "KBlocks is the classic Tetris-lik