[PATCH 1/7] !gnu QT updater

  • Done
  • quality assurance status badge
Details
3 participants
  • kiasoc5
  • Maxim Cournoyer
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 29 Jun 2022 08:21
(name . Guix Patches)(address . guix-patches@gnu.org)
dFdDqUZFbkM3zqB1ecx_pfdA8LdUimtuecw_YTd06_tT7FkzkdsustzxPpVNVUshioBzyYYweBA1qTLEmislXrBDPN6x5kEQKqWARQq9-SA=@protonmail.com
Hi,

here's my attempt to update Qt5 packages.

Currently there are two main issues to deal with:

- 5.15.5 changed the URL where they use "-everywhere-opensource-src-" instead of "-everywhere-src-". Changing it directly in qt5-urls breaks the qtbase (Qt6 version of the package). The solution is either to add argument or create qt6-urls.

What would be the best? Checked Qt6 modules on official release URL and there's currently no change in the link atm.

- I need help with building qtwebengine. It's massive beast that fails to build. See the logs attached. I used the patches from LFS where they use Python 3 plus more.

I've been able to build the rest of the packages.

----
Petr
Attachment: file
From 24510d3d222cef06ac3e11b828a8d088f4277410 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Mon, 27 Jun 2022 11:42:13 +0200
Subject: [PATCH 1/7] !gnu QT updater


Toggle diff (28 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 9593009ae3..469cb15f5a 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -279,17 +279,17 @@ (define (qt5-urls component version)
;; the layout differs between them.
(list (string-append "https://download.qt.io/official_releases/qt/"
(version-major+minor version) "/" version
- "/submodules/" component "-everywhere-src-"
+ "/submodules/" component "-everywhere-opensource-src-"
version ".tar.xz")
(string-append "https://download.qt.io/archive/qt/"
(version-major+minor version) "/" version
- "/submodules/" component "-everywhere-src-"
+ "/submodules/" component "-everywhere-opensource-src-"
version ".tar.xz")
(let ((directory (string-append "qt5" (string-drop component 2))))
(string-append "http://sources.buildroot.net/" directory "/"
- component "-everywhere-src-" version ".tar.xz"))
+ component "-everywhere-opensource-src-" version ".tar.xz"))
(string-append "https://distfiles.macports.org/qt5/"
- component "-everywhere-src-" version ".tar.xz")))
+ component "-everywhere-opensource-src-" version ".tar.xz")))
(define-public qtbase-5
(package
--
2.36.1
From f52b9043dc8099213ae25acbb7e0453f1e2e8bf8 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Tue, 28 Jun 2022 13:47:42 +0200
Subject: [PATCH 7/7] gnu: qtwayland: Remove input labels.

* gnu/packages/qt.scm (qtwayland): Remove input labels.

Toggle diff (37 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index e9af893fba..8cbe916fd5 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1034,18 +1034,18 @@ (define-public qtwayland
(native-inputs
(list glib perl pkg-config qtdeclarative))
(inputs
- `(("fontconfig" ,fontconfig)
- ("freetype" ,freetype)
- ("libx11" ,libx11)
- ("libxcomposite" ,libxcomposite)
- ("libxext" ,libxext)
- ("libxkbcommon" ,libxkbcommon)
- ("libxrender" ,libxrender)
- ("mesa" ,mesa)
- ("mtdev" ,mtdev)
- ("qtbase" ,qtbase-5)
- ("vulkan-headers" ,vulkan-headers)
- ("wayland" ,wayland)))
+ (list fontconfig
+ freetype
+ libx11
+ libxcomposite
+ libxext
+ libxkbcommon
+ libxrender
+ mesa
+ mtdev
+ qtbase-5
+ vulkan-headers
+ wayland))
(synopsis "Qt Wayland module")
(description "The Qt Wayland module provides the QtWayland client and
compositor libraries.")))
--
2.36.1
From d44ba404e6c40b6b8ffe56bdb75153cefd7a4582 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Mon, 27 Jun 2022 21:40:22 +0200
Subject: [PATCH 5/7] gnu: qtbase-5: Remove input labels.

* gnu/packages/qt.scm (qtbase-5): Remove input labels.

Toggle diff (101 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index f042a74ed7..42733c22e5 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -323,50 +323,50 @@ (define-public qtbase-5
;; Use which the package, not the function
(@ (gnu packages base) which)))
(inputs
- `(("alsa-lib" ,alsa-lib)
- ("cups" ,cups)
- ("dbus" ,dbus)
- ("double-conversion" ,double-conversion)
- ("eudev" ,eudev)
- ("expat" ,expat)
- ("fontconfig" ,fontconfig)
- ("freetype" ,freetype)
- ("glib" ,glib)
- ("gtk+" ,gtk+) ;for GTK theme support
- ("harfbuzz" ,harfbuzz)
- ("icu4c" ,icu4c)
- ("libinput" ,libinput-minimal)
- ("libjpeg" ,libjpeg-turbo)
- ("libmng" ,libmng)
- ("libpng" ,libpng)
- ("libx11" ,libx11)
- ("libxcomposite" ,libxcomposite)
- ("libxcursor" ,libxcursor)
- ("libxfixes" ,libxfixes)
- ("libxi" ,libxi)
- ("libxinerama" ,libxinerama)
- ("libxkbcommon" ,libxkbcommon)
- ("libxml2" ,libxml2)
- ("libxrandr" ,libxrandr)
- ("libxrender" ,libxrender)
- ("libxslt" ,libxslt)
- ("libxtst" ,libxtst)
- ("mtdev" ,mtdev)
- ("mariadb-dev" ,mariadb "dev")
- ("nss" ,nss)
- ("openssl" ,openssl)
- ("pcre2" ,pcre2)
- ("postgresql" ,postgresql)
- ("pulseaudio" ,pulseaudio)
- ("sqlite" ,sqlite)
- ("unixodbc" ,unixodbc)
- ("xcb-util" ,xcb-util)
- ("xcb-util-image" ,xcb-util-image)
- ("xcb-util-keysyms" ,xcb-util-keysyms)
- ("xcb-util-renderutil" ,xcb-util-renderutil)
- ("xcb-util-wm" ,xcb-util-wm)
- ("xdg-utils" ,xdg-utils)
- ("zlib" ,zlib)))
+ (list alsa-lib
+ cups
+ dbus
+ double-conversion
+ eudev
+ expat
+ fontconfig
+ freetype
+ glib
+ gtk+ ;for GTK theme support
+ harfbuzz
+ icu4c
+ libinput-minimal
+ libjpeg-turbo
+ libmng
+ libpng
+ libx11
+ libxcomposite
+ libxcursor
+ libxfixes
+ libxi
+ libxinerama
+ libxkbcommon
+ libxml2
+ libxrandr
+ libxrender
+ libxslt
+ libxtst
+ mtdev
+ `(,mariadb "dev")
+ nss
+ openssl
+ pcre2
+ postgresql
+ pulseaudio
+ sqlite
+ unixodbc
+ xcb-util
+ xcb-util-image
+ xcb-util-keysyms
+ xcb-util-renderutil
+ xcb-util-wm
+ xdg-utils
+ zlib))
(native-inputs
(list bison
flex
--
2.36.1
From 2079e9ce0a6a1ec3c9939bc726c3d02d3c5822d4 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Mon, 27 Jun 2022 11:43:00 +0200
Subject: [PATCH 4/7] gnu: python-pyqtwebengine: Update to 5.15.5.

* gnu/packages/qt.scm (python-pyqtwebengine): Update to 5.15.5.

Toggle diff (24 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index a4af7868de..f042a74ed7 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2219,7 +2219,7 @@ (define-public python-pyqt5-sip
(define-public python-pyqtwebengine
(package
(name "python-pyqtwebengine")
- (version "5.15.2")
+ (version "5.15.5")
(source
(origin
(method url-fetch)
@@ -2231,7 +2231,7 @@ (define-public python-pyqtwebengine
"/PyQtWebEngine-" version ".tar.gz")))
(sha256
(base32
- "0d56ak71r14w4f9r96vaj34qcn2rbln3s6ildvvyc707fjkzwwjd"))))
+ "0d56ak71r16w4f9r96vaj34qcn2rbln3s6ildvvyc707fjkzwwjd"))))
(build-system gnu-build-system)
(native-inputs
(list python python-sip
--
2.36.1
K
K
kiasoc5 wrote on 3 Aug 2022 08:21
(address . efraim@flashner.co.il)
20220803062135.4ca50c03@aria
I believe Efraim has pushed 5.15.5 updates to staging already. I can't
find the issue at the moment but from the commit log I see that:

Commit 1218a5ad6912bbfb5f25b324be8b91caf8480793 bumps QT to 5.15.5
Commit 2ca51636511aa897dfac9a32c432f6e56724645b bumps QT to 5.15.4
M
M
Maxim Cournoyer wrote on 29 Mar 2023 04:13
Re: bug#56293: [PATCH 1/7] !gnu QT updater
(name . kiasoc5)(address . kiasoc5@disroot.org)
87lejg485i.fsf_-_@gmail.com
Hello,

kiasoc5 <kiasoc5@disroot.org> writes:

Toggle quote (6 lines)
> I believe Efraim has pushed 5.15.5 updates to staging already. I can't
> find the issue at the moment but from the commit log I see that:
>
> Commit 1218a5ad6912bbfb5f25b324be8b91caf8480793 bumps QT to 5.15.5
> Commit 2ca51636511aa897dfac9a32c432f6e56724645b bumps QT to 5.15.4

Closing. We're now at 5.15.8 on the staging branch.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56293@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56293
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch