The project seems to have permanently moved to Github, with no
distribution tarballs available, so update it.
* gnu/packages/opencl.scm (ocl-icd)[origin]: Retrieve source from Github
checkout instead of distribution tarballs.
[native-inputs]: Add 'autoconf', 'automake', and 'libtool'.
---
gnu/packages/opencl.scm | 20 ++++++++++++--------
1 file changed, 12 insertions(+), 8 deletions(-)
Toggle diff (53 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index e95d19db47..4c9c440b3d 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -131,19 +132,22 @@
(name "ocl-icd")
(version "2.2.12")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://forge.imag.fr/frs/download.php/836/ocl-icd-"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OCL-dev/ocl-icd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1x2dr8p4dkfds56r38av360i3nv1y3326jmshxvjngaf6mlg6rbn"))
+ "075pj99nanl75hyv93wys9ba3x7lhcdj0awdcd8bss6mdxqxj5mc"))
(modules '((guix build utils)))
(snippet
'(delete-file-recursively "khronos-headers"))))
(native-inputs
- `(("opencl-headers" ,opencl-headers)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("opencl-headers" ,opencl-headers)
("ruby" ,ruby)))
(inputs
`(("libgcrypt" ,libgcrypt)))
@@ -155,7 +159,7 @@
(variable "OPENCL_VENDOR_PATH")
(files '("etc/OpenCL/vendors")))))
(search-paths native-search-paths)
- (home-page "https://forge.imag.fr/projects/ocl-icd/")
+ (home-page "https://github.com/OCL-dev/ocl-icd/")
(synopsis "OpenCL loader for Installable Client Drivers (ICDs)")
(description
"OpenCL implementations are provided as ICDs (Installable Client
--
2.32.0