(address . guix-patches@gnu.org)
Hi guix!
The attached patch series optimises the G-exp compiler for
local-file, by avoiding interning the file if it's already
in the store, but only if the hash is known in advance.
To take advantage of this, 'search-patch' has been modified
to compute the hash at expansion time.
The cost of this optimisation is a little additional
complexity, and computing derivations theoretically becomes
a little more expensive when the patch isn't already in
the store (1 call to 'stat' per non-yet-interned patch).
If you want to test this patch series for performance,
do _not_ run ./pre-inst-env guix, instead use
"guix pull --url=$PWD --branch=...", because the guix
from the checkout performs more 'lstat' calls than
an ‘user’ guix from "guix pull".
I'll show the patch series decreases the number of syscalls
below, using the 'strace' command. Use 'strace -c' to gather
some statistics:
# Run it twice for a hot cache. Ignore the output of the first run.
$ strace -c ./the-optimised-guix/bin/guix build -d pigx --no-grafts
$ strace -c ./the-optimised-guix/bin/guix build -d pigx --no-grafts
#
$ strace -c guix build -d pigx --no-grafts
$ strace -c guix build -d pigx --no-grafts
I've selected some syscalls from the output that seemed relevant
and formatted the call count in a table
optimised unoptimised result of optimisation:
stat 3865 3712 + 4.1%
lstat 119 321 -62.9%
fstat 59 59 unchanged
read 17303 17688 - 2.2%
write 6741 6767 - 1.9%
openat 885 1076 -17.8%
readlink 14 16 -12.5%
-------
total 28886 32539 -11.2%
Almost all syscalls are now called less (-11.2% in total),
which is good. The exception is 'stat'.
Because 'search-path' is now being called less often
(only when the patch isn't in the store), the number
of 'stat' calls decreases. However, 'local-file-compiler'
now calls 'stat' more (one or two times per patch). I think
it's worth it though, because:
(1) the second 'stat' is on the same file as the first 'stat',
so presumably the kernel has cached the result, so no need
to wait for I/O to complete the second time (there's a context
switch though). So ignoring the context switch cost,
there are only ‘effectively’ +2.1% extra calls to 'stat'.
(2) the total decrease of -11.2% syscalls
Now, what about the actual "time to derivation"?
First, let's time "guix build -d pigx --no-grafts" to get some raw numbers
on guix before the optimisation:
time guix build -d pigx --no-grafts
# repeated four times, first output is discarded
# to eliminate hot/cold cache differences
/gnu/store/03vmq94ckxfx6c4rc9zh745yy63n5i5m-pigx-0.0.3.drv
real 0m13,470s
user 0m13,526s
sys 0m0,573s
/gnu/store/03vmq94ckxfx6c4rc9zh745yy63n5i5m-pigx-0.0.3.drv
real 0m13,582s
user 0m13,639s
sys 0m0,568s
/gnu/store/03vmq94ckxfx6c4rc9zh745yy63n5i5m-pigx-0.0.3.drv
real 0m13,834s
user 0m13,901s
sys 0m0,556s
Average numbers:
real 0m13,629s
user 0m13,689s
sys 0m0,566s
After the optimisation:
time ./the-optimised-guix/bin/guix build -d pigx --no-grafts
/gnu/store/fq6x8d2vcm6sbjkimg7g8kcgb4c5xv1b-pigx-0.0.3.drv
real 0m14,150s
user 0m13,979s
sys 0m0,685s
/gnu/store/fq6x8d2vcm6sbjkimg7g8kcgb4c5xv1b-pigx-0.0.3.drv
real 0m13,781s
user 0m13,697s
sys 0m0,580s
/gnu/store/fq6x8d2vcm6sbjkimg7g8kcgb4c5xv1b-pigx-0.0.3.drv
real 0m14,247s
user 0m14,160s
sys 0m0,548s
The numbers are higher somehow after the optimisations?
Even the 'sys' time is higher, even though there are less syscalls?
I re-ran the time commands, and got a decrease in 'real' time this time.
/gnu/store/fq6x8d2vcm6sbjkimg7g8kcgb4c5xv1b-pigx-0.0.3.drv
real 0m13,304s
user 0m13,146s
sys 0m0,609s
/gnu/store/fq6x8d2vcm6sbjkimg7g8kcgb4c5xv1b-pigx-0.0.3.drv
real 0m12,132s
user 0m11,940s
sys 0m0,589s
/gnu/store/fq6x8d2vcm6sbjkimg7g8kcgb4c5xv1b-pigx-0.0.3.drv
real 0m13,716s
user 0m13,723s
sys 0m0,529s
The output of "time ..." seems inconclusive
(can possibly be attributed to things like CPU frequency changing?),
but the decrease in syscall counts seems quite nice to me.
Feel free to run your own tests!
Greetings,
Maxime.
From a8e24a5258aa05689bcafa70af071da5296f63a4 Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Sat, 4 Sep 2021 20:09:03 +0200
Subject: [PATCH 1/6] build-self: Implement basic 'hash-algorithm'.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
The module (guix hash) used from 'search-patch' in a future
patch needs it to be properly defined when (guix hash) is being
compiled. 'search-patch' is used when the derivation of Guix is
being computed, so it is important to avoid the ‘wrong type to
apply: #<syntax-transformer hash-algorithm>’ error.
* build-aux/build-self.scm
(build-program)[fake-gcrypt-hash]: Define hash-algorithm for sha1
and sha256.
---
build-aux/build-self.scm | 13 +++++++++++--
1 file changed, 11 insertions(+), 2 deletions(-)
Toggle diff (34 lines)
diff --git a/build-aux/build-self.scm b/build-aux/build-self.scm
index 3a2d13cc09..2c13d9d530 100644
--- a/build-aux/build-self.scm
+++ b/build-aux/build-self.scm
@@ -259,8 +259,17 @@ interface (FFI) of Guile.")
(define fake-gcrypt-hash
;; Fake (gcrypt hash) module; see below.
(scheme-file "hash.scm"
- #~(define-module (gcrypt hash)
- #:export (sha1 sha256))))
+ #~(begin
+ (define-module (gcrypt hash)
+ #:export (sha1 sha256 hash-algorithm))
+ ;; Avoid ‘Wrong type to apply:
+ ;; #<syntax-transformer hash-algorithm>’ errors.
+ (define sha1)
+ (define sha256)
+ (define-syntax hash-algorithm
+ (syntax-rules (sha1 sha256)
+ ((_ sha1) 2)
+ ((_ sha256) 8))))))
(define fake-git
(scheme-file "git.scm" #~(define-module (git))))
base-commit: b4d132f98e03fae559db832e88897f1e166c4d47
prerequisite-patch-id: 91a26ba19372112a11a0eea2b066d2f63641deb1
prerequisite-patch-id: a535c1ae2a1fbf75d7ac9a3118ed23bd4fa03ecc
prerequisite-patch-id: 29eba0cede1c1e7153a7c7b9a58b33b67f693a13
prerequisite-patch-id: 8dd2234fa0f867081c6cf614c7a22b00022702b4
prerequisite-patch-id: 2fe0e5c67a37ef3f0e22813c9808eaeec83bb552
prerequisite-patch-id: 91514568f1ef4870ad7ed7b3f685f04703f9c090
--
2.33.0
From cc54e1c5021119bfaba07849e83ea31f7099970e Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Sat, 4 Sep 2021 15:35:51 +0200
Subject: [PATCH 3/6] gexp: Allow computing the hash of the local file in
advance.
The new field is currently unused. The following patches will
populate and use the field to reduce the time-to-derivation
when the file is already interned in the store.
* guix/gexp.scm
(<local-file>): Add sha256 field.
(%local-file): Add sha256 argument for populating the field.
(local-file-compiler): Adjust 'match' expression.
---
guix/gexp.scm | 12 ++++++++----
1 file changed, 8 insertions(+), 4 deletions(-)
Toggle diff (51 lines)
diff --git a/guix/gexp.scm b/guix/gexp.scm
index f3d278b3e6..a633984688 100644
--- a/guix/gexp.scm
+++ b/guix/gexp.scm
@@ -419,13 +419,16 @@ Here TARGET is bound to the cross-compilation triplet or #f."
;; A local file name. FILE is the file name the user entered, which can be a
;; relative file name, and ABSOLUTE is a promise that computes its canonical
;; absolute file name. We keep it in a promise to compute it lazily and avoid
-;; repeated 'stat' calls.
+;; repeated 'stat' calls. Allow computing the hash of the file in advance,
+;; to avoid having to send the file to the daemon when it is already interned
+;; in the store.
(define-record-type <local-file>
- (%%local-file file absolute name recursive? select?)
+ (%%local-file file absolute name sha256 recursive? select?)
local-file?
(file local-file-file) ;string
(absolute %local-file-absolute-file-name) ;promise string
(name local-file-name) ;string
+ (sha256 local-file-sha256) ;sha256 bytevector | #f
(recursive? local-file-recursive?) ;Boolean
(select? local-file-select?)) ;string stat -> Boolean
@@ -434,6 +437,7 @@ Here TARGET is bound to the cross-compilation triplet or #f."
(define* (%local-file file promise #:optional (name (basename file))
#:key
(literal? #t) location
+ sha256
recursive? (select? true))
;; This intermediate procedure is part of our ABI, but the underlying
;; %%LOCAL-FILE is not.
@@ -441,7 +445,7 @@ Here TARGET is bound to the cross-compilation triplet or #f."
(warning (and=> location source-properties->location)
(G_ "resolving '~a' relative to current directory~%")
file))
- (%%local-file file promise name recursive? select?))
+ (%%local-file file promise name sha256 recursive? select?))
(define (absolute-file-name file directory)
"Return the canonical absolute file name for FILE, which lives in the
@@ -517,7 +521,7 @@ appears."
(define-gexp-compiler (local-file-compiler (file <local-file>) system target)
;; "Compile" FILE by adding it to the store.
(match file
- (($ <local-file> file (= force absolute) name recursive? select?)
+ (($ <local-file> file (= force absolute) name sha256 recursive? select?)
;; Canonicalize FILE so that if it's a symlink, it is resolved. Failing
;; to do that, when RECURSIVE? is #t, we could end up creating a dangling
;; symlink in the store, and when RECURSIVE? is #f 'add-to-store' would
--
2.33.0
From 1937edd906b817dd15648fa682d55d3b3f779e45 Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Sat, 4 Sep 2021 16:25:22 +0200
Subject: [PATCH 4/6] gexp: Allow overriding the absolute file name.
This will be used by the next patch to implement search-patch in
terms of local-file.
* guix/gexp.scm
(precanonicalized-file-name): New macro.
(local-file): Use the absolute file name from precanonicalized-file-name
when available.
---
guix/gexp.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)
Toggle diff (46 lines)
diff --git a/guix/gexp.scm b/guix/gexp.scm
index a633984688..c69e4aa299 100644
--- a/guix/gexp.scm
+++ b/guix/gexp.scm
@@ -51,6 +51,7 @@
gexp-input-output
gexp-input-native?
+ precanonicalized-file-name
assume-valid-file-name
local-file
local-file?
@@ -463,6 +464,12 @@ the given file name is valid, even if it's not a string literal, and thus not
warn about it."
file)
+(define-syntax-rule (precanonicalized-file-name file absolute)
+ "This is a syntactic keyword to tell 'local-file' that it can assume that
+the given file name FILE has ABSOLUTE as absolute file name and 'local-file'
+does not need to compute the absolute file name by itself."
+ absolute)
+
(define-syntax local-file
(lambda (s)
"Return an object representing local file FILE to add to the store; this
@@ -481,7 +488,7 @@ where FILE is the entry's absolute file name and STAT is the result of
This is the declarative counterpart of the 'interned-file' monadic procedure.
It is implemented as a macro to capture the current source directory where it
appears."
- (syntax-case s (assume-valid-file-name)
+ (syntax-case s (assume-valid-file-name precanonicalized-file-name)
((_ file rest ...)
(string? (syntax->datum #'file))
;; FILE is a literal, so resolve it relative to the source directory.
@@ -495,6 +502,9 @@ appears."
#'(%local-file file
(delay (absolute-file-name file (getcwd)))
rest ...))
+ ((_ (precanonicalized-file-name file absolute) rest ...)
+ ;; Use the given file name ABSOLUTE as absolute file name.
+ #'(%local-file file (delay absolute) rest ...))
((_ file rest ...)
;; Resolve FILE relative to the current directory.
(with-syntax ((location (datum->syntax s (syntax-source s))))
--
2.33.0
From 0fc54bdd9ccc9729fff54f5935a552e5e608a1d0 Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Sat, 4 Sep 2021 18:10:32 +0200
Subject: [PATCH 6/6] gexp: Do not intern if the file is already in the store.
* guix/gexp.scm (local-file-compiler): When the file is already in the
store, re-use the fixed output path instead of interning the file
again.
---
guix/gexp.scm | 38 +++++++++++++++++++++++++++++++-------
1 file changed, 31 insertions(+), 7 deletions(-)
Toggle diff (51 lines)
diff --git a/guix/gexp.scm b/guix/gexp.scm
index c69e4aa299..da1e918801 100644
--- a/guix/gexp.scm
+++ b/guix/gexp.scm
@@ -531,13 +531,37 @@ appears."
(define-gexp-compiler (local-file-compiler (file <local-file>) system target)
;; "Compile" FILE by adding it to the store.
(match file
- (($ <local-file> file (= force absolute) name sha256 recursive? select?)
- ;; Canonicalize FILE so that if it's a symlink, it is resolved. Failing
- ;; to do that, when RECURSIVE? is #t, we could end up creating a dangling
- ;; symlink in the store, and when RECURSIVE? is #f 'add-to-store' would
- ;; just throw an error, both of which are inconvenient.
- (interned-file absolute name
- #:recursive? recursive? #:select? select?))))
+ ;; Delay computing the absolute file name until 'intern', as this
+ ;; might be a relatively expensive computation (e.g. if search-patch
+ ;; is used), especially on a spinning disk.
+ (($ <local-file> file absolute-promise name sha256 recursive? select?)
+ (let ()
+ (define (intern)
+ ;; Canonicalize FILE so that if it's a symlink, it is resolved.
+ ;; Failing to do that, when RECURSIVE? is #t, we could end up creating
+ ;; a dangling symlink in the store, and when RECURSIVE? is #f
+ ;; 'add-to-store' would just throw an error, both of which are
+ ;; inconvenient.
+ (interned-file (force absolute-promise) name
+ #:recursive? recursive? #:select? select?))
+ (if sha256
+ (let ((path (fixed-output-path name sha256 #:recursive? recursive?)))
+ ;; If the hash is known in advance and the store already has the
+ ;; item, there is no need to intern the file.
+ (if (file-exists? path)
+ (mbegin %store-monad
+ ;; Tell the GC that PATH will be used, such that it won't
+ ;; be deleted.
+ ((store-lift add-temp-root) path)
+ ;; The GC could have deleted the item before add-temp-root
+ ;; completed, so check again if PATH exists.
+ (if (file-exists? path)
+ (return path)
+ ;; If it has been removed, fall-back interning.
+ (intern)))
+ ;; If PATH does not yet exist, fall back to interning.
+ (intern)))
+ (intern))))))
(define-record-type <plain-file>
(%plain-file name content references)
--
2.33.0
-----BEGIN PGP SIGNATURE-----
iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYTPiVhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7mUPAP9Tp6RrxYBG01bX5pGGZjhkUVxB
VlrLlALonb/bUSqfwgEA2ICKcwCwWq6gd7PZCTO2sGhtcgFlksT1MzyoNH+KHw0=
=D7ID
-----END PGP SIGNATURE-----