[PATCH] Improve default diff hunk header detection.

  • Done
  • quality assurance status badge
Details
5 participants
  • Sarah Morgensen
  • Kyle Meyer
  • Ludovic Courtès
  • Marius Bakke
  • Maxime Devos
Owner
unassigned
Submitted by
Sarah Morgensen
Severity
normal
S
S
Sarah Morgensen wrote on 4 Sep 2021 00:39
[PATCH v2] Improve default diff hunk header detection.
(address . guix-patches@gnu.org)
e6e08312afa17ee812f8b538118bec6da86d3357.1630708121.git.iskarian@mgsn.dev
Tell git to look for top-level definitions for diff hunk headers in
Scheme files.

.gitattributes: New file.
.gitconfig: New file.
---
Hello Guix,

This patch improves the diff hunk headers for diffs on scheme files in this
repository. These settings are always settable (and overridable) on a
per-user basis, but I think having them as defaults is nice.

This may help with patches applying in general, but the main goal is to make
etc/committer.scm a little less brittle.

The default "scheme" function regex (enabled with .gitattributes) recognizes
both toplevel and non-toplevel defines. I've modified the regex in .gitconfig
to only recognize the toplevel defines. I think this makes more sense for our
purposes.

Unfortunately, checked-in git config settings cannot be automatically used
(for security reasons), and must be enabled with a once-per-clone

git config --local include.path ../.gitconfig

which isn't ideal. I suppose we could make a 'make' target for setup like
this if we wanted to make it easy.

WDYT?

--
Sarah

.gitattributes | 2 ++
.gitconfig | 2 ++
2 files changed, 4 insertions(+)
create mode 100644 .gitattributes
create mode 100644 .gitconfig

Toggle diff (20 lines)
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 0000000000..5c1b15e9e0
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1,2 @@
+*.scm diff=scheme
+*.scm.in diff=scheme
diff --git a/.gitconfig b/.gitconfig
new file mode 100644
index 0000000000..344d829824
--- /dev/null
+++ b/.gitconfig
@@ -0,0 +1,2 @@
+[diff "scheme"]
+ xfuncname = "^(\\(define.*)$"

base-commit: 522a3bf99cbc21a9093f63280b9508cd69b94ff0
--
2.31.1
S
S
Sarah Morgensen wrote on 4 Sep 2021 00:57
control message for bug #50363
(address . control@debbugs.gnu.org)
E1mMI83-0003YU-Cv@debbugs.gnu.org
retitle 50363 [PATCH] Improve default diff hunk header detection.
quit
M
M
Maxime Devos wrote on 10 Sep 2021 19:07
Re: [bug#50363] [PATCH v2] Improve default diff hunk header detection.
02da42c122f4fe839e12a3c8688cc49b140fcb12.camel@telenet.be
Sarah Morgensen schreef op vr 03-09-2021 om 15:39 [-0700]:
Toggle quote (30 lines)
> Tell git to look for top-level definitions for diff hunk headers in
> Scheme files.
>
> .gitattributes: New file.
> .gitconfig: New file.
> ---
> Hello Guix,
>
> This patch improves the diff hunk headers for diffs on scheme files in this
> repository. These settings are always settable (and overridable) on a
> per-user basis, but I think having them as defaults is nice.
>
> This may help with patches applying in general, but the main goal is to make
> etc/committer.scm a little less brittle.
>
> The default "scheme" function regex (enabled with .gitattributes) recognizes
> both toplevel and non-toplevel defines. I've modified the regex in .gitconfig
> to only recognize the toplevel defines. I think this makes more sense for our
> purposes.
>
> Unfortunately, checked-in git config settings cannot be automatically used
> (for security reasons), and must be enabled with a once-per-clone
>
> git config --local include.path ../.gitconfig
>
> which isn't ideal. I suppose we could make a 'make' target for setup like
> this if we wanted to make it easy.
>
> WDYT?

This seems nice to me.
Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYTuQ4BccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7sL+AP0XTB0DRfZieAK5bg5AOFScKtyE
MKwCjiqyJC0lkYKdlwEAk0I4q/9EZC/xJ4Pc8psDAe8H9M1x+hOedOuORgnFOgU=
=M7LK
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 13 Sep 2021 12:24
Re: bug#50363: [PATCH] Improve default diff hunk header detection.
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)(address . 50363@debbugs.gnu.org)
87czpcai3q.fsf@gnu.org
Hi!

Sarah Morgensen <iskarian@mgsn.dev> skribis:

Toggle quote (30 lines)
> Tell git to look for top-level definitions for diff hunk headers in
> Scheme files.
>
> .gitattributes: New file.
> .gitconfig: New file.
> ---
> Hello Guix,
>
> This patch improves the diff hunk headers for diffs on scheme files in this
> repository. These settings are always settable (and overridable) on a
> per-user basis, but I think having them as defaults is nice.
>
> This may help with patches applying in general, but the main goal is to make
> etc/committer.scm a little less brittle.
>
> The default "scheme" function regex (enabled with .gitattributes) recognizes
> both toplevel and non-toplevel defines. I've modified the regex in .gitconfig
> to only recognize the toplevel defines. I think this makes more sense for our
> purposes.
>
> Unfortunately, checked-in git config settings cannot be automatically used
> (for security reasons), and must be enabled with a once-per-clone
>
> git config --local include.path ../.gitconfig
>
> which isn't ideal. I suppose we could make a 'make' target for setup like
> this if we wanted to make it easy.
>
> WDYT?

That LGTM too. Rather than a ‘make’ target, how about a adding a line
or two under “Contributing”?

Thanks,
Ludo’.
S
S
Sarah Morgensen wrote on 19 Sep 2021 20:36
[PATCH v3] Improve default diff hunk header detection.
(address . 50363@debbugs.gnu.org)
58187bb9c61bc7599cde31b52a5dd58e90c1f78f.1632076068.git.iskarian@mgsn.dev
Tell git where to look for diff hunk headers: top-level definitions for
Scheme files, and (sub)section headers for texi files.

* .gitattributes, etc/git/gitconfig: New files.
* doc/contributing.texi ("Submitting Patches"): Add subsection
"Configuring Git". Document etc/git/gitconfig.
---
Changes from previous version:

* Added rule for .texi files

* Documented how to use the advanced settings in the manual (as well as some
other related information)

Note that I am currently working on a rewrite of "Submitting Patches", so
"Configuring Git" will eventually get its own proper subsection.

--
Sarah
.gitattributes | 3 +++
doc/contributing.texi | 46 +++++++++++++++++++++++++++++++++++++++----
doc/guix.texi | 1 +
etc/git/gitconfig | 5 +++++
4 files changed, 51 insertions(+), 4 deletions(-)
create mode 100644 .gitattributes
create mode 100644 etc/git/gitconfig

Toggle diff (104 lines)
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 0000000000..51f29b8a48
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1,3 @@
+*.scm diff=scheme
+*.scm.in diff=scheme
+*.texi diff=tex
diff --git a/doc/contributing.texi b/doc/contributing.texi
index d1b77d7d05..0e8747ab25 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -992,9 +992,12 @@ @section Submitting Patches
Development is done using the Git distributed version control system.
Thus, access to the repository is not strictly necessary. We welcome
contributions in the form of patches as produced by @code{git
-format-patch} sent to the @email{guix-patches@@gnu.org} mailing list.
-Seasoned Guix developers may also want to look at the section on commit
-access (@pxref{Commit Access}).
+format-patch} sent to the @email{guix-patches@@gnu.org} mailing list
+(@pxref{submitting patches,, Submitting patches to a project, git, Git
+User Manual}). Contributors are encouraged to take a moment to set some
+Git repository options (@pxref{Configuring Git}) first, which can
+improve the readability of patches. Seasoned Guix developers may also
+want to look at the section on commit access (@pxref{Commit Access}).
This mailing list is backed by a Debbugs instance, which allows us to
keep track of submissions (@pxref{Tracking Bugs and Patches}). Each
@@ -1205,11 +1208,46 @@ @section Submitting Patches
When a bug is resolved, please close the thread by sending an email to
@email{@var{NNN}-done@@debbugs.gnu.org}.
+@node Configuring Git
+@subsection Configuring Git
+@cindex git configuration
+@cindex @code{git format-patch}
+@cindex @code{git send-email}
+
+If you have not done so already, you may wish to set a name and email
+that will be associated with your commits (@pxref{telling git your name,
+, Telling Git your name, git, Git User Manual}). If you wish to use a
+different name or email just for commits in this respository, you can
+use @command{git config --local}, or edit @file{.git/config} in the
+repository instead of @file{~/.gitconfig}.
+
+We provide some default settings in @file{etc/git/gitconfig} which
+modify how patches are generated, making them easier to read and apply.
+These settings can be applied by manually copying them to
+@file{.git/config} in your checkout, or by telling Git to include the
+whole file:
+
+@example
+git config --local include.path=../etc/git/gitconfig
+@end example
+
+From then on, any changes to @file{etc/git/gitconfig} would
+automatically take effect.
+
+Since the first patch in a series must be sent separately
+(@pxref{Sending a Patch Series}), it can also be helpful to tell
+@command{git format-patch} to handle the e-mail threading instead of
+@command{git send-email}:
+
+@example
+git config --local format.thread=shallow
+git config --local sendemail.thread=no
+@end example
+
@unnumberedsubsec Sending a Patch Series
@anchor{Sending a Patch Series}
@cindex patch series
@cindex @code{git send-email}
-@cindex @code{git-send-email}
When sending a patch series (e.g., using @code{git send-email}), please
first send one message to @email{guix-patches@@gnu.org}, and then send
diff --git a/doc/guix.texi b/doc/guix.texi
index 6436e83a7c..4dac36310f 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -96,6 +96,7 @@
Copyright @copyright{} 2021 Hui Lu@*
Copyright @copyright{} 2021 pukkamustard@*
Copyright @copyright{} 2021 Alice Brenon@*
+Copyright @copyright{} 2021 Sarah Morgensen@*
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.3 or
diff --git a/etc/git/gitconfig b/etc/git/gitconfig
new file mode 100644
index 0000000000..290006816f
--- /dev/null
+++ b/etc/git/gitconfig
@@ -0,0 +1,5 @@
+[diff "scheme"]
+ xfuncname = "^(\\(define.*)$"
+
+[diff "tex"]
+ xfuncname = "^(@((|sub|subsub)section|(unnumbered|appendix)((|sub|subsub)sec)|(|major|chap|sub|subsub)heading|chapter|part|titlepage|top)[ \t]+.*)$"

base-commit: 808f9ffbd3106da4c92d2367b118b98196c9e81e
--
2.33.0
K
K
Kyle Meyer wrote on 20 Sep 2021 00:09
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)
87o88o8bf8.fsf@kyleam.com
Sarah Morgensen writes:

Toggle quote (10 lines)
> diff --git a/.gitattributes b/.gitattributes
> new file mode 100644
> index 0000000000..51f29b8a48
> --- /dev/null
> +++ b/.gitattributes
> @@ -0,0 +1,3 @@
> +*.scm diff=scheme
> +*.scm.in diff=scheme
> +*.texi diff=tex

"tex" is a built-in pattern for LaTeX. To avoid confusion, I suggest
"texinfo", which is what the Emacs repo uses.

Toggle quote (1 lines)
> diff --git a/doc/contributing.texi b/doc/contributing.texi
[...]
Toggle quote (4 lines)
> +@example
> +git config --local include.path=../etc/git/gitconfig
> +@end example

The '=' above should be a space:

$ git config --local include.path=../etc/git/gitconfig
error: invalid key: include.path=../etc/git/gitconfig

(This is true in the other examples as well.)

Just thinking aloud: the include.path approach above assumes a clone
with the standard $GIT_DIR and working tree layout, but that seems fine
because users with more unusual setups would know how to adjust it for
their case. Also, for git-worktree users, the etc/git/gitconfig file in
the main worktree would be used within other worktrees, but for this use
case I doubt that will cause confusion.

Toggle quote (6 lines)
> @unnumberedsubsec Sending a Patch Series
> @anchor{Sending a Patch Series}
> @cindex patch series
> @cindex @code{git send-email}
> -@cindex @code{git-send-email}

I suspect the second variant was included to help those that are using
the git- variant to search (perhaps because that's how they'd refer to
the manpage or because they know about Git's exec path). Not a big deal
either way, but keeping it around seems okay to me.

Toggle quote (12 lines)
> diff --git a/etc/git/gitconfig b/etc/git/gitconfig
> new file mode 100644
> index 0000000000..290006816f
> --- /dev/null
> +++ b/etc/git/gitconfig
> @@ -0,0 +1,5 @@
> +[diff "scheme"]
> + xfuncname = "^(\\(define.*)$"
> +
> +[diff "tex"]
> + xfuncname = "^(@((|sub|subsub)section|(unnumbered|appendix)((|sub|subsub)sec)|(|major|chap|sub|subsub)heading|chapter|part|titlepage|top)[ \t]+.*)$"

Fwiw the Emacs repo sets a simpler value (via autogen.sh):

^@node[[:space:]]+([^,[:space:]][^,]+)
S
S
Sarah Morgensen wrote on 20 Sep 2021 00:56
(name . Kyle Meyer)(address . kyle@kyleam.com)
86ee9kgono.fsf@mgsn.dev
Hello Kyle,

Thanks for taking a look and trying this out!

Kyle Meyer <kyle@kyleam.com> writes:

Toggle quote (15 lines)
> Sarah Morgensen writes:
>
>> diff --git a/.gitattributes b/.gitattributes
>> new file mode 100644
>> index 0000000000..51f29b8a48
>> --- /dev/null
>> +++ b/.gitattributes
>> @@ -0,0 +1,3 @@
>> +*.scm diff=scheme
>> +*.scm.in diff=scheme
>> +*.texi diff=tex
>
> "tex" is a built-in pattern for LaTeX. To avoid confusion, I suggest
> "texinfo", which is what the Emacs repo uses.

Good point. I was trying to use the built-in because it has a
whitespace regex defined in userdiff.c, but I just found that I can set
that with wordRegex, so I'll do that. I'll take a look at the Emacs
repo as well.

Toggle quote (14 lines)
>
>> diff --git a/doc/contributing.texi b/doc/contributing.texi
> [...]
>> +@example
>> +git config --local include.path=../etc/git/gitconfig
>> +@end example
>
> The '=' above should be a space:
>
> $ git config --local include.path=../etc/git/gitconfig
> error: invalid key: include.path=../etc/git/gitconfig
>
> (This is true in the other examples as well.)

Thanks for catching this.

Toggle quote (8 lines)
>
> Just thinking aloud: the include.path approach above assumes a clone
> with the standard $GIT_DIR and working tree layout, but that seems fine
> because users with more unusual setups would know how to adjust it for
> their case. Also, for git-worktree users, the etc/git/gitconfig file in
> the main worktree would be used within other worktrees, but for this use
> case I doubt that will cause confusion.

I actually wrote about the worktree limitation at first, but I thought
including it would be more confusing to people who don't use them than
it would be helpful to people who do.

Toggle quote (11 lines)
>> @unnumberedsubsec Sending a Patch Series
>> @anchor{Sending a Patch Series}
>> @cindex patch series
>> @cindex @code{git send-email}
>> -@cindex @code{git-send-email}
>
> I suspect the second variant was included to help those that are using
> the git- variant to search (perhaps because that's how they'd refer to
> the manpage or because they know about Git's exec path). Not a big deal
> either way, but keeping it around seems okay to me.

Hmmm. I originally removed it because it results in two entries in the
index. Perhaps I can index them as

@cindex @code{git send-email} (or @code{git-send-email})

or similar. What do you think?

Toggle quote (16 lines)
>> diff --git a/etc/git/gitconfig b/etc/git/gitconfig
>> new file mode 100644
>> index 0000000000..290006816f
>> --- /dev/null
>> +++ b/etc/git/gitconfig
>> @@ -0,0 +1,5 @@
>> +[diff "scheme"]
>> + xfuncname = "^(\\(define.*)$"
>> +
>> +[diff "tex"]
>> + xfuncname = "^(@((|sub|subsub)section|(unnumbered|appendix)((|sub|subsub)sec)|(|major|chap|sub|subsub)heading|chapter|part|titlepage|top)[ \t]+.*)$"
>
> Fwiw the Emacs repo sets a simpler value (via autogen.sh):
>
> ^@node[[:space:]]+([^,[:space:]][^,]+)

I made this choice because we have several unnumbered subsections
without nodes that are fairly long. Otherwise, nodes make a good
choice.

Also, their xfuncname will only show the node name as the diff hunk
header--not the whole line. I also considered this (I think it's
cleaner) but I thought it might be confusing. If others like it, let's
do it.

--
Sarah
K
K
Kyle Meyer wrote on 20 Sep 2021 02:57
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)
87k0jc83n2.fsf@kyleam.com
Sarah Morgensen writes:

Toggle quote (3 lines)
> Kyle Meyer <kyle@kyleam.com> writes:
>
>> Sarah Morgensen writes:
[...]
Toggle quote (15 lines)
>>> @cindex @code{git send-email}
>>> -@cindex @code{git-send-email}
>>
>> I suspect the second variant was included to help those that are using
>> the git- variant to search (perhaps because that's how they'd refer to
>> the manpage or because they know about Git's exec path). Not a big deal
>> either way, but keeping it around seems okay to me.
>
> Hmmm. I originally removed it because it results in two entries in the
> index. Perhaps I can index them as
>
> @cindex @code{git send-email} (or @code{git-send-email})
>
> or similar. What do you think?

I don't see having entries in the index for different variants as an
issue (although I can see the point of view that it's just noise in this
case). As for packing them into one line, dunno, think I'd just leave
it either as it is (separate lines) or how your patch has it.

But, again, I don't think it matters much either way (and perhaps wasn't
worth me commenting on it :]).
S
S
Sarah Morgensen wrote on 21 Sep 2021 01:37
[PATCH v4] Improve default diff hunk header detection.
(address . 50363@debbugs.gnu.org)
bbac973c0d0388fabe126bd44b60b0683ffe9f03.1632180690.git.iskarian@mgsn.dev
Tell git where to look for diff hunk headers: top-level definitions for
Scheme files, and (sub)section headers for texi files.

* .gitattributes, etc/git/gitconfig: New files.
* doc/contributing.texi ("Submitting Patches"): Add subsection
"Configuring Git". Document etc/git/gitconfig.
---
Changes since v3 (thanks to Kyle for the suggestions):

* Diff name changed from "tex" to "texinfo"

* "texinfo" diff matches nodes rather than sections (this is what most
texinfo diff drivers seem to do)

* Examples fixed

--
.gitattributes | 3 +++
doc/contributing.texi | 46 +++++++++++++++++++++++++++++++++++++++----
doc/guix.texi | 1 +
etc/git/gitconfig | 5 +++++
4 files changed, 51 insertions(+), 4 deletions(-)
create mode 100644 .gitattributes
create mode 100644 etc/git/gitconfig

Toggle diff (104 lines)
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 0000000000..b31f7fd74d
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1,3 @@
+*.scm diff=scheme
+*.scm.in diff=scheme
+*.texi diff=texinfo
diff --git a/doc/contributing.texi b/doc/contributing.texi
index d1b77d7d05..a6bfcb82e0 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -992,9 +992,12 @@ Submitting Patches
Development is done using the Git distributed version control system.
Thus, access to the repository is not strictly necessary. We welcome
contributions in the form of patches as produced by @code{git
-format-patch} sent to the @email{guix-patches@@gnu.org} mailing list.
-Seasoned Guix developers may also want to look at the section on commit
-access (@pxref{Commit Access}).
+format-patch} sent to the @email{guix-patches@@gnu.org} mailing list
+(@pxref{submitting patches,, Submitting patches to a project, git, Git
+User Manual}). Contributors are encouraged to take a moment to set some
+Git repository options (@pxref{Configuring Git}) first, which can
+improve the readability of patches. Seasoned Guix developers may also
+want to look at the section on commit access (@pxref{Commit Access}).
This mailing list is backed by a Debbugs instance, which allows us to
keep track of submissions (@pxref{Tracking Bugs and Patches}). Each
@@ -1205,11 +1208,46 @@ Submitting Patches
When a bug is resolved, please close the thread by sending an email to
@email{@var{NNN}-done@@debbugs.gnu.org}.
+@node Configuring Git
+@subsection Configuring Git
+@cindex git configuration
+@cindex @code{git format-patch}
+@cindex @code{git send-email}
+
+If you have not done so already, you may wish to set a name and email
+that will be associated with your commits (@pxref{telling git your name,
+, Telling Git your name, git, Git User Manual}). If you wish to use a
+different name or email just for commits in this respository, you can
+use @command{git config --local}, or edit @file{.git/config} in the
+repository instead of @file{~/.gitconfig}.
+
+We provide some default settings in @file{etc/git/gitconfig} which
+modify how patches are generated, making them easier to read and apply.
+These settings can be applied by manually copying them to
+@file{.git/config} in your checkout, or by telling Git to include the
+whole file:
+
+@example
+git config --local include.path ../etc/git/gitconfig
+@end example
+
+From then on, any changes to @file{etc/git/gitconfig} would
+automatically take effect.
+
+Since the first patch in a series must be sent separately
+(@pxref{Sending a Patch Series}), it can also be helpful to tell
+@command{git format-patch} to handle the e-mail threading instead of
+@command{git send-email}:
+
+@example
+git config --local format.thread shallow
+git config --local sendemail.thread no
+@end example
+
@unnumberedsubsec Sending a Patch Series
@anchor{Sending a Patch Series}
@cindex patch series
@cindex @code{git send-email}
-@cindex @code{git-send-email}
When sending a patch series (e.g., using @code{git send-email}), please
first send one message to @email{guix-patches@@gnu.org}, and then send
diff --git a/doc/guix.texi b/doc/guix.texi
index 6436e83a7c..4dac36310f 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -96,6 +96,7 @@
Copyright @copyright{} 2021 Hui Lu@*
Copyright @copyright{} 2021 pukkamustard@*
Copyright @copyright{} 2021 Alice Brenon@*
+Copyright @copyright{} 2021 Sarah Morgensen@*
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.3 or
diff --git a/etc/git/gitconfig b/etc/git/gitconfig
new file mode 100644
index 0000000000..c9ebdc8fa8
--- /dev/null
+++ b/etc/git/gitconfig
@@ -0,0 +1,5 @@
+[diff "scheme"]
+ xfuncname = "^(\\(define.*)$"
+
+[diff "texinfo"]
+ xfuncname = "^@node[[:space:]]+([^,]+).*$"

base-commit: 808f9ffbd3106da4c92d2367b118b98196c9e81e
--
2.33.0
L
L
Ludovic Courtès wrote on 22 Sep 2021 14:55
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)
87o88khirl.fsf@gnu.org
Hi,

Sarah Morgensen <iskarian@mgsn.dev> skribis:

Toggle quote (7 lines)
> Tell git where to look for diff hunk headers: top-level definitions for
> Scheme files, and (sub)section headers for texi files.
>
> * .gitattributes, etc/git/gitconfig: New files.
> * doc/contributing.texi ("Submitting Patches"): Add subsection
> "Configuring Git". Document etc/git/gitconfig.

I have one last question:

Toggle quote (4 lines)
> +format-patch} sent to the @email{guix-patches@@gnu.org} mailing list
> +(@pxref{submitting patches,, Submitting patches to a project, git, Git
> +User Manual}). Contributors are encouraged to take a moment to set some

AFAICS, there’s no Info-format Git manual, is there? In that case, the
pxref above is incorrect, but we can use @uref instead and/or suggest
‘man git’ or similar.

The rest LGTM, thank you, and thanks Kyle!

Ludo’.
S
S
Sarah Morgensen wrote on 22 Sep 2021 18:22
Re: [bug#50363] [PATCH v4] Improve default diff hunk header detection.
(name . Ludovic Courtès)(address . ludo@gnu.org)
86zgs4wpf0.fsf@mgsn.dev
Hi Ludo,

Toggle quote (10 lines)
> I have one last question:
>
>> +format-patch} sent to the @email{guix-patches@@gnu.org} mailing list
>> +(@pxref{submitting patches,, Submitting patches to a project, git, Git
>> +User Manual}). Contributors are encouraged to take a moment to set some
>
> AFAICS, there’s no Info-format Git manual, is there? In that case, the
> pxref above is incorrect, but we can use @uref instead and/or suggest
> ‘man git’ or similar.

We don't currently build it, but there is. In the git repo, in
Documentation/Makefile:

Toggle snippet (6 lines)
info: git.info gitman.info
[...]
git.info: user-manual.texi
$(QUIET_MAKEINFO)$(MAKEINFO) --no-split -o $@ user-manual.texi

It's available online at


and



My other patch, #50683, adds this reference to htmlxref.cnf.

Toggle quote (5 lines)
>
> The rest LGTM, thank you, and thanks Kyle!
>
> Ludo’.

--
Sarah
L
L
Ludovic Courtès wrote on 4 Oct 2021 14:26
Re: bug#50363: [PATCH] Improve default diff hunk header detection.
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)
874k9xq8m2.fsf_-_@gnu.org
Hi Sarah,

Sarah Morgensen <iskarian@mgsn.dev> skribis:

Toggle quote (28 lines)
>> I have one last question:
>>
>>> +format-patch} sent to the @email{guix-patches@@gnu.org} mailing list
>>> +(@pxref{submitting patches,, Submitting patches to a project, git, Git
>>> +User Manual}). Contributors are encouraged to take a moment to set some
>>
>> AFAICS, there’s no Info-format Git manual, is there? In that case, the
>> pxref above is incorrect, but we can use @uref instead and/or suggest
>> ‘man git’ or similar.
>
> We don't currently build it, but there is. In the git repo, in
> Documentation/Makefile:
>
> info: git.info gitman.info
> [...]
> git.info: user-manual.texi
> $(QUIET_MAKEINFO)$(MAKEINFO) --no-split -o $@ user-manual.texi
>
> It's available online at
>
> https://git-scm.com/docs/user-manual
>
> and
>
> https://mirrors.edge.kernel.org/pub/software/scm/git/docs/user-manual.html
>
> My other patch, #50683, adds this reference to htmlxref.cnf.

Oh, nice; thanks for explaining.

Finally applied!

Ludo’.
Closed
M
M
Marius Bakke wrote on 14 Oct 2021 00:30
(address . 50363-done@debbugs.gnu.org)
87wnmgk15x.fsf@gnu.org
Ludovic Courtès <ludo@gnu.org> skriver:

Toggle quote (2 lines)
> Finally applied!

It looks like this commit contained the documentation changes only.
Fixed in f8b10932c86cf4c1657a67e8c484d76f757b64bd. :-)
-----BEGIN PGP SIGNATURE-----

iIUEARYKAC0WIQRNTknu3zbaMQ2ddzTocYulkRQQdwUCYWdeGg8cbWFyaXVzQGdu
dS5vcmcACgkQ6HGLpZEUEHfC+wEA8Hj8TzKPHkL0k10cOORixM+/GFHc8s/kq1WX
gUrx/QEBAJOQ/ww/HGjfprby59DfOybUzpvZtr00XfkRdfXpS50J
=mWgE
-----END PGP SIGNATURE-----

Closed
?