(address . bug-guix@gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
Hello,
I tried to upgrade glade to the 3.38.2 release on core-update and
encountered the following test issue:
Toggle snippet (13 lines)
2/5 modules FAIL 0.29s killed by signal 5 SIGTRAP
>>> GLADE_MODULE_SEARCH_PATH=/home/mathieu/glade-3.38.2/build/plugins/gtk+:/home/mathieu/glade-3.38.2/build/plugins/python:/home/mathieu/glade-3.38.2/build/plugins/gjs:/home/mathieu/glade-3.38.2/tests/modules MALLOC_PERTURB_=195 GLADE_TESTING=1 GLADE_CATALOG_SEARCH_PATH=/home/mathieu/glade-3.38.2/plugins/gtk+:/home/mathieu/glade-3.38.2/plugins/python:/home/mathieu/glade-3.38.2/plugins/gjs:/home/mathieu/glade-3.38.2/tests/catalogs GLADE_PIXMAP_DIR=/home/mathieu/glade-3.38.2/data/icons GLADE_ICON_THEME_PATH=/home/mathieu/glade-3.38.2/plugins/gtk+/icons/22x22 /home/mathieu/glade-3.38.2/build/tests/modules
?????????????????????????????????????????????????????????????????????????????????????????????????????? ? ???????????????????????????????????????????????????????????????????????????????????????????????????????
stdout:
# random seed: R02Sd222538bc9b76b6e424ec0cb17ee887c
# GLib-GIO-DEBUG: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ?gio-vfs?
Bail out! GladeUI-PYTHON-FATAL-WARNING: Error initializing Python interpreter: could not import pygobject
stderr:
Error in sitecustomize; set PYTHONVERBOSE for traceback:
ValueError: '/home/mathieu/glade-3.38.2/build/lib/python3.9/site-packages' is not in list
(/home/mathieu/glade-3.38.2/build/tests/modules:4898): GladeUI-PYTHON-WARNING **: 09:43:58.605: Error initializing Python interpreter: could not import pygobject
I think the issue here lies in the sitecustomize.py file introduced with
cb72f9a773e0931ee3758c851d96007ded034e4c.
Toggle snippet (2 lines)
python_root = os.path.realpath(sys.executable).split('/bin/')[0]
When using the Python C library, sys.executable is not the expected
python binary but the test binary.
So when we try to find the associated libraries in the Python search
path, this way:
Toggle snippet (3 lines)
index = sys_path_absolute.index(python_site)
sys.path = sys.path[:index] + matching_sites + sys.path[index:]
we get:
Toggle snippet (2 lines)
ValueError: '/home/mathieu/glade-3.38.2/build/lib/python3.9/site-packages' is not in list
Running the test with the PYTHONPATH set to:
Toggle snippet (2 lines)
PYTHONPATH=/home/mathieu/glade-3.38.2/build/lib/python3.9/site-packages:$PYTHONPATH
is a way to work around this issue.
The fix here would be to replace sys.executable in the sitecustomize.py
with something more adequate, but I have no idea what could it be.
Thanks,
Mathieu