[PATCH] gnu: gnome-maps: Unregister from DBus when asked to.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal
L
L
Leo Prikler wrote on 21 Jul 2021 00:34
(address . guix-patches@gnu.org)
20210720223452.9471-1-leo.prikler@student.tugraz.at
* gnu/packages/patches/gnome-maps-really-do-unregister.patch: New file.
* gnu/packages/geo.scm (gnome-maps)[patches]: Add it here...
* gnu/local.mk (dist_patch_DATA): ... and here.
---
I've opened a separate merge request upsteam [1], but since their CI is
currently failing, it will take some time for this patch to make it into a
release.


gnu/local.mk | 1 +
gnu/packages/geo.scm | 5 ++++-
.../patches/gnome-maps-really-do-unregister.patch | 13 +++++++++++++
3 files changed, 18 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/gnome-maps-really-do-unregister.patch

Toggle diff (49 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 9a3d8f6eca..0743daf0f7 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1155,6 +1155,7 @@ dist_patch_DATA = \
%D%/packages/patches/gmp-arm-asm-nothumb.patch \
%D%/packages/patches/gmp-faulty-test.patch \
%D%/packages/patches/gnash-fix-giflib-version.patch \
+ %D%/packages/patches/gnome-maps-really-do-unregister.patch \
%D%/packages/patches/gnome-shell-theme.patch \
%D%/packages/patches/gnome-shell-disable-test.patch \
%D%/packages/patches/gnome-shell-CVE-2020-17489.patch \
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 37be78edbf..9bf6749dca 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -218,7 +218,10 @@ topology functions.")
name "-" version ".tar.xz"))
(sha256
(base32
- "09rgw8hq3ligap1zzjhx25q354ficpbiw1z9ramghhcqbpylsxdh"))))
+ "09rgw8hq3ligap1zzjhx25q354ficpbiw1z9ramghhcqbpylsxdh"))
+ (patches
+ (search-patches
+ "gnome-maps-really-do-unregister.patch"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
diff --git a/gnu/packages/patches/gnome-maps-really-do-unregister.patch b/gnu/packages/patches/gnome-maps-really-do-unregister.patch
new file mode 100644
index 0000000000..3b201f363d
--- /dev/null
+++ b/gnu/packages/patches/gnome-maps-really-do-unregister.patch
@@ -0,0 +1,13 @@
+Index: gnome-maps-3.36.7/src/application.js
+===================================================================
+--- gnome-maps-3.36.7.orig/src/application.js
++++ gnome-maps-3.36.7/src/application.js
+@@ -277,7 +277,7 @@ var Application = GObject.registerClass(
+ }
+
+ vfunc_dbus_unregister(connection, path) {
+- super.vfunc_dbus_register(connection, path);
++ super.vfunc_dbus_unregister(connection, path);
+ }
+
+ vfunc_activate() {
--
2.32.0
L
L
Leo Prikler wrote on 21 Jul 2021 13:04
[PATCH] gnu: gnome-maps: Update to 3.38.5.
(address . 49670@debbugs.gnu.org)
20210721110431.21634-1-leo.prikler@student.tugraz.at
* gnu/packages/geo.scm (gnome-maps): Update to 3.38.5.
---
As expected, 3.36 is quite dead and a fix for this issue already exists in 3.38.
We could backport their patch, but it turns out 3.38.5 builds with a minor
patch.

gnu/packages/geo.scm | 13 +++++++++++--
1 file changed, 11 insertions(+), 2 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 37be78edbf..8b71f5b03c 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -210,7 +210,7 @@ topology functions.")
(define-public gnome-maps
(package
(name "gnome-maps")
- (version "3.36.7")
+ (version "3.38.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -218,7 +218,7 @@ topology functions.")
name "-" version ".tar.xz"))
(sha256
(base32
- "09rgw8hq3ligap1zzjhx25q354ficpbiw1z9ramghhcqbpylsxdh"))))
+ "1llgzm2ni3iy31dznqkc81vadv0fpqgpz2l9zzrj5jshvyq0akgh"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -236,6 +236,15 @@ topology functions.")
(("@pkgdatadir@/org.gnome.Maps")
(string-append (assoc-ref outputs "out") "/bin/gnome-maps")))
#t))
+ (add-after 'unpack 'fix-broken-tests
+ (lambda _
+ ;; For some reason setting LC_ALL=C and LANG=C as done in the
+ ;; build system does not prevent these gratuitous commas from
+ ;; being inserted.
+ (substitute* "tests/utilsTest.js"
+ (("1001 m") "1,001 m")
+ (("1000 ft") "1,000 ft")
+ (("5282 ft") "5,282 ft"))))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
--
2.32.0
L
L
Ludovic Courtès wrote on 21 Jul 2021 16:28
Re: bug#49670: [PATCH] gnu: gnome-maps: Unregister from DBus when asked to.
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 49670@debbugs.gnu.org)
87fsw7hhce.fsf@gnu.org
Hi!

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (14 lines)
> * gnu/packages/patches/gnome-maps-really-do-unregister.patch: New file.
> * gnu/packages/geo.scm (gnome-maps)[patches]: Add it here...
> * gnu/local.mk (dist_patch_DATA): ... and here.
> ---
> I've opened a separate merge request upsteam [1], but since their CI is
> currently failing, it will take some time for this patch to make it into a
> release.
>
> [1] https://gitlab.gnome.org/GNOME/gnome-maps/-/merge_requests/187

> + (patches
> + (search-patches
> + "gnome-maps-really-do-unregister.patch"))))

This can all go on a single line.

Toggle quote (4 lines)
> +++ b/gnu/packages/patches/gnome-maps-really-do-unregister.patch
> @@ -0,0 +1,13 @@
> +Index: gnome-maps-3.36.7/src/application.js

Could you add a line at the top of this patch saying what it does along
with a link to the merge request above?

Apart from that the two patches LGTM, especially if it allows me to use
gnome-maps again. :-)

Thanks!

Ludo’.
L
L
Leo Prikler wrote on 22 Jul 2021 10:31
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 49670@debbugs.gnu.org)
5af9faa539c916abf3fce795e1e127614456fa43.camel@student.tugraz.at
Am Mittwoch, den 21.07.2021, 16:28 +0200 schrieb Ludovic Courtès:
Toggle quote (21 lines)
> Hi!
>
> Leo Prikler <leo.prikler@student.tugraz.at> skribis:
>
> > * gnu/packages/patches/gnome-maps-really-do-unregister.patch: New
> > file.
> > * gnu/packages/geo.scm (gnome-maps)[patches]: Add it here...
> > * gnu/local.mk (dist_patch_DATA): ... and here.
> > ---
> > I've opened a separate merge request upsteam [1], but since their
> > CI is
> > currently failing, it will take some time for this patch to make it
> > into a
> > release.
> >
> > [1] https://gitlab.gnome.org/GNOME/gnome-maps/-/merge_requests/187
> > + (patches
> > + (search-patches
> > + "gnome-maps-really-do-unregister.patch"))))
>
> This can all go on a single line.
Forgot to count there, but thanks.

Toggle quote (6 lines)
> > +++ b/gnu/packages/patches/gnome-maps-really-do-unregister.patch
> > @@ -0,0 +1,13 @@
> > +Index: gnome-maps-3.36.7/src/application.js
>
> Could you add a line at the top of this patch saying what it does
> along with a link to the merge request above?
It turns out a similar fix already exists upstream [1], so if we decide
to backport that to 3.36 instead of bumping the package to 3.38, I
think we should pick the "official" one.

Toggle quote (2 lines)
> Apart from that the two patches LGTM, especially if it allows me to
> use gnome-maps again. :-)
Do "the two patches" refer to this one alone or also to the one bumping
the package to 3.38? Again, I'm a little unsure what would be the
preferred solution here, as either patch adds additional code that
would probably need to be reverted by Raghav in their GNOME 40 work.

Regards,

[1]
L
L
Ludovic Courtès wrote on 23 Jul 2021 11:29
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 49670@debbugs.gnu.org)
87tuklbcpj.fsf@gnu.org
Hi Leo,

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (2 lines)
> Am Mittwoch, den 21.07.2021, 16:28 +0200 schrieb Ludovic Courtès:

[...]

Toggle quote (10 lines)
>> > +++ b/gnu/packages/patches/gnome-maps-really-do-unregister.patch
>> > @@ -0,0 +1,13 @@
>> > +Index: gnome-maps-3.36.7/src/application.js
>>
>> Could you add a line at the top of this patch saying what it does
>> along with a link to the merge request above?
> It turns out a similar fix already exists upstream [1], so if we decide
> to backport that to 3.36 instead of bumping the package to 3.38, I
> think we should pick the "official" one.

Even better.

Toggle quote (5 lines)
>> Apart from that the two patches LGTM, especially if it allows me to
>> use gnome-maps again. :-)
> Do "the two patches" refer to this one alone or also to the one bumping
> the package to 3.38?

Both, but I hadn’t realized there’s was an exclusive choice.

Toggle quote (4 lines)
> Again, I'm a little unsure what would be the preferred solution here,
> as either patch adds additional code that would probably need to be
> reverted by Raghav in their GNOME 40 work.

I don’t know, I think it’s good to have short-term fixes anyway and it’s
OK if they have to be undone when we eventually upgrade. Your call!

Thanks,
Ludo’.
L
L
Leo Prikler wrote on 23 Jul 2021 12:51
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 49670-done@debbugs.gnu.org)
63a2a1a14cfcb6d9dfed2749ff5d93b2e9de72f8.camel@student.tugraz.at
Am Freitag, den 23.07.2021, 11:29 +0200 schrieb Ludovic Courtès:
Toggle quote (31 lines)
> Hi Leo,
>
> Leo Prikler <leo.prikler@student.tugraz.at> skribis:
>
> > Am Mittwoch, den 21.07.2021, 16:28 +0200 schrieb Ludovic Courtès:
>
> [...]
>
> > > > +++ b/gnu/packages/patches/gnome-maps-really-do-
> > > > unregister.patch
> > > > @@ -0,0 +1,13 @@
> > > > +Index: gnome-maps-3.36.7/src/application.js
> > >
> > > Could you add a line at the top of this patch saying what it does
> > > along with a link to the merge request above?
> > It turns out a similar fix already exists upstream [1], so if we
> > decide
> > to backport that to 3.36 instead of bumping the package to 3.38, I
> > think we should pick the "official" one.
>
> Even better.
>
> > > Apart from that the two patches LGTM, especially if it allows me
> > > to
> > > use gnome-maps again. :-)
> > Do "the two patches" refer to this one alone or also to the one
> > bumping
> > the package to 3.38?
>
> Both, but I hadn’t realized there’s was an exclusive choice.

Well, the exclusive choice comes from the fact that the patch we would
have to add to 3.36 is already present in 3.38.1+. So bumping to a
sufficiently recent gnome-maps "voids" the patch in that it is already
applied.

Toggle quote (9 lines)
> > Again, I'm a little unsure what would be the preferred solution
> > here,
> > as either patch adds additional code that would probably need to be
> > reverted by Raghav in their GNOME 40 work.
>
> I don’t know, I think it’s good to have short-term fixes anyway and
> it’s
> OK if they have to be undone when we eventually upgrade. Your call!

I went with bumping to 3.38. While I hope the test suite doesn't break
in 40 the same way it does here, there is a slim chance the phase I've
added needs to be kept.

Thanks
Closed
?