[PATCH 2/2] Add pirate-get

  • Open
  • quality assurance status badge
Details
2 participants
  • Sarah Morgensen
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
Merged with
P
P
phodina wrote on 18 Jul 2021 13:37
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Ko2gpHllZIoGR5jyOu1v0rgJSa-DpfJZ6aJK1EYq0ooMcI3D_kkBPw-k86vgqdMe2py1XWJ1Mo00o-mv-9ayQwsdqhWY2gqXAkokz0iSTjQ=@protonmail.com
And the pirate-get definition itself

---
index 40b93c4b30..eaf521090c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1778,6 +1778,33 @@ helpers.")
appealing ASCII table format")
(license license:bsd3)))

+(define-public python-pirate-get
+ (package
+ (name "python-pirate-get")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pirate-get" version))
+ (sha256
+ (base32
+ "07s5ss9dxccx1mip7pyga1fagywkqchxmzz55ng47ac9053ffxkq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-pyperclip" ,python-pyperclip)
+ ("python-veryprettytable"
+ ,python-veryprettytable)))
+ (home-page
+ (synopsis
+ "A command line interface for The Pirate Bay")
+ (description
+ "pirate-get is a convenient command line tool (inspired by APT)
+to speed up your trip to the Pirate Bay and get your completely legal
+torrents more quickly.")
+ (license license:gpl3)))
+
(define-public python2-humanfriendly
(let ((base (package-with-python2
(strip-python2-variant python-humanfriendly))))
--
2.31.1
S
S
Sarah Morgensen wrote on 21 Jul 2021 04:53
Re: bug#49619: [PATCH 1/2] Add pirate-get
(name . phodina)(address . phodina@protonmail.com)
86bl6wtm1a.fsf@mgsn.dev
merge 49619 49620
thanks

Hello,

Thanks for the patch. Please note that when submitting patchsets, only
the first patch should be sent to guix-patches@gnu.org; the rest should
be sent to the generated bug number, in this case 49619@debbugs.gnu.org,
in reply to the first email. You can find information about contributing
at:


I also have a few suggestions so your patch can be accepted.

phodina <phodina@protonmail.com> writes:

Toggle quote (4 lines)
> Add pkg veryprettytable as a dependency for pkg pirate-get
>
> ---

Commit messages should follow the ChangeLog format; see the commit
history for examples. For example, this commit message would look like:

Toggle snippet (5 lines)
gnu: Add python-veryprettytable.

* gnu/packages/python-xyz.scm (python-veryprettytable): New variable.

Toggle quote (28 lines)
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index d8c3fbec07..40b93c4b30 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -1754,6 +1754,30 @@ helpers.")
> (properties `((python2-variant . ,(delay python2-humanfriendly))))
> (license license:expat)))
>
> +(define-public python-veryprettytable
> + (package
> + (name "python-veryprettytable")
> + (version "0.8.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "veryprettytable" version))
> + (sha256
> + (base32
> + "1k1rifz8x6qcicmx2is9vgxcj0qb2f5pvzrp7zhmvbmci3yack3f"))))
> + (build-system python-build-system)
> + (propagated-inputs
> + `(("python-colorama" ,python-colorama)
> + ("python-termcolor" ,python-termcolor)))
> + (home-page
> + "https://github.com/smeggingsmegger/VeryPrettyTable")
> + (synopsis
> + "A visually appealing ASCII table output format")

Avoid starting synopses and descriptions with articles. "Visually
appealing..." would be fine.

Toggle quote (4 lines)
> + (description
> + "A simple Python library for easily displaying tabular data in a visually
> +appealing ASCII table format")

Descriptions typically start: "VeryPrettyTable is a simple..."

The description for pirate-get should probably start "Pirate-get is
a..." or "@code{pirate-get} is a..."

Toggle quote (2 lines)
> + (license license:bsd3)))

This should be license:bsd-3.

Toggle quote (7 lines)
> +
> (define-public python2-humanfriendly
> (let ((base (package-with-python2
> (strip-python2-variant python-humanfriendly))))
> --
> 2.31.1

You should also add your copyright at the top of the file, below all the
others.

Please use `--reroll-count=` when generating revised patchsets and
`--to=49169@debbugs.gnu.org --in-reply-to=<original patch's Message-ID>`
when sending.

--
Sarah
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 49620@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49620
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch