[PATCH 1/2] Add pirate-get

  • Open
  • quality assurance status badge
Details
3 participants
  • Sarah Morgensen
  • jgart
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
Merged with
P
P
phodina wrote on 18 Jul 2021 13:36
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
JuV3kXY4ae-0f4PzOqwU4h0_Vh24XCQbm0P3uWqIKZ_-_7hOqSjxqsSHPpVdGA1OPcVRuyq0GT5UNjV_a8ZrDHuaZmNbh81jQzI644BmQR8=@protonmail.com
Add pkg veryprettytable as a dependency for pkg pirate-get

---
Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d8c3fbec07..40b93c4b30 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1754,6 +1754,30 @@ helpers.")
(properties `((python2-variant . ,(delay python2-humanfriendly))))
(license license:expat)))

+(define-public python-veryprettytable
+ (package
+ (name "python-veryprettytable")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "veryprettytable" version))
+ (sha256
+ (base32
+ "1k1rifz8x6qcicmx2is9vgxcj0qb2f5pvzrp7zhmvbmci3yack3f"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-termcolor" ,python-termcolor)))
+ (home-page
+ "https://github.com/smeggingsmegger/VeryPrettyTable")
+ (synopsis
+ "A visually appealing ASCII table output format")
+ (description
+ "A simple Python library for easily displaying tabular data in a visually
+appealing ASCII table format")
+ (license license:bsd3)))
+
(define-public python2-humanfriendly
(let ((base (package-with-python2
(strip-python2-variant python-humanfriendly))))
--
2.31.1
S
S
Sarah Morgensen wrote on 21 Jul 2021 04:53
(name . phodina)(address . phodina@protonmail.com)
86bl6wtm1a.fsf@mgsn.dev
merge 49619 49620
thanks

Hello,

Thanks for the patch. Please note that when submitting patchsets, only
the first patch should be sent to guix-patches@gnu.org; the rest should
be sent to the generated bug number, in this case 49619@debbugs.gnu.org,
in reply to the first email. You can find information about contributing
at:


I also have a few suggestions so your patch can be accepted.

phodina <phodina@protonmail.com> writes:

Toggle quote (4 lines)
> Add pkg veryprettytable as a dependency for pkg pirate-get
>
> ---

Commit messages should follow the ChangeLog format; see the commit
history for examples. For example, this commit message would look like:

Toggle snippet (5 lines)
gnu: Add python-veryprettytable.

* gnu/packages/python-xyz.scm (python-veryprettytable): New variable.

Toggle quote (28 lines)
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index d8c3fbec07..40b93c4b30 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -1754,6 +1754,30 @@ helpers.")
> (properties `((python2-variant . ,(delay python2-humanfriendly))))
> (license license:expat)))
>
> +(define-public python-veryprettytable
> + (package
> + (name "python-veryprettytable")
> + (version "0.8.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "veryprettytable" version))
> + (sha256
> + (base32
> + "1k1rifz8x6qcicmx2is9vgxcj0qb2f5pvzrp7zhmvbmci3yack3f"))))
> + (build-system python-build-system)
> + (propagated-inputs
> + `(("python-colorama" ,python-colorama)
> + ("python-termcolor" ,python-termcolor)))
> + (home-page
> + "https://github.com/smeggingsmegger/VeryPrettyTable")
> + (synopsis
> + "A visually appealing ASCII table output format")

Avoid starting synopses and descriptions with articles. "Visually
appealing..." would be fine.

Toggle quote (4 lines)
> + (description
> + "A simple Python library for easily displaying tabular data in a visually
> +appealing ASCII table format")

Descriptions typically start: "VeryPrettyTable is a simple..."

The description for pirate-get should probably start "Pirate-get is
a..." or "@code{pirate-get} is a..."

Toggle quote (2 lines)
> + (license license:bsd3)))

This should be license:bsd-3.

Toggle quote (7 lines)
> +
> (define-public python2-humanfriendly
> (let ((base (package-with-python2
> (strip-python2-variant python-humanfriendly))))
> --
> 2.31.1

You should also add your copyright at the top of the file, below all the
others.

Please use `--reroll-count=` when generating revised patchsets and
`--to=49169@debbugs.gnu.org --in-reply-to=<original patch's Message-ID>`
when sending.

--
Sarah
P
P
phodina wrote on 22 Jul 2021 14:17
(address . 49619@debbugs.gnu.org)
8k-2wKQa0LpuopuIhb_90q6sfNtDiGhbFkLzul2M96i5hYKCwOLP-lC9QHmUeTn4dSl7Rx60bUu_RTIxXDnq0XpKV0gZrJq6BtzeHtsRv1k=@protonmail.com
Thanks again Sarah for the suggestions.

---
In-Reply-To: <JuV3kXY4ae-0f4PzOqwU4h0_Vh24XCQbm0P3uWqIKZ_-_7hOqSjxqsSHPpVdGA1OPcVRuyq0GT5UNjV_a8ZrDHuaZmNbh81jQzI644BmQR8=@protonmail.com>
References: <JuV3kXY4ae-0f4PzOqwU4h0_Vh24XCQbm0P3uWqIKZ_-_7hOqSjxqsSHPpVdGA1OPcVRuyq0GT5UNjV_a8ZrDHuaZmNbh81jQzI644BmQR8=@protonmail.com>
From: Petr Hodina <phodina@protonmail.com>
Date: Sun, 18 Jul 2021 12:59:49 +0200
Subject: [PATCH v2 1/2] gnu: Add python-very-pretty-table
To: 49619@debbugs.gnu.org


Toggle diff (43 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d8c3fbec07..020ba78401 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -105,6 +105,7 @@
;;; Copyright © 2021 Danial Behzadi <dani.behzi@ubuntu.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1754,6 +1755,30 @@ helpers.")
(properties `((python2-variant . ,(delay python2-humanfriendly))))
(license license:expat)))

+(define-public python-veryprettytable
+ (package
+ (name "python-veryprettytable")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "veryprettytable" version))
+ (sha256
+ (base32
+ "1k1rifz8x6qcicmx2is9vgxcj0qb2f5pvzrp7zhmvbmci3yack3f"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-termcolor" ,python-termcolor)))
+ (home-page
+ "https://github.com/smeggingsmegger/VeryPrettyTable")
+ (synopsis
+ "Visually appealing ASCII table output format")
+ (description
+ "The functions and classes in @code{veryprettytable} allow for easily
+ displaying tabular data in a visually appealing ASCII table format.")
+ (license license:bsd-3)))
+
(define-public python2-humanfriendly
(let ((base (package-with-python2
(strip-python2-variant python-humanfriendly))))
--
2.31.1
P
P
phodina wrote on 22 Jul 2021 14:22
Re: bug#49619: [PATCH 2/2] Add pirate-get
(address . 49619@debbugs.gnu.org)(name . Sarah Morgensen)(address . iskarian@mgsn.dev)
XnItfta1qBuzHN4Qry9ln_5BinMAFHH_e2lBuJIRyrni65GW8zdksUYEwqn69dj-1o_pLN8WMi13S0i5V--ayequIOtDz84D88Wqz6LKV10=@protonmail.com
And I guess control@debbugs.gnu.org is some kind of bot, right?
Here's the second patch:

---
In-Reply-To: <JuV3kXY4ae-0f4PzOqwU4h0_Vh24XCQbm0P3uWqIKZ_-_7hOqSjxqsSHPpVdGA1OPcVRuyq0GT5UNjV_a8ZrDHuaZmNbh81jQzI644BmQR8=@protonmail.com>
References: <JuV3kXY4ae-0f4PzOqwU4h0_Vh24XCQbm0P3uWqIKZ_-_7hOqSjxqsSHPpVdGA1OPcVRuyq0GT5UNjV_a8ZrDHuaZmNbh81jQzI644BmQR8=@protonmail.com>
From: Petr Hodina <phodina@protonmail.com>
Date: Sun, 18 Jul 2021 13:02:14 +0200
Subject: [PATCH v2 2/2] gnu: Add python-pirate-get
To: 49619@debbugs.gnu.org


Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 020ba78401..a3b181cc30 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1779,6 +1779,33 @@ helpers.")
displaying tabular data in a visually appealing ASCII table format.")
(license license:bsd-3)))

+(define-public python-pirate-get
+ (package
+ (name "python-pirate-get")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pirate-get" version))
+ (sha256
+ (base32
+ "07s5ss9dxccx1mip7pyga1fagywkqchxmzz55ng47ac9053ffxkq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-pyperclip" ,python-pyperclip)
+ ("python-veryprettytable"
+ ,python-veryprettytable)))
+ (home-page
+ "https://github.com/vikstrous/pirate-get")
+ (synopsis
+ "Command line interface for The Pirate Bay")
+ (description
+ "@code{pirate-get} is a convenient command line tool (inspired by APT)
+to speed up your trip to the Pirate Bay and get your completely legal
+torrents more quickly.")
+ (license license:gpl3)))
+
(define-public python2-humanfriendly
(let ((base (package-with-python2
(strip-python2-variant python-humanfriendly))))
--
2.31.1
P
P
phodina wrote on 18 Sep 2021 10:07
Patch status
(address . 49619@debbugs.gnu.org)(name . Sarah Morgensen)(address . iskarian@mgsn.dev)
UYEcZcGN4_oeq_jcBjzrBVp6ZtnmxmapPhveIX9NMDBSzKrs908MojvbQuYzpZdB2VLUr6hFbFtFNGhmZ1YFJX4oxTKbBjf9tHAt6FNX73s=@protonmail.com
Hi Sarah!

Are these fixes now compliant to upstream the patch?
P
P
phodina wrote on 18 Sep 2021 14:44
[PATCH v3 1/2] gnu: Add python-very-pretty-table.
(address . 49619@debbugs.gnu.org)(name . Sarah Morgensen)(address . iskarian@mgsn.dev)
ixy1HtzUo9-aHVUDiGsmrv4eo6ujfqKN3bdVhgPAZRsXySRs1eUKkvl1wQcPI3wzv_FlTMcc8-tvTMZFjHFowaKdNDR-QRYS9bIyMyuPH8Q=@protonmail.com
Hi Sarah,

here are some the changes for upstreaming :-)

Toggle snippet (41 lines)
* gnu/packages/python-xyz.scm (python-very-pretty-table): New variable.

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 66857b31b0..c4fb6edd40 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1793,6 +1793,30 @@ helpers.")
(properties `((python2-variant . ,(delay python2-humanfriendly))))
(license license:expat)))

+(define-public python-very-pretty-table
+ (package
+ (name "python-very-pretty-table")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "veryprettytable" version))
+ (sha256
+ (base32
+ "1k1rifz8x6qcicmx2is9vgxcj0qb2f5pvzrp7zhmvbmci3yack3f"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-termcolor" ,python-termcolor)))
+ (home-page
+ "https://github.com/smeggingsmegger/VeryPrettyTable")
+ (synopsis
+ "Visually appealing ASCII table output format")
+ (description
+ "Functions and classes in @code{very-pretty-table} allow for easily
+ displaying tabular data in a visually appealing ASCII table format.")
+ (license license:bsd-3)))
+
(define-public python2-humanfriendly
(let ((base (package-with-python2
(strip-python2-variant python-humanfriendly))))
--
2.32.0
P
P
phodina wrote on 18 Sep 2021 14:45
[PATCH v3 2/2] gnu: Add python-pirate-get.
(address . 49619@debbugs.gnu.org)(name . Sarah Morgensen)(address . iskarian@mgsn.dev)
ydYY7B1n1EvbMlgcAX7iB7Cf1pJxMP1J7vb8zcZK9AYiIHG3tfmmJwBGyXidfCddw_tDBsH_8jTmqcoZLgWlaUYP_P3BsnkKskSd4FsB198=@protonmail.com
* gnu/packages/python-xyz.scm (python-pirate-get): New variable.

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c4fb6edd40..6dcef95f1e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1817,6 +1817,33 @@ helpers.")
displaying tabular data in a visually appealing ASCII table format.")
(license license:bsd-3)))

+(define-public python-pirate-get
+ (package
+ (name "python-pirate-get")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pirate-get" version))
+ (sha256
+ (base32
+ "07s5ss9dxccx1mip7pyga1fagywkqchxmzz55ng47ac9053ffxkq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-pyperclip" ,python-pyperclip)
+ ("python-veryprettytable"
+ ,python-veryprettytable)))
+ (home-page
+ "https://github.com/vikstrous/pirate-get")
+ (synopsis
+ "Command line interface for The Pirate Bay")
+ (description
+ "@code{pirate-get} is a convenient command line tool (inspired by APT)
+to speed up your trip to the Pirate Bay and get your completely legal
+torrents more quickly.")
+ (license license:gpl3)))
+
(define-public python2-humanfriendly
(let ((base (package-with-python2
(strip-python2-variant python-humanfriendly))))
--
2.32.0
S
S
Sarah Morgensen wrote on 22 Sep 2021 05:21
Re: [bug#49619] [PATCH v3 1/2] gnu: Add python-very-pretty-table.
(name . phodina)(address . phodina@protonmail.com)(address . 49619@debbugs.gnu.org)
8635pxxpke.fsf@mgsn.dev
Hi,

phodina <phodina@protonmail.com> writes:

Toggle quote (4 lines)
> Hi Sarah!
>
> Are these fixes now compliant to upstream the patch?

It's pretty good. I went ahead and made a few changes (attached below):
I tweaked the descriptions, I changed very-pretty-table to
veryprettytable so the python importer can find it in the future, I
changed pirate-get's propagated-inputs to inputs since it's an end-user
package, and I changed the license of pirate-get to AGPL-3.

* Package review checklist (WIP)
Lack of a check is not proof of noncompliance.

1. [X] Package builds (guix build package)
[X] x86_64 [ ] aarch64 [ ] armhf [ ] powerpc64le
[ ] i686 [ ] i586 [ ] mips64le
2. [X] Build is reproducible (guix build --rounds=n package)
3. [X] Tests enabled (if available) or disabled with in-source comment
4. [X] No extraneous dependencies (guix size package)
5. [X] No unnecessary pre-built binaries/blobs
6. [X] Dependencies unvendored when available in Guix
7. [X] Cross-compile friendly (cc-for-target, patches with inputs)
8. [X] License matches source
9. [X] No problematic lints (guix lint package)
10. [X] Formatting follows guidelines
- [X] Lines wrap at 80 characters
- [X] Indentation passes etc/indent-code.el
- [X] Two spaces used between sentences

For new packages:
1. [X] Source url is robust
* mirror:// used with url-fetch when possible
* No auto-generated archives from source repo (prefer cloning)
2. [X] Synopsis is short, descriptive, and meaningful to a wide audience
3. [X] Description is objective, takes 5-10 lines, uses full sentences,
and provides the information users need to decide whether the
software fits their needs.

I also gave it a spin, and it works fine as long as the SSL_CERT_DIR
environment variable is defined (I think that's beyond the scope of this
package). LGTM.

Thanks for your work!

--
Sarah
From e468a5f5722a31ce9999ddba43a8de120521a938 Mon Sep 17 00:00:00 2001
Message-Id: <e468a5f5722a31ce9999ddba43a8de120521a938.1632277047.git.iskarian@mgsn.dev>
From: phodina <phodina@protonmail.com>
Date: Sat, 18 Sep 2021 12:44:21 +0000
Subject: [PATCH v4 1/2] gnu: Add python-veryprettytable.

* gnu/packages/python-xyz.scm (python-veryprettytable): New variable.
---
gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4e2e719afc..b1f162d079 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1793,6 +1793,33 @@ helpers.")
(properties `((python2-variant . ,(delay python2-humanfriendly))))
(license license:expat)))
+(define-public python-veryprettytable
+ (package
+ (name "python-veryprettytable")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "veryprettytable" version))
+ (sha256
+ (base32
+ "1k1rifz8x6qcicmx2is9vgxcj0qb2f5pvzrp7zhmvbmci3yack3f"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-termcolor" ,python-termcolor)))
+ (home-page
+ "https://github.com/smeggingsmegger/VeryPrettyTable")
+ (synopsis
+ "Visually appealing ASCII table output format for Python")
+ (description
+ "VeryPrettyTable is a Python library for displaying tabular data in a
+visually appealing ASCII or HTML table. Output is highly configurable,
+including text alignment, padding, borders, sort order, and more. Data can be
+inserted directly, read from a CSV file, or imported using a Python DB-API
+database cursor such as @code{sqlite3}.")
+ (license license:bsd-3)))
+
(define-public python2-humanfriendly
(let ((base (package-with-python2
(strip-python2-variant python-humanfriendly))))

base-commit: a916d50566e77ae730e34f1753ceb78cc6bf0a5a
--
2.33.0
From 5e99c1f791c990dd76cd63a9ab2a5196656c5c6f Mon Sep 17 00:00:00 2001
Message-Id: <5e99c1f791c990dd76cd63a9ab2a5196656c5c6f.1632277047.git.iskarian@mgsn.dev>
In-Reply-To: <e468a5f5722a31ce9999ddba43a8de120521a938.1632277047.git.iskarian@mgsn.dev>
References: <e468a5f5722a31ce9999ddba43a8de120521a938.1632277047.git.iskarian@mgsn.dev>
From: phodina <phodina@protonmail.com>
Date: Sat, 18 Sep 2021 12:45:04 +0000
Subject: [PATCH v4 2/2] gnu: Add python-pirate-get.

* gnu/packages/python-xyz.scm (python-pirate-get): New variable.
---
gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b1f162d079..86962e35b8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1820,6 +1820,34 @@ inserted directly, read from a CSV file, or imported using a Python DB-API
database cursor such as @code{sqlite3}.")
(license license:bsd-3)))
+(define-public python-pirate-get
+ (package
+ (name "python-pirate-get")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pirate-get" version))
+ (sha256
+ (base32
+ "07s5ss9dxccx1mip7pyga1fagywkqchxmzz55ng47ac9053ffxkq"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-pyperclip" ,python-pyperclip)
+ ("python-veryprettytable" ,python-veryprettytable)))
+ (home-page
+ "https://github.com/vikstrous/pirate-get")
+ (synopsis
+ "Command line interface for The Pirate Bay")
+ (description
+ "@code{pirate-get} is an unofficial command line interface for searching
+The Pirate Bay, inspired by @command{apt}. Results can be saved as JSON,
+@code{.torrent} files, or magnet links, or they can be opened directly in
+@command{transmission-remote}. @code{pirate-get} also supports searching
+mirrors or a local copy of The Pirate Bay's database.")
+ (license license:agpl3)))
+
(define-public python2-humanfriendly
(let ((base (package-with-python2
(strip-python2-variant python-humanfriendly))))
--
2.33.0
P
P
phodina wrote on 28 Sep 2021 00:41
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)(address . 49619@debbugs.gnu.org)
NVSWrjmeVSch6-txA4p00GDXnBCcrMtz5zt8l1Gmaj7BU4wXnC08eJQZ3yHMCcTtzOTePpvVtWWUD6VnB90Vesb2guwenPbjALbceuhWCQw=@protonmail.com
On Wednesday, September 22nd, 2021 at 5:21 AM, Sarah Morgensen <iskarian@mgsn.dev> wrote:

Toggle quote (48 lines)
> Hi,
>
> phodina phodina@protonmail.com writes:
>
> > Hi Sarah!
> >
> > Are these fixes now compliant to upstream the patch?
>
> It's pretty good. I went ahead and made a few changes (attached below):
>
> I tweaked the descriptions, I changed very-pretty-table to
>
> veryprettytable so the python importer can find it in the future, I
>
> changed pirate-get's propagated-inputs to inputs since it's an end-user
>
> package, and I changed the license of pirate-get to AGPL-3.
>
> - Package review checklist (WIP)
>
> Lack of a check is not proof of noncompliance.
>
> 1. [X] Package builds (guix build package)
>
> [X] x86_64 [ ] aarch64 [ ] armhf [ ] powerpc64le
>
> [ ] i686 [ ] i586 [ ] mips64le
> 2. [X] Build is reproducible (guix build --rounds=n package)
> 3. [X] Tests enabled (if available) or disabled with in-source comment
> 4. [X] No extraneous dependencies (guix size package)
> 5. [X] No unnecessary pre-built binaries/blobs
> 6. [X] Dependencies unvendored when available in Guix
> 7. [X] Cross-compile friendly (cc-for-target, patches with inputs)
> 8. [X] License matches source
> 9. [X] No problematic lints (guix lint package)
> 10. [X] Formatting follows guidelines
> - [X] Lines wrap at 80 characters
> - [X] Indentation passes etc/indent-code.el
> - [X] Two spaces used between sentences
>
> For new packages:
> 11. [X] Source url is robust
> - mirror:// used with url-fetch when possible
> - No auto-generated archives from source repo (prefer cloning)
> 12. [X] Synopsis is short, descriptive, and meaningful to a wide audience
> 13. [X] Description is objective, takes 5-10 lines, uses full sentences,
>

Thanks for the list! I'll follow it next time I'll submit a package or propose a change :-)
Toggle quote (9 lines)
> and provides the information users need to decide whether the
>
> software fits their needs.
>
> I also gave it a spin, and it works fine as long as the SSL_CERT_DIR
>
> environment variable is defined (I think that's beyond the scope of this
>

Well I also thought about the certificates but as you mentioned that's probably out of scope and it would be good to handle it by default in the build script so that we don't have to do it for the packages requiring network connectivity.
Toggle quote (4 lines)
> package). LGTM.
>
> Thanks for your work!

You're welcome. Guix is the exact distribution I've been looking for and porting tools I use is a nice way to get familiar with the Guile programming language and the ideas behind Guix (and Nix :)
Toggle quote (4 lines)
>
> --
>
> Sarah
P
P
phodina wrote on 8 Nov 2021 17:52
Re: [PATCH v3 2/2] gnu: Add python-pirate-get.
(address . 49619@debbugs.gnu.org)(name . Sarah Morgensen)(address . iskarian@mgsn.dev)
wSbMfisFjdxijtHEwxjB51bGHk4DYdNGN0oTmFDDrcGlvXYPodPiabUsy5gxa5SuLFQb6MHsLxI2FNbeXEWEWLDC4ksHyWXY9P_DhX0qqrU=@protonmail.com
Hi Sarah,

is there still something missing for upstreaming?

--
Kind Regards
Petr
P
P
phodina wrote on 30 Oct 2022 21:22
Upstream or close the ticket
nes0GJ47W_qRA-Z46_msG4REzB7pUywCaPovHhGKCl2RcqOyFVstPponD6wQqkweBy28NIJX1wFXI7ESQQaPcRdzM7o9MQjk5bzv2kBNBrU=@protonmail.com
Hi,

this ticket has been dormant for some time.

Is it technically all right and can it be upstreamed or should it be closed due to being tied to "non-libre" service?

----
Petr
Attachment: file
J
(name . phodina)(address . phodina@protonmail.com)
20221030172303.GB15447@dismail.de
On Sun, 30 Oct 2022 20:22:35 +0000 phodina <phodina@protonmail.com> wrote:
Toggle quote (3 lines)
> Is it technically all right and can it be upstreamed or should it be closed due to being tied to "non-libre" service?
>

The fact that this software interacts with a "non-libre" service/backend should not be a blocker for Guix.

all best,

jgart
P
P
phodina wrote on 25 Dec 2022 19:01
Upstream or close the ticket
(name . jgart)(address . jgart@dismail.de)
mpqyyeiOO-mbV6FvLI6WVnOLhTQ7ZisNcd_hQp6CuBxKtiLqGIMmaUVH0q2T4ITHfu8BGS6oxxo1htW-tBiwlkG20RM96h5i_MIVtkqQTxE=@protonmail.com
Hi Ludo’,

another ancient package that fell through :-)


----
Petr
?