(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Add pkg veryprettytable as a dependency for pkg pirate-get
---
Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d8c3fbec07..40b93c4b30 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1754,6 +1754,30 @@ helpers.")
(properties `((python2-variant . ,(delay python2-humanfriendly))))
(license license:expat)))
+(define-public python-veryprettytable
+ (package
+ (name "python-veryprettytable")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "veryprettytable" version))
+ (sha256
+ (base32
+ "1k1rifz8x6qcicmx2is9vgxcj0qb2f5pvzrp7zhmvbmci3yack3f"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-termcolor" ,python-termcolor)))
+ (home-page
+ "https://github.com/smeggingsmegger/VeryPrettyTable")
+ (synopsis
+ "A visually appealing ASCII table output format")
+ (description
+ "A simple Python library for easily displaying tabular data in a visually
+appealing ASCII table format")
+ (license license:bsd3)))
+
(define-public python2-humanfriendly
(let ((base (package-with-python2
(strip-python2-variant python-humanfriendly))))
--
2.31.1