(address . guix-patches@gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
* gnu/packages/audio.sm (invada-studio-plugins-lv2): New variable.
---
gnu/packages/audio.scm | 51 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 50 insertions(+), 1 deletion(-)
Toggle diff (68 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 70c06f54a1..c4141280dc 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5275,3 +5275,52 @@ Icecast server.")
generator, generating audio signals out of Linux's /dev/dsp audio
device. There is support for mono and/or stereo and 8 or 16 bit samples.")
(license license:gpl2)))
+
+(define-public invada-studio-plugins-lv2
+ (package
+ (name "invada-studio-plugins-lv2")
+ (version "1.3pre")
+ ;; Last release 1.2 is from 2009 and lacks required changes.
+ (source (origin
+ (method bzr-fetch)
+ (uri (bzr-reference
+ (url "lp:invada-studio")
+ (revision "108")))
+ (sha256
+ (base32
+ "05flf9b25z14380b54z47jvnbyilq24arm6jysk29zmxq28a6d3l"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases
+ %standard-phases
+ (delete 'configure) ; There is no configure script
+ (add-after 'unpack 'adjust-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ ;; Set proper LV2 plugin target
+ ;; directory:
+ (("/usr/local")
+ (assoc-ref outputs "out"))
+ ;; The default install target just
+ ;; prints a note about install-user and
+ ;; install-sys, the one we want:
+ (("install:") "install: install-sys"))
+ #t)))))
+ (inputs
+ `(("lv2" ,lv2)
+ ("gtk" ,gtk+-2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "LV2_PATH")
+ (files '("lib/lv2")))))
+ (home-page "https://launchpad.net/invada-studio/lv2")
+ (synopsis "Audio plug-in pack for LV2")
+ (description
+ "Invada Studio Plugins are LV2 audio plugins, including distortion, delay,
+compressor, filters, Phasers, early-reflections-based reverb, utility and test
+tone generator. ")
+ (license (list license:gpl2+ license:gpl2+))))
--
2.32.0