[PATCH] gnu: Add invada-studio-plugins-lv2.

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxime Devos
  • Thorsten Wilms
Owner
unassigned
Submitted by
Thorsten Wilms
Severity
normal
T
T
Thorsten Wilms wrote on 13 Jun 2021 21:25
(address . guix-patches@gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20210613192515.9046-1-t_w_@freenet.de
* gnu/packages/audio.sm (invada-studio-plugins-lv2): New variable.
---
gnu/packages/audio.scm | 51 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 50 insertions(+), 1 deletion(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 70c06f54a1..c4141280dc 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5275,3 +5275,52 @@ Icecast server.")
generator, generating audio signals out of Linux's /dev/dsp audio
device. There is support for mono and/or stereo and 8 or 16 bit samples.")
(license license:gpl2)))
+
+(define-public invada-studio-plugins-lv2
+ (package
+ (name "invada-studio-plugins-lv2")
+ (version "1.3pre")
+ ;; Last release 1.2 is from 2009 and lacks required changes.
+ (source (origin
+ (method bzr-fetch)
+ (uri (bzr-reference
+ (url "lp:invada-studio")
+ (revision "108")))
+ (sha256
+ (base32
+ "05flf9b25z14380b54z47jvnbyilq24arm6jysk29zmxq28a6d3l"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases
+ %standard-phases
+ (delete 'configure) ; There is no configure script
+ (add-after 'unpack 'adjust-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ ;; Set proper LV2 plugin target
+ ;; directory:
+ (("/usr/local")
+ (assoc-ref outputs "out"))
+ ;; The default install target just
+ ;; prints a note about install-user and
+ ;; install-sys, the one we want:
+ (("install:") "install: install-sys"))
+ #t)))))
+ (inputs
+ `(("lv2" ,lv2)
+ ("gtk" ,gtk+-2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "LV2_PATH")
+ (files '("lib/lv2")))))
+ (home-page "https://launchpad.net/invada-studio/lv2")
+ (synopsis "Audio plug-in pack for LV2")
+ (description
+ "Invada Studio Plugins are LV2 audio plugins, including distortion, delay,
+compressor, filters, Phasers, early-reflections-based reverb, utility and test
+tone generator. ")
+ (license (list license:gpl2+ license:gpl2+))))
--
2.32.0
T
T
Thorsten Wilms wrote on 26 Oct 2021 14:40
[PATCH v2] gnu: Add invada-studio-plugins-lv2.
(address . 49008@debbugs.gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20211026124050.11299-1-t_w_@freenet.de
* gnu/packages/audio.scm (invada-studio-plugins-lv2): New Varaible.
---
gnu/packages/audio.scm | 45 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 44 insertions(+), 1 deletion(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index faf106fc68..62e8a0532a 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018. 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5566,3 +5566,46 @@ (define-public mda-lv2
"MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and a few
instrument plugins.")
(license license:gpl3+)))
+
+(define-public invada-studio-plugins-lv2
+ (package
+ (name "invada-studio-plugins-lv2")
+ (version "1.3pre")
+ ;; Last release 1.2 is from 2009 and lacks required changes.
+ (source (origin
+ (method bzr-fetch)
+ (uri (bzr-reference
+ (url "lp:invada-studio")
+ (revision "108")))
+ (sha256
+ (base32
+ "05flf9b25z14380b54z47jvnbyilq24arm6jysk29zmxq28a6d3l"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases
+ %standard-phases
+ (delete 'configure) ; There is no configure script
+ (add-after 'unpack 'adjust-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ ;; Set proper LV2 plugin target directory:
+ (("/usr/local")
+ (assoc-ref outputs "out"))
+ ;; The default install target just prints a note about
+ ;; install-user and install-sys, the one we want:
+ (("install:") "install: install-sys"))
+ #t)))))
+ (inputs
+ `(("lv2" ,lv2)
+ ("gtk" ,gtk+-2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://launchpad.net/invada-studio/lv2")
+ (synopsis "LV2 audio plugin collection.")
+ (description
+ "Invada Studio Plugins are LV2 audio plugins, including distortion, delay,
+compressor, filters, Phasers, early-reflections-based reverb, utility and test
+tone generator. ")
+ (license (list license:gpl2+ license:gpl2+))))
--
2.33.1
M
M
Maxime Devos wrote on 23 Apr 2022 14:45
Re: bug#55069: Add some means to find LV2 plugins
12b95f88fd08ad5d5ca4ab8ce07eac9a8015501e.camel@telenet.be
Toggle quote (2 lines)
> [PATCH] gnu: mda-lv2: Remove unnecessary search-path-specification.

Isn't it currently necessary? Because lv2 doesn't have a LV2_PATH
search path yet.

Nathan Dehnel schreef op vr 22-04-2022 om 17:13 [-0500]:
Toggle quote (4 lines)
> It seems DAWs and plugins can't find each other because there is no
> way to find the plugins outside of the store because there is no
> directory where the plugins are aggregated, and $LV2_PATH isn't set.

I think this would be resolved by adding the search path to the 'lv2'
package (and removing it from lv2-mda-piano, mda-lv2 and calf).

Toggle quote (5 lines)
> [PATCH] gnu: Add invada-studio-plugins-lv2.
> [PATCH] gnu: Add distrho-ports-lv2.
> [PATCH] gnu: Add omins-lv2.
> [PATCH] Add drumgizmo

The convention is to add the search paths to the users of the plugins,
not the plugins theirselves. Cf. GUILE_LOAD_PATH, LIBRARY_PATH,
MINETEST_MOD_PATH, EMACSLOADPATH, INFOPATH ... See

The benefit is that this avoids forgetting LV2_PATH for some plugins,
as it only needs to be added to relatively few places (lv2 itself,
maybe guitarix, maybe ir, arour ...).

Greetings,
Maxime
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYmP1AhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7h+eAP49mWmaho4w9vOh+7fFYDXFvQD1
KG3WRZSoOgbk/eEjFQD/Z2mBpR/uc2eFo+5y/S+/+wh/TVNHXtWJffrmesex7AQ=
=rtun
-----END PGP SIGNATURE-----


?