(address . guix-patches@gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
* gnu/packages/audio.scm (omins-lv2): New variable.
---
gnu/packages/audio.scm | 38 +++++++++++++++++++++++++++++++++++++-
1 file changed, 37 insertions(+), 1 deletion(-)
Toggle diff (55 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3939d4bc7e..8eceb839ad 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5410,3 +5410,39 @@ device. There is support for mono and/or stereo and 8 or 16 bit samples.")
"MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and a few
instrument plugins.")
(license license:gpl3+)))
+
+(define-public omins-lv2
+ (package
+ (name "omins-lv2")
+ ;; No release despite being perfectly usable. 0.0.0 seems to be the only
+ ;; version the author ever specified:
+ (version "0.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+ (commit "058f341053067b69a84d4081107fda5058290ff9")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01hnx4hhbz3ap3bw15s42q4q1mw1mhdjwygq4550wvjfg6k4ga8w"))))
+ (build-system waf-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:configure-flags
+ (list (string-append "--prefix="
+ (assoc-ref %outputs "out")))))
+ (inputs
+ `(("lv2" ,lv2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "LV2_PATH")
+ (files '("lib/lv2")))))
+ (home-page "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+ (synopsis "LV2 audio plugins for modular synthesis")
+ (description
+ "Omins-lv2 is a small collection of LV2 audio plugins for modular synthesis.")
+ (license (list license:gpl2+ license:gpl2+))))
--
2.32.0