[PATCH] gnu: Add omins-lv2.

  • Done
  • quality assurance status badge
Details
4 participants
  • Sarah Morgensen
  • Ludovic Courtès
  • Ricardo Wurmus
  • Thorsten Wilms
Owner
unassigned
Submitted by
Thorsten Wilms
Severity
normal
T
T
Thorsten Wilms wrote on 12 Jul 2021 11:45
(address . guix-patches@gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20210712094506.6432-1-t_w_@freenet.de
* gnu/packages/audio.scm (omins-lv2): New variable.
---
gnu/packages/audio.scm | 38 +++++++++++++++++++++++++++++++++++++-
1 file changed, 37 insertions(+), 1 deletion(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3939d4bc7e..8eceb839ad 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5410,3 +5410,39 @@ device. There is support for mono and/or stereo and 8 or 16 bit samples.")
"MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and a few
instrument plugins.")
(license license:gpl3+)))
+
+(define-public omins-lv2
+ (package
+ (name "omins-lv2")
+ ;; No release despite being perfectly usable. 0.0.0 seems to be the only
+ ;; version the author ever specified:
+ (version "0.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+ (commit "058f341053067b69a84d4081107fda5058290ff9")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01hnx4hhbz3ap3bw15s42q4q1mw1mhdjwygq4550wvjfg6k4ga8w"))))
+ (build-system waf-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:configure-flags
+ (list (string-append "--prefix="
+ (assoc-ref %outputs "out")))))
+ (inputs
+ `(("lv2" ,lv2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "LV2_PATH")
+ (files '("lib/lv2")))))
+ (home-page "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+ (synopsis "LV2 audio plugins for modular synthesis")
+ (description
+ "Omins-lv2 is a small collection of LV2 audio plugins for modular synthesis.")
+ (license (list license:gpl2+ license:gpl2+))))
--
2.32.0
S
S
Sarah Morgensen wrote on 22 Jul 2021 06:15
(name . Thorsten Wilms)(address . t_w_@freenet.de)(address . 49533@debbugs.gnu.org)
86fsw7rnln.fsf@mgsn.dev
Hello,

Thanks for the patch. Just a quick comment...

Thorsten Wilms <t_w_@freenet.de> writes:

Toggle quote (46 lines)
> * gnu/packages/audio.scm (omins-lv2): New variable.
> ---
> gnu/packages/audio.scm | 38 +++++++++++++++++++++++++++++++++++++-
> 1 file changed, 37 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index 3939d4bc7e..8eceb839ad 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -15,7 +15,7 @@
> ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
> ;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
> ;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
> -;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
> +;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
> ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
> ;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
> ;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
> @@ -5410,3 +5410,39 @@ device. There is support for mono and/or stereo and 8 or 16 bit samples.")
> "MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and a few
> instrument plugins.")
> (license license:gpl3+)))
> +
> +(define-public omins-lv2
> + (package
> + (name "omins-lv2")
> + ;; No release despite being perfectly usable. 0.0.0 seems to be the only
> + ;; version the author ever specified:
> + (version "0.0.0")
> + (source
> + (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
> + (commit "058f341053067b69a84d4081107fda5058290ff9")))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "01hnx4hhbz3ap3bw15s42q4q1mw1mhdjwygq4550wvjfg6k4ga8w"))))
> + (build-system waf-build-system)
> + (arguments
> + `(#:tests? #f ; There are no tests.
> + #:configure-flags
> + (list (string-append "--prefix="
> + (assoc-ref %outputs "out")))))

Setting --prefix shouldn't be necessary, as the build systems usually
add that themselves. (And yep, just tried building without it, and the
outputs are identical.)

Toggle quote (14 lines)
> + (inputs
> + `(("lv2" ,lv2)))
> + (native-inputs
> + `(("pkg-config" ,pkg-config)))
> + (native-search-paths
> + (list (search-path-specification
> + (variable "LV2_PATH")
> + (files '("lib/lv2")))))
> + (home-page "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
> + (synopsis "LV2 audio plugins for modular synthesis")
> + (description
> + "Omins-lv2 is a small collection of LV2 audio plugins for modular synthesis.")
> + (license (list license:gpl2+ license:gpl2+))))

--
Sarah
T
T
Thorsten Wilms wrote on 24 Jul 2021 21:41
[PATCH v2] gnu: Add omins-lv2.
(address . 49533@debbugs.gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20210724194117.8372-1-t_w_@freenet.de
* gnu/packages/audio.scm (omins-lv2): New variable.
---
Thanks to Sarah for having a look and noticing the superfluous --prefix.

gnu/packages/audio.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3939d4bc7e..b5471c9d3d 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5410,3 +5410,36 @@ device. There is support for mono and/or stereo and 8 or 16 bit samples.")
"MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and a few
instrument plugins.")
(license license:gpl3+)))
+
+(define-public omins-lv2
+ (package
+ (name "omins-lv2")
+ ;; No release despite being perfectly usable. 0.0.0 seems to be the only
+ ;; version the author ever specified:
+ (version "0.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+ (commit "058f341053067b69a84d4081107fda5058290ff9")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01hnx4hhbz3ap3bw15s42q4q1mw1mhdjwygq4550wvjfg6k4ga8w"))))
+ (build-system waf-build-system)
+ (arguments
+ `(#:tests? #f)) ; There are no tests.
+ (inputs
+ `(("lv2" ,lv2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "LV2_PATH")
+ (files '("lib/lv2")))))
+ (home-page "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+ (synopsis "LV2 audio plugins for modular synthesis")
+ (description
+ "Omins-lv2 is a small collection of LV2 audio plugins for modular synthesis.")
+ (license (list license:gpl2+ license:gpl2+))))
--
2.32.0
L
L
Ludovic Courtès wrote on 29 Jul 2021 21:53
Re: bug#49533: [PATCH] gnu: Add omins-lv2.
(name . Thorsten Wilms)(address . t_w_@freenet.de)
874kcc28xz.fsf_-_@gnu.org
Hi Thorsten,

Thorsten Wilms <t_w_@freenet.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/audio.scm (omins-lv2): New variable.

It LGTM, modulo minor issues:

Toggle quote (4 lines)
> +(define-public omins-lv2
> + (package
> + (name "omins-lv2")

Please consider passing it through ./etc/indent-code.el:


Toggle quote (11 lines)
> + ;; No release despite being perfectly usable. 0.0.0 seems to be the only
> + ;; version the author ever specified:
> + (version "0.0.0")
> + (source
> + (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
> + (commit "058f341053067b69a84d4081107fda5058290ff9")))

Please check out
to compute version numbers in such cases.

Toggle quote (5 lines)
> + (native-search-paths
> + (list (search-path-specification
> + (variable "LV2_PATH")
> + (files '("lib/lv2")))))

I’m surprised this is here (in the plugin) rather than in the package
that loads this plugin. There are other LV2 plugins doing that though.
Ricardo, WDYT?

Toggle quote (2 lines)
> + (license (list license:gpl2+ license:gpl2+))))

(license license:gpl2+) should be enough. :-)

Could you send an updated patch?

Thank you, and thanks, Sarah!

Ludo’.
L
L
Ludovic Courtès wrote on 1 Sep 2021 23:29
(name . Thorsten Wilms)(address . t_w_@freenet.de)
87y28g56j5.fsf_-_@gnu.org
Hi Thorsten,

Did you have a chance to look into this?

Thanks,
Ludo’.

Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (49 lines)
> Hi Thorsten,
>
> Thorsten Wilms <t_w_@freenet.de> skribis:
>
>> * gnu/packages/audio.scm (omins-lv2): New variable.
>
> It LGTM, modulo minor issues:
>
>> +(define-public omins-lv2
>> + (package
>> + (name "omins-lv2")
>
> Please consider passing it through ./etc/indent-code.el:
>
> https://guix.gnu.org/manual/en/html_node/Formatting-Code.html
>
>> + ;; No release despite being perfectly usable. 0.0.0 seems to be the only
>> + ;; version the author ever specified:
>> + (version "0.0.0")
>> + (source
>> + (origin
>> + (method git-fetch)
>> + (uri
>> + (git-reference
>> + (url "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
>> + (commit "058f341053067b69a84d4081107fda5058290ff9")))
>
> Please check out
> <https://guix.gnu.org/manual/en/html_node/Version-Numbers.html> on how
> to compute version numbers in such cases.
>
>> + (native-search-paths
>> + (list (search-path-specification
>> + (variable "LV2_PATH")
>> + (files '("lib/lv2")))))
>
> I’m surprised this is here (in the plugin) rather than in the package
> that loads this plugin. There are other LV2 plugins doing that though.
> Ricardo, WDYT?
>
>> + (license (list license:gpl2+ license:gpl2+))))
>
> (license license:gpl2+) should be enough. :-)
>
> Could you send an updated patch?
>
> Thank you, and thanks, Sarah!
>
> Ludo’.
R
R
Ricardo Wurmus wrote on 2 Sep 2021 09:56
(name . Ludovic Courtès)(address . ludo@gnu.org)
87bl5b8l6r.fsf@elephly.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (11 lines)
>> + (native-search-paths
>> + (list (search-path-specification
>> + (variable "LV2_PATH")
>> + (files '("lib/lv2")))))
>
> I’m surprised this is here (in the plugin) rather than in the
> package
> that loads this plugin. There are other LV2 plugins doing that
> though.
> Ricardo, WDYT?

Yes, this looks wrong.

Plugins don’t need to set LV2_PATH; only hosts (such as Ardour,
jalv, and others) do. This must have been an early mistake that
has been copied for other plugins. None of the LV2 hosts that we
offer set LV2_PATH.

--
Ricardo
T
T
Thorsten Wilms wrote on 2 Sep 2021 10:03
(name . Ludovic Courtès)(address . ludo@gnu.org)
20210902100352.f45c5862e26068aea3467248@freenet.de
On Wed, 01 Sep 2021 23:29:18 +0200
Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (2 lines)
> Did you have a chance to look into this?

Hi Ludovic, I missed to notice your earlier email. Thanks for it and
this reminder!


Toggle quote (4 lines)
> > Please consider passing it through ./etc/indent-code.el:
> >
> > https://guix.gnu.org/manual/en/html_node/Formatting-Code.html

I assumed Emacs would do the right thing as is. My guix-installed Emacs
does not offer a guix-devel-mode. There’s also no ./etc/indent-code.el
on this foreign distro.


Toggle quote (4 lines)
> > Please check out
> > <https://guix.gnu.org/manual/en/html_node/Version-Numbers.html> on
> > how to compute version numbers in such cases.

Done. Assuming the very last example shows the pattern to use, I
suspect that there are a lot of packages that should, but do not use
it. At least in audio.scm.


Toggle quote (9 lines)
> >> + (native-search-paths
> >> + (list (search-path-specification
> >> + (variable "LV2_PATH")
> >> + (files '("lib/lv2")))))
> >
> > I’m surprised this is here (in the plugin) rather than in the
> > package that loads this plugin. There are other LV2 plugins doing
> > that though. Ricardo, WDYT?

I mean to recall that this was necessary for the first lv2 package I
wrote, but from then on, I may have been cargo-culting. Since my
lilv and sord are still broken, no lv2-host will run. So I can’t even
test this now.


Toggle quote (4 lines)
> >> + (license (list license:gpl2+ license:gpl2+))))
> >
> > (license license:gpl2+) should be enough. :-)

Sheesh, I did it again!

New patch version follows in separate email.


Thanks!

--
Thorsten Wilms <t_w_@freenet.de>
T
T
Thorsten Wilms wrote on 2 Sep 2021 10:56
[PATCH v3] gnu: Add omins-lv2.
(address . 49533@debbugs.gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20210902085647.6272-1-t_w_@freenet.de
* gnu/packages/audio.scm (omins-lv2): New variable.
---
gnu/packages/audio.scm | 33 ++++++++++++++++++++++++++++++++-
1 file changed, 32 insertions(+), 1 deletion(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 80cd521773..d135bfdf3d 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5410,3 +5410,34 @@ device. There is support for mono and/or stereo and 8 or 16 bit samples.")
"MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and a few
instrument plugins.")
(license license:gpl3+)))
+
+(define-public omins-lv2
+ (let ((commit "058f341053067b69a84d4081107fda5058290ff9")
+ (revision "1"))
+ (package
+ (name "omins-lv2")
+ ;; No release despite being perfectly usable. 0.0.0 seems to be the only
+ ;; version the author ever specified:
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01hnx4hhbz3ap3bw15s42q4q1mw1mhdjwygq4550wvjfg6k4ga8w"))))
+ (build-system waf-build-system)
+ (arguments
+ `(#:tests? #f)) ; There are no tests.
+ (inputs
+ `(("lv2" ,lv2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+ (synopsis "LV2 audio plugins for modular synthesis")
+ (description
+ "Omins-lv2 is a small collection of LV2 audio plugins for modular synthesis.")
+ (license license:gpl2+))))
--
2.33.0
L
L
Ludovic Courtès wrote on 2 Sep 2021 11:45
Re: bug#49533: [PATCH] gnu: Add omins-lv2.
(name . Thorsten Wilms)(address . t_w_@freenet.de)
87bl5b5mzt.fsf@gnu.org
Hi!

Thorsten Wilms <t_w_@freenet.de> skribis:

Toggle quote (3 lines)
> On Wed, 01 Sep 2021 23:29:18 +0200
> Ludovic Courtès <ludo@gnu.org> wrote:

[...]

Toggle quote (8 lines)
>> > Please consider passing it through ./etc/indent-code.el:
>> >
>> > https://guix.gnu.org/manual/en/html_node/Formatting-Code.html
>
> I assumed Emacs would do the right thing as is. My guix-installed Emacs
> does not offer a guix-devel-mode. There’s also no ./etc/indent-code.el
> on this foreign distro.

‘guix-devel-mode’ is part of the ‘emacs-guix’ package (aka. guix.el).
(If you have that, you don’t need indent-code.el, which is itself in the
Guix source tree.)

Thanks,
Ludo’.
T
T
Thorsten Wilms wrote on 26 Oct 2021 14:47
[PATCH v4] gnu: Add omins-lv2.
(address . 49533@debbugs.gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20211026124702.11400-1-t_w_@freenet.de
* gnu/packages/audio.scm (omins-lv2): New Variable.
---
This time with indentation via guix-devel-mode.

gnu/packages/audio.scm | 33 ++++++++++++++++++++++++++++++++-
1 file changed, 32 insertions(+), 1 deletion(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index faf106fc68..425af448a0 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5566,3 +5566,34 @@ (define-public mda-lv2
"MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and a few
instrument plugins.")
(license license:gpl3+)))
+
+(define-public omins-lv2
+ (let ((commit "058f341053067b69a84d4081107fda5058290ff9")
+ (revision "1"))
+ (package
+ (name "omins-lv2")
+ ;; No release despite being perfectly usable. 0.0.0 seems to be the only
+ ;; version the author ever specified:
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01hnx4hhbz3ap3bw15s42q4q1mw1mhdjwygq4550wvjfg6k4ga8w"))))
+ (build-system waf-build-system)
+ (arguments
+ `(#:tests? #f)) ; There are no tests.
+ (inputs
+ `(("lv2" ,lv2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+ (synopsis "LV2 audio plugins for modular synthesis")
+ (description
+ "Omins-lv2 is a small collection of LV2 audio plugins for modular synthesis.")
+ (license license:gpl2+))))
--
2.33.1
R
R
Ricardo Wurmus wrote on 25 Feb 13:15 +0100
[PATCH] gnu: Add omins-lv2.
(address . 49533-done@debbugs.gnu.org)
87sf1gzqlk.fsf@elephly.net
I'm sorry for the long delay.

I adjusted the package definition and pushed to the master branch with
commit 386080366c642d887f9156059e4e894cd2d4e9b1.

--
Ricardo
Closed
?