[PATCH 0/2] icecat, icedove: Add U2F and WebAuthn support

  • Done
  • quality assurance status badge
Details
3 participants
  • Brice Waegeneire
  • Jonathan Brielmaier
  • Mark H Weaver
Owner
unassigned
Submitted by
Brice Waegeneire
Severity
normal
Merged with
B
B
Brice Waegeneire wrote on 12 Jun 2021 23:16
(address . guix-patches@gnu.org)
20210612211630.10339-1-brice@waegenei.re
This patch set closes https://issues.guix.gnu.org/45613and

Brice Waegeneire (2):
gnu: icecat: Add WebAuthn support.
gnu: icedove: Add WebAuthn support.

gnu/packages/gnuzilla.scm | 24 +++++++++++++++---------
1 file changed, 15 insertions(+), 9 deletions(-)

--
2.31.1
B
B
Brice Waegeneire wrote on 12 Jun 2021 23:19
[PATCH 2/2] gnu: icedove: Add WebAuthn support.
(address . guix-patches@gnu.org)
20210612211931.11736-2-brice@waegenei.re
* gnu/packages/gnuzilla.scm (icedove)[inputs]: Add eudev.
[phases]: Add eudev to the wrapper.
---
gnu/packages/gnuzilla.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 6255d56f16..a6f0e61b12 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1541,10 +1541,12 @@ standards of the IceCat project.")
(gtk (assoc-ref inputs "gtk+"))
(gtk-share (string-append gtk "/share"))
(pulseaudio (assoc-ref inputs "pulseaudio"))
- (pulseaudio-lib (string-append pulseaudio "/lib")))
+ (pulseaudio-lib (string-append pulseaudio "/lib"))
+ (eudev (assoc-ref inputs "eudev"))
+ (eudev-lib (string-append eudev "/lib")))
(wrap-program (car (find-files lib "^icedove$"))
`("XDG_DATA_DIRS" prefix (,gtk-share))
- `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib)))
+ `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib ,eudev-lib)))
#t))))))
(inputs
`(("bzip2" ,bzip2)
@@ -1580,6 +1582,7 @@ standards of the IceCat project.")
("pulseaudio" ,pulseaudio)
("sqlite" ,sqlite)
("startup-notification" ,startup-notification)
+ ("eudev" ,eudev)
("unzip" ,unzip)
("zip" ,zip)
("zlib" ,zlib)))
--
2.31.1
B
B
Brice Waegeneire wrote on 12 Jun 2021 23:19
[PATCH 1/2] gnu: icecat: Add WebAuthn support.
(address . guix-patches@gnu.org)
20210612211931.11736-1-brice@waegenei.re
* gnu/packages/gnuzilla.scm (icecat)[inputs]: Add eudev.
[phases]: Add eudev to the wrapper.
---
gnu/packages/gnuzilla.scm | 17 ++++++++++-------
1 file changed, 10 insertions(+), 7 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index c63809c20c..6255d56f16 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2019, 2020 Adrian Malacoda <malacoda@monarch-pass.net>
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -910,6 +911,7 @@ from forcing GEXP-PROMISE."
;; UNBUNDLE-ME! ("nss" ,nss)
("shared-mime-info" ,shared-mime-info)
;; UNBUNDLE-ME! ("sqlite" ,sqlite)
+ ("eudev" ,eudev)
("unzip" ,unzip)
("zip" ,zip)
;; UNBUNDLE-ME! ("zlib" ,zlib)
@@ -1271,19 +1273,20 @@ from forcing GEXP-PROMISE."
(lib (string-append out "/lib"))
(gtk (assoc-ref inputs "gtk+"))
(gtk-share (string-append gtk "/share"))
- (mesa (assoc-ref inputs "mesa"))
- (mesa-lib (string-append mesa "/lib"))
- (pulseaudio (assoc-ref inputs "pulseaudio"))
- (pulseaudio-lib (string-append pulseaudio "/lib"))
- (libxscrnsaver (assoc-ref inputs "libxscrnsaver"))
- (libxscrnsaver-lib (string-append libxscrnsaver "/lib")))
+ (ld-libs (map (lambda (lib)
+ (string-append (assoc-ref inputs lib)
+ "/lib"))
+ '("libxscrnsaver"
+ "mesa"
+ "udev"
+ "pulseaudio"))))
(wrap-program (car (find-files lib "^icecat$"))
`("XDG_DATA_DIRS" prefix (,gtk-share))
;; The following line is commented out because the icecat
;; package on guix has been observed to be unstable when
;; using wayland, and the bundled extensions stop working.
;; `("MOZ_ENABLE_WAYLAND" = ("1"))
- `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib ,mesa-lib ,libxscrnsaver-lib)))
+ `("LD_LIBRARY_PATH" prefix ,ld-libs))
#t))))))
(home-page "https://www.gnu.org/software/gnuzilla/")
(synopsis "Entirely free browser derived from Mozilla Firefox")
--
2.31.1
J
J
Jonathan Brielmaier wrote on 13 Jun 2021 00:09
Re: [bug#48980] [PATCH 2/2] gnu: icedove: Add WebAuthn support.
(address . guix-patches@gnu.org)
43c38e66-a37b-a781-280c-cbe591250449@web.de
Hi Brice,

does Webauthn have any use case in Thunderbird? do you use it?

Am 12.06.21 um 23:19 schrieb Brice Waegeneire:
Toggle quote (2 lines)
> * gnu/packages/gnuzilla.scm (icedove)[inputs]: Add eudev.
> [phases]: Add eudev to the wrapper.
B
B
Brice Waegeneire wrote on 13 Jun 2021 09:51
Re: bug#48980: [PATCH 0/2] icecat, icedove: Add U2F and WebAuthn support
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 48980@debbugs.gnu.org)
877diyfbii.fsf_-_@waegenei.re
Hello Jonathan,

Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:

Toggle quote (2 lines)
> does Webauthn have any use case in Thunderbird? do you use it?

I don't need U2F support in Icecdove. Before working on this patch I too
didn't knew Icedove was missing U2F support. But glanccing at nixpkgs
repo I have found a closed bug¹ about that; there you can see someone
needed two factor authorization to login into its account.


Cheers,
- Brice
B
B
Brice Waegeneire wrote on 20 Jun 2021 11:32
[PATCH v2 1/2] gnu: icecat: Add WebAuthn support.
(address . 48980@debbugs.gnu.org)
20210620093222.3519-1-brice@waegenei.re
* gnu/packages/gnuzilla.scm (icecat)[inputs]: Add eudev.
[phases]: Add eudev to the wrapper.
---
gnu/packages/gnuzilla.scm | 23 +++++++++++------------
1 file changed, 11 insertions(+), 12 deletions(-)

Rebased.

Toggle diff (56 lines)
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index a997fc1c73..84feab777e 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2019, 2020 Adrian Malacoda <malacoda@monarch-pass.net>
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -910,6 +911,7 @@ from forcing GEXP-PROMISE."
;; UNBUNDLE-ME! ("nss" ,nss)
("shared-mime-info" ,shared-mime-info)
;; UNBUNDLE-ME! ("sqlite" ,sqlite)
+ ("eudev" ,eudev)
("unzip" ,unzip)
("zip" ,zip)
;; UNBUNDLE-ME! ("zlib" ,zlib)
@@ -1271,24 +1273,21 @@ from forcing GEXP-PROMISE."
(lib (string-append out "/lib"))
(gtk (assoc-ref inputs "gtk+"))
(gtk-share (string-append gtk "/share"))
- (mesa (assoc-ref inputs "mesa"))
- (mesa-lib (string-append mesa "/lib"))
- (pulseaudio (assoc-ref inputs "pulseaudio"))
- (pulseaudio-lib (string-append pulseaudio "/lib"))
- (libxscrnsaver (assoc-ref inputs "libxscrnsaver"))
- (libxscrnsaver-lib (string-append libxscrnsaver "/lib"))
- (mit-krb5 (assoc-ref inputs "mit-krb5"))
- (mit-krb5-lib (string-append mit-krb5 "/lib")))
+ (ld-libs (map (lambda (lib)
+ (string-append (assoc-ref inputs lib)
+ "/lib"))
+ '("libxscrnsaver"
+ "mesa"
+ "mit-krb5"
+ "udev"
+ "pulseaudio"))))
(wrap-program (car (find-files lib "^icecat$"))
`("XDG_DATA_DIRS" prefix (,gtk-share))
;; The following line is commented out because the icecat
;; package on guix has been observed to be unstable when
;; using wayland, and the bundled extensions stop working.
;; `("MOZ_ENABLE_WAYLAND" = ("1"))
- `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib
- ,mesa-lib
- ,libxscrnsaver-lib
- ,mit-krb5-lib)))
+ `("LD_LIBRARY_PATH" prefix ,ld-libs))
#t))))))
(home-page "https://www.gnu.org/software/gnuzilla/")
(synopsis "Entirely free browser derived from Mozilla Firefox")
--
2.31.1
B
B
Brice Waegeneire wrote on 20 Jun 2021 11:32
[PATCH v2 2/2] gnu: icedove: Add WebAuthn support.
(address . 48980@debbugs.gnu.org)
20210620093222.3519-2-brice@waegenei.re
* gnu/packages/gnuzilla.scm (icedove)[inputs]: Add eudev.
[phases]: Add eudev to the wrapper.
---
gnu/packages/gnuzilla.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 84feab777e..053d4f1822 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1542,10 +1542,12 @@ standards of the IceCat project.")
(gtk (assoc-ref inputs "gtk+"))
(gtk-share (string-append gtk "/share"))
(pulseaudio (assoc-ref inputs "pulseaudio"))
- (pulseaudio-lib (string-append pulseaudio "/lib")))
+ (pulseaudio-lib (string-append pulseaudio "/lib"))
+ (eudev (assoc-ref inputs "eudev"))
+ (eudev-lib (string-append eudev "/lib")))
(wrap-program (car (find-files lib "^icedove$"))
`("XDG_DATA_DIRS" prefix (,gtk-share))
- `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib)))
+ `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib ,eudev-lib)))
#t))))))
(inputs
`(("bzip2" ,bzip2)
@@ -1581,6 +1583,7 @@ standards of the IceCat project.")
("pulseaudio" ,pulseaudio)
("sqlite" ,sqlite)
("startup-notification" ,startup-notification)
+ ("eudev" ,eudev)
("unzip" ,unzip)
("zip" ,zip)
("zlib" ,zlib)))
--
2.31.1
J
J
Jonathan Brielmaier wrote on 23 Jun 2021 23:09
[PATCH 0/2] icecat, icedove: Add U2F and WebAuthn support
(address . 48980@debbugs.gnu.org)
b4b431c7-fd63-0165-295b-86ed4ce91789@web.de
I pushed the icedove patch as a807d849219c34d45310634ef0cfc94ad9b7025a,
for the icecat one I would wait on Marks opinion...
B
B
Brice Waegeneire wrote on 3 Jul 2021 17:55
(address . mhw@netris.org)
87k0m7xugh.fsf_-_@waegenei.re
Hello Mark,

Could you take a look at this patch adding U2F support to icecat ?

Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:

Toggle quote (3 lines)
> I pushed the icedove patch as a807d849219c34d45310634ef0cfc94ad9b7025a,
> for the icecat one I would wait on Marks opinion...

Cheers,
- Brice
M
M
Mark H Weaver wrote on 3 Jul 2021 19:18
(name . Brice Waegeneire)(address . brice@waegenei.re)
87tulbgvs1.fsf@netris.org
Hi Brice,

Brice Waegeneire <brice@waegenei.re> writes:
Toggle quote (2 lines)
> Could you take a look at this patch adding U2F support to icecat ?

Thanks for this, but I see a problem. The new input has key "eudev":

Toggle quote (9 lines)
> @@ -910,6 +911,7 @@ from forcing GEXP-PROMISE."
> ;; UNBUNDLE-ME! ("nss" ,nss)
> ("shared-mime-info" ,shared-mime-info)
> ;; UNBUNDLE-ME! ("sqlite" ,sqlite)
> + ("eudev" ,eudev)
> ("unzip" ,unzip)
> ("zip" ,zip)
> ;; UNBUNDLE-ME! ("zlib" ,zlib)

but the code added to the 'wrap-program' phase looks for key "udev":

Toggle quote (9 lines)
> + (ld-libs (map (lambda (lib)
> + (string-append (assoc-ref inputs lib)
> + "/lib"))
> + '("libxscrnsaver"
> + "mesa"
> + "mit-krb5"
> + "udev"
> + "pulseaudio"))))

I don't see how this can work. Did you test it?

Regards,
Mark

--
Disinformation flourishes because many people care deeply about injustice
but very few check the facts. Ask me about https://stallmansupport.org.
B
B
Brice Waegeneire wrote on 6 Jul 2021 06:23
control message for bug #49362
(address . control@debbugs.gnu.org)
E1m0ccY-0006w0-FL@debbugs.gnu.org
merge 49362 48980
quit
?