`guix install mes` fails in 'check'-phase

  • Done
  • quality assurance status badge
Details
3 participants
  • Ekaitz Zarraga
  • Gabriel Wicki
  • Ludovic Courtès
Owner
unassigned
Submitted by
Gabriel Wicki
Severity
normal
Merged with
G
G
Gabriel Wicki wrote on 23 May 2021 00:11
(address . bug-guix@gnu.org)
20210522221133.zu2pqmuzdxuta364@silver
i tried running `guix install mes` which fails on my x86_64 debian
machine. CI fails as well

log output shows a couple of segmentation faults and an undefined
variable in phase 'check':

test/test10/hello.sh
+ '[' amd64 = amd64 ']'
+ ./test/results/test1-binary
+ . ./sha256.sh
++ set -ex
test/test1/hello.sh: line 37: 171 Segmentation fault ./test/results/test1-binary < test/test1/hex0.hex0 > test/test1/proof1
+ '[' amd64 = x86 ']'
+ exit 0
make: *** [makefile:104: test1-binary] Error 139
[...]
test/test7/hello.sh: line 31: 175 Segmentation fault ./test/results/test7-binary test/test7/hex1.hex1 > test/test7/proof
[...]
test/test3/hello.sh: line 23: GET_MACHINE_FLAGS: unbound variable
L
L
Ludovic Courtès wrote on 13 Jun 2021 14:52
(name . Gabriel Wicki)(address . gabriel@erlikon.ch)
87a6nu0vvq.fsf@gnu.org
Hi,

(Cc: Janneke.)

Gabriel Wicki <gabriel@erlikon.ch> skribis:

Toggle quote (21 lines)
> i tried running `guix install mes` which fails on my x86_64 debian
> machine. CI fails as well
> (https://ci.guix.gnu.org/build/286577/details).
>
> log output shows a couple of segmentation faults and an undefined
> variable in phase 'check':
>
> test/test10/hello.sh
> + '[' amd64 = amd64 ']'
> + ./test/results/test1-binary
> + . ./sha256.sh
> ++ set -ex
> test/test1/hello.sh: line 37: 171 Segmentation fault ./test/results/test1-binary < test/test1/hex0.hex0 > test/test1/proof1
> + '[' amd64 = x86 ']'
> + exit 0
> make: *** [makefile:104: test1-binary] Error 139
> [...]
> test/test7/hello.sh: line 31: 175 Segmentation fault ./test/results/test7-binary test/test7/hex1.hex1 > test/test7/proof
> [...]
> test/test3/hello.sh: line 23: GET_MACHINE_FLAGS: unbound variable

Could this be non-deterministic?

I just got substitutes from bayfront.guix.gnu.org:

Toggle snippet (18 lines)
$ guix build mes
1.4 MB will be downloaded:
/gnu/store/2x63a7415vfz605pw33awfccrn0z74dg-mes-0.23
substituting /gnu/store/2x63a7415vfz605pw33awfccrn0z74dg-mes-0.23...
downloading from https://bayfront.guix.gnu.org/nar/lzip/2x63a7415vfz605pw33awfccrn0z74dg-mes-0.23 ...
mes-0.23 1.3MiB 3.4MiB/s 00:00 [##################] 100.0%

/gnu/store/2x63a7415vfz605pw33awfccrn0z74dg-mes-0.23
$ guix build mes -d --no-grafts
/gnu/store/nb6vmrz197bfpz4w5mdrmj0r10mszzig-mes-0.23.drv
ludo@ribbon ~/src/guix$ guix describe
Generacio 185 Jun 07 2021 15:07:46 (nuna)
guix e3611cc
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: e3611cc412e7b1c750a56d17fb1b7cde684baa3f

I rebuilt it with ‘--check’ and it went fine. Hmm!

Thoughts?

Ludo’.
G
G
Gabriel Wicki wrote on 15 Jun 2021 01:14
(address . bug-guix@gnu.org)(address . bug-mes@gnu.org)
20210614231425.vikalmhitpgvinbc@silver
(This is a reply to the original bug report [0]; cross-posting to
bug-mes@gnu.org for reasons described below. I hope this is ok)

On Sun, Jun 13, 2021 at 02:52:41PM +0200, Ludovic Court�s wrote:
Toggle quote (1 lines)
> Hi,
Hello!

I guess i need to clarify: it's not mes building that fails; it's
mescc-tools (version 0.7.0 on x86_64) (which mes depends upon).
Sorry for the confusion.

Toggle quote (1 lines)
> Could this be non-deterministic?
I have the same problem in guix on my Debian host and in my qemu Guix
System. And since the error is the same as in the build on
ci.guix.gnu.org [1] i'm under the impression that it might be (at least
somewhat) deterministic ;)
I should be able to test this in my (real) Guix System host tomorrow.


Toggle quote (1 lines)
> Thoughts?
Digging through the CI logs a bit i found mescc-tools-0.7.0 failing
to build for x86_64[2]. Also there is this build (mes-0.23 for x86_64)
failing with the same errors [3], but during `check' phase for
dependency nyacc-1.00.2 (this is not the current version; also: i'm
not sure if this really is related, but the log outputs are strikingly
similar).

My debugging[5] didn't reveal anything further than what's already in
the logs. So i'm CC-ing bug-mes mailing list, since that's probably
the most adequate place to discuss this issue :)

g



[4] mescc-tools/test/test1/hello.sh:26
[5] ./test/results/test1-binary --> segfault
E
E
Ekaitz Zarraga wrote on 27 Jul 2021 10:11
r1WZy9RkvzmtKyCw7Mi4bhGEAioNrvBn267VSmH81fxtpKzVBy7GyTuGqlUgdDUuoZLHM6-JmTr7clqq4AdLWafFjf18sFhX7d254GvLzBg=@elenq.tech
Hi,

I found the same issue while trying to set the environment for gnu-mes using the scripts the directory includes.

I updated the mescc-tools version to 1.1.0 and it worked.

I attach a possible patch for the `mes` repository that can easily be translated for the `guix` package.

hth,

Ekaitz


From 828ba527e652de9166eddf24a9296b5aa2db3f79 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Tue, 27 Jul 2021 10:00:30 +0200
Subject: [PATCH] Update guix helper files

Bump mescc-tools to 1.1.0
---
guix/git/mes.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (33 lines)
diff --git a/guix/git/mes.scm b/guix/git/mes.scm
index 0c7c5566..21b8591a 100644
--- a/guix/git/mes.scm
+++ b/guix/git/mes.scm
@@ -54,7 +54,7 @@
(define-public mescc-tools
(package
(name "mescc-tools")
- (version "0.7.0")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
@@ -65,7 +65,7 @@
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1p1ijia4rm3002f5sypidl9v5gq0mlch9b0n61rpxkdsaaxjqax3"))))
+ "12cjryqfd6m6j807pvhk7i4vr2q0jiibpfrpnq5s67iq9l4rrc6b"))))
(build-system gnu-build-system)
(supported-systems
'("aarch64-linux" "armhf-linux" "i686-linux" "x86_64-linux"))
@@ -80,6 +80,7 @@
(substitute* "sha256.sh"
(("/usr/bin/sha256sum") (which "sha256sum")))
#t)))))
+ (propagated-inputs `(("which" ,which)))
(synopsis "Tools for the full source bootstrapping process")
(description
"Mescc-tools is a collection of tools for use in a full source
--

2.31.0
Attachment: signature.asc
E
E
Ekaitz Zarraga wrote on 27 Jul 2021 10:37
pe6yjS_3B9nWwkaH7u1ICmh_OyqJJTOJVxFWxehjZzBHO1NSAZMasKamz8GMsZHr8Yv29atsb_EYQ6ou33dRERGCejaWpzbK6EdBQ392jHY=@elenq.tech
BTW,

Toggle quote (4 lines)
> #t)))))
> - (propagated-inputs `(("which" ,which)))
>

It's wrong. It should be `inputs` but you get what I mean.
:S
L
L
Ludovic Courtès wrote on 27 Jul 2021 11:40
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
87pmv45c38.fsf@gnu.org
Hi!

Ekaitz Zarraga <ekaitz@elenq.tech> skribis:

Toggle quote (6 lines)
> I found the same issue while trying to set the environment for gnu-mes using the scripts the directory includes.
>
> I updated the mescc-tools version to 1.1.0 and it worked.
>
> I attach a possible patch for the `mes` repository that can easily be translated for the `guix` package.

I pushed this update on ‘core-updates’ as part of fixing
https://issues.guix.gnu.org/49515, which seems to be a duplicate of
this issue.

Is this needed on ‘master’ as well? If so, I can cherry-pick those
changes.

Thanks!

Ludo’.
L
L
Ludovic Courtès wrote on 27 Jul 2021 11:43
control message for bug #48595
(address . control@debbugs.gnu.org)
87o8ao5byx.fsf@gnu.org
close 48595
quit
L
L
Ludovic Courtès wrote on 27 Jul 2021 11:43
control message for bug #49515
(address . control@debbugs.gnu.org)
87mtq85by7.fsf@gnu.org
merge 49515 48595
quit
?