[PATCH]: Gnu: Add Weir

  • Open
  • quality assurance status badge
Details
3 participants
  • Giovanni Biscuolo
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 21 Apr 2021 23:38
(address . guix-patches@gnu.org)
CAO+9K5qKqCmAddOSPamTJ_5ruGBZwC5EiX2A0nzJxqkdYy-poQ@mail.gmail.com
Hi Guix team!
New Common Lisp system for digital Art with fixes applied upstream
Toggle snippet (5 lines)
successfully built
/gnu/store/cz7rcj884p4cb6ps9rkq835f72qy8fhd-ecl-weir-4.9.1-1.beb4f6f.drv
/gnu/store/zcvz1fzj4dngvh5p6sr0y1lfajd8x19j-ecl-weir-4.9.1-1.beb4f6f
/gnu/store/zwz00r53lhswk5nfbkjw1i4cpzm5306g-sbcl-weir-4.9.1-1.beb4f6f
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From ffb12b7132e4e831bccab0c22b4de96923b8c079 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 21 Apr 2021 22:34:26 +0100
Subject: [PATCH] gnu: Add weir

* gnu/packages/lisp-xyz.scm (sbcl-weir, cl-weir, ecl-weir): New variables
---
gnu/packages/lisp-xyz.scm | 53 +++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0e82f8fc2c..f133d372a5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16034,3 +16034,56 @@ lQuery.")
(define-public cl-clip
(sbcl-package->cl-source-package sbcl-clip))
+
+(define-public sbcl-weir
+ (let ((commit "beb4f6f47f0538d2c6d73b1d3c9d7f58ac8aa0e9")
+ (revision "1"))
+ (package
+ (name "sbcl-weir")
+ (version (git-version "4.9.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/inconvergent/weir")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vm10kb51g4ba2nl5yixswkk47vwqgwqdlz5031xfff8h9z2a6ad"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ ;; FIXME: (Sharlatan-20210415T165228+0100): All tests have been passed
+ ;; but terminated with error status after `check' phase is completed.
+ ;;
+ ;; tests: 303
+ ;; fails: 0
+ ;; passes: 303
+ ;; "--- at least one catastrophe! ---"
+ ;; terminated with status: 1
+ ;; ;
+ ;; ; compilation unit aborted
+ ;; ; caught 1 fatal ERROR condition
+ ;; ; caught 3 STYLE-WARNING conditions
+ ;; ; printed 91 notes
+ `(#:tests? #f))
+ (inputs
+ `(("alexandira" ,sbcl-alexandria)
+ ("cl-json" ,sbcl-cl-json)
+ ("cl-svg" ,sbcl-cl-svg)
+ ("inferior-shell" ,sbcl-inferior-shell)
+ ("lparallel" ,sbcl-lparallel)
+ ("png" ,sbcl-png)
+ ("split-sequence" ,sbcl-split-sequence)
+ ("zpng" ,sbcl-zpng)))
+ (home-page "https://github.com/inconvergent/weir")
+ (synopsis "System for making generative systems")
+ (description
+ "This package provides Common Lisp system for generating 2d and 3d vector
+artworks with SVG and PNG export format.")
+ (license license:expat))))
+
+(define-public ecl-weir
+ (sbcl-package->ecl-package sbcl-weir))
+
+(define-public cl-weir
+ (sbcl-package->cl-source-package sbcl-fare-mop))
--
2.31.1
G
G
Giovanni Biscuolo wrote on 22 Apr 2021 10:40
87im4eg1ag.fsf@biscuolo.net
Hello Sharlatan,

thank you very much for your patch, Weir and generative algorithms for
art graphic production are very interesting

We should check the overall license status of weir, see below

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

[...]

Toggle quote (10 lines)
> From ffb12b7132e4e831bccab0c22b4de96923b8c079 Mon Sep 17 00:00:00 2001
> From: Sharlatan Hellseher <sharlatanus@gmail.com>
> Date: Wed, 21 Apr 2021 22:34:26 +0100
> Subject: [PATCH] gnu: Add weir
>
> * gnu/packages/lisp-xyz.scm (sbcl-weir, cl-weir, ecl-weir): New variables
> ---
> gnu/packages/lisp-xyz.scm | 53 +++++++++++++++++++++++++++++++++++++++
> 1 file changed, 53 insertions(+)

[...]

Toggle quote (7 lines)
> + (synopsis "System for making generative systems")
> + (description
> + "This package provides Common Lisp system for generating 2d and 3d vector
> +artworks with SVG and PNG export format.")
> + (license license:expat))))

Toggle snippet (48 lines)
This code is released under the MIT license(see below). Unless otherwise noted.

Most prominent exceptions are:

1. Some utilities from On Lisp by Paul Graham (in src/various.lisp). They are
bound by this notice:

---
This code is copyright 1993 by Paul Graham, but anyone who wants
to use the code in any nonprofit activity, or distribute free
verbatim copies (including this notice), is encouraged to do so.
---

2. Some modified code by Victor Anyakin in (in src/auxiliary/dat.lisp):

---
Copyright (c) 2013-2018 Victor Anyakin <anyakinvictor@yahoo.com>
All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:
* Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the distribution.
* Neither the name of the organization nor the
names of its contributors may be used to endorse or promote products
derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL COPYRIGHT HOLDER BE LIABLE FOR ANY
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
---

3. Some code suggested by @lispm (in src/auxiliary/dat.lisp, src/various.lisp). There
are links to the original suggestions


AFAIU the license in 1. means that that piece of code is not free
software, since "verbatim copy" AFAIU is not free

The license in 2. AFAIU is free software, license:expat or other? Can
you clarify please?

The code referenced in 3. is suggested by lispm in
and AFAIU is not a trivial patch with no clear license: I really don't
know how this kind of code is normally evaluated from a GNU FSDG point
of view

I think we need some guidance from someone more experienced in license
issues.

Thanks! Giovanni.

--
Giovanni Biscuolo

Xelera IT Infrastructures
-----BEGIN PGP SIGNATURE-----

iQJABAEBCgAqFiEERcxjuFJYydVfNLI5030Op87MORIFAmCBNngMHGdAeGVsZXJh
LmV1AAoJENN9DqfOzDkSzGoQAJZSP4kTHLv5ZPIbc2+kRhY1k7Us+QiX9vRfwInA
q4ObzyrqOOCNueUyvE0iPKF3wku+/LJlzYZIFxKASMJ1kAkXfnr2mevl7Y21iR4v
HpgqdgpvHU6A4TsXcsHn2kWOYGw1h5mEoUEiGeZjNyxevKhFsXHDno8qfqlH7uRd
nRC9wZ8DNXt2sgHp1mBdjoh+rFcrVleUWDf/cPZfWFw3nSC0q13yn6favjaLaJjq
VZoiODlEBx5pv2RDqHT9XTkMFq1HhaN8HW55pMdU8KOIl6S3aKxBQYlxv2MbmM3Y
Np+4WwwsC0nshT4mOdA1m2S4CUCA4cXwbLNYHhnYXXyDlGoi8gkrtuTLKDc6sSix
RGIeokMdKLFDGeW5cq591BY4lP4rFU7ahaJnEMVnJf8wCnj1X6ozZAszg/teRT9Q
uGoAdHrxTCfdOVGbB85JgbLtmIbKDeyok01knzWWWyTkaqydJ81x1j9ZwhkDL+Gf
xOp81JungRwoFKripoa0hAnp+k4ph+On4kPYBJxlz71/NrliZCrrgqGIoiiYRnxv
hWVnmDYfMlISGo4chT+pov/0S2EaBn1RQRutqij+Bd/tqexbTcT1OC+Y7X5zH07y
v+NZnOhdGL6qieKgIEZXgJRanWYJqGWNZfNolL6pSwLmOypsr/ngxJUB9COJ21ba
poor
=OqoE
-----END PGP SIGNATURE-----

G
G
Guillaume Le Vaillant wrote on 22 Apr 2021 10:43
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 47943-done@debbugs.gnu.org)
87wnsuogkd.fsf@yamatai
Patch pushed as 5763eba94cccc4019cb07b0cac6c16132c741e11.
I managed to get the tests working on SBCL, it was a file access
permission issue. However a few tests are failing on ECL, so I disabled
them for now.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYIE3Ig8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+3NwD9FTZC6rnplOcB4Uxfh+oTkIkCbjTH3/GvMvRI
7XdheFgA+QGdgbhmAElYssnGLoFX3SpTJu7R5y2puE7Pv+Lqlqwh
=WSAG
-----END PGP SIGNATURE-----

Closed
G
G
Guillaume Le Vaillant wrote on 22 Apr 2021 11:02
(name . Giovanni Biscuolo)(address . g@xelera.eu)
87tunyofo0.fsf@yamatai
Giovanni Biscuolo <g@xelera.eu> skribis:

Toggle quote (80 lines)
> Hello Sharlatan,
>
> thank you very much for your patch, Weir and generative algorithms for
> art graphic production are very interesting
>
> We should check the overall license status of weir, see below
>
> [...]
>
> The license file
> https://github.com/inconvergent/weir/blob/master/LICENSE
>
> contains this:
>
> --8<---------------cut here---------------start------------->8---
>
> This code is released under the MIT license(see below). Unless otherwise noted.
>
> Most prominent exceptions are:
>
> 1. Some utilities from On Lisp by Paul Graham (in src/various.lisp). They are
> bound by this notice:
>
> ---
> This code is copyright 1993 by Paul Graham, but anyone who wants
> to use the code in any nonprofit activity, or distribute free
> verbatim copies (including this notice), is encouraged to do so.
> ---
>
> 2. Some modified code by Victor Anyakin in (in src/auxiliary/dat.lisp):
>
> ---
> Copyright (c) 2013-2018 Victor Anyakin <anyakinvictor@yahoo.com>
> All rights reserved.
>
> Redistribution and use in source and binary forms, with or without
> modification, are permitted provided that the following conditions are met:
> * Redistributions of source code must retain the above copyright
> notice, this list of conditions and the following disclaimer.
> * Redistributions in binary form must reproduce the above copyright
> notice, this list of conditions and the following disclaimer in the
> documentation and/or other materials provided with the distribution.
> * Neither the name of the organization nor the
> names of its contributors may be used to endorse or promote products
> derived from this software without specific prior written permission.
>
> THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
> ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
> WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
> DISCLAIMED. IN NO EVENT SHALL COPYRIGHT HOLDER BE LIABLE FOR ANY
> DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
> (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
> LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
> ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
> (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
> SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
> ---
>
> 3. Some code suggested by @lispm (in src/auxiliary/dat.lisp, src/various.lisp). There
> are links to the original suggestions
>
> --8<---------------cut here---------------end--------------->8---
>
> AFAIU the license in 1. means that that piece of code is not free
> software, since "verbatim copy" AFAIU is not free
>
> The license in 2. AFAIU is free software, license:expat or other? Can
> you clarify please?
>
> The code referenced in 3. is suggested by lispm in
> https://gist.github.com/inconvergent/8b6ccfbde4fca7844c1962082ef07a7e
> and AFAIU is not a trivial patch with no clear license: I really don't
> know how this kind of code is normally evaluated from a GNU FSDG point
> of view
>
> I think we need some guidance from someone more experienced in license
> issues.
>
> Thanks! Giovanni.

Hi Giovanni,

I pushed the patch just before receiving your email about the possible
license issue. Bad timing...

I'm not a lawyer and I'm not sure what the final license of Weir is, so
it would be nice if some license expert could give us their opinion on
this. And in case there's a problem, I'll revert the patch.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYIE7rw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9kbwD+InkreB7+2mtIoRoVilzin8cbrWPoYczdfjZI
3BMwdBcA/iUWnzd54FeOYd53Gd4wl2zFJKW13LLIkEzF8B4hkMCg
=t2MW
-----END PGP SIGNATURE-----

G
G
Giovanni Biscuolo wrote on 22 Apr 2021 11:22
(name . Guillaume Le Vaillant)(address . glv@posteo.net)
87fszifzcw.fsf@biscuolo.net
Hi Guillaume,

thank you for your follow up and for your contribution to Guix!

Guillaume Le Vaillant <glv@posteo.net> writes:

Toggle quote (2 lines)
> Giovanni Biscuolo <g@xelera.eu> skribis:

[...]

Toggle quote (18 lines)
>> AFAIU the license in 1. means that that piece of code is not free
>> software, since "verbatim copy" AFAIU is not free
>>
>> The license in 2. AFAIU is free software, license:expat or other? Can
>> you clarify please?
>>
>> The code referenced in 3. is suggested by lispm in
>> https://gist.github.com/inconvergent/8b6ccfbde4fca7844c1962082ef07a7e
>> and AFAIU is not a trivial patch with no clear license: I really don't
>> know how this kind of code is normally evaluated from a GNU FSDG point
>> of view
>>
>> I think we need some guidance from someone more experienced in license
>> issues.

> I pushed the patch just before receiving your email about the possible
> license issue. Bad timing...

I saw your push some minutes after my message :-)

Toggle quote (4 lines)
> I'm not a lawyer and I'm not sure what the final license of Weir is, so
> it would be nice if some license expert could give us their opinion on
> this. And in case there's a problem, I'll revert the patch.

I am almost sure that the licenses for the points 1 (license clearly
stated by Paul Graham) and 3 (no license for that code means "classic"
full copyright) are non-free.

Please do not forget that a reasonable copyright and license audit is
one of the things to do before committing, so please do not skip this
important step just IANAL ;-)

Please can you yust revert this patch and give us some time to settle
this issue?

Thanks! Giovanni

--
Giovanni Biscuolo

Xelera IT Infrastructures
-----BEGIN PGP SIGNATURE-----

iQJABAEBCgAqFiEERcxjuFJYydVfNLI5030Op87MORIFAmCBQEAMHGdAeGVsZXJh
LmV1AAoJENN9DqfOzDkSWc4QAK2o9Uxcf3cnGBiaZQdlmxYgWVh0qS/Z2SimYuDb
Cr8Ev7SYv/1yvgv6ryAWeHjzWcNJ1IPJP88K7hqh1CqXcH6k0MfPIF3toVojZR20
tQnc2fjxLr+ZCbYAQgR3TZnkOdvtknR+t9tSf4D97+/rcBtfs1YANyMxubkn7e2v
t4bWHQ+UTtt2Iwp3D02PIdU3YZwjpS58bfldhD/KdUnjep204/MWU/LSOZxVeTXn
oPiOuPuTAXiTw5lJ7Fai0ubMuGoW1lyaPg2qUyWakbfKAdMJqwMvNrlmUZE93SWe
IMXRJbbVtdzxXSp3Lhoh6F8un+SG4kHx6PG58yOzk5lWaZCyqkS6fJlc2kJJxnZL
2goNNUaG8wOBuns/uljWq/g4Gr/3/spWXKtH1pBKvDkWJdUAa/bKn3dZVPMcXdCY
SXr3J65lgJXwTUvgMaMsVb1y8pMNLDQ0Vmh0mpbKPkt1A24QT+v+V0B7tfvi5VB7
Dj4VUz8shOnFPaRuEw9OqZ4bFgcRo4AXsySCH22c/NcMQvMwt21CfkWxGd/8yOCh
3ej2dB4VPiR1aT6pND7WUIZGC3hblHLIDmvUXUpP26fm6+uadfaBovQGedZyz8NI
vpMBhUB7Ll+oPkFp5YUtoc3RBHtV3opsLdDawpggwpHhCBwvNYRxfsu9muJZ9mTO
nnny
=jqGr
-----END PGP SIGNATURE-----

G
G
Guillaume Le Vaillant wrote on 22 Apr 2021 13:43
(name . Giovanni Biscuolo)(address . g@xelera.eu)
87im4ek0iu.fsf@yamatai
Giovanni Biscuolo <g@xelera.eu> skribis:

Toggle quote (9 lines)
> I am almost sure that the licenses for the points 1 (license clearly
> stated by Paul Graham) and 3 (no license for that code means "classic"
> full copyright) are non-free.
>
> [...]
>
> Please can you yust revert this patch and give us some time to settle
> this issue?

I reverted the patch in 2eb9e57c0c554a926ba363031dd4ee7bb215034f.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYIFhWQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8ojAD/b5jv7WOmOBDAx9EgSiQYmfIKns8IaUaIz+US
tudROEoA+wan5z4gHn908RLGuku431Bw5cEYSvySXcEcD5D30iSS
=b8dQ
-----END PGP SIGNATURE-----

G
G
Guillaume Le Vaillant wrote on 22 Apr 2021 14:12
(name . Giovanni Biscuolo)(address . g@xelera.eu)
87czumjz72.fsf@yamatai
Giovanni Biscuolo <g@xelera.eu> skribis:
Toggle quote (21 lines)
> --8<---------------cut here---------------start------------->8---
> This code is released under the MIT license(see below). Unless otherwise noted.
>
> Most prominent exceptions are:
>
> 1. Some utilities from On Lisp by Paul Graham (in src/various.lisp). They are
> bound by this notice:
>
> ---
> This code is copyright 1993 by Paul Graham, but anyone who wants
> to use the code in any nonprofit activity, or distribute free
> verbatim copies (including this notice), is encouraged to do so.
> ---
> --8<---------------cut here---------------end--------------->8---
>
> [...]
>
> I am almost sure that the licenses for the points 1 (license clearly
> stated by Paul Graham) and 3 (no license for that code means "classic"
> full copyright) are non-free.

Concerning point 1, there's a modified version of the code from
The file "on-lisp.asd" contains an extra indication by Paul Graham about
the license:

Toggle snippet (9 lines)
Original code:
This code is copyright 1993 by Paul Graham, but anyone who wants
to use the code in any nonprofit activity, or distribute free
verbatim copies (including this notice), is encouraged to do so.

Modified code:
As long as you tell people it's modified and link to
the original, that's fine. --pg
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYIFoEQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/8CgEAjHs5S63fCnWGFdy9KbyVYsWWEwgvyNFfpPp1
K283dDUBAIAMVeiWFpy458UD1bsLPupBp8gr3oR45Ih36k/qXqPC
=Wvyg
-----END PGP SIGNATURE-----

G
G
Giovanni Biscuolo wrote on 22 Apr 2021 15:24
(name . Guillaume Le Vaillant)(address . glv@posteo.net)
875z0efo4g.fsf@biscuolo.net
Hi Guillaume and Sharlatan,

Guillaume Le Vaillant <glv@posteo.net> writes:

[...]

Toggle quote (16 lines)
> Concerning point 1, there's a modified version of the code from
> "On Lisp" at <https://github.com/DalekBaldwin/on-lisp>.
> The file "on-lisp.asd" contains an extra indication by Paul Graham about
> the license:
>
> --8<---------------cut here---------------start------------->8---
> Original code:
> This code is copyright 1993 by Paul Graham, but anyone who wants
> to use the code in any nonprofit activity, or distribute free
> verbatim copies (including this notice), is encouraged to do so.
>
> Modified code:
> As long as you tell people it's modified and link to
> the original, that's fine. --pg
> --8<---------------cut here---------------end--------------->8---

Unfortunately AFAIU the "Modified code" license addition (where does it
comes from?) still does not qualify the license as free.

"On Lisp" official page is here:
extracted from the TeX source files of _On Lisp_) is copyright by Paul
Graham. AFAIU today both the code and the book are freeware but not
free.

The original code (officially linked in the book web page) is here:

A good chance to ask Paul Graham (and Dalek Baldwin... or Kyle Littler?)
to release the code as free software? :-D

Thanks! Giovanni.

P.S.: I'm not familiar with Common Lisp but is it possible that the
functions from "On Lisp" has been somehow replaced or incorporated in a
proper library? ...I'm going to ask on guix-devel.

This alone will not fix the problem with "point 3." of the Weir license,
but would be a start.


--
Giovanni Biscuolo

Xelera IT Infrastructures
-----BEGIN PGP SIGNATURE-----

iQJABAEBCgAqFiEERcxjuFJYydVfNLI5030Op87MORIFAmCBeR8MHGdAeGVsZXJh
LmV1AAoJENN9DqfOzDkS55kQAL3vo6NnePclFHn/k5BS3cuAAKNwSRJoQrEa4gI/
l9FQfB3SGKbMRUm/SO1BQ5pRHG/uWzI1gvzcRXjcZrsHDHRotitgFSkdIMavTRvh
E4E61NDlxtq9wSNuTGFkSy9O6F4+Tgs8bW5sjeDDPUPZy1taBv814qw8MH3kYaOs
BDwXl2r9TPCDRSuJ5lqmvByMi57bMoI1qPM4VkG1UK8GFA1L/sGNh99uMUK3FbwQ
+vuu1nnEGeKV3xCSMmBZG0UV0dzExoIaUo87Y669pwAxYzvspHJfAoIjsatkh0ov
TsK4aHBaqrkK6rf9Oio6A+NZMeNbJLZswXre/PAS1si8A/n72LmkNJKcB1xF/maB
pzqg8M0WFFa0rlwxfoG4yHupeWHiYMc+f+GOIGA7vcgtt0bvtlok1VrHQLzMlojw
jji6/E8fUzJ6vtDHGTEyUi0XC9wuWBX2H7wRW2vCpQMPi3pJ/ZG7K46TRVf5V1Wd
Rz0G2hQ5q9lpHh0Dyl6OMBU3xz8lg8BiwR57RDkHigZMgGmcEkSrC4aL6uEDrT3o
8/dQ1KJ2dacm3Q6vvVsfsitZnB3Mj7MJ3q3lCnAZA12+KxIbEKL+u8K4/alDKznE
jWd6mAmJKdF6Df2mu8xIH660mptpi+QUjKzqtn+bsmGxrr9oSyYyMmmhbuB/q1fF
hUI9
=M96G
-----END PGP SIGNATURE-----

G
G
Giovanni Biscuolo wrote on 26 Apr 2021 15:24
[bug#47943] Weir licensing issue (was [PATCH]: Gnu: Add Weir)
(address . licensing@fsf.org)
878s55ch5t.fsf@biscuolo.net
Hello Licensing Team!

in Guix we are considering adding a new package, Weir, but we need some
clarificartions about it's license.

This is what I found:

Giovanni Biscuolo <g@xelera.eu> writes:

[...]

Toggle quote (54 lines)
> The license file
> https://github.com/inconvergent/weir/blob/master/LICENSE
>
> contains this:
>
> --8<---------------cut here---------------start------------->8---
>
> This code is released under the MIT license(see below). Unless otherwise noted.
>
> Most prominent exceptions are:
>
> 1. Some utilities from On Lisp by Paul Graham (in src/various.lisp). They are
> bound by this notice:
>
> ---
> This code is copyright 1993 by Paul Graham, but anyone who wants
> to use the code in any nonprofit activity, or distribute free
> verbatim copies (including this notice), is encouraged to do so.
> ---
>
> 2. Some modified code by Victor Anyakin in (in src/auxiliary/dat.lisp):
>
> ---
> Copyright (c) 2013-2018 Victor Anyakin <anyakinvictor@yahoo.com>
> All rights reserved.
>
> Redistribution and use in source and binary forms, with or without
> modification, are permitted provided that the following conditions are met:
> * Redistributions of source code must retain the above copyright
> notice, this list of conditions and the following disclaimer.
> * Redistributions in binary form must reproduce the above copyright
> notice, this list of conditions and the following disclaimer in the
> documentation and/or other materials provided with the distribution.
> * Neither the name of the organization nor the
> names of its contributors may be used to endorse or promote products
> derived from this software without specific prior written permission.
>
> THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
> ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
> WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
> DISCLAIMED. IN NO EVENT SHALL COPYRIGHT HOLDER BE LIABLE FOR ANY
> DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
> (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
> LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
> ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
> (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
> SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
> ---
>
> 3. Some code suggested by @lispm (in src/auxiliary/dat.lisp, src/various.lisp). There
> are links to the original suggestions
>
> --8<---------------cut here---------------end--------------->8---

Can you please clarify how to manage the three different licenses
declared above?

AFAIU:

1. the license is not free since "verbatim copy" is not free

2. is a free software, seems a modified version of the expat
license... or other? Can you clarify please?

3. the code (I read it) suggested by lispm in
not a trivial patch and no license is included, so it should be
"copyright by default", right?

Thank you for your support!

Best regards, Giovanni.

--
Giovanni Biscuolo

Xelera IT Infrastructures
-----BEGIN PGP SIGNATURE-----

iQJABAEBCgAqFiEERcxjuFJYydVfNLI5030Op87MORIFAmCGvx4MHGdAeGVsZXJh
LmV1AAoJENN9DqfOzDkSYp4QANHFhqa5WKmPI0gjuOApIE4ctsFnMhA8QBrYprwE
92+e49EuE7YXZn11F3JFd500lChiQ3jeumZN4bJqCPi4JWYZr6BOp/eZTOSxCZ3A
Fl6/KV4o6StmU7Eoydx0wPKco9/O2NeVLzqJxbXZkK/PwfIDhi/FhoIFXoJzLqPL
kW3lm9f8/8sRMF+nICjWcQpzPJAPgMSdnv3bIY2Nhx0KHsYQWo+wUIO3G5X3+s8a
Gt1Hwh0FpjnLX3V0BoSQLtQO2lyLYr6ffOwwK6YZr/QXc/xLQ8qQvcG+hrrEFuVC
LNUrNMZpRbYSK9BlPMjaaJyN1RSlhk1BZNCxuxWNIvWdqrGBuC9C9pSxjn/x8Poz
xuehE8qP51oE8MI8Lr4v7vgpeYYEgrhgN6ZR8xtULMBZ0Jf6POcHO8d6R4wOY6QO
i0qwdDhLughIQ6x5CEpaN4eRFyy3+9kLHVsCTX9lqiJdD/QHTSHqbTcIK9EV42Wv
sDbppaTaewdW746nC5bxNTlSTb5h4TcBbs5r6SWtUerT0fpFMLW9GaLKPva/q7a9
QkBdEVPTLsOrCDTHbsBILrBcKAFjN5kwBQHoj0VEwjs7KYNRwLp2uVlh1IVL4EDH
JVQl9xnCa/TYmD3eAGv1Ff3gfA959N8dkP/1a4EkBrJZm6fpGyZoeS8DX+9/RalG
ZX75
=zZyD
-----END PGP SIGNATURE-----

?